Update to 7.0.3

This commit is contained in:
Simone Caronni 2014-05-15 16:02:42 +02:00
parent 4e31608406
commit 47fa612afe
12 changed files with 91 additions and 321 deletions

1
.gitignore vendored
View File

@ -20,3 +20,4 @@ bacula-docs-5.0.3.tar.bz2
/bacula-7.0.0.tar.gz
/bacula-7.0.1.tar.gz
/bacula-7.0.2.tar.gz
/bacula-7.0.3.tar.gz

View File

@ -1,24 +0,0 @@
diff -up bacula-5.0.2/bacula-5.0.2/src/lib/crypto.c.openssl bacula-5.0.2/bacula-5.0.2/src/lib/crypto.c
--- bacula-5.0.2/bacula-5.0.2/src/lib/crypto.c.openssl 2010-04-27 21:58:29.000000000 +0200
+++ bacula-5.0.2/bacula-5.0.2/src/lib/crypto.c 2010-06-01 17:51:52.846894465 +0200
@@ -51,7 +51,7 @@
* For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
* exists. It was not an official API.
*/
-#ifdef HAVE_OPENSSLv1
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
#endif
diff -up bacula-5.0.2/bacula-5.0.2/src/lib/tls.c.openssl bacula-5.0.2/bacula-5.0.2/src/lib/tls.c
--- bacula-5.0.2/bacula-5.0.2/src/lib/tls.c.openssl 2010-04-27 21:58:29.000000000 +0200
+++ bacula-5.0.2/bacula-5.0.2/src/lib/tls.c 2010-06-01 17:52:15.535769446 +0200
@@ -315,7 +315,7 @@ bool tls_postconnect_verify_host(JCR *jc
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
if (strcmp(extname, "subjectAltName") == 0) {
-#ifdef HAVE_OPENSSLv1
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
const X509V3_EXT_METHOD *method;
#else
X509V3_EXT_METHOD *method;

View File

@ -1,9 +0,0 @@
diff -up src/cats/make_sqlite3_tables.in~ src/cats/make_sqlite3_tables.in
--- src/cats/make_sqlite3_tables.in~ 2010-11-16 17:57:12.705837000 +0100
+++ src/cats/make_sqlite3_tables.in 2010-11-16 17:57:12.715837000 +0100
@@ -426,4 +426,5 @@ PRAGMA synchronous = NORMAL;
END-OF-DATA
chmod 640 ${db_name}.db
+chown bacula:bacula ${db_name}.db
exit 0

View File

@ -1,225 +0,0 @@
diff --git a/bacula/src/lib/lockmgr.h b/bacula/src/lib/lockmgr.h
index d112ee8..6844eeb 100644
--- a/bacula/src/lib/lockmgr.h
+++ b/bacula/src/lib/lockmgr.h
@@ -230,6 +230,7 @@ int bthread_kill(pthread_t thread, int sig,
# define BTHREAD_MUTEX_NO_PRIORITY PTHREAD_MUTEX_INITIALIZER
# define BTHREAD_MUTEX_INITIALIZER PTHREAD_MUTEX_INITIALIZER
# define lmgr_mutex_is_locked(m) (1)
+# define bthread_cond_wait_p(w, x, y, z) pthread_cond_wait(w,x)
#endif /* _USE_LOCKMGR */
diff --git a/bacula/src/lib/sellist.c b/bacula/src/lib/sellist.c
index 3f58de0..003fec7 100644
--- a/bacula/src/lib/sellist.c
+++ b/bacula/src/lib/sellist.c
@@ -105,10 +105,6 @@ int64_t sellist::next()
errmsg = _("Selection items must be be greater than zero.\n");
goto bail_out;
}
- if (end > max) {
- errmsg = _("Selection item too large.\n");
- goto bail_out;
- }
if (beg <= end) {
return beg++;
}
diff --git a/bacula/src/lib/sellist.h b/bacula/src/lib/sellist.h
index e075191..c9716a0 100644
--- a/bacula/src/lib/sellist.h
+++ b/bacula/src/lib/sellist.h
@@ -37,7 +37,6 @@ class sellist : public SMARTALLOC {
char esave, hsave;
bool all;
int64_t beg, end;
- int64_t max;
int num_items;
char *str;
char *expanded;
@@ -64,7 +63,6 @@ public:
inline sellist::sellist()
{
num_items = 0;
- max = 99999;
expanded = NULL;
str = NULL;
e = NULL;
diff --git a/bacula/src/stored/bcopy.c b/bacula/src/stored/bcopy.c
index 5fe76df..ce1144e 100644
--- a/bacula/src/stored/bcopy.c
+++ b/bacula/src/stored/bcopy.c
@@ -24,8 +24,6 @@
#include "bacula.h"
#include "stored.h"
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
extern bool parse_sd_config(CONFIG *config, const char *configfile, int exit_code);
/* Forward referenced functions */
diff --git a/bacula/src/stored/bls.c b/bacula/src/stored/bls.c
index c7d1957..ce8e53f 100644
--- a/bacula/src/stored/bls.c
+++ b/bacula/src/stored/bls.c
@@ -25,8 +25,6 @@
#include "stored.h"
#include "findlib/find.h"
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
extern bool parse_sd_config(CONFIG *config, const char *configfile, int exit_code);
static void do_blocks(char *infname);
diff --git a/bacula/src/stored/bscan.c b/bacula/src/stored/bscan.c
index fbfe75a..0a02971 100644
--- a/bacula/src/stored/bscan.c
+++ b/bacula/src/stored/bscan.c
@@ -29,8 +29,6 @@
#include "cats/cats.h"
#include "cats/sql_glue.h"
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
extern bool parse_sd_config(CONFIG *config, const char *configfile, int exit_code);
/* Forward referenced functions */
diff --git a/bacula/src/stored/btape.c b/bacula/src/stored/btape.c
index 4082de2..3ca97ff 100644
--- a/bacula/src/stored/btape.c
+++ b/bacula/src/stored/btape.c
@@ -34,8 +34,6 @@
#include "vtape_dev.h"
#endif
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
extern bool parse_sd_config(CONFIG *config, const char *configfile, int exit_code);
/* External subroutines */
@@ -1117,8 +1115,9 @@ static bool write_two_files()
/*
* Set big max_file_size so that write_record_to_block
* doesn't insert any additional EOF marks
+ * Do calculation in 64 bits to avoid overflow.
*/
- dev->max_file_size = 2 * num_recs * dev->max_block_size;
+ dev->max_file_size = (uint64_t)2 * (uint64_t)num_recs * (uint64_t)dev->max_block_size;
Pmsg2(-1, _("\n=== Write, rewind, and re-read test ===\n\n"
"I'm going to write %d records and an EOF\n"
"then write %d records and an EOF, then rewind,\n"
diff --git a/bacula/src/stored/reserve.c b/bacula/src/stored/reserve.c
index 5f696a3..30719a7 100644
--- a/bacula/src/stored/reserve.c
+++ b/bacula/src/stored/reserve.c
@@ -445,7 +445,7 @@ bool find_suitable_device_for_job(JCR *jcr, RCTX &rctx)
}
if (vol->dev->is_autochanger()) {
Dmsg1(dbglvl, "vol=%s is in changer\n", vol->vol_name);
- if (!is_vol_in_autochanger(rctx, vol) || vol->dev->autoselect) {
+ if (!is_vol_in_autochanger(rctx, vol) || !vol->dev->autoselect) {
continue;
}
} else if (strcmp(device_name, vol->dev->device->hdr.name) != 0) {
diff --git a/bacula/src/tools/Makefile.in b/bacula/src/tools/Makefile.in
index 22d9601..47a5128 100644
--- a/bacula/src/tools/Makefile.in
+++ b/bacula/src/tools/Makefile.in
@@ -141,7 +141,7 @@ bpluginfo.o: bpluginfo.c
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) -I../filed -I../dird -I../stored $(DINCLUDE) $(CFLAGS) $<
bpluginfo: Makefile bpluginfo.o
- $(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ bpluginfo.o -lbac $(GETTEXT_LIBS)
+ $(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ bpluginfo.o -lbac $(DLIB) $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
cd $(topdir) \
diff --git a/bacula/src/tools/bsmtp.c b/bacula/src/tools/bsmtp.c
index b227438..a3e5eef 100644
--- a/bacula/src/tools/bsmtp.c
+++ b/bacula/src/tools/bsmtp.c
@@ -60,13 +60,6 @@
#include <lmcons.h>
#endif
-/*
- * Dummy functions
- */
-int generate_daemon_event(JCR *jcr, const char *event)
-{
- return 1;
-}
#ifndef MAXSTRING
#define MAXSTRING 254
diff --git a/bacula/src/tools/dbcheck.c b/bacula/src/tools/dbcheck.c
index 069d07a..60f3301 100644
--- a/bacula/src/tools/dbcheck.c
+++ b/bacula/src/tools/dbcheck.c
@@ -30,12 +30,6 @@
extern bool parse_dir_config(CONFIG *config, const char *configfile, int exit_code);
-/*
- * Dummy functions
- */
-int generate_daemon_event(JCR *jcr, const char *event)
- { return 1; }
-
typedef struct s_id_ctx {
int64_t *Id; /* ids to be modified */
int num_ids; /* ids stored */
diff --git a/bacula/src/tools/drivetype.c b/bacula/src/tools/drivetype.c
index 23cb42d..3112e37 100644
--- a/bacula/src/tools/drivetype.c
+++ b/bacula/src/tools/drivetype.c
@@ -25,10 +25,6 @@
#include "bacula.h"
#include "findlib/find.h"
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event)
- { return 1; }
-
static void usage()
{
fprintf(stderr, _(
diff --git a/bacula/src/tools/fstype.c b/bacula/src/tools/fstype.c
index 2335a20..3e2e315 100644
--- a/bacula/src/tools/fstype.c
+++ b/bacula/src/tools/fstype.c
@@ -26,10 +26,6 @@
#include "findlib/find.h"
#include "lib/mntent_cache.h"
-/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event)
- { return 1; }
-
static void usage()
{
fprintf(stderr, _(
diff --git a/bacula/src/tools/testfind.c b/bacula/src/tools/testfind.c
index 71bc7a7..d19a82a 100644
--- a/bacula/src/tools/testfind.c
+++ b/bacula/src/tools/testfind.c
@@ -31,7 +31,6 @@
#endif
/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
int generate_job_event(JCR *jcr, const char *event) { return 1; }
void generate_plugin_event(JCR *jcr, bEventType eventType, void *value) { }
extern bool parse_dir_config(CONFIG *config, const char *configfile, int exit_code);
diff --git a/bacula/src/tools/testls.c b/bacula/src/tools/testls.c
index 6cedf40..ebf1bb3 100644
--- a/bacula/src/tools/testls.c
+++ b/bacula/src/tools/testls.c
@@ -26,7 +26,6 @@
#include "findlib/find.h"
/* Dummy functions */
-int generate_daemon_event(JCR *jcr, const char *event) { return 1; }
int generate_job_event(JCR *jcr, const char *event) { return 1; }
void generate_plugin_event(JCR *jcr, bEventType eventType, void *value) { }

View File

@ -1,6 +1,6 @@
diff -Naur bacula-5.2.13.old/src/qt-console/bat.pro.in bacula-5.2.13/src/qt-console/bat.pro.in
--- bacula-5.2.13.old/src/qt-console/bat.pro.in 2013-02-19 20:21:35.000000000 +0100
+++ bacula-5.2.13/src/qt-console/bat.pro.in 2013-02-20 09:45:44.110033340 +0100
diff -Naur bacula-7.0.3.old/src/qt-console/bat.pro.in bacula-7.0.3/src/qt-console/bat.pro.in
--- bacula-7.0.3.old/src/qt-console/bat.pro.in 2014-05-15 15:45:13.750148702 +0200
+++ bacula-7.0.3/src/qt-console/bat.pro.in 2014-05-15 15:49:57.592032881 +0200
@@ -6,13 +6,13 @@
#
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
@ -17,10 +17,10 @@ diff -Naur bacula-5.2.13.old/src/qt-console/bat.pro.in bacula-5.2.13/src/qt-cons
help.files = help/*.html images/status.png images/mail-message-new.png
TEMPLATE = app
diff -Naur bacula-5.2.13.old/src/qt-console/main.cpp bacula-5.2.13/src/qt-console/main.cpp
--- bacula-5.2.13.old/src/qt-console/main.cpp 2013-02-19 20:21:35.000000000 +0100
+++ bacula-5.2.13/src/qt-console/main.cpp 2013-02-20 09:46:19.556679571 +0100
@@ -40,9 +40,9 @@
diff -Naur bacula-7.0.3.old/src/qt-console/main.cpp bacula-7.0.3/src/qt-console/main.cpp
--- bacula-7.0.3.old/src/qt-console/main.cpp 2014-05-15 15:45:13.749148713 +0200
+++ bacula-7.0.3/src/qt-console/main.cpp 2014-05-15 15:49:57.593032870 +0200
@@ -28,9 +28,9 @@
/*
* We need Qt version 4.8.4 or later to be able to comple correctly
*/

View File

@ -1,8 +1,18 @@
diff --git a/src/lib/Makefile.in b/src/lib/Makefile.in
index 009f157..a813a7c 100644
--- a/src/lib/Makefile.in
+++ b/src/lib/Makefile.in
@@ -39,7 +39,7 @@ INCLUDE_FILES = ../baconfig.h ../bacula.h ../bc_types.h \
diff -Naur bacula-7.0.3.old/src/lib/lib.h bacula-7.0.3/src/lib/lib.h
--- bacula-7.0.3.old/src/lib/lib.h 2014-05-15 15:45:13.745148756 +0200
+++ bacula-7.0.3/src/lib/lib.h 2014-05-15 15:52:33.005327683 +0200
@@ -47,7 +47,6 @@
#include "fnmatch.h"
#endif
#include "md5.h"
-#include "sha1.h"
#include "tree.h"
#include "watchdog.h"
#include "btimers.h"
diff -Naur bacula-7.0.3.old/src/lib/Makefile.in bacula-7.0.3/src/lib/Makefile.in
--- bacula-7.0.3.old/src/lib/Makefile.in 2014-05-15 15:45:13.748148724 +0200
+++ bacula-7.0.3/src/lib/Makefile.in 2014-05-15 15:52:33.005327683 +0200
@@ -37,7 +37,7 @@
fnmatch.h guid_to_name.h htable.h lex.h \
lib.h md5.h mem_pool.h message.h mntent_cache.h \
openssl.h plugins.h protos.h queue.h rblist.h \
@ -11,7 +21,7 @@ index 009f157..a813a7c 100644
smartall.h status.h tls.h tree.h var.h \
waitq.h watchdog.h workq.h \
parse_conf.h ini.h \
@@ -55,7 +55,7 @@ LIBBAC_SRCS = attr.c base64.c berrno.c bsys.c binflate.c bget_msg.c \
@@ -53,7 +53,7 @@
guid_to_name.c hmac.c jcr.c lex.c alist.c dlist.c \
md5.c message.c mem_pool.c mntent_cache.c openssl.c \
plugins.c priv.c queue.c bregex.c \
@ -20,7 +30,7 @@ index 009f157..a813a7c 100644
signal.c smartall.c rblist.c tls.c tree.c \
util.c var.c watchdog.c workq.c btimers.c \
address_conf.c breg.c htable.c lockmgr.c devlock.c
@@ -193,13 +193,6 @@ md5sum: Makefile md5.o
@@ -169,13 +169,6 @@
$(RMF) md5.o
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) md5.c
@ -34,7 +44,7 @@ index 009f157..a813a7c 100644
bsnprintf: Makefile bsnprintf.o
$(RMF) bsnprintf.o
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) bsnprintf.c
@@ -250,7 +243,7 @@ libtool-clean:
@@ -225,7 +218,7 @@
clean: libtool-clean
@$(RMF) core a.out *.o *.bak *.tex *.pdf *~ *.intpro *.extpro 1 2 3
@ -43,23 +53,9 @@ index 009f157..a813a7c 100644
realclean: clean
@$(RMF) tags
diff --git a/src/lib/lib.h b/src/lib/lib.h
index b81f89f..c82dc29 100644
--- a/src/lib/lib.h
+++ b/src/lib/lib.h
@@ -59,7 +59,6 @@
#include "fnmatch.h"
#endif
#include "md5.h"
-#include "sha1.h"
#include "tree.h"
#include "watchdog.h"
#include "btimers.h"
diff --git a/src/lib/sha1.c b/src/lib/sha1.c
deleted file mode 100644
index 7e58128..0000000
--- a/src/lib/sha1.c
+++ /dev/null
diff -Naur bacula-7.0.3.old/src/lib/sha1.c bacula-7.0.3/src/lib/sha1.c
--- bacula-7.0.3.old/src/lib/sha1.c 2014-05-15 15:45:13.745148756 +0200
+++ bacula-7.0.3/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
@@ -1,510 +0,0 @@
-/*
- * sha1.c
@ -571,11 +567,9 @@ index 7e58128..0000000
- fclose(fd);
-}
-#endif
diff --git a/src/lib/sha1.h b/src/lib/sha1.h
deleted file mode 100644
index 437fe19..0000000
--- a/src/lib/sha1.h
+++ /dev/null
diff -Naur bacula-7.0.3.old/src/lib/sha1.h bacula-7.0.3/src/lib/sha1.h
--- bacula-7.0.3.old/src/lib/sha1.h 2014-05-15 15:45:13.742148789 +0200
+++ bacula-7.0.3/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
@@ -1,107 +0,0 @@
-/*
- * sha1.h

View File

@ -0,0 +1,24 @@
diff -Naur bacula-7.0.3.old/src/lib/crypto.c bacula-7.0.3/src/lib/crypto.c
--- bacula-7.0.3.old/src/lib/crypto.c 2014-05-15 15:45:13.744148767 +0200
+++ bacula-7.0.3/src/lib/crypto.c 2014-05-15 15:45:23.381043832 +0200
@@ -39,7 +39,7 @@
* For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
* exists. It was not an official API.
*/
-#ifdef HAVE_OPENSSLv1
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
#endif
diff -Naur bacula-7.0.3.old/src/lib/tls.c bacula-7.0.3/src/lib/tls.c
--- bacula-7.0.3.old/src/lib/tls.c 2014-05-15 15:45:13.742148789 +0200
+++ bacula-7.0.3/src/lib/tls.c 2014-05-15 15:45:23.381043832 +0200
@@ -304,7 +304,7 @@
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
if (strcmp(extname, "subjectAltName") == 0) {
-#ifdef HAVE_OPENSSLv1
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
const X509V3_EXT_METHOD *method;
#else
X509V3_EXT_METHOD *method;

View File

@ -1,8 +1,7 @@
diff --git a/src/lib/message.c b/src/lib/message.c
index 24afdf1..5d2c2ef 100644
--- a/src/lib/message.c
+++ b/src/lib/message.c
@@ -37,6 +37,7 @@
diff -Naur bacula-7.0.3.old/src/lib/message.c bacula-7.0.3/src/lib/message.c
--- bacula-7.0.3.old/src/lib/message.c 2014-05-15 15:45:13.744148767 +0200
+++ bacula-7.0.3/src/lib/message.c 2014-05-15 15:51:08.911250228 +0200
@@ -25,6 +25,7 @@
*
*/
@ -10,7 +9,7 @@ index 24afdf1..5d2c2ef 100644
#include "bacula.h"
#include "jcr.h"
@@ -1230,7 +1231,8 @@ e_msg(const char *file, int line, int type, int level, const char *fmt,...)
@@ -1322,7 +1323,8 @@
if (type == M_ABORT) {
char *p = 0;

View File

@ -0,0 +1,9 @@
diff -Naur bacula-7.0.3.old/src/cats/make_sqlite3_tables.in bacula-7.0.3/src/cats/make_sqlite3_tables.in
--- bacula-7.0.3.old/src/cats/make_sqlite3_tables.in 2014-05-15 15:45:13.730148920 +0200
+++ bacula-7.0.3/src/cats/make_sqlite3_tables.in 2014-05-15 15:47:26.465692114 +0200
@@ -458,4 +458,5 @@
END-OF-DATA
chmod 640 ${db_name}.db
+chown bacula:bacula ${db_name}.db
exit 0

View File

@ -1,16 +1,16 @@
diff -Naur bacula-7.0.2.old/configure bacula-7.0.2/configure
--- bacula-7.0.2.old/configure 2014-04-03 09:14:50.713286953 +0200
+++ bacula-7.0.2/configure 2014-04-03 09:14:59.093210079 +0200
@@ -30680,7 +30680,7 @@
diff -Naur bacula-7.0.3.old/configure bacula-7.0.3/configure
--- bacula-7.0.3.old/configure 2014-05-15 15:45:13.795148212 +0200
+++ bacula-7.0.3/configure 2014-05-15 15:55:54.512118343 +0200
@@ -30748,7 +30748,7 @@
exit 1
fi
-ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/install_conf_file src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
+ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/install_conf_file src/qt-console/tray-monitor/tray-monitor.conf src/qt-console/tray-monitor/tray-monitor.pro src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
-ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/install_conf_file src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 updatedb/update_mysql_tables_12_to_14 updatedb/update_sqlite3_tables_12_to_14 updatedb/update_postgresql_tables_12_to_14 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
+ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/install_conf_file src/qt-console/tray-monitor/tray-monitor.conf src/qt-console/tray-monitor/tray-monitor.pro src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 updatedb/update_mysql_tables_12_to_14 updatedb/update_sqlite3_tables_12_to_14 updatedb/update_postgresql_tables_12_to_14 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
ac_config_commands="$ac_config_commands default"
@@ -31813,6 +31813,8 @@
@@ -31879,6 +31879,8 @@
"src/qt-console/bat.pro") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro" ;;
"src/qt-console/bat.pro.mingw32") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro.mingw32" ;;
"src/qt-console/install_conf_file") CONFIG_FILES="$CONFIG_FILES src/qt-console/install_conf_file" ;;

View File

@ -2,8 +2,8 @@
%global username bacula
Name: bacula
Version: 7.0.2
Release: 2%{?dist}
Version: 7.0.3
Release: 1%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details
License: AGPLv3 with exceptions
@ -31,15 +31,14 @@ Source16: %{name}-dir.sysconfig
Source17: %{name}-sd.sysconfig
Source18: %{name}-sd.sysconfig.el5
Patch1: %{name}-5.0.2-openssl.patch
Patch1: %{name}-7.0.3-openssl.patch
Patch2: %{name}-7.0.0-queryfile.patch
Patch3: %{name}-5.0.3-sqlite-priv.patch
Patch4: %{name}-5.2.13-bat-build.patch
Patch5: %{name}-5.2.12-seg-fault.patch
Patch3: %{name}-7.0.3-sqlite-priv.patch
Patch4: %{name}-7.0.3-bat-build.patch
Patch5: %{name}-7.0.3-seg-fault.patch
Patch6: %{name}-5.2.13-logwatch.patch
Patch7: %{name}-non-free-code.patch
Patch8: %{name}-7.0.2-configure.patch
Patch9: %{name}-7.0.2-git.patch
Patch7: %{name}-7.0.3-non-free-code.patch
Patch8: %{name}-7.0.3-tray-monitor-configure.patch
BuildRequires: desktop-file-utils
BuildRequires: perl
@ -295,15 +294,14 @@ Provides check_bacula support for Nagios.
%prep
%setup -q
%patch1 -p2
%patch1 -p1
%patch2 -p1
%patch3 -p0
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p2
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
# Remove execution permissions from files we're packaging as docs later on
@ -737,6 +735,9 @@ fi
%{_libdir}/nagios/plugins/check_bacula
%changelog
* Thu May 15 2014 Simone Caronni <negativo17@gmail.com> - 7.0.3-1
- Update to 7.0.3.
* Thu Apr 24 2014 Simone Caronni <negativo17@gmail.com> - 7.0.2-2
- Bug fixes from upstream.

View File

@ -1 +1 @@
5c85acb539118df0baded1d004d532a4 bacula-7.0.2.tar.gz
d21bd92311396828daa776d3d076a2da bacula-7.0.3.tar.gz