Update to 7.4.0.
This commit is contained in:
parent
949abfaa47
commit
38cff71ea0
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@ bacula-docs-5.0.3.tar.bz2
|
|||||||
/bacula-7.0.4.tar.gz
|
/bacula-7.0.4.tar.gz
|
||||||
/bacula-7.0.5.tar.gz
|
/bacula-7.0.5.tar.gz
|
||||||
/bacula-7.2.0.tar.gz
|
/bacula-7.2.0.tar.gz
|
||||||
|
/bacula-7.4.0.tar.gz
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -Naur bacula-7.0.3.old/src/lib/message.c bacula-7.0.3/src/lib/message.c
|
|
||||||
--- bacula-7.0.3.old/src/lib/message.c 2014-05-15 15:45:13.744148767 +0200
|
|
||||||
+++ bacula-7.0.3/src/lib/message.c 2014-05-15 15:51:08.911250228 +0200
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
*
|
|
||||||
*/
|
|
||||||
|
|
||||||
+#include <assert.h>
|
|
||||||
#include "bacula.h"
|
|
||||||
#include "jcr.h"
|
|
||||||
|
|
||||||
@@ -1322,7 +1323,8 @@
|
|
||||||
|
|
||||||
if (type == M_ABORT) {
|
|
||||||
char *p = 0;
|
|
||||||
- p[0] = 0; /* generate segmentation violation */
|
|
||||||
+ //p[0] = 0; /* generate segmentation violation */
|
|
||||||
+ assert(p!=NULL);
|
|
||||||
}
|
|
||||||
if (type == M_ERROR_TERM) {
|
|
||||||
exit(1);
|
|
@ -1,9 +0,0 @@
|
|||||||
diff -Naur bacula-7.0.3.old/src/cats/make_sqlite3_tables.in bacula-7.0.3/src/cats/make_sqlite3_tables.in
|
|
||||||
--- bacula-7.0.3.old/src/cats/make_sqlite3_tables.in 2014-05-15 15:45:13.730148920 +0200
|
|
||||||
+++ bacula-7.0.3/src/cats/make_sqlite3_tables.in 2014-05-15 15:47:26.465692114 +0200
|
|
||||||
@@ -458,4 +458,5 @@
|
|
||||||
END-OF-DATA
|
|
||||||
|
|
||||||
chmod 640 ${db_name}.db
|
|
||||||
+chown bacula:bacula ${db_name}.db
|
|
||||||
exit 0
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -Naur bacula-7.2.0.old/src/qt-console/bat.pro.in bacula-7.2.0/src/qt-console/bat.pro.in
|
diff -Naur bacula-7.4.0.old/src/qt-console/bat.pro.in bacula-7.4.0/src/qt-console/bat.pro.in
|
||||||
--- bacula-7.2.0.old/src/qt-console/bat.pro.in 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.0.old/src/qt-console/bat.pro.in 2016-01-25 21:00:14.022670354 +0100
|
||||||
+++ bacula-7.2.0/src/qt-console/bat.pro.in 2015-09-29 10:31:49.354763250 +0200
|
+++ bacula-7.4.0/src/qt-console/bat.pro.in 2016-01-25 21:04:26.092297488 +0100
|
||||||
@@ -6,13 +6,13 @@
|
@@ -6,13 +6,13 @@
|
||||||
#
|
#
|
||||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||||
@ -17,10 +17,10 @@ diff -Naur bacula-7.2.0.old/src/qt-console/bat.pro.in bacula-7.2.0/src/qt-consol
|
|||||||
help.files = help/*.html images/status.png images/mail-message-new.png
|
help.files = help/*.html images/status.png images/mail-message-new.png
|
||||||
|
|
||||||
TEMPLATE = app
|
TEMPLATE = app
|
||||||
diff -Naur bacula-7.2.0.old/src/qt-console/main.cpp bacula-7.2.0/src/qt-console/main.cpp
|
diff -Naur bacula-7.4.0.old/src/qt-console/main.cpp bacula-7.4.0/src/qt-console/main.cpp
|
||||||
--- bacula-7.2.0.old/src/qt-console/main.cpp 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.0.old/src/qt-console/main.cpp 2016-01-25 21:00:14.023670369 +0100
|
||||||
+++ bacula-7.2.0/src/qt-console/main.cpp 2015-09-29 10:30:54.252674240 +0200
|
+++ bacula-7.4.0/src/qt-console/main.cpp 2016-01-25 21:04:26.093297507 +0100
|
||||||
@@ -32,9 +32,9 @@
|
@@ -31,9 +31,9 @@
|
||||||
/*
|
/*
|
||||||
* We need Qt version 4.8.4 or later to be able to comple correctly
|
* We need Qt version 4.8.4 or later to be able to comple correctly
|
||||||
*/
|
*/
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur bacula-7.0.3.old/src/lib/crypto.c bacula-7.0.3/src/lib/crypto.c
|
diff -Naur bacula-7.4.0.old/src/lib/crypto.c bacula-7.4.0/src/lib/crypto.c
|
||||||
--- bacula-7.0.3.old/src/lib/crypto.c 2014-05-15 15:45:13.744148767 +0200
|
--- bacula-7.4.0.old/src/lib/crypto.c 2016-01-25 21:00:14.019670307 +0100
|
||||||
+++ bacula-7.0.3/src/lib/crypto.c 2014-05-15 15:45:23.381043832 +0200
|
+++ bacula-7.4.0/src/lib/crypto.c 2016-01-25 21:00:22.216798164 +0100
|
||||||
@@ -39,7 +39,7 @@
|
@@ -42,7 +42,7 @@
|
||||||
* For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
|
* For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
|
||||||
* exists. It was not an official API.
|
* exists. It was not an official API.
|
||||||
*/
|
*/
|
||||||
@ -10,10 +10,10 @@ diff -Naur bacula-7.0.3.old/src/lib/crypto.c bacula-7.0.3/src/lib/crypto.c
|
|||||||
#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
|
#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
|
||||||
#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
|
#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
|
||||||
#endif
|
#endif
|
||||||
diff -Naur bacula-7.0.3.old/src/lib/tls.c bacula-7.0.3/src/lib/tls.c
|
diff -Naur bacula-7.4.0.old/src/lib/tls.c bacula-7.4.0/src/lib/tls.c
|
||||||
--- bacula-7.0.3.old/src/lib/tls.c 2014-05-15 15:45:13.742148789 +0200
|
--- bacula-7.4.0.old/src/lib/tls.c 2016-01-25 21:00:14.019670307 +0100
|
||||||
+++ bacula-7.0.3/src/lib/tls.c 2014-05-15 15:45:23.381043832 +0200
|
+++ bacula-7.4.0/src/lib/tls.c 2016-01-25 21:00:22.218798196 +0100
|
||||||
@@ -304,7 +304,7 @@
|
@@ -329,7 +329,7 @@
|
||||||
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
|
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
|
||||||
|
|
||||||
if (strcmp(extname, "subjectAltName") == 0) {
|
if (strcmp(extname, "subjectAltName") == 0) {
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur bacula-7.2.0/src/dird/bacula-dir.conf.in bacula-7.2.0.new/src/dird/bacula-dir.conf.in
|
diff -Naur bacula-7.4.0.old/src/dird/bacula-dir.conf.in bacula-7.4.0/src/dird/bacula-dir.conf.in
|
||||||
--- bacula-7.2.0/src/dird/bacula-dir.conf.in 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.0.old/src/dird/bacula-dir.conf.in 2016-01-25 21:00:14.020670323 +0100
|
||||||
+++ bacula-7.2.0.new/src/dird/bacula-dir.conf.in 2015-09-29 10:27:30.691039725 +0200
|
+++ bacula-7.4.0/src/dird/bacula-dir.conf.in 2016-01-25 21:01:40.449132870 +0100
|
||||||
@@ -15,7 +15,7 @@
|
@@ -18,7 +18,7 @@
|
||||||
Director { # define myself
|
Director { # define myself
|
||||||
Name = @basename@-dir
|
Name = @basename@-dir
|
||||||
DIRport = @dir_port@ # where we listen for UA connections
|
DIRport = @dir_port@ # where we listen for UA connections
|
||||||
@ -10,9 +10,9 @@ diff -Naur bacula-7.2.0/src/dird/bacula-dir.conf.in bacula-7.2.0.new/src/dird/ba
|
|||||||
WorkingDirectory = "@working_dir@"
|
WorkingDirectory = "@working_dir@"
|
||||||
PidDirectory = "@piddir@"
|
PidDirectory = "@piddir@"
|
||||||
Maximum Concurrent Jobs = 20
|
Maximum Concurrent Jobs = 20
|
||||||
diff -Naur bacula-7.2.0/src/dird/Makefile.in bacula-7.2.0.new/src/dird/Makefile.in
|
diff -Naur bacula-7.4.0.old/src/dird/Makefile.in bacula-7.4.0/src/dird/Makefile.in
|
||||||
--- bacula-7.2.0/src/dird/Makefile.in 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.0.old/src/dird/Makefile.in 2016-01-25 21:00:14.020670323 +0100
|
||||||
+++ bacula-7.2.0.new/src/dird/Makefile.in 2015-09-29 10:29:14.069330577 +0200
|
+++ bacula-7.4.0/src/dird/Makefile.in 2016-01-25 21:01:40.449132870 +0100
|
||||||
@@ -113,11 +113,11 @@
|
@@ -113,11 +113,11 @@
|
||||||
@if test "x${dir_group}" != "x"; then \
|
@if test "x${dir_group}" != "x"; then \
|
||||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
21
bacula-7.4.0-seg-fault.patch
Normal file
21
bacula-7.4.0-seg-fault.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -Naur bacula-7.4.0.old/src/lib/message.c bacula-7.4.0/src/lib/message.c
|
||||||
|
--- bacula-7.4.0.old/src/lib/message.c 2016-01-25 21:00:14.018670291 +0100
|
||||||
|
+++ bacula-7.4.0/src/lib/message.c 2016-01-25 21:07:08.088325232 +0100
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
*
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <assert.h>
|
||||||
|
#include "bacula.h"
|
||||||
|
#include "jcr.h"
|
||||||
|
|
||||||
|
@@ -1329,7 +1330,8 @@
|
||||||
|
if (type == M_ABORT) {
|
||||||
|
assert_msg = bstrdup(buf);
|
||||||
|
char *p = 0;
|
||||||
|
- p[0] = 0; /* generate segmentation violation */
|
||||||
|
+ // p[0] = 0; /* generate segmentation violation */
|
||||||
|
+ assert(p!=NULL);
|
||||||
|
}
|
||||||
|
if (type == M_ERROR_TERM) {
|
||||||
|
exit(1);
|
9
bacula-7.4.0-sqlite-priv.patch
Normal file
9
bacula-7.4.0-sqlite-priv.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
diff -Naur bacula-7.4.0.old/src/cats/make_sqlite3_tables.in bacula-7.4.0/src/cats/make_sqlite3_tables.in
|
||||||
|
--- bacula-7.4.0.old/src/cats/make_sqlite3_tables.in 2016-01-25 21:00:13.970669543 +0100
|
||||||
|
+++ bacula-7.4.0/src/cats/make_sqlite3_tables.in 2016-01-25 21:03:01.266828351 +0100
|
||||||
|
@@ -474,4 +474,5 @@
|
||||||
|
END-OF-DATA
|
||||||
|
|
||||||
|
chmod 640 ${db_name}.db
|
||||||
|
+chown bacula:bacula ${db_name}.db
|
||||||
|
exit 0
|
20
bacula.spec
20
bacula.spec
@ -2,8 +2,8 @@
|
|||||||
%global username bacula
|
%global username bacula
|
||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 7.2.0
|
Version: 7.4.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -33,14 +33,13 @@ Source18: %{name}-sd.sysconfig.el5
|
|||||||
# Image taken from http://www.bacula.org/git/cgit.cgi/bacula/plain/bacula/src/tray-monitor/generic.xpm
|
# Image taken from http://www.bacula.org/git/cgit.cgi/bacula/plain/bacula/src/tray-monitor/generic.xpm
|
||||||
Source19: generic.xpm
|
Source19: generic.xpm
|
||||||
|
|
||||||
Patch1: %{name}-7.0.3-openssl.patch
|
Patch1: %{name}-7.4.0-openssl.patch
|
||||||
Patch2: %{name}-7.2.0-queryfile.patch
|
Patch2: %{name}-7.4.0-queryfile.patch
|
||||||
Patch3: %{name}-7.0.3-sqlite-priv.patch
|
Patch3: %{name}-7.4.0-sqlite-priv.patch
|
||||||
Patch4: %{name}-7.2.0-bat-build.patch
|
Patch4: %{name}-7.4.0-bat-build.patch
|
||||||
Patch5: %{name}-7.0.3-seg-fault.patch
|
Patch5: %{name}-7.4.0-seg-fault.patch
|
||||||
Patch6: %{name}-5.2.13-logwatch.patch
|
Patch6: %{name}-5.2.13-logwatch.patch
|
||||||
Patch7: %{name}-7.2.0-non-free-code.patch
|
Patch7: %{name}-7.2.0-non-free-code.patch
|
||||||
Patch8: %{name}-7.2.0-git.patch
|
|
||||||
|
|
||||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||||
@ -331,7 +330,6 @@ Provides check_bacula support for Nagios.
|
|||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p2
|
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
@ -773,6 +771,10 @@ fi
|
|||||||
%{_libdir}/nagios/plugins/check_bacula
|
%{_libdir}/nagios/plugins/check_bacula
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 25 2016 Simone Caronni <negativo17@gmail.com> - 7.4.0-1
|
||||||
|
- Update to 7.4.0.
|
||||||
|
- Rebase patches, remove git patch.
|
||||||
|
|
||||||
* Sun Dec 13 2015 Simone Caronni <negativo17@gmail.com> - 7.2.0-3
|
* Sun Dec 13 2015 Simone Caronni <negativo17@gmail.com> - 7.2.0-3
|
||||||
- Re-add autoconf patch erraneously removed.
|
- Re-add autoconf patch erraneously removed.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user