Update to 13.0.2
This commit is contained in:
parent
2461b70336
commit
318f6184e8
1
.gitignore
vendored
1
.gitignore
vendored
@ -60,3 +60,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-11.0.6.tar.gz
|
||||
/bacula-13.0.0.tar.gz
|
||||
/bacula-13.0.1.tar.gz
|
||||
/bacula-13.0.2.tar.gz
|
||||
|
@ -1,38 +0,0 @@
|
||||
autoconf: Do not call exit in the getaddrinfo check
|
||||
|
||||
The exit function is not declared in this context, so the check
|
||||
will always fail with compilers which do not accept implicit function
|
||||
declarations. Change the return type of main to int and return
|
||||
directly from main instead.
|
||||
|
||||
Submitted upstream: <https://gitlab.bacula.org/bacula-community-edition/bacula-community/-/issues/2666>
|
||||
|
||||
diff --git a/autoconf/configure.in b/autoconf/configure.in
|
||||
index 56cb94e9a904b47d..937ad330fb68d77b 100644
|
||||
--- a/autoconf/configure.in
|
||||
+++ b/autoconf/configure.in
|
||||
@@ -2585,7 +2585,7 @@ AC_CACHE_CHECK(for working getaddrinfo, ac_cv_working_getaddrinfo,
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
|
||||
- void main(void) {
|
||||
+ int main(void) {
|
||||
struct addrinfo hints, *ai;
|
||||
int error;
|
||||
|
||||
@@ -2594,12 +2594,12 @@ AC_CACHE_CHECK(for working getaddrinfo, ac_cv_working_getaddrinfo,
|
||||
hints.ai_socktype = SOCK_STREAM;
|
||||
error = getaddrinfo("127.0.0.1", NULL, &hints, &ai);
|
||||
if (error) {
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
}
|
||||
if (ai->ai_addr->sa_family != AF_INET) {
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
}
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
],[
|
||||
ac_cv_working_getaddrinfo="yes"
|
@ -2,8 +2,8 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 13.0.1
|
||||
Release: 6%{?dist}
|
||||
Version: 13.0.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -42,7 +42,6 @@ Patch8: %{name}-docker-plugin.patch
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch9: %{name}-autoconf.patch
|
||||
Patch10: %{name}-scripts.patch
|
||||
Patch11: bacula-configure-c99.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-generators
|
||||
@ -643,6 +642,9 @@ exit 0
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Wed Mar 29 2023 Simone Caronni <negativo17@gmail.com> - 13.0.2-1
|
||||
- Update to 13.0.2.
|
||||
|
||||
* Wed Jan 18 2023 Fedora Release Engineering <releng@fedoraproject.org> - 13.0.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-13.0.1.tar.gz) = fd10857d12bb637b9f6e51a03888d8cc93604ba1e793f888304f3c115d48800d7f0d69e30a843355c6760ff8e9b5481c174a24ace1c2adc106cf4ec73646b426
|
||||
SHA512 (bacula-13.0.2.tar.gz) = 5bb6fe935881718879df2ffcfd6bf4a74ee89b224265c44f6e470ec18253f68e93ccc576c374ef9fb9e1755d7f6e60193aee7136d084cedf12d3ffb6a52187bc
|
||||
|
Loading…
Reference in New Issue
Block a user