Update to 5.2.12, remove upstreamed patches
This commit is contained in:
parent
7874639cb5
commit
2e721e241c
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ bacula-docs-5.0.3.tar.bz2
|
|||||||
/bacula-5.2.9.tar.gz
|
/bacula-5.2.9.tar.gz
|
||||||
/bacula-5.2.10.tar.gz
|
/bacula-5.2.10.tar.gz
|
||||||
/bacula-5.2.11.tar.gz
|
/bacula-5.2.11.tar.gz
|
||||||
|
/bacula-5.2.12.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From de1d36e02d149dc1ae76504d4db1a640fd39d0dc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marco van Wieringen <mvw@planets.elm.net>
|
|
||||||
Date: Thu, 13 Sep 2012 07:43:32 +0200
|
|
||||||
Subject: [PATCH] Fix bug #1932 director crash.
|
|
||||||
|
|
||||||
---
|
|
||||||
bacula/src/lib/bsys.c | 3 +--
|
|
||||||
1 files changed, 1 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/bacula/src/lib/bsys.c b/bacula/src/lib/bsys.c
|
|
||||||
index 003585a..f9bd1d2 100644
|
|
||||||
--- a/bacula/src/lib/bsys.c
|
|
||||||
+++ b/bacula/src/lib/bsys.c
|
|
||||||
@@ -53,7 +53,7 @@ static pthread_cond_t timer = PTHREAD_COND_INITIALIZER;
|
|
||||||
int safer_unlink(const char *pathname, const char *regx)
|
|
||||||
{
|
|
||||||
int rc;
|
|
||||||
- regex_t preg1, pexc1;
|
|
||||||
+ regex_t preg1;
|
|
||||||
char prbuf[500];
|
|
||||||
const int nmatch = 30;
|
|
||||||
regmatch_t pmatch[nmatch];
|
|
||||||
@@ -83,7 +83,6 @@ int safer_unlink(const char *pathname, const char *regx)
|
|
||||||
rtn = EROFS;
|
|
||||||
}
|
|
||||||
regfree(&preg1);
|
|
||||||
- regfree(&pexc1);
|
|
||||||
return rtn;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.7
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
From 78e58ff112266e983d099be37a6ec73dfd4e5a21 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Eric Bollengier <eric@baculasystems.com>
|
|
||||||
Date: Thu, 13 Sep 2012 06:49:44 +0000
|
|
||||||
Subject: Fix accurate option in the estimate command
|
|
||||||
|
|
||||||
---
|
|
||||||
diff --git a/bacula/src/dird/ua_cmds.c b/bacula/src/dird/ua_cmds.c
|
|
||||||
index 603990e..d42bc7f 100644
|
|
||||||
--- a/bacula/src/dird/ua_cmds.c
|
|
||||||
+++ b/bacula/src/dird/ua_cmds.c
|
|
||||||
@@ -1144,9 +1144,14 @@ static int estimate_cmd(UAContext *ua, const char *cmd)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
if (strcasecmp(ua->argk[i], NT_("accurate")) == 0) {
|
|
||||||
- if (!is_yesno(ua->argv[i], &accurate)) {
|
|
||||||
- ua->error_msg(_("Invalid value for accurate. "
|
|
||||||
- "It must be yes or no.\n"));
|
|
||||||
+ if (ua->argv[i]) {
|
|
||||||
+ if (!is_yesno(ua->argv[i], &accurate)) {
|
|
||||||
+ ua->error_msg(_("Invalid value for accurate. "
|
|
||||||
+ "It must be yes or no.\n"));
|
|
||||||
+ }
|
|
||||||
+ continue;
|
|
||||||
+ } else {
|
|
||||||
+ ua->error_msg(_("Accurate value missing.\n"));
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
--
|
|
||||||
cgit v0.8.3.4
|
|
11
bacula.spec
11
bacula.spec
@ -2,8 +2,8 @@
|
|||||||
%global username bacula
|
%global username bacula
|
||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 5.2.11
|
Version: 5.2.12
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -32,8 +32,6 @@ Patch1: bacula-5.0.2-openssl.patch
|
|||||||
Patch2: bacula-5.2.2-queryfile.patch
|
Patch2: bacula-5.2.2-queryfile.patch
|
||||||
Patch3: bacula-5.0.3-sqlite-priv.patch
|
Patch3: bacula-5.0.3-sqlite-priv.patch
|
||||||
Patch4: bacula-5.2.11-bat-build.patch
|
Patch4: bacula-5.2.11-bat-build.patch
|
||||||
Patch5: bacula-5.2.11-fix-dir-crash.patch
|
|
||||||
Patch6: bacula-5.2.11-fix-estimate.patch
|
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
@ -290,8 +288,6 @@ Provides check_bacula support for Nagios.
|
|||||||
%patch2 -p1 -b .queryfile
|
%patch2 -p1 -b .queryfile
|
||||||
%patch3 -p0 -b .priv
|
%patch3 -p0 -b .priv
|
||||||
%patch4 -p1 -b .bat-build
|
%patch4 -p1 -b .bat-build
|
||||||
%patch5 -p2 -b .fix-dir-crash
|
|
||||||
%patch6 -p2 -b .fix-estimate
|
|
||||||
|
|
||||||
# Remove execution permissions from files we're packaging as docs later on
|
# Remove execution permissions from files we're packaging as docs later on
|
||||||
find updatedb -type f | xargs chmod -x
|
find updatedb -type f | xargs chmod -x
|
||||||
@ -882,6 +878,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 14 2012 Simone Caronni <negativo17@gmail.com> - 5.2.12-1
|
||||||
|
- Update to 5.2.12, containing only patches from 5.2.11-4.
|
||||||
|
|
||||||
* Fri Sep 14 2012 Simone Caronni <negativo17@gmail.com> - 5.2.11-4
|
* Fri Sep 14 2012 Simone Caronni <negativo17@gmail.com> - 5.2.11-4
|
||||||
- Add a sleep timer for RHEL init scripts restart as Debian does.
|
- Add a sleep timer for RHEL init scripts restart as Debian does.
|
||||||
Problems verified on the sd exiting too early on VMs and slow boxes.
|
Problems verified on the sd exiting too early on VMs and slow boxes.
|
||||||
|
Loading…
Reference in New Issue
Block a user