Update to 9.2.1
This commit is contained in:
parent
08a28adc94
commit
2700e7c6e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-9.0.6.tar.gz
|
||||
/bacula-9.0.7.tar.gz
|
||||
/bacula-9.0.8.tar.gz
|
||||
/bacula-9.2.1.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
--- bacula-9.0.6.old/src/qt-console/tray-monitor/task.cpp 2018-01-28 15:19:14.055587280 -0600
|
||||
+++ bacula-9.0.6/src/qt-console/tray-monitor/task.cpp 2018-01-28 15:18:55.151599308 -0600
|
||||
@@ -992,15 +992,15 @@
|
||||
}
|
||||
|
||||
/* cache the file set */
|
||||
- res->bs->fsend(".bvfs_update jobid=%s\n", jobs.toUtf8());
|
||||
+ res->bs->fsend(".bvfs_update jobid=%s\n", bstrdup(jobs.toUtf8()) );
|
||||
while (get_next_line(res)) {
|
||||
Dmsg2(dbglvl, "<- %d %s\n", res->bs->msglen, curline);
|
||||
}
|
||||
|
||||
if (pathid == 0) {
|
||||
- res->bs->fsend(".bvfs_lsdirs jobid=%s path=\"\"\n", jobs.toUtf8());
|
||||
+ res->bs->fsend(".bvfs_lsdirs jobid=%s path=\"\"\n", bstrdup(jobs.toUtf8()));
|
||||
} else {
|
||||
- res->bs->fsend(".bvfs_lsdirs jobid=%s pathid=%lld\n", jobs.toUtf8(), pathid);
|
||||
+ res->bs->fsend(".bvfs_lsdirs jobid=%s pathid=%lld\n", bstrdup(jobs.toUtf8()), pathid);
|
||||
}
|
||||
|
||||
while (get_next_line(res)) {
|
||||
@@ -1024,9 +1024,9 @@
|
||||
|
||||
/* then, request files */
|
||||
if (pathid == 0) {
|
||||
- res->bs->fsend(".bvfs_lsfiles jobid=%s path=\"\"\n", jobs.toUtf8());
|
||||
+ res->bs->fsend(".bvfs_lsfiles jobid=%s path=\"\"\n", bstrdup(jobs.toUtf8()));
|
||||
} else {
|
||||
- res->bs->fsend(".bvfs_lsfiles jobid=%s pathid=%lld\n", jobs.toUtf8(), pathid);
|
||||
+ res->bs->fsend(".bvfs_lsfiles jobid=%s pathid=%lld\n", bstrdup(jobs.toUtf8()), pathid);
|
||||
}
|
||||
|
||||
while (get_next_line(res)) {
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-9.0.7.old/autoconf/configure.in bacula-9.0.7/autoconf/configure.in
|
||||
--- bacula-9.0.7.old/autoconf/configure.in 2018-05-14 13:11:00.903170609 +0200
|
||||
+++ bacula-9.0.7/autoconf/configure.in 2018-05-14 13:14:07.173620200 +0200
|
||||
@@ -2947,11 +2947,6 @@
|
||||
diff -Naur bacula-9.2.1.old/autoconf/configure.in bacula-9.2.1/autoconf/configure.in
|
||||
--- bacula-9.2.1.old/autoconf/configure.in 2018-08-20 16:48:59.390677113 +0200
|
||||
+++ bacula-9.2.1/autoconf/configure.in 2018-08-20 17:02:58.579289152 +0200
|
||||
@@ -2983,11 +2983,6 @@
|
||||
AC_DEFINE(FDLIBS)
|
||||
|
||||
CFLAGS=${CFLAGS--O}
|
||||
@ -13,10 +13,10 @@ diff -Naur bacula-9.0.7.old/autoconf/configure.in bacula-9.0.7/autoconf/configur
|
||||
LDFLAGS=${LDFLAGS--O}
|
||||
CPPFLAGS="$CPPFLAGS"
|
||||
CFLAGS="$CFLAGS"
|
||||
diff -Naur bacula-9.0.7.old/configure bacula-9.0.7/configure
|
||||
--- bacula-9.0.7.old/configure 2018-05-14 13:11:00.822169109 +0200
|
||||
+++ bacula-9.0.7/configure 2018-05-14 13:13:59.495478007 +0200
|
||||
@@ -30826,11 +30826,6 @@
|
||||
diff -Naur bacula-9.2.1.old/configure bacula-9.2.1/configure
|
||||
--- bacula-9.2.1.old/configure 2018-08-20 16:48:59.380676927 +0200
|
||||
+++ bacula-9.2.1/configure 2018-08-20 17:02:58.582289208 +0200
|
||||
@@ -30881,11 +30881,6 @@
|
||||
|
||||
|
||||
CFLAGS=${CFLAGS--O}
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-9.0.0.old/src/lib/lib.h bacula-9.0.0/src/lib/lib.h
|
||||
--- bacula-9.0.0.old/src/lib/lib.h 2017-07-10 08:52:38.928834471 +0200
|
||||
+++ bacula-9.0.0/src/lib/lib.h 2017-07-10 09:06:14.956314468 +0200
|
||||
@@ -53,7 +53,6 @@
|
||||
diff -Naur bacula-9.2.1.old/src/lib/lib.h bacula-9.2.1/src/lib/lib.h
|
||||
--- bacula-9.2.1.old/src/lib/lib.h 2018-08-20 16:48:59.350676369 +0200
|
||||
+++ bacula-9.2.1/src/lib/lib.h 2018-08-20 16:55:33.168002883 +0200
|
||||
@@ -54,7 +54,6 @@
|
||||
#include "fnmatch.h"
|
||||
#endif
|
||||
#include "md5.h"
|
||||
@ -9,9 +9,9 @@ diff -Naur bacula-9.0.0.old/src/lib/lib.h bacula-9.0.0/src/lib/lib.h
|
||||
#include "tree.h"
|
||||
#include "watchdog.h"
|
||||
#include "btimers.h"
|
||||
diff -Naur bacula-9.0.0.old/src/lib/Makefile.in bacula-9.0.0/src/lib/Makefile.in
|
||||
--- bacula-9.0.0.old/src/lib/Makefile.in 2017-07-10 08:52:38.928834471 +0200
|
||||
+++ bacula-9.0.0/src/lib/Makefile.in 2017-07-10 09:06:49.445973039 +0200
|
||||
diff -Naur bacula-9.2.1.old/src/lib/Makefile.in bacula-9.2.1/src/lib/Makefile.in
|
||||
--- bacula-9.2.1.old/src/lib/Makefile.in 2018-08-20 16:48:59.350676369 +0200
|
||||
+++ bacula-9.2.1/src/lib/Makefile.in 2018-08-20 16:56:16.939817198 +0200
|
||||
@@ -38,7 +38,7 @@
|
||||
flist.h fnmatch.h guid_to_name.h htable.h lex.h \
|
||||
lib.h lz4.h md5.h mem_pool.h message.h \
|
||||
@ -24,13 +24,13 @@ diff -Naur bacula-9.0.0.old/src/lib/Makefile.in bacula-9.0.0/src/lib/Makefile.in
|
||||
@@ -52,7 +52,7 @@
|
||||
guid_to_name.c hmac.c jcr.c lex.c lz4.c alist.c dlist.c \
|
||||
md5.c message.c mem_pool.c openssl.c \
|
||||
plugins.c priv.c queue.c bregex.c \
|
||||
plugins.c priv.c queue.c bregex.c bsockcore.c \
|
||||
- runscript.c rwlock.c scan.c sellist.c serial.c sha1.c sha2.c \
|
||||
+ runscript.c rwlock.c scan.c sellist.c serial.c sha2.c \
|
||||
signal.c smartall.c rblist.c tls.c tree.c \
|
||||
util.c var.c watchdog.c workq.c btimers.c \
|
||||
worker.c flist.c \
|
||||
@@ -218,13 +218,6 @@
|
||||
@@ -217,13 +217,6 @@
|
||||
$(RMF) md5.o
|
||||
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) md5.c
|
||||
|
||||
@ -44,7 +44,7 @@ diff -Naur bacula-9.0.0.old/src/lib/Makefile.in bacula-9.0.0/src/lib/Makefile.in
|
||||
bsnprintf: Makefile bsnprintf.o
|
||||
$(RMF) bsnprintf.o
|
||||
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) bsnprintf.c
|
||||
@@ -274,7 +267,7 @@
|
||||
@@ -287,7 +280,7 @@
|
||||
|
||||
clean: libtool-clean
|
||||
@$(RMF) core a.out *.o *.bak *.tex *.pdf *~ *.intpro *.extpro 1 2 3
|
||||
@ -53,9 +53,9 @@ diff -Naur bacula-9.0.0.old/src/lib/Makefile.in bacula-9.0.0/src/lib/Makefile.in
|
||||
|
||||
realclean: clean
|
||||
@$(RMF) tags
|
||||
diff -Naur bacula-9.0.0.old/src/lib/sha1.c bacula-9.0.0/src/lib/sha1.c
|
||||
--- bacula-9.0.0.old/src/lib/sha1.c 2017-07-10 08:52:38.929834490 +0200
|
||||
+++ bacula-9.0.0/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-9.2.1.old/src/lib/sha1.c bacula-9.2.1/src/lib/sha1.c
|
||||
--- bacula-9.2.1.old/src/lib/sha1.c 2018-08-20 16:48:59.352676406 +0200
|
||||
+++ bacula-9.2.1/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,510 +0,0 @@
|
||||
-/*
|
||||
- * sha1.c
|
||||
@ -567,9 +567,9 @@ diff -Naur bacula-9.0.0.old/src/lib/sha1.c bacula-9.0.0/src/lib/sha1.c
|
||||
- fclose(fd);
|
||||
-}
|
||||
-#endif
|
||||
diff -Naur bacula-9.0.0.old/src/lib/sha1.h bacula-9.0.0/src/lib/sha1.h
|
||||
--- bacula-9.0.0.old/src/lib/sha1.h 2017-07-10 08:52:38.928834471 +0200
|
||||
+++ bacula-9.0.0/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-9.2.1.old/src/lib/sha1.h bacula-9.2.1/src/lib/sha1.h
|
||||
--- bacula-9.2.1.old/src/lib/sha1.h 2018-08-20 16:48:59.350676369 +0200
|
||||
+++ bacula-9.2.1/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,107 +0,0 @@
|
||||
-/*
|
||||
- * sha1.h
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-9.0.0.old/src/lib/message.c bacula-9.0.0/src/lib/message.c
|
||||
--- bacula-9.0.0.old/src/lib/message.c 2017-07-10 08:52:38.928834471 +0200
|
||||
+++ bacula-9.0.0/src/lib/message.c 2017-07-10 09:04:34.923403834 +0200
|
||||
diff -Naur bacula-9.2.1.old/src/lib/message.c bacula-9.2.1/src/lib/message.c
|
||||
--- bacula-9.2.1.old/src/lib/message.c 2018-08-20 16:48:59.351676388 +0200
|
||||
+++ bacula-9.2.1/src/lib/message.c 2018-08-20 16:50:18.934156941 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
*
|
||||
*/
|
||||
@ -9,7 +9,7 @@ diff -Naur bacula-9.0.0.old/src/lib/message.c bacula-9.0.0/src/lib/message.c
|
||||
#include "bacula.h"
|
||||
#include "jcr.h"
|
||||
|
||||
@@ -1367,7 +1368,8 @@
|
||||
@@ -1398,7 +1399,8 @@
|
||||
|
||||
if (type == M_ABORT) {
|
||||
char *p = 0;
|
15
bacula.spec
15
bacula.spec
@ -2,8 +2,8 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 9.0.8
|
||||
Release: 2%{?dist}
|
||||
Version: 9.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -32,14 +32,12 @@ Patch1: %{name}-9.0.6-openssl.patch
|
||||
Patch2: %{name}-9.0.0-queryfile.patch
|
||||
Patch3: %{name}-9.0.4-sqlite-priv.patch
|
||||
Patch4: %{name}-9.0.6-bat-build.patch
|
||||
Patch5: %{name}-9.0.0-seg-fault.patch
|
||||
Patch5: %{name}-9.2.1-seg-fault.patch
|
||||
Patch6: %{name}-5.2.13-logwatch.patch
|
||||
Patch7: %{name}-9.0.0-non-free-code.patch
|
||||
Patch7: %{name}-9.2.1-non-free-code.patch
|
||||
# desktop-file-install not supported on RHEL 6
|
||||
Patch8: %{name}-9.0.2-desktop.patch
|
||||
# http://bugs.bacula.org/view.php?id=2354
|
||||
Patch9: %{name}-9.0.6-tray-monitor-task.patch
|
||||
Patch10: %{name}-9.0.7-g++-options.patch
|
||||
Patch9: %{name}-9.2.1-g++-options.patch
|
||||
|
||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||
@ -734,6 +732,9 @@ fi
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Mon Aug 20 2018 Simone Caronni <negativo17@gmail.com> - 9.2.1-1
|
||||
- Update to 9.2.1.
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-9.0.8.tar.gz) = 4041525f594e23bfb231ea182a680899020347dd26e1d7f6d05c9f97aac8000a1bbeb9acaf2f73b283616fe03caf38fbb335b0e65e6a18e0322ca64da6f98e64
|
||||
SHA512 (bacula-9.2.1.tar.gz) = 6b14372fb505a4c5e084b96154c764b20e173504e335813cfffd406eb1739a301a5352047696501a11fcc297381a9fbed6e0e8714ad62998f02edbd9e0ff8d1b
|
||||
|
Loading…
Reference in New Issue
Block a user