Merge branch 'master' into f17
This commit is contained in:
commit
18e76ed69b
@ -1,62 +0,0 @@
|
|||||||
diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
|
|
||||||
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-24 14:08:57.595272317 +0200
|
|
||||||
+++ bacula-5.2.6/autoconf/configure.in 2012-05-24 14:11:20.313120159 +0200
|
|
||||||
@@ -1264,6 +1264,11 @@
|
|
||||||
if test x${hostname} = x ; then
|
|
||||||
hostname="localhost"
|
|
||||||
fi
|
|
||||||
+dnl Make sure hostname is resolved
|
|
||||||
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
|
|
||||||
+if test ! $? = 0; then
|
|
||||||
+ hostname="localhost"
|
|
||||||
+fi
|
|
||||||
AC_ARG_WITH(hostname,
|
|
||||||
AC_HELP_STRING([--with-hostname=RESNAME], [specify host name for daemons]),
|
|
||||||
[
|
|
||||||
@@ -2858,16 +2863,6 @@
|
|
||||||
MACOSX=
|
|
||||||
COMPRESS_MANPAGES=yes
|
|
||||||
|
|
||||||
-hostname=`uname -n | cut -d '.' -f 1`
|
|
||||||
-if test x${hostname} = x ; then
|
|
||||||
- hostname="localhost"
|
|
||||||
-fi
|
|
||||||
-dnl Make sure hostname is resolved
|
|
||||||
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
|
|
||||||
-if test ! $? = 0; then
|
|
||||||
- hostname="localhost"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
case "$DISTNAME" in
|
|
||||||
aix)
|
|
||||||
DISTVER=`uname -r`
|
|
||||||
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
|
|
||||||
--- bacula-5.2.6.old/configure 2012-05-24 14:08:57.834277377 +0200
|
|
||||||
+++ bacula-5.2.6/configure 2012-05-24 14:12:04.561861019 +0200
|
|
||||||
@@ -23174,6 +23174,10 @@
|
|
||||||
if test x${hostname} = x ; then
|
|
||||||
hostname="localhost"
|
|
||||||
fi
|
|
||||||
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
|
|
||||||
+if test ! $? = 0; then
|
|
||||||
+ hostname="localhost"
|
|
||||||
+fi
|
|
||||||
|
|
||||||
# Check whether --with-hostname was given.
|
|
||||||
if test "${with_hostname+set}" = set; then :
|
|
||||||
@@ -30010,15 +30014,6 @@
|
|
||||||
MACOSX=
|
|
||||||
COMPRESS_MANPAGES=yes
|
|
||||||
|
|
||||||
-hostname=`uname -n | cut -d '.' -f 1`
|
|
||||||
-if test x${hostname} = x ; then
|
|
||||||
- hostname="localhost"
|
|
||||||
-fi
|
|
||||||
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
|
|
||||||
-if test ! $? = 0; then
|
|
||||||
- hostname="localhost"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
case "$DISTNAME" in
|
|
||||||
aix)
|
|
||||||
DISTVER=`uname -r`
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
|
|
||||||
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-23 10:59:38.211938318 +0200
|
|
||||||
+++ bacula-5.2.6/autoconf/configure.in 2012-05-23 11:01:39.984396081 +0200
|
|
||||||
@@ -957,7 +957,7 @@
|
|
||||||
PYTHON_LIBS=`/usr/bin/python-config --libs`
|
|
||||||
else
|
|
||||||
for python_root in /usr /usr/local /usr/sfw; do
|
|
||||||
- for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python3; do
|
|
||||||
+ for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python2.7 python3 python3.1 python3.2; do
|
|
||||||
if test -f $python_root/include/${ver}/Python.h; then
|
|
||||||
PYTHON_INCDIR=-I$python_root/include/${ver}
|
|
||||||
if test -d $python_root/lib64/${ver}/config; then
|
|
||||||
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
|
|
||||||
--- bacula-5.2.6.old/configure 2012-05-23 10:59:38.284939794 +0200
|
|
||||||
+++ bacula-5.2.6/configure 2012-05-23 11:01:34.909293626 +0200
|
|
||||||
@@ -22387,7 +22387,7 @@
|
|
||||||
PYTHON_LIBS=`/usr/bin/python-config --libs`
|
|
||||||
else
|
|
||||||
for python_root in /usr /usr/local /usr/sfw; do
|
|
||||||
- for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python3; do
|
|
||||||
+ for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python2.7 python3 python3.1 python3.2; do
|
|
||||||
if test -f $python_root/include/${ver}/Python.h; then
|
|
||||||
PYTHON_INCDIR=-I$python_root/include/${ver}
|
|
||||||
if test -d $python_root/lib64/${ver}/config; then
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Naur bacula-5.2.6.old/src/filed/xattr.c bacula-5.2.6/src/filed/xattr.c
|
|
||||||
--- bacula-5.2.6.old/src/filed/xattr.c 2012-05-24 14:16:04.413581814 +0200
|
|
||||||
+++ bacula-5.2.6/src/filed/xattr.c 2012-05-24 14:18:19.439600409 +0200
|
|
||||||
@@ -448,6 +448,7 @@
|
|
||||||
* Each xattr valuepair starts with a magic so we can parse it easier.
|
|
||||||
*/
|
|
||||||
current_xattr = (xattr_t *)malloc(sizeof(xattr_t));
|
|
||||||
+ memset(current_xattr, 0, sizeof(xattr_t));
|
|
||||||
current_xattr->magic = XATTR_MAGIC;
|
|
||||||
expected_serialize_len += sizeof(current_xattr->magic);
|
|
||||||
|
|
41
bacula.spec
41
bacula.spec
@ -2,8 +2,8 @@
|
|||||||
%global username bacula
|
%global username bacula
|
||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 5.2.6
|
Version: 5.2.7
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -27,18 +27,11 @@ Source16: bacula-dir.sysconfig
|
|||||||
Source17: bacula-sd.sysconfig
|
Source17: bacula-sd.sysconfig
|
||||||
Source18: bacula-checkconf
|
Source18: bacula-checkconf
|
||||||
|
|
||||||
# bugs.bacula.org #1805: hostname is ignored during configure, always picks "uname -n"
|
Patch1: bacula-5.0.2-openssl.patch
|
||||||
Patch1: bacula-5.2.6-hostname.patch
|
Patch2: bacula-5.2.2-queryfile.patch
|
||||||
Patch2: bacula-5.0.2-openssl.patch
|
Patch3: bacula-5.2.4-log-path.patch
|
||||||
Patch3: bacula-5.2.2-queryfile.patch
|
Patch4: bacula-5.0.3-sqlite-priv.patch
|
||||||
Patch5: bacula-5.2.4-log-path.patch
|
Patch5: bacula-5.2.2-qt-console-optflags.patch
|
||||||
Patch6: bacula-5.0.3-sqlite-priv.patch
|
|
||||||
# Broken python symlink in python-devel, workaround in bacula in case it happens with other versions:
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=824303
|
|
||||||
Patch7: bacula-5.2.6-python-detect.patch
|
|
||||||
Patch8: bacula-5.2.2-qt-console-optflags.patch
|
|
||||||
# bugs.bacula.org #1874: crash with btrfs backup and xattr
|
|
||||||
Patch9: bacula-5.2.6-xattr.patch
|
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
@ -54,7 +47,7 @@ BuildRequires: mysql-devel%{?_isa}
|
|||||||
BuildRequires: ncurses-devel%{?_isa}
|
BuildRequires: ncurses-devel%{?_isa}
|
||||||
BuildRequires: openssl-devel%{?_isa}
|
BuildRequires: openssl-devel%{?_isa}
|
||||||
BuildRequires: postgresql-devel%{?_isa}
|
BuildRequires: postgresql-devel%{?_isa}
|
||||||
BuildRequires: python-devel%{?_isa}
|
BuildRequires: python-devel%{?_isa} >= 2.7.3-3
|
||||||
BuildRequires: readline-devel%{?_isa}
|
BuildRequires: readline-devel%{?_isa}
|
||||||
BuildRequires: sqlite-devel%{?_isa}
|
BuildRequires: sqlite-devel%{?_isa}
|
||||||
BuildRequires: zlib-devel%{?_isa}
|
BuildRequires: zlib-devel%{?_isa}
|
||||||
@ -292,14 +285,11 @@ Provides check_bacula support for Nagios.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .hostname
|
%patch1 -p2 -b .openssl
|
||||||
%patch2 -p2 -b .openssl
|
%patch2 -p1 -b .queryfile
|
||||||
%patch3 -p1 -b .queryfile
|
%patch3 -p1 -b .log-path
|
||||||
%patch5 -p1 -b .log-path
|
%patch4 -p0 -b .priv
|
||||||
%patch6 -p0 -b .priv
|
%patch5 -p1 -b .optflags
|
||||||
%patch7 -p1 -b .python-detect
|
|
||||||
%patch8 -p1 -b .optflags
|
|
||||||
%patch9 -p1 -b .xattr
|
|
||||||
|
|
||||||
# Remove execution permissions from files we're packaging as docs later on
|
# Remove execution permissions from files we're packaging as docs later on
|
||||||
find updatedb -type f | xargs chmod -x
|
find updatedb -type f | xargs chmod -x
|
||||||
@ -839,6 +829,11 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 04 2012 Simone Caronni <negativo17@gmail.com> - 5.2.7-1
|
||||||
|
- Updated to 5.2.7, removed patches included upstream.
|
||||||
|
- Removed python-devel patch, fix included in python package.
|
||||||
|
- Replaced tabs with blanks in spec file (rpmlint).
|
||||||
|
|
||||||
* Mon May 28 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-6
|
* Mon May 28 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-6
|
||||||
- Even if pulled in by dependencies, re-add explict BR on systemd-units.
|
- Even if pulled in by dependencies, re-add explict BR on systemd-units.
|
||||||
- Remove .gz suffix for man pages in file lists as per packaging guidelines.
|
- Remove .gz suffix for man pages in file lists as per packaging guidelines.
|
||||||
|
Loading…
Reference in New Issue
Block a user