Merge branch 'master' into f17

This commit is contained in:
Simone Caronni 2012-06-04 11:40:57 +02:00
commit 18e76ed69b
4 changed files with 195 additions and 297 deletions

View File

@ -1,62 +0,0 @@
diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-24 14:08:57.595272317 +0200
+++ bacula-5.2.6/autoconf/configure.in 2012-05-24 14:11:20.313120159 +0200
@@ -1264,6 +1264,11 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+dnl Make sure hostname is resolved
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
AC_ARG_WITH(hostname,
AC_HELP_STRING([--with-hostname=RESNAME], [specify host name for daemons]),
[
@@ -2858,16 +2863,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-dnl Make sure hostname is resolved
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
--- bacula-5.2.6.old/configure 2012-05-24 14:08:57.834277377 +0200
+++ bacula-5.2.6/configure 2012-05-24 14:12:04.561861019 +0200
@@ -23174,6 +23174,10 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
# Check whether --with-hostname was given.
if test "${with_hostname+set}" = set; then :
@@ -30010,15 +30014,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`

View File

@ -1,24 +0,0 @@
diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-23 10:59:38.211938318 +0200
+++ bacula-5.2.6/autoconf/configure.in 2012-05-23 11:01:39.984396081 +0200
@@ -957,7 +957,7 @@
PYTHON_LIBS=`/usr/bin/python-config --libs`
else
for python_root in /usr /usr/local /usr/sfw; do
- for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python3; do
+ for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python2.7 python3 python3.1 python3.2; do
if test -f $python_root/include/${ver}/Python.h; then
PYTHON_INCDIR=-I$python_root/include/${ver}
if test -d $python_root/lib64/${ver}/config; then
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
--- bacula-5.2.6.old/configure 2012-05-23 10:59:38.284939794 +0200
+++ bacula-5.2.6/configure 2012-05-23 11:01:34.909293626 +0200
@@ -22387,7 +22387,7 @@
PYTHON_LIBS=`/usr/bin/python-config --libs`
else
for python_root in /usr /usr/local /usr/sfw; do
- for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python3; do
+ for ver in python2.2 python2.3 python2.4 python2.5 python2.6 python2.7 python3 python3.1 python3.2; do
if test -f $python_root/include/${ver}/Python.h; then
PYTHON_INCDIR=-I$python_root/include/${ver}
if test -d $python_root/lib64/${ver}/config; then

View File

@ -1,11 +0,0 @@
diff -Naur bacula-5.2.6.old/src/filed/xattr.c bacula-5.2.6/src/filed/xattr.c
--- bacula-5.2.6.old/src/filed/xattr.c 2012-05-24 14:16:04.413581814 +0200
+++ bacula-5.2.6/src/filed/xattr.c 2012-05-24 14:18:19.439600409 +0200
@@ -448,6 +448,7 @@
* Each xattr valuepair starts with a magic so we can parse it easier.
*/
current_xattr = (xattr_t *)malloc(sizeof(xattr_t));
+ memset(current_xattr, 0, sizeof(xattr_t));
current_xattr->magic = XATTR_MAGIC;
expected_serialize_len += sizeof(current_xattr->magic);

View File

@ -1,72 +1,65 @@
%global uid 133
%global username bacula
Name: bacula
Version: 5.2.6
Release: 6%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
Name: bacula
Version: 5.2.7
Release: 1%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details
License: AGPLv3 with exceptions
Group: System Environment/Daemons
URL: http://www.bacula.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
License: AGPLv3 with exceptions
Group: System Environment/Daemons
URL: http://www.bacula.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://www.bacula.org/downloads/Bacula-%{version}/%{name}-%{version}.tar.gz
Source5: README.Fedora
Source6: bacula.logrotate
Source7: bacula-fd.init
Source8: bacula-dir.init
Source9: bacula-sd.init
Source10: bacula-fd.service
Source11: bacula-dir.service
Source12: bacula-sd.service
Source13: bacula-bat.desktop
Source14: bacula-traymonitor.desktop
Source15: bacula-fd.sysconfig
Source16: bacula-dir.sysconfig
Source17: bacula-sd.sysconfig
Source18: bacula-checkconf
Source0: http://www.bacula.org/downloads/Bacula-%{version}/%{name}-%{version}.tar.gz
Source5: README.Fedora
Source6: bacula.logrotate
Source7: bacula-fd.init
Source8: bacula-dir.init
Source9: bacula-sd.init
Source10: bacula-fd.service
Source11: bacula-dir.service
Source12: bacula-sd.service
Source13: bacula-bat.desktop
Source14: bacula-traymonitor.desktop
Source15: bacula-fd.sysconfig
Source16: bacula-dir.sysconfig
Source17: bacula-sd.sysconfig
Source18: bacula-checkconf
# bugs.bacula.org #1805: hostname is ignored during configure, always picks "uname -n"
Patch1: bacula-5.2.6-hostname.patch
Patch2: bacula-5.0.2-openssl.patch
Patch3: bacula-5.2.2-queryfile.patch
Patch5: bacula-5.2.4-log-path.patch
Patch6: bacula-5.0.3-sqlite-priv.patch
# Broken python symlink in python-devel, workaround in bacula in case it happens with other versions:
# https://bugzilla.redhat.com/show_bug.cgi?id=824303
Patch7: bacula-5.2.6-python-detect.patch
Patch8: bacula-5.2.2-qt-console-optflags.patch
# bugs.bacula.org #1874: crash with btrfs backup and xattr
Patch9: bacula-5.2.6-xattr.patch
Patch1: bacula-5.0.2-openssl.patch
Patch2: bacula-5.2.2-queryfile.patch
Patch3: bacula-5.2.4-log-path.patch
Patch4: bacula-5.0.3-sqlite-priv.patch
Patch5: bacula-5.2.2-qt-console-optflags.patch
BuildRequires: desktop-file-utils
BuildRequires: perl
BuildRequires: perl
BuildRequires: sed
BuildRequires: glibc-devel%{?_isa}
BuildRequires: libacl-devel%{?_isa}
BuildRequires: libstdc++-devel%{?_isa}
BuildRequires: libxml2-devel%{?_isa}
BuildRequires: libcap-devel%{?_isa}
BuildRequires: lzo-devel%{?_isa}
BuildRequires: mysql-devel%{?_isa}
BuildRequires: ncurses-devel%{?_isa}
BuildRequires: openssl-devel%{?_isa}
BuildRequires: postgresql-devel%{?_isa}
BuildRequires: python-devel%{?_isa}
BuildRequires: readline-devel%{?_isa}
BuildRequires: sqlite-devel%{?_isa}
BuildRequires: zlib-devel%{?_isa}
BuildRequires: glibc-devel%{?_isa}
BuildRequires: libacl-devel%{?_isa}
BuildRequires: libstdc++-devel%{?_isa}
BuildRequires: libxml2-devel%{?_isa}
BuildRequires: libcap-devel%{?_isa}
BuildRequires: lzo-devel%{?_isa}
BuildRequires: mysql-devel%{?_isa}
BuildRequires: ncurses-devel%{?_isa}
BuildRequires: openssl-devel%{?_isa}
BuildRequires: postgresql-devel%{?_isa}
BuildRequires: python-devel%{?_isa} >= 2.7.3-3
BuildRequires: readline-devel%{?_isa}
BuildRequires: sqlite-devel%{?_isa}
BuildRequires: zlib-devel%{?_isa}
%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
BuildRequires: qt4-devel%{?_isa} >= 4.6.2
BuildRequires: qt4-devel%{?_isa} >= 4.6.2
%endif
%if 0%{?fedora} >= 7 || 0%{?rhel} >= 6
BuildRequires: tcp_wrappers-devel%{?_isa}
BuildRequires: tcp_wrappers-devel%{?_isa}
%else
BuildRequires: tcp_wrappers%{?_isa}
BuildRequires: tcp_wrappers%{?_isa}
%endif
%if 0%{?fedora} >= 15 || 0%{?rhel} > 6
@ -83,9 +76,9 @@ or damaged files.
%package libs
Summary: Bacula libraries
Group: System Environment/Daemons
Obsoletes: bacula-sysconfdir <= 2.4
Summary: Bacula libraries
Group: System Environment/Daemons
Obsoletes: bacula-sysconfdir <= 2.4
%description libs
Bacula is a set of programs that allow you to manage the backup,
@ -97,14 +90,14 @@ Bacula programs.
%package libs-sql
Summary: Bacula SQL libraries
Group: System Environment/Daemons
Obsoletes: bacula-libs-mysql <= 5.0.3
Obsoletes: bacula-libs-sqlite <= 5.0.3
Obsoletes: bacula-libs-postgresql <= 5.0.3
Provides: bacula-libs-mysql = %{version}-%{release}
Provides: bacula-libs-sqlite = %{version}-%{release}
Provides: bacula-libs-postgresql = %{version}-%{release}
Summary: Bacula SQL libraries
Group: System Environment/Daemons
Obsoletes: bacula-libs-mysql <= 5.0.3
Obsoletes: bacula-libs-sqlite <= 5.0.3
Obsoletes: bacula-libs-postgresql <= 5.0.3
Provides: bacula-libs-mysql = %{version}-%{release}
Provides: bacula-libs-sqlite = %{version}-%{release}
Provides: bacula-libs-postgresql = %{version}-%{release}
%description libs-sql
Bacula is a set of programs that allow you to manage the backup,
@ -117,13 +110,13 @@ library through the alternatives system.
%package common
Summary: Common Bacula files
Group: System Environment/Daemons
Obsoletes: bacula-sysconfdir <= 2.4
Provides: group(%username) = %uid
Provides: user(%username) = %uid
Requires(pre): shadow-utils
Requires(postun): shadow-utils
Summary: Common Bacula files
Group: System Environment/Daemons
Obsoletes: bacula-sysconfdir <= 2.4
Provides: group(%username) = %uid
Provides: user(%username) = %uid
Requires(pre): shadow-utils
Requires(postun): shadow-utils
%description common
Bacula is a set of programs that allow you to manage the backup,
@ -134,29 +127,29 @@ This package contains files common to all Bacula daemons.
%package director
Summary: Bacula Director files
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
Requires: logwatch
Summary: Bacula Director files
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
Requires: logwatch
# Director backends merged into core.
Provides: bacula-director-common = %{version}-%{release}
Obsoletes: bacula-director-common < 5.2.3-5
Provides: bacula-director-mysql = %{version}-%{release}
Obsoletes: bacula-director-mysql < 5.2.3-5
Provides: bacula-director-sqlite = %{version}-%{release}
Obsoletes: bacula-director-sqlite < 5.2.3-5
Provides: bacula-director-postgresql = %{version}-%{release}
Obsoletes: bacula-director-postgresql < 5.2.3-5
Provides: bacula-director-common = %{version}-%{release}
Obsoletes: bacula-director-common < 5.2.3-5
Provides: bacula-director-mysql = %{version}-%{release}
Obsoletes: bacula-director-mysql < 5.2.3-5
Provides: bacula-director-sqlite = %{version}-%{release}
Obsoletes: bacula-director-sqlite < 5.2.3-5
Provides: bacula-director-postgresql = %{version}-%{release}
Obsoletes: bacula-director-postgresql < 5.2.3-5
%if 0%{?fedora} >= 15 || 0%{?rhel} > 6
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
%else
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
%endif
%description director
@ -168,28 +161,28 @@ This package contains the director files.
%package storage
Summary: Bacula storage daemon files
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
Summary: Bacula storage daemon files
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
# Storage backends merged into core.
Provides: bacula-storage-common = %{version}-%{release}
Obsoletes: bacula-storage-common < 5.2.2-2
Provides: bacula-storage-mysql = %{version}-%{release}
Obsoletes: bacula-storage-mysql < 5.2.0
Provides: bacula-storage-sqlite = %{version}-%{release}
Obsoletes: bacula-storage-sqlite < 5.2.0
Provides: bacula-storage-postgresql = %{version}-%{release}
Obsoletes: bacula-storage-postgresql < 5.2.0
Provides: bacula-storage-common = %{version}-%{release}
Obsoletes: bacula-storage-common < 5.2.2-2
Provides: bacula-storage-mysql = %{version}-%{release}
Obsoletes: bacula-storage-mysql < 5.2.0
Provides: bacula-storage-sqlite = %{version}-%{release}
Obsoletes: bacula-storage-sqlite < 5.2.0
Provides: bacula-storage-postgresql = %{version}-%{release}
Obsoletes: bacula-storage-postgresql < 5.2.0
%if 0%{?fedora} >= 15 || 0%{?rhel} > 6
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
%else
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
%endif
%description storage
@ -203,19 +196,19 @@ mass storage devices.
%package client
Summary: Bacula backup client
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
Summary: Bacula backup client
Group: System Environment/Daemons
Requires: bacula-common%{?_isa} = %{version}-%{release}
%if 0%{?fedora} >= 15 || 0%{?rhel} > 6
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
%else
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(postun): /sbin/service
%endif
%description client
@ -228,10 +221,10 @@ system to be backed up.
%package console
Summary: Bacula management console
Group: System Environment/Daemons
Obsoletes: bacula-console-gnome <= 2.4
Obsoletes: bacula-console-wxwidgets <= 5.0.3
Summary: Bacula management console
Group: System Environment/Daemons
Obsoletes: bacula-console-gnome <= 2.4
Obsoletes: bacula-console-wxwidgets <= 5.0.3
%description console
@ -245,8 +238,8 @@ backup system.
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
%package console-bat
Summary: Bacula bat console
Group: System Environment/Daemons
Summary: Bacula bat console
Group: System Environment/Daemons
%description console-bat
Bacula is a set of programs that allow you to manage the backup,
@ -257,8 +250,8 @@ This package contains the bat version of the bacula management console.
%package traymonitor
Summary: Bacula system tray monitor
Group: System Environment/Daemons
Summary: Bacula system tray monitor
Group: System Environment/Daemons
%description traymonitor
Bacula is a set of programs that allow you to manage the backup,
@ -271,8 +264,8 @@ monitor your bacula server.
%package devel
Summary: Bacula development files
Group: Development/Libraries
Summary: Bacula development files
Group: Development/Libraries
%description devel
Bacula is a set of programs that allow you to manage the backup,
@ -283,8 +276,8 @@ This development package contains static libraries and header files.
%package -n nagios-plugins-bacula
Summary: Nagios Plugin - check_bacula
Group: Applications/System
Summary: Nagios Plugin - check_bacula
Group: Applications/System
%description -n nagios-plugins-bacula
Provides check_bacula support for Nagios.
@ -292,14 +285,11 @@ Provides check_bacula support for Nagios.
%prep
%setup -q
%patch1 -p1 -b .hostname
%patch2 -p2 -b .openssl
%patch3 -p1 -b .queryfile
%patch5 -p1 -b .log-path
%patch6 -p0 -b .priv
%patch7 -p1 -b .python-detect
%patch8 -p1 -b .optflags
%patch9 -p1 -b .xattr
%patch1 -p2 -b .openssl
%patch2 -p1 -b .queryfile
%patch3 -p1 -b .log-path
%patch4 -p0 -b .priv
%patch5 -p1 -b .optflags
# Remove execution permissions from files we're packaging as docs later on
find updatedb -type f | xargs chmod -x
@ -310,45 +300,45 @@ build() {
export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
export CPPFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
%configure \
--sysconfdir=%{_sysconfdir}/bacula \
--with-dir-user=bacula \
--with-dir-group=bacula \
--with-sd-user=bacula \
--with-sd-group=disk \
--with-fd-user=root \
--with-fd-group=root \
--with-hostname=localhost \
--with-basename=bacula \
--with-dir-password=@@DIR_PASSWORD@@ \
--with-fd-password=@@FD_PASSWORD@@ \
--with-sd-password=@@SD_PASSWORD@@ \
--with-mon-dir-password=@@MON_DIR_PASSWORD@@ \
--with-mon-fd-password=@@MON_FD_PASSWORD@@ \
--with-mon-sd-password=@@MON_SD_PASSWORD@@ \
--with-working-dir=%{_localstatedir}/spool/bacula \
--with-bsrdir=%{_localstatedir}/spool/bacula \
--with-logdir=%{_localstatedir}/log/bacula \
--with-scriptdir=%{_libexecdir}/bacula \
--with-plugindir=%{_libdir}/bacula \
--with-smtp-host=localhost \
--with-subsys-dir=%{_localstatedir}/lock/subsys \
--with-pid-dir=%{_localstatedir}/run \
--disable-conio \
--enable-batch-insert \
--enable-readline \
--enable-largefile \
--enable-build-dird \
--enable-build-stored \
--with-openssl \
--with-tcp-wrappers \
--with-python \
--enable-smartalloc \
--with-x \
--disable-rpath \
--with-sqlite3 \
--with-mysql \
--with-postgresql \
$*
--sysconfdir=%{_sysconfdir}/bacula \
--with-dir-user=bacula \
--with-dir-group=bacula \
--with-sd-user=bacula \
--with-sd-group=disk \
--with-fd-user=root \
--with-fd-group=root \
--with-hostname=localhost \
--with-basename=bacula \
--with-dir-password=@@DIR_PASSWORD@@ \
--with-fd-password=@@FD_PASSWORD@@ \
--with-sd-password=@@SD_PASSWORD@@ \
--with-mon-dir-password=@@MON_DIR_PASSWORD@@ \
--with-mon-fd-password=@@MON_FD_PASSWORD@@ \
--with-mon-sd-password=@@MON_SD_PASSWORD@@ \
--with-working-dir=%{_localstatedir}/spool/bacula \
--with-bsrdir=%{_localstatedir}/spool/bacula \
--with-logdir=%{_localstatedir}/log/bacula \
--with-scriptdir=%{_libexecdir}/bacula \
--with-plugindir=%{_libdir}/bacula \
--with-smtp-host=localhost \
--with-subsys-dir=%{_localstatedir}/lock/subsys \
--with-pid-dir=%{_localstatedir}/run \
--disable-conio \
--enable-batch-insert \
--enable-readline \
--enable-largefile \
--enable-build-dird \
--enable-build-stored \
--with-openssl \
--with-tcp-wrappers \
--with-python \
--enable-smartalloc \
--with-x \
--disable-rpath \
--with-sqlite3 \
--with-mysql \
--with-postgresql \
$*
}
%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
@ -365,13 +355,13 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}
pushd examples/nagios/check_bacula
CFLAGS="%{optflags}" make LIBS="-lpthread -ldl -lssl -lcrypto -lz"
CFLAGS="%{optflags}" make LIBS="-lpthread -ldl -lssl -lcrypto -lz"
popd
%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
pushd src/qt-console/tray-monitor
/usr/bin/qmake-qt4
make %{?_smp_mflags}
/usr/bin/qmake-qt4
make %{?_smp_mflags}
popd
%endif
@ -455,8 +445,8 @@ chmod 644 %{buildroot}%{_libexecdir}/bacula/btraceback.*
# Install headers
mkdir -p %{buildroot}%{_includedir}/bacula
for dir in src src/cats src/console src/dird src/filed src/findlib src/lib src/plugins/fd src/stored; do
mkdir -p %{buildroot}%{_includedir}/bacula/$dir
install -p -m 644 $dir/*.h %{buildroot}%{_includedir}/bacula/$dir
mkdir -p %{buildroot}%{_includedir}/bacula/$dir
install -p -m 644 $dir/*.h %{buildroot}%{_includedir}/bacula/$dir
done
@ -475,19 +465,19 @@ exit 0
%post libs-sql
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-mysql-%{version}.so 50 \
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-mysql-%{version}.so
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-mysql-%{version}.so
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-sqlite3-%{version}.so 40 \
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-sqlite3-%{version}.so
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-sqlite3-%{version}.so
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-postgresql-%{version}.so 60 \
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-postgresql-%{version}.so
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-postgresql-%{version}.so
/sbin/ldconfig
%preun libs-sql
if [ "$1" = 0 ]; then
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-mysql-%{version}.so
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-sqlite3-%{version}.so
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-postgresql-%{version}.so
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-mysql-%{version}.so
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-sqlite3-%{version}.so
/usr/sbin/alternatives --remove libbaccats.so %{_libdir}/libbaccats-postgresql-%{version}.so
fi
@ -619,14 +609,14 @@ fi
%preun client
if [ "$1" = 0 ]; then
/sbin/service bacula-fd stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-fd
/sbin/service bacula-fd stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-fd
fi
%postun client
if [ "$1" -ge "1" ]; then
/sbin/service bacula-fd condrestart >/dev/null 2>&1 || :
/sbin/service bacula-fd condrestart >/dev/null 2>&1 || :
fi
@ -636,14 +626,14 @@ fi
%preun director
if [ "$1" = 0 ]; then
/sbin/service bacula-dir stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-dir
/sbin/service bacula-dir stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-dir
fi
%postun director
if [ "$1" -ge "1" ]; then
/sbin/service bacula-dir condrestart >/dev/null 2>&1 || :
/sbin/service bacula-dir condrestart >/dev/null 2>&1 || :
fi
@ -653,14 +643,14 @@ fi
%preun storage
if [ "$1" = 0 ]; then
/sbin/service bacula-sd stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-sd
/sbin/service bacula-sd stop >/dev/null 2>&1 || :
/sbin/chkconfig --del bacula-sd
fi
%postun storage
if [ "$1" -ge "1" ]; then
/sbin/service bacula-sd condrestart >/dev/null 2>&1 || :
/sbin/service bacula-sd condrestart >/dev/null 2>&1 || :
fi
%endif
@ -839,6 +829,11 @@ fi
%changelog
* Mon Jun 04 2012 Simone Caronni <negativo17@gmail.com> - 5.2.7-1
- Updated to 5.2.7, removed patches included upstream.
- Removed python-devel patch, fix included in python package.
- Replaced tabs with blanks in spec file (rpmlint).
* Mon May 28 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-6
- Even if pulled in by dependencies, re-add explict BR on systemd-units.
- Remove .gz suffix for man pages in file lists as per packaging guidelines.