Add fixes from upstream 7.2 branch

This commit is contained in:
Simone Caronni 2015-12-11 12:09:45 +01:00
parent b5979e3228
commit 1592ddf2ad
4 changed files with 1877 additions and 210 deletions

1871
bacula-7.2.0-git.patch Normal file

File diff suppressed because it is too large Load Diff

View File

@ -1,153 +0,0 @@
diff -Naur bacula-7.2.0/manpages/bpluginfo.8 bacula-7.2.0.new/manpages/bpluginfo.8
--- bacula-7.2.0/manpages/bpluginfo.8 2015-09-29 10:58:59.412811581 +0200
+++ bacula-7.2.0.new/manpages/bpluginfo.8 1970-01-01 01:00:00.000000000 +0100
@@ -1,121 +0,0 @@
-.\" Hey, EMACS: -*- nroff -*-
-.\" First parameter, NAME, should be all caps
-.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
-.\" other parameters are allowed: see man(7), man(1)
-.TH bpluginfo "8" "July 2012" "bpluginfo" "Network backup, recovery and verification"
-.\" Please adjust this date whenever revising the manpage.
-.\"
-.SH NAME
-bpluginfo \- Bacula Plugin information utility
-.SH SYNOPSIS
-.B bplufinfo
-.RI [ options ]
-.I plugin_filename.so
-.br
-.SH DESCRIPTION
-.LP
-The main purpose of
-.B bpluginfo
-is to display different information about Bacula plugin. You can use it to
-check a plugin name, author, license and short description. You can use
-'-f' option to display API implemented by the plugin. Some plugins may require
-additional '-a' option for validating a Bacula Daemons API. In most cases it
-is not required.
-.PP
-./ Bacula is a set of programs for performing a
-./ .PP
-./ -
-./ .BR bpluginfo
-
-.PP
-.SH OPTIONS
-A summary of options is included below.
-.TP
-.B \-h
-Show usage of the program.
-.TP
-.BI \-v
-Verbose information printing all available data from the plugin, including
-plugin header and implemented API.
-.TP
-.BI \-i
-Display short information from plugin header only. This is a default option.
-Option incompatible with
-.B -f
-option.
-.TP
-.BI \-f
-Display information about implemented API functions.
-.TP
-.BI \-a\ <api>
-You can supply the plugin initialization function with a particular Bacula
-API number. Without this option a default API number is '1'. Option require
-a numeric argument.
-.SH RETURN CODE
-.BR bpluginfo
-returns 0 on success, and non-zero on error.
-.TP
-You can check return code to find what was a cause of the error.
- * 0 - success
- * 1 - cannot load a plugin
- * 2 - cannot find a loadPlugin function
- * 3 - cannot find an unloadPlugin function
- * 10 - not enough memory
-.SH EXAMPLE USAGE
-This is an example of bplufinfo usage with verbose option (-v) and default plugin.
-.LP
-.sp
-.RS
-.nf
-
-\fB$ bpluginfo -v bpipe-fd.so
-
-Plugin type: File Daemon plugin
-Plugin magic: *FDPluginData*
-Plugin version: 1
-Plugin release date: January 2008
-Plugin author: Kern Sibbald
-Plugin license: Bacula or Bacula Enterprise
-Plugin description: Bacula Pipe File Daemon Plugin
-Plugin API version: 6
-
-Plugin functions:
- newPlugin()
- freePlugin()
- getPluginValue()
- setPluginValue()
- handlePluginEvent()
- startBackupFile()
- endBackupFile()
- startRestoreFile()
- endRestoreFile()
- pluginIO()
- createFile()
- setFileAttributes()
-.fi
-.RE
-
-.SH AUTHOR
-Written by Radoslaw Korzeniewski (c) Inteos Sp. z o.o.
-.SH BUGS
-Does not handle all required bacula functions callbacks which can lead to
-utility crash.
-.\".SH TODO"
-
-.PP
-
-.PP
-
-.SH "REPORTING BUGS"
-Report bugs to <support@inteos.pl>.
-.SH COPYRIGHT
-Copyright \(co 2012 Free Software Foundation Europe e.V.
-.br
-This is free software; see the source for copying conditions. There is NO
-warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-.SH "SEE ALSO"
-.BR bacula-dir,
-.BR bacula-sd,
-.BR bacula-fd,
-.BR "Bacula Plugins API"
-This man page document is released under the BSD 2-Clause license.
diff -Naur bacula-7.2.0/manpages/Makefile.in bacula-7.2.0.new/manpages/Makefile.in
--- bacula-7.2.0/manpages/Makefile.in 2015-09-29 10:58:59.412811581 +0200
+++ bacula-7.2.0.new/manpages/Makefile.in 2015-09-29 11:08:00.157868223 +0200
@@ -8,7 +8,7 @@
MAN8 = bacula.8 bacula-dir.8 bacula-fd.8 bacula-sd.8 \
bconsole.8 bcopy.8 bextract.8 bls.8 bscan.8 btape.8 \
- btraceback.8 dbcheck.8 bwild.8 bregex.8 bpluginfo.8
+ btraceback.8 dbcheck.8 bwild.8 bregex.8
MAN1 = bsmtp.1 bat.1
diff -Naur bacula-7.2.0/src/tools/Makefile.in bacula-7.2.0.new/src/tools/Makefile.in
--- bacula-7.2.0/src/tools/Makefile.in 2015-09-29 10:58:59.405811697 +0200
+++ bacula-7.2.0.new/src/tools/Makefile.in 2015-09-29 11:07:45.975102788 +0200
@@ -136,12 +136,6 @@
grow: Makefile grow.o ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ grow.o -lbac -lm $(DLIB) $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
-bpluginfo.o: bpluginfo.c
- $(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) -I../filed -I../dird -I../stored $(DINCLUDE) $(CFLAGS) $<
-
-bpluginfo: Makefile bpluginfo.o
- $(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ bpluginfo.o -lbac $(DLIB) $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
-
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
cd $(topdir) \
&& CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status

View File

@ -1,51 +0,0 @@
diff -Naur bacula-7.2.0/configure bacula-7.2.0.new/configure
--- bacula-7.2.0/configure 2015-08-13 15:52:24.000000000 +0200
+++ bacula-7.2.0.new/configure 2015-09-29 10:50:51.758874960 +0200
@@ -30881,7 +30881,7 @@
fi
-ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/bat.pro.mingw64 src/qt-console/install_conf_file src/qt-console/tray-monitor/tray-monitor.pro.mingw32 src/qt-console/tray-monitor/tray-monitor.pro.mingw64 src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables updatedb/update_sqlite3_tables updatedb/update_postgresql_tables updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 updatedb/update_mysql_tables_12_to_13 updatedb/update_postgresql_tables_12_to_13 updatedb/update_mysql_tables_13_to_14 updatedb/update_postgresql_tables_13_to_14 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
+ac_config_files="$ac_config_files autoconf/Make.common Makefile manpages/Makefile scripts/btraceback scripts/bconsole scripts/bacula scripts/bacula-ctl-dir scripts/bacula-ctl-fd scripts/bacula-ctl-sd scripts/devel_bacula scripts/Makefile scripts/logrotate scripts/mtx-changer scripts/disk-changer scripts/dvd-handler scripts/dvd-simulator scripts/logwatch/Makefile scripts/logwatch/logfile.bacula.conf scripts/bat.desktop scripts/bat.desktop.xsu scripts/bat.desktop.consolehelper scripts/bat.console_apps src/Makefile src/host.h src/console/Makefile src/console/bconsole.conf src/qt-console/bat.conf src/qt-console/bat.pro src/qt-console/bat.pro.mingw32 src/qt-console/bat.pro.mingw64 src/qt-console/install_conf_file src/qt-console/tray-monitor/tray-monitor.conf src/qt-console/tray-monitor/tray-monitor.pro src/qt-console/tray-monitor/tray-monitor.pro.mingw32 src/qt-console/tray-monitor/tray-monitor.pro.mingw64 src/dird/Makefile src/dird/bacula-dir.conf src/lib/Makefile src/stored/Makefile src/stored/bacula-sd.conf src/filed/Makefile src/filed/bacula-fd.conf src/cats/Makefile src/cats/make_catalog_backup.pl src/cats/make_catalog_backup src/cats/delete_catalog_backup src/cats/create_postgresql_database src/cats/update_postgresql_tables src/cats/make_postgresql_tables src/cats/grant_postgresql_privileges src/cats/drop_postgresql_tables src/cats/drop_postgresql_database src/cats/create_mysql_database src/cats/update_mysql_tables src/cats/make_mysql_tables src/cats/grant_mysql_privileges src/cats/drop_mysql_tables src/cats/drop_mysql_database src/cats/create_sqlite3_database src/cats/update_sqlite3_tables src/cats/make_sqlite3_tables src/cats/grant_sqlite3_privileges src/cats/drop_sqlite3_tables src/cats/drop_sqlite3_database src/cats/sqlite src/cats/mysql src/cats/create_bacula_database src/cats/update_bacula_tables src/cats/grant_bacula_privileges src/cats/make_bacula_tables src/cats/drop_bacula_tables src/cats/drop_bacula_database src/cats/install-default-backend src/findlib/Makefile src/tools/Makefile src/plugins/fd/Makefile src/plugins/sd/Makefile src/plugins/dir/Makefile po/Makefile.in updatedb/update_mysql_tables updatedb/update_sqlite3_tables updatedb/update_postgresql_tables updatedb/update_mysql_tables_9_to_10 updatedb/update_sqlite3_tables_9_to_10 updatedb/update_postgresql_tables_9_to_10 updatedb/update_mysql_tables_10_to_11 updatedb/update_sqlite3_tables_10_to_11 updatedb/update_postgresql_tables_10_to_11 updatedb/update_mysql_tables_11_to_12 updatedb/update_sqlite3_tables_11_to_12 updatedb/update_postgresql_tables_11_to_12 updatedb/update_mysql_tables_12_to_13 updatedb/update_postgresql_tables_12_to_13 updatedb/update_mysql_tables_13_to_14 updatedb/update_postgresql_tables_13_to_14 examples/nagios/check_bacula/Makefile platforms/rpms/redhat/bacula.spec platforms/rpms/redhat/bacula-bat.spec platforms/rpms/redhat/bacula-docs.spec platforms/rpms/redhat/bacula-mtx.spec platforms/rpms/suse/bacula.spec platforms/rpms/suse/bacula-bat.spec platforms/rpms/suse/bacula-docs.spec platforms/rpms/suse/bacula-mtx.spec $PFILES"
ac_config_commands="$ac_config_commands default"
@@ -32001,6 +32001,8 @@
"src/qt-console/bat.pro.mingw32") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro.mingw32" ;;
"src/qt-console/bat.pro.mingw64") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro.mingw64" ;;
"src/qt-console/install_conf_file") CONFIG_FILES="$CONFIG_FILES src/qt-console/install_conf_file" ;;
+ "src/qt-console/tray-monitor/tray-monitor.conf") CONFIG_FILES="$CONFIG_FILES src/qt-console/tray-monitor/tray-monitor.conf" ;;
+ "src/qt-console/tray-monitor/tray-monitor.pro") CONFIG_FILES="$CONFIG_FILES src/qt-console/tray-monitor/tray-monitor.pro" ;;
"src/qt-console/tray-monitor/tray-monitor.pro.mingw32") CONFIG_FILES="$CONFIG_FILES src/qt-console/tray-monitor/tray-monitor.pro.mingw32" ;;
"src/qt-console/tray-monitor/tray-monitor.pro.mingw64") CONFIG_FILES="$CONFIG_FILES src/qt-console/tray-monitor/tray-monitor.pro.mingw64" ;;
"src/dird/Makefile") CONFIG_FILES="$CONFIG_FILES src/dird/Makefile" ;;
diff -Naur bacula-7.2.0/src/qt-console/tray-monitor/authenticate.cpp bacula-7.2.0.new/src/qt-console/tray-monitor/authenticate.cpp
--- bacula-7.2.0/src/qt-console/tray-monitor/authenticate.cpp 2015-08-13 15:52:24.000000000 +0200
+++ bacula-7.2.0.new/src/qt-console/tray-monitor/authenticate.cpp 2015-09-29 10:53:52.452887255 +0200
@@ -30,7 +30,11 @@
*
*/
+#if defined(HAVE_WIN32)
+#if defined(HAVE_MINGW)
#include "winhdrs.h"
+#endif
+#endif
#include "tray-monitor.h"
void senditf(const char *fmt, ...);
diff -Naur bacula-7.2.0/src/qt-console/tray-monitor/tray-ui.h bacula-7.2.0.new/src/qt-console/tray-monitor/tray-ui.h
--- bacula-7.2.0/src/qt-console/tray-monitor/tray-ui.h 2015-08-13 15:52:24.000000000 +0200
+++ bacula-7.2.0.new/src/qt-console/tray-monitor/tray-ui.h 2015-09-29 10:55:34.295203332 +0200
@@ -27,7 +27,11 @@
# endif
#endif
+#if defined(HAVE_WIN32)
+#if defined(HAVE_MINGW)
#include "winhdrs.h"
+#endif
+#endif
#include <QAction>
#include <QApplication>
#include <QButtonGroup>

View File

@ -3,7 +3,7 @@
Name: bacula Name: bacula
Version: 7.2.0 Version: 7.2.0
Release: 1%{?dist} Release: 2%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details # See LICENSE for details
License: AGPLv3 with exceptions License: AGPLv3 with exceptions
@ -40,8 +40,7 @@ Patch4: %{name}-7.2.0-bat-build.patch
Patch5: %{name}-7.0.3-seg-fault.patch Patch5: %{name}-7.0.3-seg-fault.patch
Patch6: %{name}-5.2.13-logwatch.patch Patch6: %{name}-5.2.13-logwatch.patch
Patch7: %{name}-7.2.0-non-free-code.patch Patch7: %{name}-7.2.0-non-free-code.patch
Patch8: %{name}-7.2.0-tray-monitor-configure.patch Patch8: %{name}-7.2.0-git.patch
Patch9: %{name}-7.2.0-remove-bpluginfo-remnants.patch
# Original patch removed by mistake, upstream is not willing to add it again: # Original patch removed by mistake, upstream is not willing to add it again:
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a # http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
@ -332,9 +331,7 @@ Provides check_bacula support for Nagios.
%patch5 -p1 %patch5 -p1
%patch6 -p1 %patch6 -p1
%patch7 -p1 %patch7 -p1
%patch8 -p1 %patch8 -p2
%patch9 -p1
%patch10 -p1
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} . cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
# Remove execution permissions from files we're packaging as docs later on # Remove execution permissions from files we're packaging as docs later on
@ -775,6 +772,9 @@ fi
%{_libdir}/nagios/plugins/check_bacula %{_libdir}/nagios/plugins/check_bacula
%changelog %changelog
* Fri Dec 11 2015 Simone Caronni <negativo17@gmail.com> - 7.2.0-2
- Add fixes from upstream 7.2 branch.
* Tue Sep 29 2015 Simone Caronni <negativo17@gmail.com> - 7.2.0-1 * Tue Sep 29 2015 Simone Caronni <negativo17@gmail.com> - 7.2.0-1
- Update to 7.2.0. - Update to 7.2.0.
- Remove bpluginfo(8). - Remove bpluginfo(8).