- Update to 0.1.2
This commit is contained in:
parent
1e18a2b458
commit
aa459b5895
@ -1 +1 @@
|
|||||||
babl-0.1.0.tar.bz2
|
babl-0.1.2.tar.bz2
|
||||||
|
@ -1,49 +0,0 @@
|
|||||||
--- extensions/Makefile.am 2009-04-17 13:05:15.000000000 -0400
|
|
||||||
+++ extensions/Makefile.am.new 2009-06-02 16:39:38.659858086 -0400
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
if OS_WIN32
|
|
||||||
AM_LDFLAGS = -module -no-undefined
|
|
||||||
else
|
|
||||||
-AM_LDFLAGS = -module
|
|
||||||
+AM_LDFLAGS = -module -avoid-version
|
|
||||||
endif
|
|
||||||
|
|
||||||
noinst_HEADERS = util.h
|
|
||||||
@@ -12,7 +12,7 @@
|
|
||||||
-I$(top_srcdir)/babl \
|
|
||||||
-I$(top_srcdir)/extensions
|
|
||||||
|
|
||||||
-extdir = $(DESTDIR)$(libdir)/babl-@BABL_API_VERSION@
|
|
||||||
+extdir = $(libdir)/babl-@BABL_API_VERSION@
|
|
||||||
ext_LTLIBRARIES = \
|
|
||||||
CIE-Lab.la \
|
|
||||||
gegl-fixups.la \
|
|
||||||
--- extensions/Makefile.in 2009-05-20 16:42:51.000000000 -0400
|
|
||||||
+++ extensions/Makefile.in.new 2009-06-02 16:47:39.090987339 -0400
|
|
||||||
@@ -50,7 +50,7 @@
|
|
||||||
*) f=$$p;; \
|
|
||||||
esac;
|
|
||||||
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
||||||
-am__installdirs = "$(DESTDIR)$(extdir)"
|
|
||||||
+am__installdirs = "$(extdir)"
|
|
||||||
extLTLIBRARIES_INSTALL = $(INSTALL)
|
|
||||||
LTLIBRARIES = $(ext_LTLIBRARIES)
|
|
||||||
CIE_Lab_la_LIBADD =
|
|
||||||
@@ -233,7 +233,7 @@
|
|
||||||
top_build_prefix = @top_build_prefix@
|
|
||||||
top_builddir = @top_builddir@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
-@OS_WIN32_FALSE@AM_LDFLAGS = -module
|
|
||||||
+@OS_WIN32_FALSE@AM_LDFLAGS = -module -avoid-version
|
|
||||||
@OS_WIN32_TRUE@AM_LDFLAGS = -module -no-undefined
|
|
||||||
noinst_HEADERS = util.h
|
|
||||||
AM_CPPFLAGS = \
|
|
||||||
@@ -242,7 +242,7 @@
|
|
||||||
-I$(top_srcdir)/babl \
|
|
||||||
-I$(top_srcdir)/extensions
|
|
||||||
|
|
||||||
-extdir = $(DESTDIR)$(libdir)/babl-@BABL_API_VERSION@
|
|
||||||
+extdir = $(libdir)/babl-@BABL_API_VERSION@
|
|
||||||
ext_LTLIBRARIES = \
|
|
||||||
CIE-Lab.la \
|
|
||||||
gegl-fixups.la \
|
|
18
babl.spec
18
babl.spec
@ -1,16 +1,12 @@
|
|||||||
Summary: A dynamic, any to any, pixel format conversion library
|
Summary: A dynamic, any to any, pixel format conversion library
|
||||||
Name: babl
|
Name: babl
|
||||||
Version: 0.1.0
|
Version: 0.1.2
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
# The gggl codes contained in this package are under the GPL, with exceptions allowing their use under libraries covered under the LGPL
|
# The gggl codes contained in this package are under the GPL, with exceptions allowing their use under libraries covered under the LGPL
|
||||||
License: LGPLv3+ and GPLv3+
|
License: LGPLv3+ and GPLv3+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gegl.org/babl/
|
URL: http://www.gegl.org/babl/
|
||||||
Source0: ftp://ftp.gtk.org/pub/babl/0.1/%{name}-%{version}.tar.bz2
|
Source0: ftp://ftp.gtk.org/pub/babl/0.1/%{name}-%{version}.tar.bz2
|
||||||
# needed for building, reported upstream at
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=583565, fixed in upstream git
|
|
||||||
# repository already
|
|
||||||
Patch0: babl-build-fix.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: librsvg2 w3m
|
BuildRequires: librsvg2 w3m
|
||||||
|
|
||||||
@ -32,12 +28,11 @@ developing with %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p0 -b .fix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make V=1 %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
@ -66,16 +61,19 @@ rm -rf %{buildroot}
|
|||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%doc AUTHORS ChangeLog COPYING README NEWS
|
%doc AUTHORS ChangeLog COPYING README NEWS
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%{_libdir}/babl-0.0/
|
%{_libdir}/babl-0.1/
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%doc babl_docs/html
|
%doc babl_docs/html
|
||||||
%{_includedir}/babl-0.0/
|
%{_includedir}/babl-0.1/
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%{_libdir}/pkgconfig/%{name}.pc
|
%{_libdir}/pkgconfig/%{name}.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 21 2010 Deji Akingunola <dakingun@gmail.com> - 0.1.2-1
|
||||||
|
- Update to 0.1.2
|
||||||
|
|
||||||
* Fri Dec 18 2009 Deji Akingunola <dakingun@gmail.com> - 0.1.0-5
|
* Fri Dec 18 2009 Deji Akingunola <dakingun@gmail.com> - 0.1.0-5
|
||||||
- Remove the *.la files
|
- Remove the *.la files
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user