- Update to latest release (0.1.0)
This commit is contained in:
parent
96b1f0ea27
commit
71f17a3581
@ -1 +1 @@
|
|||||||
babl-0.0.22.tar.bz2
|
babl-0.1.0.tar.bz2
|
||||||
|
49
babl-build-fix.patch
Normal file
49
babl-build-fix.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
--- extensions/Makefile.am 2009-04-17 13:05:15.000000000 -0400
|
||||||
|
+++ extensions/Makefile.am.new 2009-06-02 16:39:38.659858086 -0400
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
if OS_WIN32
|
||||||
|
AM_LDFLAGS = -module -no-undefined
|
||||||
|
else
|
||||||
|
-AM_LDFLAGS = -module
|
||||||
|
+AM_LDFLAGS = -module -avoid-version
|
||||||
|
endif
|
||||||
|
|
||||||
|
noinst_HEADERS = util.h
|
||||||
|
@@ -12,7 +12,7 @@
|
||||||
|
-I$(top_srcdir)/babl \
|
||||||
|
-I$(top_srcdir)/extensions
|
||||||
|
|
||||||
|
-extdir = $(DESTDIR)$(libdir)/babl-@BABL_API_VERSION@
|
||||||
|
+extdir = $(libdir)/babl-@BABL_API_VERSION@
|
||||||
|
ext_LTLIBRARIES = \
|
||||||
|
CIE-Lab.la \
|
||||||
|
gegl-fixups.la \
|
||||||
|
--- extensions/Makefile.in 2009-05-20 16:42:51.000000000 -0400
|
||||||
|
+++ extensions/Makefile.in.new 2009-06-02 16:47:39.090987339 -0400
|
||||||
|
@@ -50,7 +50,7 @@
|
||||||
|
*) f=$$p;; \
|
||||||
|
esac;
|
||||||
|
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
||||||
|
-am__installdirs = "$(DESTDIR)$(extdir)"
|
||||||
|
+am__installdirs = "$(extdir)"
|
||||||
|
extLTLIBRARIES_INSTALL = $(INSTALL)
|
||||||
|
LTLIBRARIES = $(ext_LTLIBRARIES)
|
||||||
|
CIE_Lab_la_LIBADD =
|
||||||
|
@@ -233,7 +233,7 @@
|
||||||
|
top_build_prefix = @top_build_prefix@
|
||||||
|
top_builddir = @top_builddir@
|
||||||
|
top_srcdir = @top_srcdir@
|
||||||
|
-@OS_WIN32_FALSE@AM_LDFLAGS = -module
|
||||||
|
+@OS_WIN32_FALSE@AM_LDFLAGS = -module -avoid-version
|
||||||
|
@OS_WIN32_TRUE@AM_LDFLAGS = -module -no-undefined
|
||||||
|
noinst_HEADERS = util.h
|
||||||
|
AM_CPPFLAGS = \
|
||||||
|
@@ -242,7 +242,7 @@
|
||||||
|
-I$(top_srcdir)/babl \
|
||||||
|
-I$(top_srcdir)/extensions
|
||||||
|
|
||||||
|
-extdir = $(DESTDIR)$(libdir)/babl-@BABL_API_VERSION@
|
||||||
|
+extdir = $(libdir)/babl-@BABL_API_VERSION@
|
||||||
|
ext_LTLIBRARIES = \
|
||||||
|
CIE-Lab.la \
|
||||||
|
gegl-fixups.la \
|
16
babl.spec
16
babl.spec
@ -1,14 +1,15 @@
|
|||||||
Summary: A dynamic, any to any, pixel format conversion library
|
Summary: A dynamic, any to any, pixel format conversion library
|
||||||
Name: babl
|
Name: babl
|
||||||
Version: 0.0.22
|
Version: 0.1.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# The gggl codes contained in this package are under the GPL, with exceptions allowing their use under libraries covered under the LGPL
|
# The gggl codes contained in this package are under the GPL, with exceptions allowing their use under libraries covered under the LGPL
|
||||||
License: LGPLv3+ and GPLv3+
|
License: LGPLv3+ and GPLv3+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gegl.org/babl/
|
URL: http://www.gegl.org/babl/
|
||||||
Source0: ftp://ftp.gtk.org/pub/babl/0.0/%{name}-%{version}.tar.bz2
|
Source0: ftp://ftp.gtk.org/pub/babl/0.0/%{name}-%{version}.tar.bz2
|
||||||
|
Patch0: babl-build-fix.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: inkscape w3m ruby
|
BuildRequires: librsvg2 w3m
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Babl is a dynamic, any to any, pixel format conversion library. It
|
Babl is a dynamic, any to any, pixel format conversion library. It
|
||||||
@ -28,9 +29,11 @@ developing with %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p0 -b .fix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure --disable-static
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -55,7 +58,7 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%doc AUTHORS ChangeLog COPYING COPYING.LESSER README NEWS
|
%doc AUTHORS ChangeLog COPYING README NEWS
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%{_libdir}/babl-0.0/
|
%{_libdir}/babl-0.0/
|
||||||
|
|
||||||
@ -67,6 +70,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/pkgconfig/%{name}.pc
|
%{_libdir}/pkgconfig/%{name}.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 22 2009 Deji Akingunola <dakingun@gmail.com> - 0.1.0-1
|
||||||
|
- Update to latest release (0.1.0)
|
||||||
|
|
||||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-3
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user