- Apply patch to fix extensions loading on 64bit systems

This commit is contained in:
Deji Akingunola 2008-02-09 05:49:30 +00:00
parent f6559ff95e
commit 2fd1111f83
2 changed files with 30 additions and 1 deletions

View File

@ -0,0 +1,22 @@
--- babl/Makefile.am 2008-01-16 20:23:00.000000000 -0500
+++ babl/Makefile.am.new 2008-01-17 16:05:51.000000000 -0500
@@ -45,7 +45,7 @@
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/babl/base
-AM_CPPFLAGS = -DPREFIX=\""$(prefix)"\"
+AM_CPPFLAGS = -DLIBDIR=\""$(libdir)"\"
lib_LTLIBRARIES= libbabl-@BABL_API_VERSION@.la
libbabl_@BABL_API_VERSION@_la_SOURCES= $(h_sources) $(c_sources)
--- babl/babl-extension.c 2008-01-16 20:23:00.000000000 -0500
+++ babl/babl-extension.c.new 2008-01-17 16:06:32.000000000 -0500
@@ -22,7 +22,7 @@
#include "config.h"
#endif
-#define BABL_PATH PREFIX "/lib/" BABL_LIBRARY
+#define BABL_PATH LIBDIR "/" BABL_LIBRARY
#define BABL_INIT_HOOK init_hook ();
#define BABL_DESTROY_HOOK destroy_hook ();

View File

@ -1,14 +1,16 @@
Summary: A dynamic, any to any, pixel format conversion library
Name: babl
Version: 0.0.18
Release: 1%{?dist}
Release: 2%{?dist}
# The gggl codes contained in this package are under the GPL, with exceptions allowing their use under libraries covered under the LGPL
License: LGPLv3+ and GPLv3+
Group: System Environment/Libraries
URL: http://www.gegl.org/babl/
Source0: ftp://ftp.gtk.org/pub/babl/0.0/%{name}-%{version}.tar.bz2
Patch0: babl-extensions-path.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: inkscape w3m ruby
BuildRequires: automake autoconf libtool
%description
Babl is a dynamic, any to any, pixel format conversion library. It
@ -28,8 +30,10 @@ developing with %{name}.
%prep
%setup -q
%patch0 -p0 -b .ext
%build
./automake.sh
%configure
make %{?_smp_mflags}
@ -67,6 +71,9 @@ rm -rf %{buildroot}
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Thu Jan 17 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.18-2
- Apply patch to fix extensions loading on 64bit systems
* Thu Jan 10 2008 Deji Akingunola <dakingun@gmail.com> - 0.0.18-1
- Update to 0.0.18