RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/babel#cec400854373b9ab2ac275fa961a07775a76bc20
This commit is contained in:
parent
211ff7f0c6
commit
ecfb8436c0
8
.gitignore
vendored
8
.gitignore
vendored
@ -0,0 +1,8 @@
|
||||
Babel-0.9.5.tar.gz
|
||||
/Babel-0.9.6.tar.gz
|
||||
/Babel-1.3.tar.gz
|
||||
/Babel-2.3.4.tar.gz
|
||||
/Babel-2.5.1.tar.gz
|
||||
/Babel-2.6.0.tar.gz
|
||||
/Babel-2.7.0.tar.gz
|
||||
/Babel-2.8.0.tar.gz
|
66
babel-python39a6-compat.patch
Normal file
66
babel-python39a6-compat.patch
Normal file
@ -0,0 +1,66 @@
|
||||
commit f3651bebd3216cc276f7642c3807cc8d08f2bd23
|
||||
Author: Felix Schwarz <felix.schwarz@oss.schwarz.eu>
|
||||
Date: Tue May 5 08:05:56 2020 +0000
|
||||
|
||||
fix tests when using Python 3.9a6
|
||||
|
||||
In Python 3.9a6 integer values for future flags were changed to prevent
|
||||
collision with compiler flags. We need to retrieve these at runtime so
|
||||
the test suite works with Python <= 3.8 as well as Python 3.9.
|
||||
|
||||
diff --git a/tests/test_util.py b/tests/test_util.py
|
||||
index a6a4450..b9343aa 100644
|
||||
--- a/tests/test_util.py
|
||||
+++ b/tests/test_util.py
|
||||
@@ -11,6 +11,7 @@
|
||||
# individuals. For the exact contribution history, see the revision
|
||||
# history and logs, available at http://babel.edgewall.org/log/.
|
||||
|
||||
+import __future__
|
||||
import unittest
|
||||
|
||||
import pytest
|
||||
@@ -20,6 +21,12 @@ from babel._compat import BytesIO
|
||||
from babel.util import parse_future_flags
|
||||
|
||||
|
||||
+class _FF:
|
||||
+ division = __future__.division.compiler_flag
|
||||
+ print_function = __future__.print_function.compiler_flag
|
||||
+ with_statement = __future__.with_statement.compiler_flag
|
||||
+ unicode_literals = __future__.unicode_literals.compiler_flag
|
||||
+
|
||||
def test_distinct():
|
||||
assert list(util.distinct([1, 2, 1, 3, 4, 4])) == [1, 2, 3, 4]
|
||||
assert list(util.distinct('foobar')) == ['f', 'o', 'b', 'a', 'r']
|
||||
@@ -70,25 +77,25 @@ def test_parse_encoding_non_ascii():
|
||||
from __future__ import print_function,
|
||||
division, with_statement,
|
||||
unicode_literals
|
||||
-''', 0x10000 | 0x2000 | 0x8000 | 0x20000),
|
||||
+''', _FF.print_function | _FF.division | _FF.with_statement | _FF.unicode_literals),
|
||||
('''
|
||||
from __future__ import print_function, division
|
||||
print('hello')
|
||||
-''', 0x10000 | 0x2000),
|
||||
+''', _FF.print_function | _FF.division),
|
||||
('''
|
||||
from __future__ import print_function, division, unknown,,,,,
|
||||
print 'hello'
|
||||
-''', 0x10000 | 0x2000),
|
||||
+''', _FF.print_function | _FF.division),
|
||||
('''
|
||||
from __future__ import (
|
||||
print_function,
|
||||
division)
|
||||
-''', 0x10000 | 0x2000),
|
||||
+''', _FF.print_function | _FF.division),
|
||||
('''
|
||||
from __future__ import \\
|
||||
print_function, \\
|
||||
division
|
||||
-''', 0x10000 | 0x2000),
|
||||
+''', _FF.print_function | _FF.division),
|
||||
])
|
||||
def test_parse_future(source, result):
|
||||
fp = BytesIO(source.encode('latin-1'))
|
446
babel.spec
Normal file
446
babel.spec
Normal file
@ -0,0 +1,446 @@
|
||||
%global srcname Babel
|
||||
%global sum Library for internationalizing Python applications
|
||||
|
||||
# There is some bootstrapping involved when upgrading Python 3
|
||||
# First of all we need babel (this package) to use sphinx
|
||||
# And pytest is at this point not yet ready
|
||||
%bcond_with bootstrap
|
||||
|
||||
%bcond_without python2
|
||||
# We ship python2-pytest only up to F31.
|
||||
%if !0%{?fedora}%{?rhel} || 0%{?fedora} >= 32 || 0%{?rhel} >= 9
|
||||
%bcond_with python2_pytest
|
||||
%else
|
||||
%bcond_without python2_pytest
|
||||
%endif
|
||||
|
||||
|
||||
Name: babel
|
||||
Version: 2.8.0
|
||||
Release: 7%{?dist}
|
||||
Summary: Tools for internationalizing Python applications
|
||||
|
||||
License: BSD
|
||||
URL: https://babel.pocoo.org/
|
||||
Source0: %{pypi_source}
|
||||
# https://github.com/python-babel/babel/pull/712
|
||||
Patch0: babel-python39a6-compat.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%if %{with python2}
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-setuptools
|
||||
%if %{with python2_pytest}
|
||||
BuildRequires: python2-pytz
|
||||
BuildRequires: python2-pytest
|
||||
BuildRequires: python2-freezegun
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
%if !%{with bootstrap}
|
||||
BuildRequires: python3-pytz
|
||||
BuildRequires: python3-pytest
|
||||
BuildRequires: python3-freezegun
|
||||
%endif
|
||||
|
||||
# build the documentation
|
||||
BuildRequires: make
|
||||
|
||||
%if !%{with bootstrap}
|
||||
BuildRequires: python3-sphinx
|
||||
%endif
|
||||
Requires: python3-babel
|
||||
Requires: python3-setuptools
|
||||
|
||||
|
||||
%description
|
||||
Babel is composed of two major parts:
|
||||
|
||||
* tools to build and work with gettext message catalogs
|
||||
|
||||
* a Python interface to the CLDR (Common Locale Data Repository),
|
||||
providing access to various locale display names, localized number
|
||||
and date formatting, etc.
|
||||
|
||||
|
||||
%if %{with python2}
|
||||
%package -n python2-babel
|
||||
Summary: %sum
|
||||
|
||||
Requires: python2-setuptools
|
||||
Requires: python2-pytz
|
||||
|
||||
%{?python_provide:%python_provide python2-babel}
|
||||
|
||||
%description -n python2-babel
|
||||
Babel is composed of two major parts:
|
||||
|
||||
* tools to build and work with gettext message catalogs
|
||||
|
||||
* a Python interface to the CLDR (Common Locale Data Repository),
|
||||
providing access to various locale display names, localized number
|
||||
and date formatting, etc.
|
||||
%endif
|
||||
|
||||
|
||||
%package -n python3-babel
|
||||
Summary: %sum
|
||||
|
||||
%if %{without python2}
|
||||
Obsoletes: python2-babel < 2.7.0-6%{?dist}
|
||||
%endif
|
||||
|
||||
Requires: python3-setuptools
|
||||
Requires: python3-pytz
|
||||
|
||||
%{?python_provide:%python_provide python3-babel}
|
||||
|
||||
%description -n python3-babel
|
||||
Babel is composed of two major parts:
|
||||
|
||||
* tools to build and work with gettext message catalogs
|
||||
|
||||
* a Python interface to the CLDR (Common Locale Data Repository),
|
||||
providing access to various locale display names, localized number
|
||||
and date formatting, etc.
|
||||
|
||||
%if !%{with bootstrap}
|
||||
%package doc
|
||||
Summary: Documentation for Babel
|
||||
Provides: python-babel-doc = %{version}-%{release}
|
||||
Provides: python2-babel-doc = %{version}-%{release}
|
||||
Provides: python3-babel-doc = %{version}-%{release}
|
||||
|
||||
%description doc
|
||||
Documentation for Babel
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{srcname}-%{version}
|
||||
|
||||
%build
|
||||
%if %{with python2}
|
||||
%py2_build
|
||||
%endif
|
||||
%py3_build
|
||||
|
||||
BUILDDIR="$PWD/built-docs"
|
||||
rm -rf "$BUILDDIR"
|
||||
|
||||
%if !%{with bootstrap}
|
||||
pushd docs
|
||||
make \
|
||||
SPHINXBUILD=sphinx-build-3 \
|
||||
BUILDDIR="$BUILDDIR" \
|
||||
html
|
||||
popd
|
||||
rm -f "$BUILDDIR/html/.buildinfo"
|
||||
%endif
|
||||
|
||||
%install
|
||||
%if %{with python2}
|
||||
%py2_install
|
||||
%endif
|
||||
%py3_install
|
||||
|
||||
%check
|
||||
export TZ=America/New_York
|
||||
%if %{with python2} && %{with python2_pytest}
|
||||
%{__python2} -m pytest
|
||||
%endif
|
||||
%if !%{with bootstrap}
|
||||
%{__python3} -m pytest
|
||||
%endif
|
||||
|
||||
%files
|
||||
%doc CHANGES AUTHORS
|
||||
%license LICENSE
|
||||
%{_bindir}/pybabel
|
||||
|
||||
%if %{with python2}
|
||||
%files -n python2-babel
|
||||
%{python2_sitelib}/Babel-%{version}-py*.egg-info
|
||||
%{python2_sitelib}/babel
|
||||
%endif
|
||||
|
||||
%files -n python3-babel
|
||||
%{python3_sitelib}/Babel-%{version}-py*.egg-info
|
||||
%{python3_sitelib}/babel
|
||||
|
||||
%if !%{with bootstrap}
|
||||
%files doc
|
||||
%doc built-docs/html/*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 2.8.0-6
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 2.8.0-5
|
||||
- Bootstrap for Python 3.9
|
||||
|
||||
* Fri May 08 2020 Felix Schwarz <fschwarz@fedoraproject.org> - 2.8.0-4
|
||||
- reenable Python 2 subpackage for Fedora 33+ (rhbz #1737930)
|
||||
|
||||
* Tue May 05 2020 Felix Schwarz <fschwarz@fedoraproject.org> - 2.8.0-3
|
||||
- add patch for compatibility with Python 3.9a6
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jan 02 2020 Felix Schwarz <fschwarz@fedoraproject.org> - 2.8.0-1
|
||||
- update to upstream version 2.8.0
|
||||
|
||||
* Thu Oct 31 2019 Nils Philippsen <nils@tiptoe.de> - 2.7.0-7
|
||||
- drop python2-babel only from F33 on as it is needed for trac (for the time
|
||||
being, #1737930)
|
||||
|
||||
* Thu Oct 31 2019 Nils Philippsen <nils@tiptoe.de> - 2.7.0-6
|
||||
- drop python2-babel from F32 on
|
||||
|
||||
* Fri Sep 13 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.0-5
|
||||
- Reduce Python 2 build dependencies on Fedora 32
|
||||
|
||||
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.0-4
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.0-3
|
||||
- Bootstrap for Python 3.8
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon May 27 2019 Felix Schwarz <fschwarz@fedoraproject.org> - 2.7.0-1
|
||||
- update to upstream version 2.7.0
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 2.6.0-4
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 2.6.0-3
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Fri Jun 29 2018 Felix Schwarz <fschwarz@fedoraproject.org> - 2.6.0-2
|
||||
- add setting to build without Python 2 support
|
||||
|
||||
* Fri Jun 29 2018 Felix Schwarz <fschwarz@fedoraproject.org> - 2.6.0-1
|
||||
- update to upstream version 2.6.0
|
||||
|
||||
* Mon Jun 18 2018 Tomas Orsava <torsava@redhat.com> - 2.5.1-5
|
||||
- Run tests in pytest (as declared in BuildRequires)
|
||||
|
||||
* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 2.5.1-4
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 2.5.1-3
|
||||
- Bootstrap for Python 3.7
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Dec 15 2017 Felix Schwarz <fschwarz@fedoraproject.org> - 2.5.1-1
|
||||
- update to upstream version 2.5.1
|
||||
|
||||
* Fri Dec 15 2017 Iryna Shcherbina <ishcherb@redhat.com> - 2.3.4-7
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Dec 13 2016 Miro Hrončok <mhroncok@redhat.com> - 2.3.4-4
|
||||
- Finish bootstrapping for Python 3.6
|
||||
|
||||
* Tue Dec 13 2016 Miro Hrončok <mhroncok@redhat.com> - 2.3.4-3
|
||||
- Rebuild for Python 3.6
|
||||
- Add "bootstrap" conditions
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.4-2
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Tue May 31 2016 Nils Philippsen <nils@redhat.com>
|
||||
- fix source URL
|
||||
|
||||
* Mon Apr 25 2016 Nils Philippsen <nils@redhat.com> - 2.3.4-1
|
||||
- version 2.3.4
|
||||
- always build Python3 subpackages
|
||||
- remove obsolete packaging constructs
|
||||
- update to current Python packaging guidelines
|
||||
- build docs non-destructively
|
||||
- tag license file as %%license
|
||||
- use %%python_provide macro only if present
|
||||
- update remove-pytz-version patch
|
||||
- fix build dependencies
|
||||
- set TZ in %%check
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Fri Nov 6 2015 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3-10
|
||||
- Also make sure that the babel package that has pybabel depends on the correct
|
||||
packages (python2 packages on F23 or less and python3 packages on F24 and
|
||||
greater.)
|
||||
|
||||
* Wed Nov 4 2015 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3-9
|
||||
- Install the python3 version of pybabel on Fedora 24+ to match with Fedora's
|
||||
default python version
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Dec 17 2014 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3-7
|
||||
- Remove pytz version requirement in egginfo as it confuses newer setuptools
|
||||
|
||||
* Mon Jun 30 2014 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3-6
|
||||
- Change python-setuptools-devel BR into python-setuptools
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
|
||||
|
||||
* Wed Apr 02 2014 Nils Philippsen <nils@redhat.com> - 1.3-3
|
||||
- fix dependencies (#1083470)
|
||||
|
||||
* Sun Oct 06 2013 Felix Schwarz <fschwarz@fedoraproject.org> - 1.3-2
|
||||
- enable python3 subpackage
|
||||
|
||||
* Wed Oct 02 2013 Felix Schwarz <fschwarz@fedoraproject.org> - 1.3-1
|
||||
- update to Babel 1.3
|
||||
- disabled %%check as it tries to download the CLDR
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jun 26 2013 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.6-8
|
||||
- split documentation off to a separate subpackage
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Oct 18 2012 Nils Philippsen <nils@redhat.com> - 0.9.6-6
|
||||
- run tests in %%check
|
||||
- add pytz build requirement for tests
|
||||
|
||||
* Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 0.9.6-5
|
||||
- rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
|
||||
|
||||
* Wed Aug 01 2012 Felix Schwarz <felix.schwarz@oss.schwarz.eu> - 0.9.6-4
|
||||
- disable building of non-functional python3 subpackage (#761583)
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Jun 07 2011 Nils Philippsen <nils@redhat.com> - 0.9.6-1
|
||||
- version 0.9.6:
|
||||
* Backport r493-494: documentation typo fixes.
|
||||
* Make the CLDR import script work with Python 2.7.
|
||||
* Fix various typos.
|
||||
* Fixed Python 2.3 compatibility (ticket #146, #233).
|
||||
* Sort output of list-locales.
|
||||
* Make the POT-Creation-Date of the catalog being updated equal to
|
||||
POT-Creation-Date of the template used to update (ticket #148).
|
||||
* Use a more explicit error message if no option or argument (command) is
|
||||
passed to pybabel (ticket #81).
|
||||
* Keep the PO-Revision-Date if it is not the default value (ticket #148).
|
||||
* Make --no-wrap work by reworking --width's default and mimic xgettext's
|
||||
behaviour of always wrapping comments (ticket #145).
|
||||
* Fixed negative offset handling of Catalog._set_mime_headers (ticket #165).
|
||||
* Add --project and --version options for commandline (ticket #173).
|
||||
* Add a __ne__() method to the Local class.
|
||||
* Explicitly sort instead of using sorted() and don't assume ordering
|
||||
(Python 2.3 and Jython compatibility).
|
||||
* Removed ValueError raising for string formatting message checkers if the
|
||||
string does not contain any string formattings (ticket #150).
|
||||
* Fix Serbian plural forms (ticket #213).
|
||||
* Small speed improvement in format_date() (ticket #216).
|
||||
* Fix number formatting for locales where CLDR specifies alt or draft
|
||||
items (ticket #217)
|
||||
* Fix bad check in format_time (ticket #257, reported with patch and tests by
|
||||
jomae)
|
||||
* Fix so frontend.CommandLineInterface.run does not accumulate logging
|
||||
handlers (#227, reported with initial patch by dfraser)
|
||||
* Fix exception if environment contains an invalid locale setting (#200)
|
||||
- install python2 rather than python3 executable (#710880)
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Aug 26 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.5-3
|
||||
- Add python3 subpackage
|
||||
|
||||
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||
|
||||
* Wed Apr 7 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.5-1
|
||||
- This release contains a small number of bugfixes over the 0.9.4
|
||||
- release.
|
||||
-
|
||||
- What's New:
|
||||
- -----------
|
||||
- * Fixed the case where messages containing square brackets would break
|
||||
- with an unpack error
|
||||
- * Fuzzy matching regarding plurals should *NOT* be checked against
|
||||
- len(message.id) because this is always 2, instead, it's should be
|
||||
- checked against catalog.num_plurals (ticket #212).
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Sat Mar 28 2009 Robert Scheck <robert@fedoraproject.org> - 0.9.4-4
|
||||
- Added missing requires to python-setuptools for pkg_resources
|
||||
|
||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.9.4-2
|
||||
- Rebuild for Python 2.6
|
||||
|
||||
* Mon Aug 25 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.4-1
|
||||
- Update to 0.9.4
|
||||
|
||||
* Thu Jul 10 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.3-1
|
||||
- Update to 0.9.3
|
||||
|
||||
* Sun Dec 16 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.1-1
|
||||
- Update to 0.9.1
|
||||
|
||||
* Tue Aug 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9-2
|
||||
- BR python-setuptools-devel
|
||||
|
||||
* Mon Aug 27 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9-1
|
||||
- Update to 0.9
|
||||
|
||||
* Mon Jul 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.8.1-1
|
||||
- Update to 0.8.1
|
||||
- Remove upstreamed patch.
|
||||
|
||||
* Fri Jun 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.8-3
|
||||
- Replace patch with one that actually applies.
|
||||
|
||||
* Fri Jun 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.8-2
|
||||
- Apply upstream patch to rename command line script to "pybabel" - BZ#246208
|
||||
|
||||
* Thu Jun 21 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.8-1
|
||||
- First version for Fedora
|
||||
|
Loading…
Reference in New Issue
Block a user