26 lines
1.0 KiB
Diff
26 lines
1.0 KiB
Diff
diff --git a/awscli/customizations/eks/ordered_yaml.py b/awscli/customizations/eks/ordered_yaml.py
|
|
index 23834e0..828280a 100644
|
|
--- a/awscli/customizations/eks/ordered_yaml.py
|
|
+++ b/awscli/customizations/eks/ordered_yaml.py
|
|
@@ -46,6 +46,7 @@ def ordered_yaml_dump(to_dump, stream=None):
|
|
:type stream: file
|
|
"""
|
|
yaml = ruamel.yaml.YAML(typ="safe", pure=True)
|
|
+ yaml.width = 99999
|
|
yaml.default_flow_style = False
|
|
yaml.Representer.add_representer(OrderedDict, _ordered_representer)
|
|
|
|
diff --git a/pyproject.toml b/pyproject.toml
|
|
index db82f2a..991ddfa 100644
|
|
--- a/pyproject.toml
|
|
+++ b/pyproject.toml
|
|
@@ -31,7 +31,7 @@ dependencies = [
|
|
"colorama>=0.2.5,<0.4.7",
|
|
"docutils>=0.10,<0.20",
|
|
"cryptography>=3.3.2,<40.0.2",
|
|
- "ruamel.yaml>=0.15.0,<=0.17.21",
|
|
+ "ruamel.yaml>=0.15.0,<=0.17.22",
|
|
# ruamel.yaml only requires ruamel.yaml.clib for Python versions
|
|
# less than or equal to Python 3.10. In order to ensure we have
|
|
# a consistent dependency closure across all Python versions,
|