Add patch0 to relax dependencies
This commit is contained in:
parent
4540310d21
commit
fa16c4459f
@ -8,12 +8,13 @@
|
|||||||
|
|
||||||
Name: awscli
|
Name: awscli
|
||||||
Version: 1.16.28
|
Version: 1.16.28
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Universal Command Line Environment for AWS
|
Summary: Universal Command Line Environment for AWS
|
||||||
|
|
||||||
License: ASL 2.0 and MIT
|
License: ASL 2.0 and MIT
|
||||||
URL: http://aws.amazon.com/cli
|
URL: http://aws.amazon.com/cli
|
||||||
Source0: https://files.pythonhosted.org/packages/source/a/%{name}/%{name}-%{version}.tar.gz
|
Source0: https://files.pythonhosted.org/packages/source/a/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: relax-dependencies.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
@ -51,7 +52,7 @@ This package provides a unified
|
|||||||
command line interface to Amazon Web Services.
|
command line interface to Amazon Web Services.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%autosetup -n %{name}-%{version} -p 1
|
||||||
rm -rf %{name}.egg-info
|
rm -rf %{name}.egg-info
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -100,6 +101,9 @@ rm %{buildroot}%{_bindir}/aws.cmd
|
|||||||
%endif # with python3
|
%endif # with python3
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 06 2018 Carl George <carl@george.computer> - 1.16.28-3
|
||||||
|
- Add patch0 to relax dependencies
|
||||||
|
|
||||||
* Wed Oct 17 2018 Justin W. Flory <jflory7@fedoraproject.org> - 1.16.28-2
|
* Wed Oct 17 2018 Justin W. Flory <jflory7@fedoraproject.org> - 1.16.28-2
|
||||||
- Add groff dependency, fix 'aws help' issue in stock install
|
- Add groff dependency, fix 'aws help' issue in stock install
|
||||||
|
|
||||||
|
25
relax-dependencies.patch
Normal file
25
relax-dependencies.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -Nurp awscli-1.16.28.orig/setup.py awscli-1.16.28/setup.py
|
||||||
|
--- awscli-1.16.28.orig/setup.py 2018-10-05 17:12:53.000000000 -0500
|
||||||
|
+++ awscli-1.16.28/setup.py 2018-11-06 09:03:13.254273110 -0600
|
||||||
|
@@ -23,12 +23,15 @@ def find_version(*file_paths):
|
||||||
|
raise RuntimeError("Unable to find version string.")
|
||||||
|
|
||||||
|
|
||||||
|
-requires = ['botocore==1.12.18',
|
||||||
|
- 'colorama>=0.2.5,<=0.3.9',
|
||||||
|
- 'docutils>=0.10',
|
||||||
|
- 'rsa>=3.1.2,<=3.5.0',
|
||||||
|
- 's3transfer>=0.1.12,<0.2.0',
|
||||||
|
- 'PyYAML>=3.10,<=3.13']
|
||||||
|
+requires = [
|
||||||
|
+ # upstream releases awscli and botocore in lockstep, keep this pinned
|
||||||
|
+ 'botocore==1.12.18',
|
||||||
|
+ 'colorama>=0.2.5',
|
||||||
|
+ 'docutils>=0.10',
|
||||||
|
+ 'rsa>=3.1.2',
|
||||||
|
+ 's3transfer>=0.1.12',
|
||||||
|
+ 'PyYAML>=3.10'
|
||||||
|
+]
|
||||||
|
|
||||||
|
|
||||||
|
if sys.version_info[:2] == (2, 6):
|
Loading…
Reference in New Issue
Block a user