b3f4de05e3
Commit 76b6ce8
added a downstream patch to remove the use of the
deprecated stock items. This however added new strings that the current
avahi tarball doesn't ship translations for, and as such we shouldn't do
it downstream.
Instead, just allow the deprecated GTK+ symbols. The deprecated API and
-Werror should never have been enabled in the tarball builds in the
first place.
https://bugzilla.redhat.com/show_bug.cgi?id=1001676
23 lines
976 B
Diff
23 lines
976 B
Diff
--- avahi-0.6.31/avahi-ui/Makefile.am.orig 2013-09-21 16:47:28.677659361 +0200
|
|
+++ avahi-0.6.31/avahi-ui/Makefile.am 2013-09-21 16:47:34.852520537 +0200
|
|
@@ -15,7 +15,7 @@
|
|
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
|
|
# USA.
|
|
|
|
-AM_CFLAGS=-I$(top_srcdir) -DG_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DGTK_DISABLE_DEPRECATED=1
|
|
+AM_CFLAGS=-I$(top_srcdir)
|
|
|
|
# This cool debug trap works on i386/gcc only
|
|
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
|
|
--- avahi-0.6.31/configure.ac.orig 2013-09-21 16:46:43.750669413 +0200
|
|
+++ avahi-0.6.31/configure.ac 2013-09-21 16:47:02.566246400 +0200
|
|
@@ -92,7 +92,7 @@
|
|
AC_MSG_CHECKING([whether stack-smashing protection is available])
|
|
ssp_old_cflags="$CFLAGS"
|
|
ssp_old_ldflags="$LDFLAGS"
|
|
- CFLAGS="$CFLAGS -Werror -fstack-protector-all -fPIC"
|
|
+ CFLAGS="$CFLAGS -fstack-protector-all -fPIC"
|
|
LDFLAGS="$LDFLAGS -Wl,-z,defs"
|
|
cat confdefs.h > conftest.c
|
|
cat >>conftest.c <<_ACEOF
|