parent
fe40dd230c
commit
ebc5d03df4
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
*.src.rpm
|
||||
/avahi-0.6.31.tar.gz
|
||||
/avahi-0.6.32.tar.gz
|
||||
/avahi-0.7.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up avahi-0.6.32-rc/avahi-daemon/avahi-daemon.conf.use_ipv6_no avahi-0.6.32-rc/avahi-daemon/avahi-daemon.conf
|
||||
--- avahi-0.6.32-rc/avahi-daemon/avahi-daemon.conf.use_ipv6_no 2015-10-09 19:39:05.000000000 -0500
|
||||
+++ avahi-0.6.32-rc/avahi-daemon/avahi-daemon.conf 2015-11-21 07:53:38.332358201 -0600
|
||||
@@ -23,7 +23,7 @@
|
||||
#domain-name=local
|
||||
#browse-domains=0pointer.de, zeroconf.org
|
||||
use-ipv4=yes
|
||||
-use-ipv6=yes
|
||||
+use-ipv6=no
|
||||
#allow-interfaces=eth0
|
||||
#deny-interfaces=eth1
|
||||
#check-response-ttl=no
|
36
avahi.spec
36
avahi.spec
@ -17,8 +17,8 @@
|
||||
%global _changelog_trimtime %(date +%s -d "1 year ago")
|
||||
|
||||
Name: avahi
|
||||
Version: 0.6.32
|
||||
Release: 7%{?dist}
|
||||
Version: 0.7
|
||||
Release: 1%{?dist}
|
||||
Summary: Local network service discovery
|
||||
License: LGPLv2+
|
||||
URL: http://avahi.org
|
||||
@ -50,6 +50,7 @@ BuildRequires: expat-devel
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: gdbm-devel
|
||||
BuildRequires: pkgconfig(pygobject-3.0)
|
||||
BuildRequires: pygtk2
|
||||
BuildRequires: intltool
|
||||
BuildRequires: perl-XML-Parser
|
||||
@ -65,16 +66,13 @@ BuildRequires: systemd
|
||||
Source0: https://github.com/lathiat/avahi/archive/%{version}-%{beta}.tar.gz#/%{name}-%{version}-%{beta}.tar.gz
|
||||
%else
|
||||
Source0: https://github.com/lathiat/avahi/releases/download/v%{version}/avahi-%{version}.tar.gz
|
||||
#Source0: http://avahi.org/download/avahi-%{version}.tar.gz
|
||||
%endif
|
||||
|
||||
## upstream patches
|
||||
|
||||
## downstream patches
|
||||
Patch100: avahi-0.6.30-mono-libdir.patch
|
||||
# selectively set use-ipv6=yes
|
||||
%if 0%{?fedora} < 24
|
||||
Patch101: avahi-0.6.32-use_ipv6_no.patch
|
||||
%endif
|
||||
|
||||
%description
|
||||
Avahi is a system which facilitates service discovery on
|
||||
@ -99,7 +97,7 @@ Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-glib%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-ui-gtk3%{?_isa} = %{version}-%{release}
|
||||
Requires: python-avahi = %{version}-%{release}
|
||||
Requires: python2-avahi = %{version}-%{release}
|
||||
Requires: vnc
|
||||
Requires: openssh-clients
|
||||
Requires: pygtk2
|
||||
@ -323,13 +321,14 @@ avahi-dnsconfd connects to a running avahi-daemon and runs the script
|
||||
local LAN. This is useful for configuring unicast DNS servers in a DHCP-like
|
||||
fashion with mDNS.
|
||||
|
||||
%package -n python-avahi
|
||||
%package -n python2-avahi
|
||||
Summary: Python2 Avahi bindings
|
||||
Provides: python2-avahi = %{version}-%{release}
|
||||
Obsoletes: python-avahi < 0.7
|
||||
Provides: python-avahi = %{version}-%{release}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n python-avahi
|
||||
%description -n python2-avahi
|
||||
%{summary}.
|
||||
|
||||
%package -n python3-avahi
|
||||
@ -344,13 +343,12 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%prep
|
||||
%autosetup -n %{name}-%{version}%{?beta:-%{beta}} -p1
|
||||
|
||||
# let ^^ autosetup handle it -- rex
|
||||
#patch100 -p1 -b .mono-libdir
|
||||
|
||||
rm -fv docs/INSTALL
|
||||
|
||||
|
||||
%build
|
||||
# patch100 requires autogen
|
||||
# and kills rpaths a bonus
|
||||
rm -fv missing
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
|
||||
@ -377,11 +375,13 @@ NOCONFIGURE=1 ./autogen.sh
|
||||
--disable-mono \
|
||||
%endif
|
||||
;
|
||||
|
||||
make %{?_smp_mflags} V=1
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
find %{buildroot} \( -name '*.a' -o -name '*.la' \) -exec rm {} \;
|
||||
find %{buildroot} \( -name '*.a' -o -name '*.la' \) -exec rm -v {} \;
|
||||
|
||||
# remove example
|
||||
rm -fv %{buildroot}%{_sysconfdir}/avahi/services/ssh.service
|
||||
@ -418,6 +418,7 @@ rm -fv %{buildroot}%{_sysconfdir}/rc.d/init.d/avahi-dnsconfd
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
|
||||
%pre
|
||||
getent group avahi >/dev/null || groupadd -f -g 70 -r avahi
|
||||
if ! getent passwd avahi > /dev/null ; then
|
||||
@ -506,7 +507,6 @@ exit 0
|
||||
%{_sbindir}/avahi-daemon
|
||||
%dir %{_datadir}/avahi
|
||||
%{_datadir}/avahi/*.dtd
|
||||
%{_datadir}/avahi/service-types
|
||||
%dir %{_libdir}/avahi
|
||||
%{_libdir}/avahi/service-types.db
|
||||
%{_mandir}/man5/*
|
||||
@ -655,7 +655,7 @@ exit 0
|
||||
%{_libdir}/pkgconfig/libdns_sd.pc
|
||||
%endif
|
||||
|
||||
%files -n python-avahi
|
||||
%files -n python2-avahi
|
||||
# These are .py files only, so they don't go in lib64
|
||||
%{python2_sitelib}/avahi/
|
||||
|
||||
@ -665,6 +665,10 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 10 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.7-1
|
||||
- avahi-0.7 (#1469100)
|
||||
- rename python-avahi => python2-avahi
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.32-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user