- upgrade to new upstream 0.6.17
- redundant patches removal - removed auto* stuff from specfile since that was no longer needed - Resolves: #232205: 'service {avahi-dnsconfd,avahi-daemon} status' returns 0 when the service is stopped
This commit is contained in:
parent
3ba0e79cbc
commit
3799991c11
@ -1 +1 @@
|
||||
avahi-0.6.16.tar.gz
|
||||
avahi-0.6.17.tar.gz
|
||||
|
40
avahi-0.6.17-exitcode.patch
Normal file
40
avahi-0.6.17-exitcode.patch
Normal file
@ -0,0 +1,40 @@
|
||||
--- avahi-0.6.17/initscript/fedora/avahi-daemon.in.exitcode 2006-02-12 12:39:15.000000000 +0100
|
||||
+++ avahi-0.6.17/initscript/fedora/avahi-daemon.in 2007-03-14 12:12:37.000000000 +0100
|
||||
@@ -80,7 +80,9 @@
|
||||
;;
|
||||
status)
|
||||
$AVAHI_BIN -c
|
||||
- [ $? = 0 ] && echo $"Avahi daemon is running" || echo $"Avahi daemon is not running"
|
||||
+ RETVAL=$?
|
||||
+ [ $RETVAL = 0 ] && echo $"Avahi daemon is running" || echo $"Avahi daemon is not running"
|
||||
+
|
||||
;;
|
||||
restart)
|
||||
restart
|
||||
@@ -98,5 +100,5 @@
|
||||
exit 1
|
||||
esac
|
||||
|
||||
-exit $?
|
||||
+exit $RETVAL
|
||||
|
||||
--- avahi-0.6.17/initscript/fedora/avahi-dnsconfd.in.exitcode 2007-03-14 12:07:38.000000000 +0100
|
||||
+++ avahi-0.6.17/initscript/fedora/avahi-dnsconfd.in 2007-03-14 12:12:36.000000000 +0100
|
||||
@@ -76,7 +76,9 @@
|
||||
;;
|
||||
status)
|
||||
$AVAHI_BIN -c
|
||||
- [ $? = 0 ] && echo $"Avahi DNS daemon is running" || echo $"Avahi DNS daemon is not running"
|
||||
+ RETVAL=$?
|
||||
+ [ $RETVAL = 0 ] && echo $"Avahi DNS daemon is running" || echo $"Avahi DNS daemon is not running"
|
||||
+
|
||||
;;
|
||||
restart)
|
||||
restart
|
||||
@@ -95,5 +97,5 @@
|
||||
;;
|
||||
esac
|
||||
|
||||
-exit $?
|
||||
+exit $RETVAL
|
||||
|
31
avahi.spec
31
avahi.spec
@ -5,8 +5,8 @@
|
||||
%define WITH_MONO 0
|
||||
%endif
|
||||
Name: avahi
|
||||
Version: 0.6.16
|
||||
Release: 3%{?dist}
|
||||
Version: 0.6.17
|
||||
Release: 1%{?dist}
|
||||
Summary: Local network service discovery
|
||||
Group: System Environment/Base
|
||||
License: LGPL
|
||||
@ -14,9 +14,9 @@ URL: http://avahi.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: dbus, libdaemon, expat, python, dbus-python, libcap
|
||||
Requires(post): initscripts, chkconfig, ldconfig
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
# BuildRequires: autoconf
|
||||
# BuildRequires: automake
|
||||
# BuildRequires: libtool
|
||||
BuildRequires: dbus-devel >= 0.90
|
||||
BuildRequires: dbus-glib-devel >= 0.70
|
||||
BuildRequires: dbus-python
|
||||
@ -41,8 +41,7 @@ Patch6: avahi-0.6.3-MONO_SHARED_DIR.patch
|
||||
Patch14: avahi-0.6.9-bz189427.patch
|
||||
Patch17: avahi-0.6.11-use-ipv6-yes.patch
|
||||
Patch20: avahi-0.6.15-initscript.patch
|
||||
Patch21: avahi-0.6.11-align.patch
|
||||
Patch23: avahi-0.6.15-netdev.patch
|
||||
Patch21: avahi-0.6.17-exitcode.patch
|
||||
|
||||
|
||||
%description
|
||||
@ -166,15 +165,14 @@ Header files for development with the Apple Bonjour mDNSResponder compatibility
|
||||
%patch14 -p1 -b .bz189427
|
||||
%patch17 -p1 -b .use-ipv6-yes
|
||||
%patch20 -p1 -b .initscript
|
||||
%patch21 -p1 -b .align
|
||||
%patch23 -p1 -b .netdev
|
||||
%patch21 -p1 -b .exitcode
|
||||
|
||||
%build
|
||||
# auto* update needed for avahi-0.5.2-fedora.patch
|
||||
aclocal -I common
|
||||
libtoolize --force
|
||||
automake-1.10 --add-missing
|
||||
autoconf
|
||||
# aclocal -I common
|
||||
# libtoolize --force
|
||||
# automake-1.10 --add-missing
|
||||
# autoconf
|
||||
|
||||
%configure --with-distro=fedora --disable-qt4 --disable-monodoc --without-python-twisted --with-avahi-user=avahi --with-avahi-group=avahi --enable-compat-howl --with-avahi-priv-access-group=avahi\
|
||||
%if %{WITH_COMPAT_DNSSD}
|
||||
@ -377,6 +375,13 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Mar 12 2007 Martin Bacovsky <mbacovsk@redhat.com> - 0.6.17-1
|
||||
- upgrade to new upstream 0.6.17
|
||||
- redundant patches removal
|
||||
- removed auto* stuff from specfile since that was no longer needed
|
||||
- Resolves: #232205: 'service {avahi-dnsconfd,avahi-daemon} status'
|
||||
returns 0 when the service is stopped
|
||||
|
||||
* Fri Feb 2 2007 Christopher Aillon <cailloN@redhat.com> - 0.6.16-3
|
||||
- Remove bogus mono-libdir patches
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user