Change paths for mono assemblies according to updated packaging
guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
This commit is contained in:
parent
a981624d48
commit
22bc36b138
82
avahi-0.6.30-mono-libdir.patch
Normal file
82
avahi-0.6.30-mono-libdir.patch
Normal file
@ -0,0 +1,82 @@
|
|||||||
|
diff -uNr avahi-0.6.30.old/avahi-sharp/Makefile.am avahi-0.6.30/avahi-sharp/Makefile.am
|
||||||
|
--- avahi-0.6.30.old/avahi-sharp/Makefile.am 2010-06-29 05:30:35.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-sharp/Makefile.am 2011-11-27 17:03:04.933192204 +0100
|
||||||
|
@@ -73,10 +73,10 @@
|
||||||
|
endif
|
||||||
|
|
||||||
|
install-data-hook: $(ASSEMBLY)
|
||||||
|
- $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
uninstall-hook: $(ASSEMBLY)
|
||||||
|
- $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
diff -uNr avahi-0.6.30.old/avahi-sharp/Makefile.in avahi-0.6.30/avahi-sharp/Makefile.in
|
||||||
|
--- avahi-0.6.30.old/avahi-sharp/Makefile.in 2011-04-04 00:10:46.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-sharp/Makefile.in 2011-11-27 17:06:13.316193244 +0100
|
||||||
|
@@ -615,10 +615,10 @@
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_MONODOC_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)$(MDASSEMBLER) --out avahi-sharp-docs --ecma $(srcdir)/en
|
||||||
|
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@install-data-hook: $(ASSEMBLY)
|
||||||
|
-@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@uninstall-hook: $(ASSEMBLY)
|
||||||
|
-@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+@HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
diff -uNr avahi-0.6.30.old/avahi-sharp.pc.in avahi-0.6.30/avahi-sharp.pc.in
|
||||||
|
--- avahi-0.6.30.old/avahi-sharp.pc.in 2010-06-25 02:54:22.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-sharp.pc.in 2011-11-27 17:00:05.482192846 +0100
|
||||||
|
@@ -5,4 +5,4 @@
|
||||||
|
Name: avahi-sharp
|
||||||
|
Description: Mono bindings for the Avahi mDNS/DNS-SD stack
|
||||||
|
Version: @PACKAGE_VERSION@
|
||||||
|
-Libs: -r:${libdir}/mono/avahi-sharp/avahi-sharp.dll
|
||||||
|
+Libs: -r:${prefix}/lib/mono/avahi-sharp/avahi-sharp.dll
|
||||||
|
diff -uNr avahi-0.6.30.old/avahi-ui-sharp/Makefile.am avahi-0.6.30/avahi-ui-sharp/Makefile.am
|
||||||
|
--- avahi-0.6.30.old/avahi-ui-sharp/Makefile.am 2010-06-29 05:30:35.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-ui-sharp/Makefile.am 2011-11-27 17:04:59.812193067 +0100
|
||||||
|
@@ -60,10 +60,10 @@
|
||||||
|
endif
|
||||||
|
|
||||||
|
install-data-hook: $(ASSEMBLY)
|
||||||
|
- $(GACUTIL) /i $(ASSEMBLY) /package avahi-ui-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+ $(GACUTIL) /i $(ASSEMBLY) /package avahi-ui-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
uninstall-hook: $(ASSEMBLY)
|
||||||
|
- $(GACUTIL) /u avahi-ui-sharp /package avahi-ui-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+ $(GACUTIL) /u avahi-ui-sharp /package avahi-ui-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
diff -uNr avahi-0.6.30.old/avahi-ui-sharp/Makefile.in avahi-0.6.30/avahi-ui-sharp/Makefile.in
|
||||||
|
--- avahi-0.6.30.old/avahi-ui-sharp/Makefile.in 2011-04-04 00:10:46.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-ui-sharp/Makefile.in 2011-11-27 17:05:54.197220114 +0100
|
||||||
|
@@ -604,10 +604,10 @@
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONODOC_TRUE@@HAVE_MONO_TRUE@ $(AM_V_GEN)$(MDASSEMBLER) --out avahi-ui-sharp-docs --ecma $(srcdir)/en
|
||||||
|
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@install-data-hook: $(ASSEMBLY)
|
||||||
|
-@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@ $(GACUTIL) /i $(ASSEMBLY) /package avahi-ui-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@ $(GACUTIL) /i $(ASSEMBLY) /package avahi-ui-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@uninstall-hook: $(ASSEMBLY)
|
||||||
|
-@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@ $(GACUTIL) /u avahi-ui-sharp /package avahi-ui-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
|
||||||
|
+@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@@HAVE_MONO_TRUE@ $(GACUTIL) /u avahi-ui-sharp /package avahi-ui-sharp /gacdir $(prefix)/lib /root $(DESTDIR)$(prefix)/lib
|
||||||
|
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
diff -uNr avahi-0.6.30.old/avahi-ui-sharp.pc.in avahi-0.6.30/avahi-ui-sharp.pc.in
|
||||||
|
--- avahi-0.6.30.old/avahi-ui-sharp.pc.in 2010-06-25 02:54:22.000000000 +0200
|
||||||
|
+++ avahi-0.6.30/avahi-ui-sharp.pc.in 2011-11-27 17:04:05.077192737 +0100
|
||||||
|
@@ -6,4 +6,4 @@
|
||||||
|
Description: Mono bindings for the Avahi mDNS/DNS-SD stack
|
||||||
|
Version: @PACKAGE_VERSION@
|
||||||
|
Requires: gtk-sharp-2.0
|
||||||
|
-Libs: -r:${libdir}/mono/avahi-ui-sharp/avahi-ui-sharp.dll
|
||||||
|
+Libs: -r:${prefix}/lib/mono/avahi-ui-sharp/avahi-ui-sharp.dll
|
16
avahi.spec
16
avahi.spec
@ -6,7 +6,7 @@
|
|||||||
%endif
|
%endif
|
||||||
Name: avahi
|
Name: avahi
|
||||||
Version: 0.6.30
|
Version: 0.6.30
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Local network service discovery
|
Summary: Local network service discovery
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
@ -46,6 +46,7 @@ BuildRequires: monodoc-devel
|
|||||||
%endif
|
%endif
|
||||||
Obsoletes: howl
|
Obsoletes: howl
|
||||||
Source0: http://avahi.org/download/%{name}-%{version}.tar.gz
|
Source0: http://avahi.org/download/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: avahi-0.6.30-mono-libdir.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Avahi is a system which facilitates service discovery on
|
Avahi is a system which facilitates service discovery on
|
||||||
@ -302,6 +303,7 @@ fashion with mDNS.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .mono-libdir
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-distro=fedora --disable-monodoc --with-avahi-user=avahi --with-avahi-group=avahi --with-avahi-priv-access-group=avahi --with-autoipd-user=avahi-autoipd --with-autoipd-group=avahi-autoipd --with-systemdsystemunitdir=/lib/systemd/system --enable-introspection=no \
|
%configure --with-distro=fedora --disable-monodoc --with-avahi-user=avahi --with-avahi-group=avahi --with-avahi-priv-access-group=avahi --with-autoipd-user=avahi-autoipd --with-autoipd-group=avahi-autoipd --with-systemdsystemunitdir=/lib/systemd/system --enable-introspection=no \
|
||||||
@ -607,14 +609,14 @@ fi
|
|||||||
%if %{WITH_MONO}
|
%if %{WITH_MONO}
|
||||||
%files sharp
|
%files sharp
|
||||||
%defattr(0644, root, root, 0755)
|
%defattr(0644, root, root, 0755)
|
||||||
%{_libdir}/mono/avahi-sharp
|
%{_prefix}/lib/mono/avahi-sharp
|
||||||
%{_libdir}/mono/gac/avahi-sharp
|
%{_prefix}/lib/mono/gac/avahi-sharp
|
||||||
%{_libdir}/pkgconfig/avahi-sharp.pc
|
%{_libdir}/pkgconfig/avahi-sharp.pc
|
||||||
|
|
||||||
%files ui-sharp
|
%files ui-sharp
|
||||||
%defattr(0644, root, root, 0755)
|
%defattr(0644, root, root, 0755)
|
||||||
%{_libdir}/mono/avahi-ui-sharp
|
%{_prefix}/lib/mono/avahi-ui-sharp
|
||||||
%{_libdir}/mono/gac/avahi-ui-sharp
|
%{_prefix}/lib/mono/gac/avahi-ui-sharp
|
||||||
|
|
||||||
%files ui-sharp-devel
|
%files ui-sharp-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -649,6 +651,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 29 2011 Christian Krause <chkr@fedoraproject.org> - 0.6.30-6
|
||||||
|
- Change paths for mono assemblies according to updated packaging
|
||||||
|
guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
|
||||||
|
|
||||||
* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.6.30-5
|
* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.6.30-5
|
||||||
- Rebuild to break bogus libpng dep
|
- Rebuild to break bogus libpng dep
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user