Rebase to upstream version 1.16.4

This commit is contained in:
Ondrej Dubaj 2021-08-24 09:55:38 +02:00
parent c3fe43baf6
commit 550ec44a4a
4 changed files with 7 additions and 101 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/automake-1.16.1.tar.xz
/automake-1.16.2.tar.xz
/automake-1.16.3.tar.xz
/automake-1.16.4.tar.xz

View File

@ -1,94 +0,0 @@
From: Zack Weinberg <zackw@panix.com>
Subject: [PATCH] Autoconf 2.71 (released last week) makes a few changes
that broke Automakes expectations, mostly in the test suite. This
patch addresses two of the problems:
- autoconf now issues a warning if fed a configure script that doesnt invoke
both AC_INIT and AC_OUTPUT; this, plus a problem with system-provided
tools (still under investigation) broke the *build* on macOS; it also
causes a couple of spurious testsuite failures.
- AC_PACKAGE_NAME and AC_PACKAGE_VERSION are now defined unconditionally.
AM_INIT_AUTOMAKE needs to use m4_ifset instead of m4_ifdef to diagnose
the obsolete use of AC_INIT with fewer than two arguments. (This change
is compatible with autoconf 2.69; m4_ifset is much older, and it means
defined with a non-empty value.)
* configure.ac: Use both AC_INIT and AC_OUTPUT in test configure scripts.
* t/deprecated-acinit.sh, t/init.sh: Likewise.
* m4/init.m4 (AM_INIT_AUTOMAKE): Use m4_ifset, not m4_ifdef, to detect
AC_PACKAGE_NAME and/or AC_PACKAGE_VERSION not having a value.
---
configure.ac | 9 +++++++--
m4/init.m4 | 2 +-
t/deprecated-acinit.sh | 1 +
t/init.sh | 1 +
4 files changed, 10 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 15d3f8e..e3a0df2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,7 +123,9 @@ fi
AC_CACHE_CHECK([whether autoconf works], [am_cv_autoconf_works],
[mkdir conftest
-echo 'AC''_INIT' > conftest/conftest.ac
+printf '%s\n' > conftest/conftest.ac \
+ 'AC''_INIT([smoke-test], [1])' \
+ 'AC''_OUTPUT'
if AM_RUN_LOG([cd conftest && $am_AUTOCONF -o /dev/null conftest.ac]);
then
am_cv_autoconf_works=yes
@@ -139,7 +141,10 @@ fi
AC_CACHE_CHECK([whether autoconf is recent enough], [am_cv_autoconf_version],
[mkdir conftest
dnl Creative quoting required to avoid spurious expansion of AC_PREREQ macro
-echo 'AC'"_PREREQ([[$required_autoconf_version]])" > conftest/conftest.ac
+printf '%s\n' > conftest/conftest.ac \
+ 'AC'"_PREREQ([[$required_autoconf_version]])" \
+ 'AC''_INIT([smoke-test], [1])' \
+ 'AC''_OUTPUT'
if AM_RUN_LOG([cd conftest && $am_AUTOCONF -o /dev/null conftest.ac]);
then
am_cv_autoconf_version=yes
diff --git a/m4/init.m4 b/m4/init.m4
index ba73676..339a167 100644
--- a/m4/init.m4
+++ b/m4/init.m4
@@ -64,7 +64,7 @@ m4_ifval([$3], [_AM_SET_OPTION([no-define])])dnl
[_AM_SET_OPTIONS([$1])dnl
dnl Diagnose old-style AC_INIT with new-style AM_AUTOMAKE_INIT.
m4_if(
- m4_ifdef([AC_PACKAGE_NAME], [ok]):m4_ifdef([AC_PACKAGE_VERSION], [ok]),
+ m4_ifset([AC_PACKAGE_NAME], [ok]):m4_ifset([AC_PACKAGE_VERSION], [ok]),
[ok:ok],,
[m4_fatal([AC_INIT should be called with package and version arguments])])dnl
AC_SUBST([PACKAGE], ['AC_PACKAGE_TARNAME'])dnl
diff --git a/t/deprecated-acinit.sh b/t/deprecated-acinit.sh
index 21614ba..f393d65 100644
--- a/t/deprecated-acinit.sh
+++ b/t/deprecated-acinit.sh
@@ -35,6 +35,7 @@ for ac_init in AC_INIT 'AC_INIT([Makefile.am])'; do
$ac_init
$am_init_automake
AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
END
cat configure.ac # For debugging.
$ACLOCAL 2>stderr && { cat stderr >&2; exit 1; }
diff --git a/t/init.sh b/t/init.sh
index c6f6d64..df138a0 100644
--- a/t/init.sh
+++ b/t/init.sh
@@ -25,6 +25,7 @@ for ac_init_args in '' '([x])'; do
unindent >configure.ac <<END
AC_INIT$ac_init_args
AM_INIT_AUTOMAKE$am_init_args
+ AC_OUTPUT
END
cat configure.ac # For debugging.
# The error message should mention AC_INIT, not AC_PACKAGE_VERSION.
--
2.26.0

View File

@ -14,7 +14,7 @@
Summary: A GNU tool for automatically creating Makefiles
Name: automake
# Any bump here requires libtool rebuild, rhbz#1813010
Version: %{api_version}.3
Version: %{api_version}.4
Release: 1%{?dist}
# docs ~> GFDL, sources ~> GPLv2+, mkinstalldirs ~> PD and install-sh ~> MIT
@ -24,10 +24,6 @@ Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz
Source2: http://git.savannah.gnu.org/cgit/config.git/plain/config.sub
Source3: http://git.savannah.gnu.org/cgit/config.git/plain/config.guess
# Fix test failures with autoconf-2.71
# https://git.savannah.gnu.org/cgit/automake.git/commit/?id=ccb57553e3433df3e52e534e6f87915db23ff9a5
Patch0: automake-1.16.3-fix-testsuite-failures-with-autoconf-2.71.patch
URL: http://www.gnu.org/software/automake/
Requires: autoconf >= 2.65
@ -135,7 +131,10 @@ make -k %{?_smp_mflags} check %{?TESTS_FLAGS: TESTS="%{TESTS_FLAGS}"} \
%changelog
* Wed Feb 24 2021 Ondrej Dubaj <odubaj@redhat.com> - 1.16.3-1
* Tue Jul 27 2021 Ondrej Dubaj <odubaj@redhat.com> - 1.16.4-1
- Rebase to upstream version 1.16.4
* Tue Jul 27 2021 Ondrej Dubaj <odubaj@redhat.com> - 1.16.3-1
- Rebase to upstream version 1.16.3
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.2-5

View File

@ -1 +1 @@
SHA512 (automake-1.16.3.tar.xz) = 7265aeb7f82a8a205761d76e6ade7b7e97831c283349fd80f86e511f4b0b3e17f429d1506fca84c76079f63781e5dbf5ca81455d6bf6cda27d2e5c3d23b0d1aa
SHA512 (automake-1.16.4.tar.xz) = 5a8883657e73b75bfa1ee59ab04af6bf4d43f390ab62fb7a9e8e2ac66159dfe4947b2ac7bc1028afffe6a09d88f388339500e03f6cdfa1226985be45ec033246