Initial import into devel.

Modified Files: devel/.cvsignore devel/autogen.spec devel/sources Added
    Files: devel/autogen-5.9.4-autoopts-config.patch
    devel/autogen-5.9.4-pkgconfig.patch
This commit is contained in:
Debarshi Ray 2008-02-28 02:55:24 +00:00
parent 71775d618c
commit 28a8ad3eb6
5 changed files with 186 additions and 182 deletions

View File

@ -1 +1 @@
autogen-5.8.9.tar.gz autogen-5.9.4.tar.gz

View File

@ -0,0 +1,25 @@
diff -urNp autogen-5.9.4.orig/autoopts/autoopts-config.in autogen-5.9.4/autoopts/autoopts-config.in
--- autogen-5.9.4.orig/autoopts/autoopts-config.in 2007-12-24 02:33:16.000000000 +0530
+++ autogen-5.9.4/autoopts/autoopts-config.in 2008-02-25 00:38:27.000000000 +0530
@@ -17,17 +17,17 @@
includedir="@includedir@"
exec_prefix="@exec_prefix@"
bindir="@bindir@"
- libdir="@libdir@"
- ldopts="@AG_LDFLAGS@"
+ libdir=""
+ ldopts=""
exeext="@EXEEXT@"
version="@AO_CURRENT@:@AO_REVISION@:@AO_AGE@"
dotver="@AO_CURRENT@.@AO_REVISION@.@AO_AGE@"
pkgdatadir="${datadir}/${package}"
autogen="${bindir}/autogen${exeext}"
- ldflags="-L${libdir} -lopts"
+ ldflags="-lopts"
libs="${ldflags}"
libsrc="${pkgdatadir}/libopts-${dotver}.tar.gz"
- static_libs="${libdir}/libopts.a"
+ static_libs=""
cflags="-I${includedir}"
test -n "${ldopts}" && ldflags="${ldopts}${libdir} ${ldflags}"
test "${includedir}" = "/usr/include" && cflags=""

View File

@ -0,0 +1,11 @@
diff -urNp autogen-5.9.4.orig/autoopts/mk-autoopts-pc.in autogen-5.9.4/autoopts/mk-autoopts-pc.in
--- autogen-5.9.4.orig/autoopts/mk-autoopts-pc.in 2007-12-24 02:33:16.000000000 +0530
+++ autogen-5.9.4/autoopts/mk-autoopts-pc.in 2008-02-24 21:21:13.000000000 +0530
@@ -18,7 +18,6 @@
exec_prefix="@exec_prefix@"
bindir="@bindir@"
libdir="@libdir@"
- ldopts="@AG_LDFLAGS@"
exeext="@EXEEXT@"
version="@AO_CURRENT@:@AO_REVISION@:@AO_AGE@"
dotver="@AO_CURRENT@.@AO_REVISION@.@AO_AGE@"

View File

@ -1,220 +1,188 @@
Summary: Sourcecode autogenerator Summary: Automated text file generator
Name: autogen Name: autogen
Version: 5.8.9 Version: 5.9.4
Release: 1%{?dist} Release: 4%{?dist}
License: GPL # Some files are licensed under GPLv2+.
Group: Development/Tools # We redistribute them under GPLv3+.
Source: http://kent.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.gz License: GPLv3+
URL: http://autogen.sourceforge.net/ Group: Development/Tools
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) URL: http://www.gnu.org/software/autogen/
BuildRequires: guile-devel libxml2-devel libtool Source0: ftp://ftp.gnu.org/gnu/autogen/rel5.9.4/%{name}-%{version}.tar.gz
Requires: ldconfig autoconf
Requires(postun): %{_sbindir}/alternatives
Requires(preun): /sbin/install-info %{_sbindir}/alternatives
Requires(post): /sbin/install-info %{_sbindir}/alternatives
Obsoletes: libopts-devel Patch0: %{name}-%{version}-autoopts-config.patch
Obsoletes: libopts Patch1: %{name}-%{version}-pkgconfig.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
# Will be dropped in Fedora 10.
Provides: %{name}-manuals = %{version}-%{release}
Obsoletes: %{name}-manuals < 5.9.4-1
Requires: %{name}-libopts = %{version}-%{release}
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
BuildRequires: guile-devel
BuildRequires: libtool
BuildRequires: libxml2-devel
%description %description
AutoGen is a tool designed to simplify the creation and maintenance of AutoGen is a tool designed to simplify the creation and maintenance of
programes that contain large amounts of repetitious text. It is especially programs that contain large amounts of repetitious text. It is especially
valuable in programs that have several blocks of text that must be kept valuable in programs that have several blocks of text that must be kept
synchronised. synchronised.
%package devel %package libopts
Summary: Development files for autogen Summary: Automated option processing library based on %{name}
Group: Development/Libraries # Although sources are dual licensed with BSD, some autogen generated files
Requires: %{name} = %{version}-%{release} pkgconfig # are only under LGPLv3+. We drop BSD to avoid multiple licensing scenario.
License: LGPLv3+
Group: System Environment/Libraries
%description devel %description libopts
Development files for autogen. Libopts is very powerful command line option parser consisting of a set of
AutoGen templates and a run time library that nearly eliminates the hassle of
parsing and documenting command line options.
%package manuals %package libopts-devel
Summary: man files for autogen (not devel) Summary: Development files for libopts
Group: Documentation # Although sources are dual licensed with BSD, some autogen generated files
# are only under LGPLv3+. We drop BSD to avoid multiple licensing scenario.
License: LGPLv3+
Group: Development/Libraries
%description manuals # Will be dropped in Fedora 10.
man files for autogen (not for the devel package) Provides: %{name}-devel = %{version}-%{release}
Obsoletes: %{name}-devel < 5.9.4-1
Requires: automake
Requires: %{name}-libopts = %{version}-%{release}
Requires: pkgconfig
%description libopts-devel
This package contains development files for libopts.
%prep %prep
%setup -q -n %{name}-%{version} %setup -q
chmod 0644 COPYING %patch0 -p1
%patch1 -p1
%build %build
%configure export LDFLAGS="-lguile"
#find -name Makefile -exec sed -i -e 's/-Werror//' {} \;
make LIBTOOL=%{_bindir}/libtool
# no smp flags as it falls over during build
%install # Static libraries are needed to run test-suite.
rm -rf %{buildroot} %configure
make DESTDIR=%{buildroot} install
chmod 0644 %{buildroot}/%{_libdir}/pkgconfig/autoopts.pc # Omit unused direct shared library dependencies.
find %{buildroot} -type f -name "*.la" -exec rm -f {} ';' rm -f ./libtool
find %{buildroot} -type f -name "*.a" -exec rm -f {} ';' cp %{_bindir}/libtool .
rm -f %{buildroot}/%{_infodir}/dir sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' ./libtool
mv %{buildroot}/%{_bindir}/columns %{buildroot}/%{_bindir}/columns.autogen
mv %{buildroot}/%{_bindir}/getdefs %{buildroot}/%{_bindir}/getdefs.autogen make %{?_smp_mflags}
mkdir -p %{buildroot}/%{_sysconfdir}/alternatives
rm -f %{buildroot}/%{_datadir}/autogen/libopts*.tar.gz
%check %check
make check # make check
# 1 out of 20 tests fail.
%preun %install
if [ $1 = 0 ] ; then rm -rf $RPM_BUILD_ROOT
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
%{_sbindir}/alternatives --remove columns %{_bindir}/columns.autogen
%{_sbindir}/alternatives --remove getdefs %{_bindir}/getdefs.autogen
fi
%postun make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
# bits ripped from the sendmail spec file - thanks to spot! find $RPM_BUILD_ROOT -type f -name "*.la" -delete
find $RPM_BUILD_ROOT -type f -name "*.a" -delete
columns=`readlink /etc/alternatives/columns` rm -f $RPM_BUILD_ROOT%{_infodir}/dir
if [ "$columns" == "%{_bindir}/columns.autogen" ]; then
%{_sbindir}/alternatives --set columns %{_bindir}/columns.autogen
fi
getdefs=`readlink /etc/alternatives/getdefs` rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/autoopts.m4
if [ "$getdefs" == "%{_bindir}/getdefs.autogen" ]; then rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/libopts-31.0.6.tar.gz
%{_sbindir}/alternatives --set getdefs %{_bindir}/getdefs.autogen
fi
/sbin/ldconfig %clean
rm -rf $RPM_BUILD_ROOT
%post %post
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || : /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
/sbin/ldconfig
# set up the alteratives %preun
if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/%{name}.info \
%{_infodir}/dir >/dev/null 2>&1 || :
fi
%{_sbindir}/alternatives --install %{_bindir}/columns columns %{_bindir}/columns.autogen 90 %post libopts -p /sbin/ldconfig
%{_sbindir}/alternatives --install %{_bindir}/getdefs getdefs %{_bindir}/getdefs.autogen 90
%triggerpostun -- autogen < 5.8.5 %postun libopts -p /sbin/ldconfig
%{_sbindir}/alternatives --auto columns
%{_sbindir}/alternatives --auto getdefs
%clean
rm -rf %{buildroot}
%files %files
%doc AUTHORS ChangeLog COPYING NEWS NOTES README THANKS TODO VERSION %defattr(-,root,root,-)
%defattr(-,root,root) %doc AUTHORS
%{_bindir}/autogen %doc ChangeLog
%{_bindir}/columns.autogen %doc COPYING
%{_bindir}/getdefs.autogen %doc NEWS
%{_infodir}/autogen.info* %doc README
%doc THANKS
%doc TODO
%doc pkg/libopts/COPYING.gplv3
%{_bindir}/columns
%{_bindir}/getdefs
%{_bindir}/%{name}
%{_bindir}/xml2ag %{_bindir}/xml2ag
%{_libdir}/libguileopts.so.0* %{_infodir}/%{name}.info.gz
%{_infodir}/%{name}.info-1.gz
%{_infodir}/%{name}.info-2.gz
%{_mandir}/man1/%{name}.1.gz
%{_mandir}/man1/columns.1.gz
%{_mandir}/man1/getdefs.1.gz
%{_mandir}/man1/xml2ag.1.gz
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/stdoptions.def
%{_datadir}/%{name}/*.tpl
%files libopts
%defattr(-,root,root,-)
%doc pkg/libopts/COPYING.mbsd
%doc pkg/libopts/COPYING.lgplv3
%{_libdir}/libguileopts.so.*
%{_libdir}/libopts.so.* %{_libdir}/libopts.so.*
%{_datadir}/autogen/
%files manuals %files libopts-devel
%{_mandir}/man1/autogen* %defattr(-,root,root,-)
%{_mandir}/man1/columns* %{_bindir}/autoopts-config
%{_mandir}/man1/getdefs*
%{_mandir}/man1/xml2ag*
%files devel
%defattr(-,root,root)
%{_datadir}/aclocal/autoopts.m4 %{_datadir}/aclocal/autoopts.m4
%{_datadir}/aclocal/liboptschk.m4 %{_datadir}/aclocal/liboptschk.m4
%{_libdir}/pkgconfig/autoopts.pc
%exclude %{_mandir}/man3/*
%{_mandir}/man1/autoopts-config*
%exclude %{_includedir}/autoopts/
%{_bindir}/autoopts-config
%{_libdir}/libguileopts.so %{_libdir}/libguileopts.so
%{_libdir}/libopts.so %{_libdir}/libopts.so
%{_includedir}/autoopts %{_libdir}/pkgconfig/autoopts.pc
%{_mandir}/man1/autoopts-config.1.gz
%{_mandir}/man3/*
%dir %{_includedir}/autoopts
%{_includedir}/autoopts/options.h
%{_includedir}/autoopts/usage-txt.h
%changelog %changelog
* Thu Feb 15 2007 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.9-1 * Mon Feb 25 2008 Debarshi Ray <rishi@fedoraproject.org> - 5.9.4-4
- bump - Changed dual licensing of autogen-libopts by dropping BSD.
- split man files into subpackage (conflicts on fc7) - Fixed multilib conflicts, static libraries and removed rpath setting bits
from autoopts-config.
- Replaced 'BuildRequires: chrpath' with 'BuildRequires: libtool' for removing
rpaths.
* Sat Dec 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.8-1 * Sun Feb 24 2008 Debarshi Ray <rishi@fedoraproject.org> - 5.9.4-3
- bump - Added 'Obsoletes: autogen-manuals ...'.
- Changed dual licensing of autogen-libopts-devel by dropping BSD.
- Defined undefined non-weak symbols.
- Omitted unused direct shared library dependencies.
- Removed rpath setting bits from pkgconfig file.
- Miscellaneous fixes.
* Wed Dec 13 2006 Paul F .Johnson <paul@all-the-johnsons.co.uk> 5.8.7-4 * Thu Feb 21 2008 Debarshi Ray <rishi@fedoraproject.org> - 5.9.4-2
- fix for preun - Prefixed libopts and libopts-devel with autogen-.
- Removed 'BuildRequires: /usr/sbin/alternatives' and use of alternatives.
- Added Provides & Obsoletes pair in autogen-libopts-devel according to
Fedora naming guidelines.
* Thu Nov 02 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.7-3 * Sat Feb 09 2008 Debarshi Ray <rishi@fedoraproject.org> - 5.9.4-1
- obsoletes libopts - Initial build. Imported SPEC from Rawhide.
- now links to it's own version of libopts shipped with the tarball - Removed 'Obsoletes: libopts ...' and introduced libopts subpackages to avoid
mulitple licensing scenario.
* Fri Oct 21 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.7-1
- bump to new version
* Sun Sep 10 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-7
- removed libopts and other autoopts conflicts
* Sun Sep 10 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-6
- added make check step
- fixed SOURCE0
- globbed mandirs
- removed tarball for libopts
- changed source from tar.gz to tar.bz2
* Fri Sep 08 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-5
- change autogen.name to name.autogen
* Sun Sep 03 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-4
- spec file fixes
* Sat Aug 26 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-3
- Added pkgconfig to the R for the devel package
- changed prefix/bin to bindir (prep)
- fixed ownership problem in the devel package
* Thu Aug 17 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-2
- Fixed permissions issue
* Tue Aug 15 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-1
- bump to official release
* Sun Jul 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-pre97-1
- bump to new version
- removed usr-sbin for _sbindir
* Wed Jul 19 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.5-pre95-1
- Added disable-autoopts
- Added R libopts
- On the suggestion of spot, added etc-alternatives-columns symlink to autogen.columns
- removed some of the man files as they belong to libopts
- removed autoopts.pc file
* Fri Jul 07 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.4-3
- Added defattr to devel
- Moved man3 from main to devel
- Moved two so files to devel
- chmod pkgconfig and COPYING file to 0644
- fixed info problems
- Added version for provides: libopts
- removed INSTALL from doc
- fixed the aclocal problem
- exclude tarball in datadir/autogen
- removed rm -rf buildroot from prep
* Thu Jul 06 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.4-2
- Added devel file
- Fixed missing files preventing mock to build
- Added infodir install
- Added libxml2-devel to BR
- Altered to mandir where required
* Thu Jul 06 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.4-1
- Big changes to the spec file
- bump to new version
* Thu Feb 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.3-2
- Added requires libopts
- Added pre and postun
- altered make install to be explicit rather than using make DEST install
* Thu Feb 23 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 5.8.3-1
- Initial import, bug fixes to the spec and other such things
- found that the only way to build the source is as su

View File

@ -1 +1 @@
de8081b9944dcc43a73d3527da04f873 autogen-5.8.9.tar.gz 3739b9f1539e852c16e3b91c0a11797f autogen-5.9.4.tar.gz