67 lines
2.3 KiB
Diff
67 lines
2.3 KiB
Diff
autofs-5.1.4 - Makefiles.rules: remove 'samples' from SUBDIRS
|
|
|
|
From: NeilBrown <neilb@suse.com>
|
|
|
|
The rules in Makefile make it quite clear that
|
|
'samples' is not expected to be part of SUBDIRS.
|
|
e.g.
|
|
- The rule for "clean" handles both $(SUBDIRS) *and* samples.
|
|
- There are separate "install" and "install_samples" targets.
|
|
|
|
However SUBDIRS does contain 'samples'. This means that
|
|
a simple "make; make install" will over-write your configuration files.
|
|
|
|
So remove 'samples' from SUBDIRS. Note that it has been removed in
|
|
the past, but then got added back again.
|
|
|
|
Signed-off-by: NeilBrown <neilb@suse.com>
|
|
Signed-off-by: Ian Kent <raven@themaw.net>
|
|
---
|
|
CHANGELOG | 1 +
|
|
Makefile.rules | 2 +-
|
|
autofs.spec | 6 ++++++
|
|
3 files changed, 8 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CHANGELOG b/CHANGELOG
|
|
index 313730b1..1e5ec15b 100644
|
|
--- a/CHANGELOG
|
|
+++ b/CHANGELOG
|
|
@@ -11,6 +11,7 @@ xx/xx/2018 autofs-5.1.5
|
|
- account for recent libnsl changes.
|
|
- use_hostname_for_mounts shouldn't prevent selection among replicas.
|
|
- fix monotonic_elapsed.
|
|
+- Makefiles.rules: remove 'samples' from SUBDIRS.
|
|
|
|
19/12/2017 autofs-5.1.4
|
|
- fix spec file url.
|
|
diff --git a/Makefile.rules b/Makefile.rules
|
|
index 2bfa043c..4deab3b9 100644
|
|
--- a/Makefile.rules
|
|
+++ b/Makefile.rules
|
|
@@ -3,7 +3,7 @@
|
|
#
|
|
|
|
# Root directory contents
|
|
-SUBDIRS = lib daemon modules man samples
|
|
+SUBDIRS = lib daemon modules man
|
|
INCDIRS = include
|
|
INCFILES = COPYING COPYRIGHT NEWS README* TODO Makefile Makefile.rules \
|
|
Makefile.conf.in .version .autofs-* configure.in aclocal.m4 \
|
|
diff --git a/autofs.spec b/autofs.spec
|
|
index 6da0655d..57d8db46 100644
|
|
--- a/autofs.spec
|
|
+++ b/autofs.spec
|
|
@@ -121,6 +121,12 @@ install -m 755 redhat/autofs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
|
|
install -m 644 redhat/autofs.conf $RPM_BUILD_ROOT/etc/autofs.conf
|
|
install -m 644 redhat/autofs.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/autofs
|
|
|
|
+install -m 644 samples/auto.master $RPM_BUILD_ROOT/etc/auto.master
|
|
+install -m 644 samples/auto.misc $RPM_BUILD_ROOT/etc/auto.misc
|
|
+install -m 644 samples/auto.net $RPM_BUILD_ROOT/etc/auto.net
|
|
+install -m 644 samples/auto.smb $RPM_BUILD_ROOT/etc/auto.smb
|
|
+install -m 600 samples/autofs_ldap_auth.conf $RPM_BUILD_ROOT/etc/autofs_ldap_auth.conf
|
|
+
|
|
%clean
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
|
|