- add changes for bugs 2122565 and 2126176.
This commit is contained in:
parent
511169a715
commit
cae98da176
46
autofs-5.1.8-fix-invalid-tsv-access.patch
Normal file
46
autofs-5.1.8-fix-invalid-tsv-access.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
autofs-5.1.8 - fix invalid tsv access
|
||||||
|
|
||||||
|
From: Ian Kent <raven@themaw.net>
|
||||||
|
|
||||||
|
When using the --dumpmaps option of automount(8) a SEGV can occur
|
||||||
|
because a thread specific data variable accessed in the code hasn't
|
||||||
|
yet been created.
|
||||||
|
|
||||||
|
The thread specific data doesn't need to be set to list the maps
|
||||||
|
so we can create the key and rely on pthread_getspecific() returning
|
||||||
|
NULL when the value hasn't been set as this case is handled correctly.
|
||||||
|
|
||||||
|
Signed-off-by: Ian Kent <raven@themaw.net>
|
||||||
|
---
|
||||||
|
CHANGELOG | 1 +
|
||||||
|
daemon/automount.c | 9 +++++++++
|
||||||
|
2 files changed, 10 insertions(+)
|
||||||
|
|
||||||
|
--- autofs-5.1.7.orig/CHANGELOG
|
||||||
|
+++ autofs-5.1.7/CHANGELOG
|
||||||
|
@@ -102,6 +102,7 @@
|
||||||
|
- bailout on rpc systemerror.
|
||||||
|
- fix nfsv4 only mounts should not use rpcbind.
|
||||||
|
- dont use initgroups() at spawn.
|
||||||
|
+- fix invalid tsv access.
|
||||||
|
|
||||||
|
25/01/2021 autofs-5.1.7
|
||||||
|
- make bind mounts propagation slave by default.
|
||||||
|
--- autofs-5.1.7.orig/daemon/automount.c
|
||||||
|
+++ autofs-5.1.7/daemon/automount.c
|
||||||
|
@@ -2518,6 +2518,15 @@ int main(int argc, char *argv[])
|
||||||
|
master = argv[2];
|
||||||
|
}
|
||||||
|
|
||||||
|
+ status = pthread_key_create(&key_thread_stdenv_vars,
|
||||||
|
+ key_thread_stdenv_vars_destroy);
|
||||||
|
+ if (status) {
|
||||||
|
+ logerr("%s: failed to create thread data key for std env vars!",
|
||||||
|
+ program);
|
||||||
|
+ macro_free_global_table();
|
||||||
|
+ exit(1);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (master)
|
||||||
|
master_list = master_new(NULL, timeout, flags);
|
||||||
|
else
|
13
autofs.spec
13
autofs.spec
@ -12,7 +12,7 @@
|
|||||||
Summary: A tool for automatically mounting and unmounting filesystems
|
Summary: A tool for automatically mounting and unmounting filesystems
|
||||||
Name: autofs
|
Name: autofs
|
||||||
Version: 5.1.7
|
Version: 5.1.7
|
||||||
Release: 31%{?dist}
|
Release: 32%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}-2.tar.gz
|
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}-2.tar.gz
|
||||||
@ -128,6 +128,7 @@ Patch101: autofs-5.1.8-bailout-on-rpc-systemerror.patch
|
|||||||
Patch102: autofs-5.1.8-fix-nfsv4-only-mounts-should-not-use-rpcbind.patch
|
Patch102: autofs-5.1.8-fix-nfsv4-only-mounts-should-not-use-rpcbind.patch
|
||||||
|
|
||||||
Patch103: autofs-5.1.8-dont-use-initgroups-at-spawn.patch
|
Patch103: autofs-5.1.8-dont-use-initgroups-at-spawn.patch
|
||||||
|
Patch104: autofs-5.1.8-fix-invalid-tsv-access.patch
|
||||||
|
|
||||||
%if %{with_systemd}
|
%if %{with_systemd}
|
||||||
BuildRequires: systemd-units
|
BuildRequires: systemd-units
|
||||||
@ -300,6 +301,7 @@ echo %{version}-%{release} > .version
|
|||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
|
|
||||||
%patch103 -p1
|
%patch103 -p1
|
||||||
|
%patch104 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
LDFLAGS=-Wl,-z,now
|
LDFLAGS=-Wl,-z,now
|
||||||
@ -408,6 +410,13 @@ fi
|
|||||||
%dir /etc/auto.master.d
|
%dir /etc/auto.master.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 04 2022 Ian Kent <ikent@redhat.com> - 1:5.1.7-32
|
||||||
|
- bz2122565 - automount -m crashes with Segmentation fault (core dumped)
|
||||||
|
- fix invalid tsv access.
|
||||||
|
- bz2126176 - autofs: %changelog entries are out of order
|
||||||
|
- fix changelog date of out of order entry.
|
||||||
|
- Resolves: rhbz#2122565 rhbz#2126176
|
||||||
|
|
||||||
* Mon May 30 2022 Ian Kent <ikent@redhat.com> - 1:5.1.7-31
|
* Mon May 30 2022 Ian Kent <ikent@redhat.com> - 1:5.1.7-31
|
||||||
- bz2087535 - libnss_sss: threads stuck at sss_nss_lock from initgroups
|
- bz2087535 - libnss_sss: threads stuck at sss_nss_lock from initgroups
|
||||||
- dont use initgroups() at spawn.
|
- dont use initgroups() at spawn.
|
||||||
@ -545,7 +554,7 @@ fi
|
|||||||
- fix incorrect changelog revision.
|
- fix incorrect changelog revision.
|
||||||
- Resolves: rhbz#1942371
|
- Resolves: rhbz#1942371
|
||||||
|
|
||||||
* Tue Apr 13 2021 Ian Kent <ikent@redhat.com> - 1:5.1.7-12
|
* Fri Apr 16 2021 Ian Kent <ikent@redhat.com> - 1:5.1.7-12
|
||||||
- bz1948956 - Using -hosts option does not resolve host from /etc/hosts
|
- bz1948956 - Using -hosts option does not resolve host from /etc/hosts
|
||||||
and mount failes
|
and mount failes
|
||||||
- Coverity fixes (arising from RHEL-8 bug 1912106)
|
- Coverity fixes (arising from RHEL-8 bug 1912106)
|
||||||
|
Loading…
Reference in New Issue
Block a user