- fix fedfs build flags (realted bug 2028301).

This commit is contained in:
Ian Kent 2021-12-21 09:00:12 +08:00
parent 56a6a32540
commit 623c34c5e9
2 changed files with 48 additions and 1 deletions

View File

@ -0,0 +1,39 @@
autofs-5.1.8 - fix fedfs build flags
From: Ian Kent <raven@themaw.net>
Dynamic executables should be compiled with -fPIE and linked with -pie.
Signed-off-by: Ian Kent <raven@themaw.net>
---
CHANGELOG | 1 +
fedfs/Makefile | 4 ++--
2 files changed, 3 insertions(+), 2 deletions(-)
--- autofs-5.1.7.orig/CHANGELOG
+++ autofs-5.1.7/CHANGELOG
@@ -81,6 +81,7 @@
- eliminate some more alloca usage.
- use default stack size for threads.
- fix kernel mount status notification.
+- fix fedfs build flags.
25/01/2021 autofs-5.1.7
- make bind mounts propagation slave by default.
--- autofs-5.1.7.orig/fedfs/Makefile
+++ autofs-5.1.7/fedfs/Makefile
@@ -23,12 +23,12 @@ LDFLAGS += -rdynamic
all: mount.fedfs fedfs-map-nfs4
mount.fedfs: $(mount_fedfs_OBJ) $(fedfs-getsrvinfo_OBJ) $(HDRS)
- $(CC) -o mount.fedfs \
+ $(CC) $(DAEMON_LDFLAGS) -o mount.fedfs \
$(mount_fedfs_OBJ) $(fedfs-getsrvinfo_OBJ) \
$(LDFLAGS) $(LIBRESOLV) $(LIBS)
fedfs-map-nfs4: $(fedfs-map-nfs4_OBJ) $(fedfs-getsrvinfo_OBJ) $(HDRS)
- $(CC) -o fedfs-map-nfs4 \
+ $(CC) $(DAEMON_LDFLAGS) -o fedfs-map-nfs4 \
$(fedfs-map-nfs4_OBJ) $(fedfs-getsrvinfo_OBJ) \
$(LDFLAGS) $(LIBRESOLV) $(LIBS)

View File

@ -12,7 +12,7 @@
Summary: A tool for automatically mounting and unmounting filesystems
Name: autofs
Version: 5.1.7
Release: 25%{?dist}
Release: 26%{?dist}
Epoch: 1
License: GPLv2+
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}-2.tar.gz
@ -103,6 +103,7 @@ Patch80: autofs-5.1.7-eliminate-some-more-alloca-usage.patch
Patch81: autofs-5.1.7-use-default-stack-size-for-threads.patch
Patch82: autofs-5.1.8-fix-kernel-mount-status-notification.patch
Patch83: autofs-5.1.8-fix-fedfs-build-flags.patch
%if %{with_systemd}
BuildRequires: systemd-units
@ -252,6 +253,7 @@ echo %{version}-%{release} > .version
%patch81 -p1
%patch82 -p1
%patch83 -p1
%build
LDFLAGS=-Wl,-z,now
@ -360,6 +362,12 @@ fi
%dir /etc/auto.master.d
%changelog
* Tue Dec 21 2021 Ian Kent <ikent@redhat.com> - 1:5.1.7-26
- bz2028301 - autofs: send FAIL cmd/ioctl mess when encountering problems with
mount trigger
- fix fedfs build flags.
- Related: rhbz#2028301
* Mon Dec 20 2021 Ian Kent <ikent@redhat.com> - 1:5.1.7-25
- bz2028301 - autofs: send FAIL cmd/ioctl mess when encountering problems with
mount trigger