- fix configure force shutdown check.

This commit is contained in:
Ian Kent 2020-08-31 12:40:46 +08:00
parent d029998929
commit 6051f634fb
2 changed files with 58 additions and 1 deletions

View File

@ -0,0 +1,52 @@
autofs-5.1.6 - fix configure force shutdown check
From: Ian Kent <raven@themaw.net>
Not strickly broken but there is a mis-match between the --enable-force-shutdown
and the configure variable naming.
Signed-off-by: Ian Kent <raven@themaw.net>
---
CHANGELOG | 1 +
configure | 2 +-
configure.in | 2 +-
3 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/CHANGELOG b/CHANGELOG
index 09d44998..10ad19e2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -17,6 +17,7 @@ xx/xx/2020 autofs-5.1.7
- Use PKG_CHECK_MODULES to detect the libxml2 library.
- fix ldap sasl reconnect problem.
- samples/ldap.schema fix.
+- fix configure force shutdown check.
07/10/2019 autofs-5.1.6
- support strictexpire mount option.
diff --git a/configure b/configure
index a2884397..112238da 100755
--- a/configure
+++ b/configure
@@ -6264,7 +6264,7 @@ else
enableval=no
fi
-if test x$enable_forced_shutdown = xyes -o x$enableval = xyes; then
+if test x$enable_force_shutdown = xyes -o x$enableval = xyes; then
$as_echo "#define ENABLE_FORCED_SHUTDOWN 1" >>confdefs.h
diff --git a/configure.in b/configure.in
index 9e211c91..c0fb0d2d 100644
--- a/configure.in
+++ b/configure.in
@@ -407,7 +407,7 @@ AC_ARG_ENABLE(force-shutdown,
[ --enable-force-shutdown enable USR1 signal to force unlink umount of any
busy mounts during shutdown],,
enableval=no)
-if test x$enable_forced_shutdown = xyes -o x$enableval = xyes; then
+if test x$enable_force_shutdown = xyes -o x$enableval = xyes; then
AC_DEFINE(ENABLE_FORCED_SHUTDOWN, 1, [Enable forced shutdown on USR1 signal])
fi

View File

@ -8,7 +8,7 @@
Summary: A tool for automatically mounting and unmounting filesystems
Name: autofs
Version: 5.1.6
Release: 10%{?dist}
Release: 11%{?dist}
Epoch: 1
License: GPLv2+
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}.tar.gz
@ -29,6 +29,7 @@ Patch014: autofs-5.1.6-fix-autofs-mount-options-construction.patch
Patch015: autofs-5.1.6-mount_nfs_c-fix-local-rdma-share-not-mounting.patch
Patch016: autofs-5.1.6-fix-ldap-sasl-reconnect-problem.patch
Patch017: autofs-5.1.6-ldap-schema-fix.patch
Patch018: autofs-5.1.6-fix-configure-force-shutdown-check.patch
%if %{with_systemd}
BuildRequires: systemd-units
@ -106,6 +107,7 @@ echo %{version}-%{release} > .version
%patch015 -p1
%patch016 -p1
%patch017 -p1
%patch018 -p1
%build
LDFLAGS=-Wl,-z,now
@ -205,6 +207,9 @@ fi
%dir /etc/auto.master.d
%changelog
* Mon Aug 31 2020 Ian Kent <ikent@redhat.com> - 1:5.1.6-11
- fix configure force shutdown check.
* Tue Aug 25 2020 Ian Kent <ikent@redhat.com> - 1:5.1.6-10
- fix incorrect configure option.