- add fix for bug RHEL-7997.
This commit is contained in:
parent
e44639bfa7
commit
35188d0fd6
44
autofs-5.1.8-fix-multi-mount-check.patch
Normal file
44
autofs-5.1.8-fix-multi-mount-check.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
autofs-5.1.8 - fix multi-mount check
|
||||||
|
|
||||||
|
From: Ian Kent <raven@themaw.net>
|
||||||
|
|
||||||
|
When checking if a mount location is a multi-mount after the first location
|
||||||
|
the next '-' or '/' indicates it's a multi-mount.
|
||||||
|
|
||||||
|
But the '-' can be part of a mount location and can follow a space leading
|
||||||
|
to incorrectly deciding the location is a multi-mount.
|
||||||
|
|
||||||
|
Signed-off-by: Ian Kent <raven@themaw.net>
|
||||||
|
---
|
||||||
|
CHANGELOG | 1 +
|
||||||
|
modules/parse_sun.c | 9 ++++++++-
|
||||||
|
2 files changed, 9 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- autofs-5.1.7.orig/CHANGELOG
|
||||||
|
+++ autofs-5.1.7/CHANGELOG
|
||||||
|
@@ -158,6 +158,7 @@
|
||||||
|
- fix incorrect matching of cached wildcard key.
|
||||||
|
- fix expire retry looping.
|
||||||
|
- allow -null map in indirect maps.
|
||||||
|
+- fix multi-mount check.
|
||||||
|
|
||||||
|
25/01/2021 autofs-5.1.7
|
||||||
|
- make bind mounts propagation slave by default.
|
||||||
|
--- autofs-5.1.7.orig/modules/parse_sun.c
|
||||||
|
+++ autofs-5.1.7/modules/parse_sun.c
|
||||||
|
@@ -787,7 +787,14 @@ static int check_is_multi(const char *ma
|
||||||
|
if (not_first_chunk) {
|
||||||
|
if (*p == '"')
|
||||||
|
p++;
|
||||||
|
- if (*p == '/' || *p == '-') {
|
||||||
|
+ /*
|
||||||
|
+ * Although an options string here would mean
|
||||||
|
+ * we have a multi-mount we can't rely on it
|
||||||
|
+ * since it's also valid in a mount location.
|
||||||
|
+ */
|
||||||
|
+ if (*p == '-')
|
||||||
|
+ p++;
|
||||||
|
+ if (*p == '/') {
|
||||||
|
multi = 1;
|
||||||
|
break;
|
||||||
|
}
|
10
autofs.spec
10
autofs.spec
@ -12,7 +12,7 @@
|
|||||||
Summary: A tool for automatically mounting and unmounting filesystems
|
Summary: A tool for automatically mounting and unmounting filesystems
|
||||||
Name: autofs
|
Name: autofs
|
||||||
Version: 5.1.7
|
Version: 5.1.7
|
||||||
Release: 56%{?dist}
|
Release: 57%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}-2.tar.gz
|
Source: https://www.kernel.org/pub/linux/daemons/autofs/v5/autofs-%{version}-2.tar.gz
|
||||||
@ -187,6 +187,7 @@ Patch174: autofs-5.1.8-fix-incorrect-matching-of-cached-wildcard-key.patch
|
|||||||
Patch175: autofs-5.1.8-fix-expire-retry-looping.patch
|
Patch175: autofs-5.1.8-fix-expire-retry-looping.patch
|
||||||
|
|
||||||
Patch176: autofs-5.1.8-allow-null-map-in-indirect-maps.patch
|
Patch176: autofs-5.1.8-allow-null-map-in-indirect-maps.patch
|
||||||
|
Patch177: autofs-5.1.8-fix-multi-mount-check.patch
|
||||||
|
|
||||||
%if %{with_systemd}
|
%if %{with_systemd}
|
||||||
BuildRequires: systemd-units
|
BuildRequires: systemd-units
|
||||||
@ -418,6 +419,7 @@ echo %{version}-%{release} > .version
|
|||||||
%patch175 -p1
|
%patch175 -p1
|
||||||
|
|
||||||
%patch176 -p1
|
%patch176 -p1
|
||||||
|
%patch177 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
LDFLAGS=-Wl,-z,now
|
LDFLAGS=-Wl,-z,now
|
||||||
@ -526,6 +528,12 @@ fi
|
|||||||
%dir /etc/auto.master.d
|
%dir /etc/auto.master.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 30 2023 Ian Kent <ikent@redhat.com> - 1:5.1.7-57
|
||||||
|
- RHEL-13084 - multi mount detection fails for share with blank+dash causing
|
||||||
|
SEGV crash
|
||||||
|
- fix multi-mount check.
|
||||||
|
- Resolves: RHEL-13084
|
||||||
|
|
||||||
* Thu Oct 26 2023 Ian Kent <ikent@redhat.com> - 1:5.1.7-56
|
* Thu Oct 26 2023 Ian Kent <ikent@redhat.com> - 1:5.1.7-56
|
||||||
- RHEL-13083 - autofs attempts to mount nonexistant ".hidden" filesystems
|
- RHEL-13083 - autofs attempts to mount nonexistant ".hidden" filesystems
|
||||||
- allow -null map in indirect maps.
|
- allow -null map in indirect maps.
|
||||||
|
Loading…
Reference in New Issue
Block a user