- buildroot fixed

- removed textutils requirement
- dot removed from summary
- requires gawk, but not perl
- use install-info
- use BuildArch
- replace tabs with spaces
- fix defattr
- use 'make install DESTDIR=...'
This commit is contained in:
Karsten Hopp 2007-02-14 15:27:33 +00:00
parent 29f4cdbe4f
commit 68912c0fd5
2 changed files with 96 additions and 26 deletions

46
autoconf213-destdir.patch Normal file
View File

@ -0,0 +1,46 @@
--- autoconf-2.13/Makefile.in.rh1 2007-02-14 16:22:52.000000000 +0100
+++ autoconf-2.13/Makefile.in 2007-02-14 16:23:26.000000000 +0100
@@ -137,23 +137,23 @@
cd testsuite && ${MAKE} AUTOCONF=${bindir}/autoconf $@
installdirs:
- $(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(infodir) $(acdatadir)
+ $(SHELL) ${srcdir}/mkinstalldirs $(DESTDIR)/$(bindir) $(DESTDIR)/$(infodir) $(DESTDIR)/$(acdatadir)
install: all $(M4FILES) acconfig.h installdirs install-info
for p in $(ASCRIPTS); do \
- $(INSTALL_PROGRAM) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
+ $(INSTALL_PROGRAM) $$p $(DESTDIR)/$(bindir)/`echo $$p|sed '$(transform)'`; \
done
for i in $(M4FROZEN); do \
- $(INSTALL_DATA) $$i $(acdatadir)/$$i; \
+ $(INSTALL_DATA) $$i $(DESTDIR)/$(acdatadir)/$$i; \
done
for i in $(M4FILES) acconfig.h; do \
- $(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
+ $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)/$(acdatadir)/$$i; \
done
-if test -f autoscan; then \
- $(INSTALL_PROGRAM) autoscan $(bindir)/`echo autoscan|sed '$(transform)'`; \
+ $(INSTALL_PROGRAM) autoscan $(DESTDIR)/$(bindir)/`echo autoscan|sed '$(transform)'`; \
for i in acfunctions acheaders acidentifiers acprograms \
acmakevars; do \
- $(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
+ $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)/$(acdatadir)/$$i; \
done; \
else :; fi
@@ -161,11 +161,11 @@
install-info: info installdirs
if test -f autoconf.info; then \
for i in *.info*; do \
- $(INSTALL_DATA) $$i $(infodir)/$$i; \
+ $(INSTALL_DATA) $$i $(DESTDIR)/$(infodir)/$$i; \
done; \
else \
for i in $(srcdir)/*.info*; do \
- $(INSTALL_DATA) $$i $(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \
+ $(INSTALL_DATA) $$i $(DESTDIR)/$(infodir)/`echo $$i | sed 's|^$(srcdir)/||'`; \
done; \
fi

View File

@ -1,7 +1,7 @@
Summary: A GNU tool for automatically configuring source code.
Summary: A GNU tool for automatically configuring source code
Name: autoconf213
Version: 2.13
Release: 12.1
Release: 13
License: GPL
Group: Development/Tools
URL: http://www.gnu.org/software/autoconf/
@ -16,10 +16,13 @@ Patch6: autoconf-2.13-exit.patch
Patch7: autoconf-2.13-wait3test.patch
Patch8: autoconf-2.13-make-defs-62361.patch
Patch9: autoconf-2.13-versioning.patch
Requires: gawk, m4 >= 1.1, mktemp, perl, textutils
Patch10: autoconf213-destdir.patch
Requires: gawk, m4 >= 1.1, mktemp
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Buildrequires: texinfo, m4 >= 1.1
BuildArchitectures: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
GNU's Autoconf is a tool for configuring source code and Makefiles.
@ -48,7 +51,8 @@ use.
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1 -b .version
%patch9 -p1
%patch10 -p1 -b .rh1
%build
%configure --program-suffix=-%{version}
@ -56,7 +60,8 @@ make
%install
rm -rf ${RPM_BUILD_ROOT}
%makeinstall
#makeinstall
make install DESTDIR=$RPM_BUILD_ROOT
mv ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info ${RPM_BUILD_ROOT}%{_infodir}/%{name}.info
@ -66,17 +71,36 @@ rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/*
%post
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
%preun
if [ "$1" = 0 ]; then
/sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
fi
%clean
rm -rf ${RPM_BUILD_ROOT}
%files
%defattr(-,root,root)
%defattr(-,root,root,-)
%{_bindir}/*
%{_infodir}/*.info*
%{_datadir}/autoconf-%{version}
%{_datadir}/autoconf-%{version}/
%doc AUTHORS COPYING NEWS README TODO
%changelog
* Wed Feb 14 2007 Karsten Hopp <karsten@redhat.com> 2.13-13
- buildroot fixed
- removed textutils requirement
- dot removed from summary
- requires gawk, but not perl
- use install-info
- use BuildArch
- replace tabs with spaces
- fix defattr
- use 'make install DESTDIR=...'
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.13-12.1
- rebuild