63 lines
2.0 KiB
Diff
63 lines
2.0 KiB
Diff
From 6b09724c69d91668418ddb3af00da6db6755208c Mon Sep 17 00:00:00 2001
|
|
From: Steve Grubb <sgrubb@redhat.com>
|
|
Date: Thu, 2 Sep 2021 15:01:12 -0400
|
|
Subject: [PATCH] Make IPX packet interpretation dependent on the ipx header
|
|
file existing
|
|
|
|
---
|
|
ChangeLog | 1 +
|
|
auparse/interpret.c | 8 ++++++--
|
|
configure.ac | 6 ++++++
|
|
3 files changed, 13 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/auparse/interpret.c b/auparse/interpret.c
|
|
index 63829aa0..6c316456 100644
|
|
--- a/auparse/interpret.c
|
|
+++ b/auparse/interpret.c
|
|
@@ -44,8 +44,10 @@
|
|
#include <linux/ax25.h>
|
|
#include <linux/atm.h>
|
|
#include <linux/x25.h>
|
|
-#include <linux/if.h> // FIXME: remove when ipx.h is fixed
|
|
-#include <linux/ipx.h>
|
|
+#ifdef HAVE_IPX_HEADERS
|
|
+ #include <linux/if.h> // FIXME: remove when ipx.h is fixed
|
|
+ #include <linux/ipx.h>
|
|
+#endif
|
|
#include <linux/capability.h>
|
|
#include <sys/personality.h>
|
|
#include <sys/prctl.h>
|
|
@@ -1279,6 +1281,7 @@ static const char *print_sockaddr(const char *val)
|
|
x->sax25_call.ax25_call[6]);
|
|
}
|
|
break;
|
|
+#ifdef HAVE_IPX_HEADERS
|
|
case AF_IPX:
|
|
{
|
|
const struct sockaddr_ipx *ip =
|
|
@@ -1288,6 +1291,7 @@ static const char *print_sockaddr(const char *val)
|
|
str, ip->sipx_port, ip->sipx_network);
|
|
}
|
|
break;
|
|
+#endif
|
|
case AF_ATMPVC:
|
|
{
|
|
const struct sockaddr_atmpvc* at =
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 8f541e4c..005eb0b5 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -418,6 +418,12 @@ if test x"$LIBWRAP_LIBS" != "x"; then
|
|
AC_DEFINE_UNQUOTED(HAVE_LIBWRAP, [], Define if tcp_wrappers support is enabled )
|
|
fi
|
|
|
|
+# linux/ipx.h - deprecated in 2018
|
|
+AC_CHECK_HEADER(linux/ipx.h, ipx_headers=yes, ipx_headers=no)
|
|
+if test $ipx_headers = yes ; then
|
|
+ AC_DEFINE(HAVE_IPX_HEADERS,1,[IPX packet interpretation])
|
|
+fi
|
|
+
|
|
# See if we want to support lower capabilities for plugins
|
|
LIBCAP_NG_PATH
|
|
|