When interpreting, if val is NULL return an empty string
Resolves: rhbz#2004420
This commit is contained in:
parent
e16aa2564c
commit
eb340e9e16
@ -0,0 +1,26 @@
|
|||||||
|
From ae210cb59accb6ee03488b6ec14fb67aca22660f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Steve Grubb <sgrubb@redhat.com>
|
||||||
|
Date: Sat, 21 Aug 2021 10:20:11 -0400
|
||||||
|
Subject: [PATCH 4/4] When interpreting, if val is NULL return an empty string
|
||||||
|
|
||||||
|
---
|
||||||
|
auparse/interpret.c | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/auparse/interpret.c b/auparse/interpret.c
|
||||||
|
index 177ab82..63829aa 100644
|
||||||
|
--- a/auparse/interpret.c
|
||||||
|
+++ b/auparse/interpret.c
|
||||||
|
@@ -840,6 +840,9 @@ static char *print_escaped(const char *val)
|
||||||
|
{
|
||||||
|
char *out;
|
||||||
|
|
||||||
|
+ if (val == NULL)
|
||||||
|
+ return strdup(" ");
|
||||||
|
+
|
||||||
|
if (*val == '"') {
|
||||||
|
char *term;
|
||||||
|
val++;
|
||||||
|
--
|
||||||
|
2.33.1
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
Summary: User space tools for kernel auditing
|
Summary: User space tools for kernel auditing
|
||||||
Name: audit
|
Name: audit
|
||||||
Version: 3.0.5
|
Version: 3.0.5
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://people.redhat.com/sgrubb/audit/
|
URL: http://people.redhat.com/sgrubb/audit/
|
||||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||||
@ -11,6 +11,7 @@ Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
|||||||
Patch1: 0001-Add-ausysrulevalidate.patch
|
Patch1: 0001-Add-ausysrulevalidate.patch
|
||||||
Patch2: 0002-audit-3.0.6-time.patch
|
Patch2: 0002-audit-3.0.6-time.patch
|
||||||
Patch3: 0003-Carry-functions-file-from-initscripts-in-audit.patch
|
Patch3: 0003-Carry-functions-file-from-initscripts-in-audit.patch
|
||||||
|
Patch4: 0004-When-interpreting-if-val-is-NULL-return-an-empty-str.patch
|
||||||
|
|
||||||
BuildRequires: make gcc swig
|
BuildRequires: make gcc swig
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
@ -94,6 +95,7 @@ cp %{SOURCE1} .
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
# Remove the ids code, its not ready
|
# Remove the ids code, its not ready
|
||||||
sed -i 's/ ids / /' audisp/plugins/Makefile.in
|
sed -i 's/ ids / /' audisp/plugins/Makefile.in
|
||||||
@ -264,6 +266,10 @@ fi
|
|||||||
%attr(750,root,root) %{_sbindir}/audispd-zos-remote
|
%attr(750,root,root) %{_sbindir}/audispd-zos-remote
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 03 2021 Sergio Correia <scorreia@redhat.com> - 3.0.5-4
|
||||||
|
- When interpreting, if val is NULL return an empty string
|
||||||
|
Resolves: rhbz#2004420
|
||||||
|
|
||||||
* Wed Nov 03 2021 Sergio Correia <scorreia@redhat.com> - 3.0.5-3
|
* Wed Nov 03 2021 Sergio Correia <scorreia@redhat.com> - 3.0.5-3
|
||||||
- Update dependency to initscripts-service instead of initscripts
|
- Update dependency to initscripts-service instead of initscripts
|
||||||
Resolves: rhbz#2000933
|
Resolves: rhbz#2000933
|
||||||
|
Loading…
Reference in New Issue
Block a user