Bug fixes pulled from upstrean
This commit is contained in:
parent
1f866afd4b
commit
c81b8a0bab
@ -1,19 +0,0 @@
|
||||
commit 59c886a671c53741399fe9dea710c2bf1ae3d8f4
|
||||
Author: Steve Grubb <sgrubb@redhat.com>
|
||||
Date: Wed Nov 1 15:40:32 2023 -0400
|
||||
|
||||
use correct arg in audit_add_perm_syscalls
|
||||
|
||||
diff --git a/lib/libaudit.c b/lib/libaudit.c
|
||||
index 563cc2f..0a52285 100644
|
||||
--- a/lib/libaudit.c
|
||||
+++ b/lib/libaudit.c
|
||||
@@ -1522,7 +1522,7 @@ static int audit_add_perm_syscalls(int perm, struct audit_rule_data *rule)
|
||||
_audit_syscalladded = 1;
|
||||
break;
|
||||
case -1: // Should never happen
|
||||
- audit_msg(LOG_ERR, "Syscall name unknown: %s", syscall);
|
||||
+ audit_msg(LOG_ERR, "Syscall name unknown: %s", syscalls);
|
||||
break;
|
||||
default: // Error reported - do nothing here
|
||||
break;
|
@ -9,9 +9,8 @@ Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
Patch1: audit-3.9-1-aureport.patch
|
||||
Patch2: audit-3.9-2-no-io_uring.patch
|
||||
Patch3: audit-3.9-3-fix-arg.patch
|
||||
Patch4: audit-3.9-4-fix-leak.patch
|
||||
Patch5: audit-3.9-5-mk-static.patch
|
||||
Patch3: audit-3.9-4-fix-leak.patch
|
||||
Patch4: audit-3.9-5-mk-static.patch
|
||||
|
||||
BuildRequires: make gcc
|
||||
BuildRequires: krb5-devel
|
||||
@ -98,7 +97,6 @@ cp %{SOURCE1} .
|
||||
%patch 2 -p1
|
||||
%patch 3 -p1
|
||||
%patch 4 -p1
|
||||
%patch 5 -p1
|
||||
|
||||
# Remove the ids code, its not ready
|
||||
sed -i 's/ ids / /' audisp/plugins/Makefile.am
|
||||
|
Loading…
Reference in New Issue
Block a user