- Add system-config-audit (Miloslav Trmac)
- Correct bug in audit_make_equivalent function (Al Viro)
This commit is contained in:
parent
35912257bd
commit
c56912826f
@ -75,3 +75,4 @@ audit-1.5.tar.gz
|
|||||||
audit-1.5.1.tar.gz
|
audit-1.5.1.tar.gz
|
||||||
audit-1.5.2.tar.gz
|
audit-1.5.2.tar.gz
|
||||||
audit-1.5.3.tar.gz
|
audit-1.5.3.tar.gz
|
||||||
|
audit-1.5.5.tar.gz
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
diff -ur audit-1.3.1.orig/audisp/Makefile audit-1.3.1/audisp/Makefile
|
|
||||||
--- audit-1.3.1.orig/audisp/Makefile 2006-12-21 19:10:45.000000000 -0500
|
|
||||||
+++ audit-1.3.1/audisp/Makefile 2006-12-21 19:11:04.000000000 -0500
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
# Installation directories.
|
|
||||||
PREFIX ?= $(DESTDIR)/usr
|
|
||||||
-LIBDIR ?= $(PREFIX)/lib/python2.4/site-packages
|
|
||||||
+LIBDIR ?= $(PREFIX)/lib/python2.5/site-packages
|
|
||||||
SBINDIR ?= $(DESTDIR)/sbin
|
|
||||||
LIB=AuditMsg.py
|
|
||||||
|
|
||||||
diff -ur audit-1.3.1.orig/configure.ac audit-1.3.1/configure.ac
|
|
||||||
--- audit-1.3.1.orig/configure.ac 2006-12-21 19:10:45.000000000 -0500
|
|
||||||
+++ audit-1.3.1/configure.ac 2006-12-21 19:11:37.000000000 -0500
|
|
||||||
@@ -39,7 +39,7 @@
|
|
||||||
AM_INIT_AUTOMAKE
|
|
||||||
AM_PROG_LIBTOOL
|
|
||||||
AC_SUBST(LIBTOOL_DEPS)
|
|
||||||
-AM_PATH_PYTHON(2.4)
|
|
||||||
+AM_PATH_PYTHON
|
|
||||||
|
|
||||||
echo .
|
|
||||||
echo Checking for programs
|
|
||||||
diff -ur audit-1.3.1.orig/src/ausearch-lookup.c audit-1.3.1/src/ausearch-lookup.c
|
|
||||||
--- audit-1.3.1.orig/src/ausearch-lookup.c 2006-12-21 19:10:45.000000000 -0500
|
|
||||||
+++ audit-1.3.1/src/ausearch-lookup.c 2006-12-21 20:10:06.000000000 -0500
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
#include "config.h"
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <string.h>
|
|
||||||
+#include <asm/types.h> // to work around buggy kernel headers
|
|
||||||
#include <linux/net.h>
|
|
||||||
#include "ausearch-lookup.h"
|
|
||||||
#include "ausearch-options.h"
|
|
51
audit.spec
51
audit.spec
@ -1,17 +1,21 @@
|
|||||||
|
%define sca_version 0.4.2
|
||||||
|
|
||||||
Summary: User space tools for 2.6 kernel auditing
|
Summary: User space tools for 2.6 kernel auditing
|
||||||
Name: audit
|
Name: audit
|
||||||
Version: 1.5.3
|
Version: 1.5.5
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://people.redhat.com/sgrubb/audit/
|
URL: http://people.redhat.com/sgrubb/audit/
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libtool swig python-devel pkgconfig
|
BuildRequires: libtool swig python-devel
|
||||||
BuildRequires: kernel-headers >= 2.6.18
|
BuildRequires: kernel-headers >= 2.6.18
|
||||||
BuildRequires: automake >= 1.9
|
BuildRequires: automake >= 1.9
|
||||||
BuildRequires: autoconf >= 2.59
|
BuildRequires: autoconf >= 2.59
|
||||||
|
BuildRequires: gettext-devel intltool
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
|
Requires: %{name}-libs-python = %{version}-%{release}
|
||||||
Requires: chkconfig
|
Requires: chkconfig
|
||||||
Prereq: coreutils
|
Prereq: coreutils
|
||||||
|
|
||||||
@ -59,11 +63,21 @@ Group: System Environment/Daemons
|
|||||||
%description audispd-plugins
|
%description audispd-plugins
|
||||||
The audispd-plugins package contains plugins for the audit dispatcher.
|
The audispd-plugins package contains plugins for the audit dispatcher.
|
||||||
|
|
||||||
|
%package -n system-config-audit
|
||||||
|
Summary: Utility for editing audit configuration
|
||||||
|
Version: %{sca_version}
|
||||||
|
License: GPL
|
||||||
|
Group: Applications/System
|
||||||
|
Requires: pygtk2-libglade usermode usermode-gtk
|
||||||
|
|
||||||
|
%description -n system-config-audit
|
||||||
|
An utility for editing audit configuration.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -iv --install
|
aclocal && autoconf && autoheader && automake
|
||||||
%configure --sbindir=/sbin --libdir=/%{_lib}
|
%configure --sbindir=/sbin --libdir=/%{_lib}
|
||||||
make
|
make
|
||||||
|
|
||||||
@ -75,6 +89,7 @@ mkdir -p $RPM_BUILD_ROOT/%{_lib}
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
|
mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
||||||
# This winds up in the wrong place when libtool is involved
|
# This winds up in the wrong place when libtool is involved
|
||||||
@ -100,6 +115,8 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_auparse.la
|
|||||||
# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
|
# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
|
||||||
touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
|
touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
|
||||||
|
|
||||||
|
%find_lang system-config-audit
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -180,7 +197,35 @@ fi
|
|||||||
%config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
|
%config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
|
||||||
%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
|
%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
|
||||||
|
|
||||||
|
%files -n system-config-audit -f system-config-audit.lang
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc system-config-audit/AUTHORS
|
||||||
|
%doc system-config-audit/COPYING
|
||||||
|
%doc system-config-audit/ChangeLog
|
||||||
|
%doc system-config-audit/NEWS
|
||||||
|
%doc system-config-audit/README
|
||||||
|
%{_bindir}/system-config-audit
|
||||||
|
%{_datadir}/applications/system-config-audit.desktop
|
||||||
|
%{_datadir}/system-config-audit
|
||||||
|
%{_libexecdir}/system-config-audit-server-real
|
||||||
|
%{_libexecdir}/system-config-audit-server
|
||||||
|
%config(noreplace) %{_sysconfdir}/pam.d/system-config-audit-server
|
||||||
|
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
|
||||||
|
- Add system-config-audit (Miloslav Trmac)
|
||||||
|
- Correct bug in audit_make_equivalent function (Al Viro)
|
||||||
|
|
||||||
|
* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
|
||||||
|
- Add feed interface to auparse library (John Dennis)
|
||||||
|
- Apply patch to libauparse for unresolved symbols (#241178)
|
||||||
|
- Apply patch to add line numbers for file events in libauparse (John Dennis)
|
||||||
|
- Change seresults to seresult in libauparse (John Dennis)
|
||||||
|
- Add unit32_t definition to swig (#244210)
|
||||||
|
- Add support for directory auditing
|
||||||
|
- Update acct field to be escaped
|
||||||
|
|
||||||
* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
|
* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
|
||||||
- Change buffer size to prevent truncation of DAEMON events with large labels
|
- Change buffer size to prevent truncation of DAEMON events with large labels
|
||||||
- Fix memory leaks in auparse (John Dennis)
|
- Fix memory leaks in auparse (John Dennis)
|
||||||
|
Loading…
Reference in New Issue
Block a user