- Fix a double free when auditd receives SIGHUP

- Move the system-config-audit menu entry to the Administration menu
This commit is contained in:
Miloslav Trmac 2007-07-16 23:30:49 +00:00
parent c56912826f
commit be93e36052
3 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,14 @@
--- audit/src/auditd.c.reconfig 2007-07-01 04:12:43.000000000 +0200
+++ audit/src/auditd.c 2007-07-01 04:25:41.000000000 +0200
@@ -522,10 +522,8 @@ int main(int argc, char *argv[])
AUDIT_DAEMON_CONFIG,
"auditd error getting hup info - no change,"
" sending auid=? pid=? subj=? res=failed");
- } else {
- free(rep);
- rep = NULL;
}
+ rep = NULL;
hup_info_requested = 0;
} else if(usr1_info_requested){
char usr1[MAX_AUDIT_MESSAGE_LENGTH];

View File

@ -0,0 +1,22 @@
diff -urN audit/system-config-audit/ChangeLog audit-1.5.5/system-config-audit/ChangeLog
--- audit/system-config-audit/ChangeLog 2007-06-27 15:07:59.000000000 +0200
+++ audit-1.5.5/system-config-audit/ChangeLog 2007-07-17 01:20:02.000000000 +0200
@@ -1,3 +1,8 @@
+2007-07-17 Miloslav Trmač <mitr@redhat.com>
+
+ * system-config-audit.desktop.in (Categories): Add System, to move the
+ menu entry to the Administration submenu.
+
2007-06-27 Miloslav Trmač <mitr@redhat.com>
* configure.ac: Release 0.4.2.
diff -urN audit/system-config-audit/system-config-audit.desktop.in audit-1.5.5/system-config-audit/system-config-audit.desktop.in
--- audit/system-config-audit/system-config-audit.desktop.in 2007-05-15 00:41:31.000000000 +0200
+++ audit-1.5.5/system-config-audit/system-config-audit.desktop.in 2007-07-17 01:20:02.000000000 +0200
@@ -6,4 +6,4 @@
Terminal=false
Type=Application
Icon=logviewer
-Categories=Settings;
\ Chybí znak konce řádku na konci souboru
+Categories=Settings;System;

View File

@ -3,11 +3,13 @@
Summary: User space tools for 2.6 kernel auditing
Name: audit
Version: 1.5.5
Release: 1%{?dist}
Release: 5%{?dist}
License: GPL
Group: System Environment/Daemons
URL: http://people.redhat.com/sgrubb/audit/
Source0: %{name}-%{version}.tar.gz
Patch0: audit-1.5.5-reconfig.patch
Patch1: audit-1.5.5-sca-categories.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool swig python-devel
BuildRequires: kernel-headers >= 2.6.18
@ -75,6 +77,8 @@ An utility for editing audit configuration.
%prep
%setup -q
%patch0 -p1 -b .reconfig
%patch1 -p1 -b .sca-categories
%build
aclocal && autoconf && autoheader && automake
@ -213,6 +217,10 @@ fi
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
%changelog
* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
- Fix a double free when auditd receives SIGHUP
- Move the system-config-audit menu entry to the Administration menu
* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
- Add system-config-audit (Miloslav Trmac)
- Correct bug in audit_make_equivalent function (Al Viro)