New upstream release, 3.0.2.
Fix issues detected by static analyzers Resolves: rhbz#1938680
This commit is contained in:
parent
b7bafe97c3
commit
8f56ad5dee
1
.gitignore
vendored
1
.gitignore
vendored
@ -166,3 +166,4 @@ audit-2.0.4.tar.gz
|
|||||||
/audit-3.0-alpha9.tar.gz
|
/audit-3.0-alpha9.tar.gz
|
||||||
/audit-3.0.tar.gz
|
/audit-3.0.tar.gz
|
||||||
/audit-3.0.1.tar.gz
|
/audit-3.0.1.tar.gz
|
||||||
|
/audit-3.0.2.tar.gz
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
diff -urp audit-3.0.2.orig/audisp/plugins/statsd/audisp-statsd.c audit-3.0.2/audisp/plugins/statsd/audisp-statsd.c
|
|
||||||
--- audit-3.0.2.orig/audisp/plugins/statsd/audisp-statsd.c 2021-02-12 10:13:09.000000000 -0500
|
|
||||||
+++ audit-3.0.2/audisp/plugins/statsd/audisp-statsd.c 2021-02-16 22:39:05.429139678 -0500
|
|
||||||
@@ -46,7 +46,7 @@ struct daemon_config
|
|
||||||
unsigned int port;
|
|
||||||
unsigned int interval;
|
|
||||||
int sock;
|
|
||||||
- struct sockaddr addr;
|
|
||||||
+ struct sockaddr_storage addr;
|
|
||||||
socklen_t addrlen;
|
|
||||||
};
|
|
||||||
|
|
||||||
@@ -287,7 +287,8 @@ static void send_statsd(void)
|
|
||||||
r.events_anomaly_count, r.events_response_count);
|
|
||||||
|
|
||||||
if (len > 0 && len < (int)sizeof(message))
|
|
||||||
- sendto(d.sock, message, len, 0, &d.addr, d.addrlen);
|
|
||||||
+ sendto(d.sock, message, len, 0, (struct sockaddr *)&d.addr,
|
|
||||||
+ d.addrlen);
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
54
audit.spec
54
audit.spec
@ -1,13 +1,12 @@
|
|||||||
|
|
||||||
Summary: User space tools for kernel auditing
|
Summary: User space tools for kernel auditing
|
||||||
Name: audit
|
Name: audit
|
||||||
Version: 3.0.1
|
Version: 3.0.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://people.redhat.com/sgrubb/audit/
|
URL: http://people.redhat.com/sgrubb/audit/
|
||||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||||
Patch1: audit-3.0.2-sockaddr.patch
|
|
||||||
|
|
||||||
BuildRequires: make gcc swig
|
BuildRequires: make gcc swig
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
@ -88,13 +87,12 @@ Management Facility) database, through an IBM Tivoli Directory Server
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Remove the ids code, its not ready
|
# Remove the ids code, its not ready
|
||||||
sed -i 's/ ids / /' audisp/plugins/Makefile.in
|
sed -i 's/ ids / /' audisp/plugins/Makefile.in
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --sbindir=/sbin --libdir=/%{_lib} --with-python=no \
|
%configure --with-python=no \
|
||||||
--with-python3=yes \
|
--with-python3=yes \
|
||||||
--enable-gssapi-krb5=yes --with-arm --with-aarch64 \
|
--enable-gssapi-krb5=yes --with-arm --with-aarch64 \
|
||||||
--with-libcap-ng=yes --enable-zos-remote \
|
--with-libcap-ng=yes --enable-zos-remote \
|
||||||
@ -111,26 +109,13 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
|
mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
|
||||||
curdir=`pwd`
|
|
||||||
cd $RPM_BUILD_ROOT/%{_libdir}
|
|
||||||
LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.1.*.*\``
|
|
||||||
ln -s ../../%{_lib}/$LIBNAME libaudit.so
|
|
||||||
LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.0.*.*\``
|
|
||||||
ln -s ../../%{_lib}/$LIBNAME libauparse.so
|
|
||||||
cd $curdir
|
|
||||||
# Remove these items so they don't get picked up.
|
# Remove these items so they don't get picked up.
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libaudit.a
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libauparse.a
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.a
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.a
|
|
||||||
|
|
||||||
find $RPM_BUILD_ROOT -name '*.la' -delete
|
find $RPM_BUILD_ROOT -name '*.la' -delete
|
||||||
find $RPM_BUILD_ROOT/%{_libdir}/python%{python3_version}/site-packages -name '*.a' -delete
|
find $RPM_BUILD_ROOT/%{_libdir}/python%{python3_version}/site-packages -name '*.a' -delete
|
||||||
|
|
||||||
# Move the pkgconfig file
|
|
||||||
mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
|
|
||||||
|
|
||||||
# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
|
# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
|
||||||
touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
|
touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
|
||||||
touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
|
touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
|
||||||
@ -167,8 +152,8 @@ fi
|
|||||||
%files libs
|
%files libs
|
||||||
%{!?_licensedir:%global license %%doc}
|
%{!?_licensedir:%global license %%doc}
|
||||||
%license lgpl-2.1.txt
|
%license lgpl-2.1.txt
|
||||||
/%{_lib}/libaudit.so.1*
|
%{_libdir}/libaudit.so.1*
|
||||||
/%{_lib}/libauparse.*
|
%{_libdir}/libauparse.*
|
||||||
%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
|
%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
|
||||||
%{_mandir}/man5/libaudit.conf.5.gz
|
%{_mandir}/man5/libaudit.conf.5.gz
|
||||||
|
|
||||||
@ -206,12 +191,12 @@ fi
|
|||||||
%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
|
%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
|
||||||
%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
|
%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
|
||||||
%attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
|
%attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
|
||||||
%attr(755,root,root) /sbin/auditctl
|
%attr(755,root,root) %{_sbindir}/auditctl
|
||||||
%attr(755,root,root) /sbin/auditd
|
%attr(755,root,root) %{_sbindir}/auditd
|
||||||
%attr(755,root,root) /sbin/ausearch
|
%attr(755,root,root) %{_sbindir}/ausearch
|
||||||
%attr(755,root,root) /sbin/aureport
|
%attr(755,root,root) %{_sbindir}/aureport
|
||||||
%attr(750,root,root) /sbin/autrace
|
%attr(750,root,root) %{_sbindir}/autrace
|
||||||
%attr(755,root,root) /sbin/augenrules
|
%attr(755,root,root) %{_sbindir}/augenrules
|
||||||
%attr(755,root,root) %{_bindir}/aulast
|
%attr(755,root,root) %{_bindir}/aulast
|
||||||
%attr(755,root,root) %{_bindir}/aulastlog
|
%attr(755,root,root) %{_bindir}/aulastlog
|
||||||
%attr(755,root,root) %{_bindir}/ausyscall
|
%attr(755,root,root) %{_bindir}/ausyscall
|
||||||
@ -242,9 +227,9 @@ fi
|
|||||||
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
|
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
|
%config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
|
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
|
||||||
%attr(750,root,root) /sbin/audisp-remote
|
%attr(750,root,root) %{_sbindir}/audisp-remote
|
||||||
%attr(750,root,root) /sbin/audisp-syslog
|
%attr(750,root,root) %{_sbindir}/audisp-syslog
|
||||||
%attr(750,root,root) /sbin/audisp-statsd
|
%attr(750,root,root) %{_sbindir}/audisp-statsd
|
||||||
%attr(700,root,root) %dir %{_var}/spool/audit
|
%attr(700,root,root) %dir %{_var}/spool/audit
|
||||||
%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
|
%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
|
||||||
%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
|
%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
|
||||||
@ -256,9 +241,14 @@ fi
|
|||||||
%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
|
%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
|
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
|
%config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
|
||||||
%attr(750,root,root) /sbin/audispd-zos-remote
|
%attr(750,root,root) %{_sbindir}/audispd-zos-remote
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 22 2021 Sergio Correia <scorreia@redhat.com> - 3.0.2-1
|
||||||
|
- New upstream release, 3.0.2.
|
||||||
|
Fix issues detected by static analyzers
|
||||||
|
Resolves: rhbz#1938680
|
||||||
|
|
||||||
* Mon Jun 21 2021 Sergio Correia <scorreia@redhat.com> - 3.0.1-4
|
* Mon Jun 21 2021 Sergio Correia <scorreia@redhat.com> - 3.0.1-4
|
||||||
- Enable default RHEL configuration
|
- Enable default RHEL configuration
|
||||||
This enables syscall auditing by default.
|
This enables syscall auditing by default.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (audit-3.0.1.tar.gz) = ad2897c9f539681f0f65b08cd0e650c528957fd4799755c2bcc47f869e04272aad31684c46847124d7b42dde243a16ba2754936890189610814c7007c0381d8c
|
SHA512 (audit-3.0.2.tar.gz) = 9e831ed6f30ac7d58f028cede97adba431bde18dfd9045c19f5e03eff52cd28db3a6792e5969f555ce51aa562662b59fa5cc5265586c6acf0b3aa1feae4d720f
|
||||||
|
Loading…
Reference in New Issue
Block a user