- New upstream release

This commit is contained in:
Steve 2010-11-02 16:53:07 -04:00
parent cbcebc21db
commit 86f9e56bf6
7 changed files with 7 additions and 65 deletions

1
.gitignore vendored
View File

@ -104,3 +104,4 @@ audit-1.8.tar.gz
audit-2.0.1.tar.gz
audit-2.0.3.tar.gz
audit-2.0.4.tar.gz
/audit-2.0.5.tar.gz

View File

@ -1,12 +0,0 @@
diff -up audit-2.0.4/src/Makefile.am.jx audit-2.0.4/src/Makefile.am
--- audit-2.0.4/src/Makefile.am.jx 2009-12-07 16:16:45.000000000 -0500
+++ audit-2.0.4/src/Makefile.am 2010-02-16 16:51:21.000000000 -0500
@@ -34,7 +34,7 @@ auditd_SOURCES = auditd.c auditd-event.c
auditd_CFLAGS = -fPIE -DPIE -g -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing
auditd_LDFLAGS = -pie -Wl,-z,relro
auditd_DEPENDENCIES = mt/libauditmt.a libev/libev.a
-auditd_LDADD = @LIBWRAP_LIBS@ @libev_LIBS@ -Llibev -lev -lrt -lm $(gss_libs)
+auditd_LDADD = @LIBWRAP_LIBS@ @libev_LIBS@ -Llibev -lev -lrt -lpthread -lm $(gss_libs)
auditctl_SOURCES = auditctl.c auditctl-llist.c delete_all.c
auditctl_DEPENDENCIES = mt/libauditmt.a

View File

@ -1,14 +0,0 @@
diff -urp audit-2.0.5.orig/auparse/auparse.c audit-2.0.5/auparse/auparse.c
--- audit-2.0.5.orig/auparse/auparse.c 2009-12-09 09:49:10.000000000 -0500
+++ audit-2.0.5/auparse/auparse.c 2009-12-09 09:49:24.000000000 -0500
@@ -782,6 +782,10 @@ static int retrieve_next_line(auparse_st
case AUSOURCE_FILE_ARRAY:
// if the first time through, open file
if (au->list_idx == 0 && au->in == NULL) {
+ if (au->source_list[au->list_idx] == NULL) {
+ errno = 0;
+ return -2;
+ }
au->line_number = 0;
au->in = fopen(au->source_list[au->list_idx],
"r");

View File

@ -1,11 +0,0 @@
diff -urp audit-2.0.5.orig/lib/libaudit.c audit-2.0.5/lib/libaudit.c
--- audit-2.0.5.orig/lib/libaudit.c 2009-12-09 09:49:10.000000000 -0500
+++ audit-2.0.5/lib/libaudit.c 2010-01-13 19:28:10.000000000 -0500
@@ -34,6 +34,7 @@
#include <errno.h>
#include <sys/poll.h>
#include <sys/utsname.h>
+#include <sys/stat.h>
#include <fcntl.h> /* O_NOFOLLOW needs gnu defined */
#include <limits.h> /* for PATH_MAX */

View File

@ -1,17 +0,0 @@
diff -urp audit-2.0.5.orig/lib/libaudit.c audit-2.0.5/lib/libaudit.c
--- audit-2.0.5.orig/lib/libaudit.c 2009-12-09 09:49:10.000000000 -0500
+++ audit-2.0.5/lib/libaudit.c 2010-01-13 14:28:52.000000000 -0500
@@ -1130,7 +1130,12 @@ int audit_rule_fieldpair_data(struct aud
if (!isdigit((char)*(v)))
return -21;
- rule->values[rule->field_count] = strtol(v, NULL, 0);
+ if (field == AUDIT_INODE)
+ rule->values[rule->field_count] =
+ strtoul(v, NULL, 0);
+ else
+ rule->values[rule->field_count] =
+ strtol(v, NULL, 0);
break;
}
rule->field_count++;

View File

@ -2,16 +2,12 @@
Summary: User space tools for 2.6 kernel auditing
Name: audit
Version: 2.0.4
Release: 4%{?dist}
Version: 2.0.5
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Daemons
URL: http://people.redhat.com/sgrubb/audit/
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
Patch1: audit-2.0.5-auparse-empty-FILE_ARRAY.patch
Patch2: audit-2.0.5-i386-inode.patch
Patch3: audit-2.0.5-glibc.patch
Patch4: audit-2.0.4-add-needed.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: swig python-devel
BuildRequires: tcp_wrappers-devel libcap-ng-devel
@ -85,10 +81,6 @@ behavior.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%build
autoreconf -v --install
@ -242,6 +234,9 @@ fi
%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
%changelog
* Tue Nov 02 2010 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
- New upstream release
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.0.4-4
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild

View File

@ -1 +1 @@
90d2c70e74041fca5ac4b999cb915d68 audit-2.0.4.tar.gz
1326b712dab362acbc8686cd91f8e3e1 audit-2.0.5.tar.gz