New upstream release
This commit is contained in:
parent
fdb1089881
commit
82c73eb149
1
.gitignore
vendored
1
.gitignore
vendored
@ -176,3 +176,4 @@ audit-2.0.4.tar.gz
|
||||
/audit-3.0.9.tar.gz
|
||||
/audit-3.1.tar.gz
|
||||
/audit-3.1.1.tar.gz
|
||||
/audit-3.1.2.tar.gz
|
||||
|
@ -1,37 +0,0 @@
|
||||
diff -urp audit-3.0.8.orig/bindings/swig/src/auditswig.i audit-3.0.8/bindings/swig/src/auditswig.i
|
||||
--- audit-3.0.8.orig/bindings/swig/src/auditswig.i 2022-03-29 16:52:34.000000000 -0400
|
||||
+++ audit-3.0.8/bindings/swig/src/auditswig.i 2022-03-29 17:31:15.810268855 -0400
|
||||
@@ -39,7 +39,7 @@ signed
|
||||
#define __attribute(X) /*nothing*/
|
||||
typedef unsigned __u32;
|
||||
typedef unsigned uid_t;
|
||||
-%include "/usr/include/linux/audit.h"
|
||||
+%include "../lib/audit.h"
|
||||
#define __extension__ /*nothing*/
|
||||
%include <stdint.i>
|
||||
%include "../lib/libaudit.h"
|
||||
diff -urp audit-3.0.8.orig/lib/audit.h audit-3.0.8/lib/audit.h
|
||||
--- audit-3.0.8.orig/lib/audit.h 2022-03-29 17:29:30.358211892 -0400
|
||||
+++ audit-3.0.8/lib/audit.h 2022-03-29 17:31:15.811268833 -0400
|
||||
@@ -514,7 +514,7 @@ struct audit_rule_data {
|
||||
__u32 values[AUDIT_MAX_FIELDS];
|
||||
__u32 fieldflags[AUDIT_MAX_FIELDS];
|
||||
__u32 buflen; /* total length of string fields */
|
||||
- char buf[]; /* string fields buffer */
|
||||
+ char buf[0]; /* string fields buffer */
|
||||
};
|
||||
|
||||
#endif /* _LINUX_AUDIT_H_ */
|
||||
diff -urp audit-3.0.8.orig/lib/libaudit.h audit-3.0.8/lib/libaudit.h
|
||||
--- audit-3.0.8.orig/lib/libaudit.h 2022-03-29 16:52:34.000000000 -0400
|
||||
+++ audit-3.0.8/lib/libaudit.h 2022-03-29 17:31:15.812268812 -0400
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <stdint.h>
|
||||
#include <sys/socket.h>
|
||||
#include <linux/netlink.h>
|
||||
-#include <linux/audit.h>
|
||||
+#include "audit.h"
|
||||
#include <stdarg.h>
|
||||
#include <syslog.h>
|
||||
#ifndef __attr_access
|
||||
Only in audit-3.0.8/lib: libaudit.h.orig
|
@ -1,12 +0,0 @@
|
||||
diff -urp usr.orig/include/libaudit.h.orig usr/include/libaudit.h
|
||||
--- usr.orig/include/libaudit.h.orig 2022-02-14 14:14:08.000000000 -0500
|
||||
+++ usr/include/libaudit.h 2022-02-23 13:35:52.638340789 -0500
|
||||
@@ -39,7 +39,7 @@ extern "C" {
|
||||
#include <stdint.h>
|
||||
#include <sys/socket.h>
|
||||
#include <linux/netlink.h>
|
||||
-#include "audit.h"
|
||||
+#include <linux/audit.h>
|
||||
#include <stdarg.h>
|
||||
#include <syslog.h>
|
||||
|
19
audit.spec
19
audit.spec
@ -1,14 +1,12 @@
|
||||
|
||||
Summary: User space tools for kernel auditing
|
||||
Name: audit
|
||||
Version: 3.1.1
|
||||
Release: 4%{?dist}
|
||||
Version: 3.1.2
|
||||
Release: 1%{?dist}
|
||||
License: GPL-2.0-or-later AND LGPL-2.0-or-later
|
||||
URL: http://people.redhat.com/sgrubb/audit/
|
||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
Patch1: audit-3.0.8-flex-array-workaround.patch
|
||||
Patch2: audit-3.0.8-undo-flex-array.patch
|
||||
|
||||
BuildRequires: make gcc
|
||||
BuildRequires: krb5-devel
|
||||
@ -90,8 +88,6 @@ Management Facility) database, through an IBM Tivoli Directory Server
|
||||
%prep
|
||||
%setup -q
|
||||
cp %{SOURCE1} .
|
||||
cp /usr/include/linux/audit.h lib/
|
||||
%patch1 -p1
|
||||
|
||||
# Remove the ids code, its not ready
|
||||
sed -i 's/ ids / /' audisp/plugins/Makefile.am
|
||||
@ -126,13 +122,6 @@ find $RPM_BUILD_ROOT/%{_libdir}/python%{python3_version}/site-packages -name '*.
|
||||
touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
|
||||
touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
|
||||
|
||||
# undo the workaround
|
||||
cur=`pwd`
|
||||
cd $RPM_BUILD_ROOT
|
||||
patch -p0 < %{PATCH2}
|
||||
find . -name '*.orig' -delete
|
||||
cd $cur
|
||||
|
||||
%check
|
||||
make check
|
||||
# Get rid of make files so that they don't get packaged.
|
||||
@ -239,7 +228,6 @@ fi
|
||||
%ghost %config(noreplace) %attr(600,root,root) /etc/audit/rules.d/audit.rules
|
||||
%ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
|
||||
%config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
|
||||
%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
|
||||
|
||||
%files -n audispd-plugins
|
||||
%config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
|
||||
@ -267,6 +255,9 @@ fi
|
||||
%attr(750,root,root) %{_sbindir}/audispd-zos-remote
|
||||
|
||||
%changelog
|
||||
* Sun Aug 06 2023 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (audit-3.1.1.tar.gz) = 4917970cc4c7f786c464a6d101bf66d55d55ac4716cf415ff97177f08176a6301e946716d28cf5b16054538469b3140b97db99d55a28686a9a807eea60c070f3
|
||||
SHA512 (audit-3.1.2.tar.gz) = a97003a294ed3671df01e2952688e7d5eef59a35f6891feb53e67c4c7eab9ae8c2d18de41a5b5b20e0ad7156fac93aec05f32f6bc5eea706b42b6f27f676446a
|
||||
|
Loading…
Reference in New Issue
Block a user