New upstream bugfix release
This commit is contained in:
parent
01401f2484
commit
5eb0df1ff8
1
.gitignore
vendored
1
.gitignore
vendored
@ -170,3 +170,4 @@ audit-2.0.4.tar.gz
|
||||
/audit-3.0.3.tar.gz
|
||||
/audit-3.0.4.tar.gz
|
||||
/audit-3.0.5.tar.gz
|
||||
/audit-3.0.6.tar.gz
|
||||
|
@ -1,62 +0,0 @@
|
||||
From 6b09724c69d91668418ddb3af00da6db6755208c Mon Sep 17 00:00:00 2001
|
||||
From: Steve Grubb <sgrubb@redhat.com>
|
||||
Date: Thu, 2 Sep 2021 15:01:12 -0400
|
||||
Subject: [PATCH] Make IPX packet interpretation dependent on the ipx header
|
||||
file existing
|
||||
|
||||
---
|
||||
ChangeLog | 1 +
|
||||
auparse/interpret.c | 8 ++++++--
|
||||
configure.ac | 6 ++++++
|
||||
3 files changed, 13 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/auparse/interpret.c b/auparse/interpret.c
|
||||
index 63829aa0..6c316456 100644
|
||||
--- a/auparse/interpret.c
|
||||
+++ b/auparse/interpret.c
|
||||
@@ -44,8 +44,10 @@
|
||||
#include <linux/ax25.h>
|
||||
#include <linux/atm.h>
|
||||
#include <linux/x25.h>
|
||||
-#include <linux/if.h> // FIXME: remove when ipx.h is fixed
|
||||
-#include <linux/ipx.h>
|
||||
+#ifdef HAVE_IPX_HEADERS
|
||||
+ #include <linux/if.h> // FIXME: remove when ipx.h is fixed
|
||||
+ #include <linux/ipx.h>
|
||||
+#endif
|
||||
#include <linux/capability.h>
|
||||
#include <sys/personality.h>
|
||||
#include <sys/prctl.h>
|
||||
@@ -1279,6 +1281,7 @@ static const char *print_sockaddr(const char *val)
|
||||
x->sax25_call.ax25_call[6]);
|
||||
}
|
||||
break;
|
||||
+#ifdef HAVE_IPX_HEADERS
|
||||
case AF_IPX:
|
||||
{
|
||||
const struct sockaddr_ipx *ip =
|
||||
@@ -1288,6 +1291,7 @@ static const char *print_sockaddr(const char *val)
|
||||
str, ip->sipx_port, ip->sipx_network);
|
||||
}
|
||||
break;
|
||||
+#endif
|
||||
case AF_ATMPVC:
|
||||
{
|
||||
const struct sockaddr_atmpvc* at =
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 8f541e4c..005eb0b5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -418,6 +418,12 @@ if test x"$LIBWRAP_LIBS" != "x"; then
|
||||
AC_DEFINE_UNQUOTED(HAVE_LIBWRAP, [], Define if tcp_wrappers support is enabled )
|
||||
fi
|
||||
|
||||
+# linux/ipx.h - deprecated in 2018
|
||||
+AC_CHECK_HEADER(linux/ipx.h, ipx_headers=yes, ipx_headers=no)
|
||||
+if test $ipx_headers = yes ; then
|
||||
+ AC_DEFINE(HAVE_IPX_HEADERS,1,[IPX packet interpretation])
|
||||
+fi
|
||||
+
|
||||
# See if we want to support lower capabilities for plugins
|
||||
LIBCAP_NG_PATH
|
||||
|
10
audit.spec
10
audit.spec
@ -7,9 +7,6 @@ License: GPLv2+
|
||||
URL: http://people.redhat.com/sgrubb/audit/
|
||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
# Remove the next 2 lines for audit-3.0.6
|
||||
Patch1: audit-ipx.patch
|
||||
BuildRequires: autoconf automake libtool
|
||||
|
||||
BuildRequires: make gcc
|
||||
BuildRequires: krb5-devel
|
||||
@ -91,10 +88,6 @@ Management Facility) database, through an IBM Tivoli Directory Server
|
||||
%prep
|
||||
%setup -q
|
||||
cp %{SOURCE1} .
|
||||
%patch1 -p1
|
||||
|
||||
# Remove next line for audit-3.0.6
|
||||
autoreconf -fv --install
|
||||
|
||||
# Remove the ids code, its not ready
|
||||
sed -i 's/ ids / /' audisp/plugins/Makefile.in
|
||||
@ -253,6 +246,9 @@ fi
|
||||
%attr(750,root,root) %{_sbindir}/audispd-zos-remote
|
||||
|
||||
%changelog
|
||||
* Fri Oct 01 2021 Steve Grubb <sgrubb@redhat.com> 3.0.6-1
|
||||
- New upstream bugfix release
|
||||
|
||||
* Tue Sep 14 2021 Steve Grubb <sgrubb@redhat.com> 3.0.5-3
|
||||
- Move BuildRequires around to what actually needs it
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (audit-3.0.5.tar.gz) = 147b8aab7801ac286d8d634736b90b94cf497c5d3a6142f521e527dec9b989ed884caf0ac08aa533635276da46e78a65b14ebf165cd847a8500e29a2829a890d
|
||||
SHA512 (audit-3.0.6.tar.gz) = 74734e1b1fddea086db9c5dc8c4b7817917fdf17bc7ca4e5b440aae975484d020a17c3f485f6a37b6b150a307d809e50d559d31a8cbd6f1e554933719551bcd1
|
||||
|
Loading…
Reference in New Issue
Block a user