- New upstream release
This commit is contained in:
parent
333ae898aa
commit
26bdc0669a
@ -94,3 +94,4 @@ audit-1.7.5.tar.gz
|
|||||||
audit-1.7.6.tar.gz
|
audit-1.7.6.tar.gz
|
||||||
audit-1.7.7.tar.gz
|
audit-1.7.7.tar.gz
|
||||||
audit-1.7.8.tar.gz
|
audit-1.7.8.tar.gz
|
||||||
|
audit-1.7.9.tar.gz
|
||||||
|
@ -1,42 +0,0 @@
|
|||||||
diff -urp audit-1.7.8/src/auditd-config.c audit-1.7.9/src/auditd-config.c
|
|
||||||
--- audit-1.7.8/src/auditd-config.c 2008-10-22 14:02:04.000000000 -0400
|
|
||||||
+++ audit-1.7.9/src/auditd-config.c 2008-10-23 15:55:45.000000000 -0400
|
|
||||||
@@ -1372,7 +1372,7 @@ static int enable_krb5_parser(struct nv_
|
|
||||||
nv->value);
|
|
||||||
|
|
||||||
#ifndef USE_GSSAPI
|
|
||||||
- audit_msg(LOG_NOTICE,
|
|
||||||
+ audit_msg(LOG_DEBUG,
|
|
||||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
|
||||||
line);
|
|
||||||
return 0;
|
|
||||||
@@ -1395,7 +1395,7 @@ static int krb5_principal_parser(struct
|
|
||||||
|
|
||||||
audit_msg(LOG_DEBUG,"krb5_principal_parser called with: %s",nv->value);
|
|
||||||
#ifndef USE_GSSAPI
|
|
||||||
- audit_msg(LOG_NOTICE,
|
|
||||||
+ audit_msg(LOG_DEBUG,
|
|
||||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
|
||||||
line);
|
|
||||||
return 0;
|
|
||||||
@@ -1412,7 +1412,7 @@ static int krb5_key_file_parser(struct n
|
|
||||||
|
|
||||||
audit_msg(LOG_DEBUG, "krb5_key_file_parser called with: %s", nv->value);
|
|
||||||
#ifndef USE_GSSAPI
|
|
||||||
- audit_msg(LOG_NOTICE,
|
|
||||||
+ audit_msg(LOG_DEBUG,
|
|
||||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
|
||||||
line);
|
|
||||||
return 0;
|
|
||||||
diff -urp audit-1.7.8/src/aureport.c audit-1.7.9/src/aureport.c
|
|
||||||
--- audit-1.7.8/src/aureport.c 2008-10-22 14:02:04.000000000 -0400
|
|
||||||
+++ audit-1.7.9/src/aureport.c 2008-10-23 15:55:45.000000000 -0400
|
|
||||||
@@ -105,6 +105,8 @@ int main(int argc, char *argv[])
|
|
||||||
config.admin_space_left_exe = NULL;
|
|
||||||
config.disk_full_exe = NULL;
|
|
||||||
config.disk_error_exe = NULL;
|
|
||||||
+ config.krb5_principal = NULL;
|
|
||||||
+ config.krb5_key_file = NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
print_title();
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -urp audit-1.7.9.orig/src/ausearch-report.c audit-1.7.9/src/ausearch-report.c
|
|
||||||
--- audit-1.7.9.orig/src/ausearch-report.c 2008-10-24 13:49:39.000000000 -0400
|
|
||||||
+++ audit-1.7.9/src/ausearch-report.c 2008-10-24 15:24:51.000000000 -0400
|
|
||||||
@@ -63,7 +63,7 @@ static void output_interpreted_node(cons
|
|
||||||
static void interpret(char *name, char *val, int comma, int rtype);
|
|
||||||
|
|
||||||
/* The machine based on elf type */
|
|
||||||
-static int machine = 0;
|
|
||||||
+static int machine = -1;
|
|
||||||
|
|
||||||
/* The first syscall argument */
|
|
||||||
static unsigned long long a0;
|
|
||||||
@@ -424,7 +424,7 @@ static void print_syscall(const char *va
|
|
||||||
const char *sys;
|
|
||||||
int ival;
|
|
||||||
|
|
||||||
- if (machine <= 0)
|
|
||||||
+ if (machine < 0)
|
|
||||||
machine = audit_detect_machine();
|
|
||||||
if (machine < 0) {
|
|
||||||
printf("%s ", val);
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -urp audit-1.7.9.orig/src/auditd.c audit-1.7.9/src/auditd.c
|
|
||||||
--- audit-1.7.9.orig/src/auditd.c 2008-10-25 08:25:39.000000000 -0400
|
|
||||||
+++ audit-1.7.9/src/auditd.c 2008-10-25 08:42:08.000000000 -0400
|
|
||||||
@@ -664,7 +664,7 @@ int main(int argc, char *argv[])
|
|
||||||
tell_parent(SUCCESS);
|
|
||||||
|
|
||||||
/* Depending on value of opt_startup (-s) set initial audit state */
|
|
||||||
- if (opt_startup != startup_nochange &&
|
|
||||||
+ if ((audit_is_enabled(fd) < 2) && opt_startup != startup_nochange &&
|
|
||||||
audit_set_enabled(fd, (int)opt_startup) < 0) {
|
|
||||||
char emsg[DEFAULT_BUF_SZ];
|
|
||||||
if (*subj)
|
|
@ -1,28 +0,0 @@
|
|||||||
diff -urp audit-1.7.9.orig/src/ausearch-time.c audit-1.7.9/src/ausearch-time.c
|
|
||||||
--- audit-1.7.9.orig/src/ausearch-time.c 2008-10-25 08:25:39.000000000 -0400
|
|
||||||
+++ audit-1.7.9/src/ausearch-time.c 2008-10-27 08:11:49.000000000 -0400
|
|
||||||
@@ -282,7 +282,7 @@ int ausearch_time_start(const char *da,
|
|
||||||
} else {
|
|
||||||
int keyword=lookup_time(da);
|
|
||||||
if (keyword == T_RECENT || keyword == T_NOW) {
|
|
||||||
- if (ti == NULL)
|
|
||||||
+ if (ti == NULL || strcmp(ti, "00:00:00") == 0)
|
|
||||||
goto set_it;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
@@ -352,13 +352,13 @@ int ausearch_time_end(const char *da, co
|
|
||||||
} else {
|
|
||||||
int keyword=lookup_time(da);
|
|
||||||
if (keyword == T_RECENT || keyword == T_NOW) {
|
|
||||||
- if (ti == NULL)
|
|
||||||
+ if (ti == NULL || strcmp(ti, "00:00:00") == 0)
|
|
||||||
goto set_it;
|
|
||||||
}
|
|
||||||
// Special case today
|
|
||||||
if (keyword == T_TODAY) {
|
|
||||||
set_tm_now(&d);
|
|
||||||
- if (ti == NULL)
|
|
||||||
+ if (ti == NULL || strcmp(ti, "00:00:00") == 0)
|
|
||||||
goto set_it;
|
|
||||||
}
|
|
||||||
}
|
|
20
audit.spec
20
audit.spec
@ -1,7 +1,7 @@
|
|||||||
%define audit_version 1.7.8
|
%define audit_version 1.7.9
|
||||||
%define audit_release 6%{?dist}
|
%define audit_release 1%{?dist}
|
||||||
%define sca_version 0.4.8
|
%define sca_version 0.4.8
|
||||||
%define sca_release 10
|
%define sca_release 11
|
||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
Summary: User space tools for 2.6 kernel auditing
|
Summary: User space tools for 2.6 kernel auditing
|
||||||
@ -12,10 +12,6 @@ License: GPLv2+
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://people.redhat.com/sgrubb/audit/
|
URL: http://people.redhat.com/sgrubb/audit/
|
||||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||||
Patch1: audit-1.7.9-bugs.patch
|
|
||||||
Patch2: audit-1.7.9-i386.patch
|
|
||||||
Patch3: audit-1.7.9-startup.patch
|
|
||||||
Patch4: audit-1.7.9-time.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gettext-devel intltool libtool swig python-devel
|
BuildRequires: gettext-devel intltool libtool swig python-devel
|
||||||
BuildRequires: tcp_wrappers-devel
|
BuildRequires: tcp_wrappers-devel
|
||||||
@ -93,13 +89,8 @@ A graphical utility for editing audit configuration.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
(cd system-config-audit; ./autogen.sh)
|
|
||||||
%configure --sbindir=/sbin --libdir=/%{_lib} --with-prelude --with-libwrap --enable-gssapi-krb5=no
|
%configure --sbindir=/sbin --libdir=/%{_lib} --with-prelude --with-libwrap --enable-gssapi-krb5=no
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -206,6 +197,7 @@ fi
|
|||||||
%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
|
%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
|
||||||
%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
|
%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
|
||||||
%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
|
%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
|
||||||
|
%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
|
||||||
%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
|
%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
|
||||||
%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
|
%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
|
||||||
%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
|
%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
|
||||||
@ -217,6 +209,7 @@ fi
|
|||||||
%attr(755,root,root) /sbin/aureport
|
%attr(755,root,root) /sbin/aureport
|
||||||
%attr(750,root,root) /sbin/autrace
|
%attr(750,root,root) /sbin/autrace
|
||||||
%attr(750,root,root) /sbin/audispd
|
%attr(750,root,root) /sbin/audispd
|
||||||
|
%attr(750,root,root) %{_bindir}/aulast
|
||||||
%attr(750,root,root) %{_bindir}/aulastlog
|
%attr(750,root,root) %{_bindir}/aulastlog
|
||||||
%attr(755,root,root) %{_bindir}/ausyscall
|
%attr(755,root,root) %{_bindir}/ausyscall
|
||||||
%attr(755,root,root) /etc/rc.d/init.d/auditd
|
%attr(755,root,root) /etc/rc.d/init.d/auditd
|
||||||
@ -266,6 +259,9 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 05 2008 Steve Grubb <sgrubb@redhat.com> 1.7.9-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Tue Oct 28 2008 Steve Grubb <sgrubb@redhat.com> 1.7.8-6
|
* Tue Oct 28 2008 Steve Grubb <sgrubb@redhat.com> 1.7.8-6
|
||||||
- Update specfile requires to include dist
|
- Update specfile requires to include dist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user