- Remove selinux policy for zos-remote
This commit is contained in:
parent
0a9e32d94a
commit
0983360c7f
@ -1,12 +0,0 @@
|
|||||||
diff -urp audit-1.7.5.orig/audisp/plugins/zos-remote/policy/audispd-zos-remote.te audit-1.7.5/audisp/plugins/zos-remote/policy/audispd-zos-remote.te
|
|
||||||
--- audit-1.7.5.orig/audisp/plugins/zos-remote/policy/audispd-zos-remote.te 2008-08-31 12:42:58.000000000 -0400
|
|
||||||
+++ audit-1.7.5/audisp/plugins/zos-remote/policy/audispd-zos-remote.te 2008-08-31 12:43:24.000000000 -0400
|
|
||||||
@@ -10,7 +10,7 @@ type zos_remote_exec_t;
|
|
||||||
|
|
||||||
## use below if selinux-policy_devel > 3:
|
|
||||||
## zos_remote_application_domain(zos_remote_t, zos_remote_exec_t)
|
|
||||||
-logging_audisp_system_domain(zos_remote_t, zos_remote_exec_t)
|
|
||||||
+## logging_audisp_system_domain(zos_remote_t, zos_remote_exec_t)
|
|
||||||
|
|
||||||
## use below for RHEL5 series:
|
|
||||||
init_system_domain(zos_remote_t, zos_remote_exec_t)
|
|
363
audit-1.7.8-nopolicy.patch
Normal file
363
audit-1.7.8-nopolicy.patch
Normal file
@ -0,0 +1,363 @@
|
|||||||
|
diff -ur audit-1.7.8.orig/audisp/plugins/zos-remote/Makefile.am audit-1.7.8/audisp/plugins/zos-remote/Makefile.am
|
||||||
|
--- audit-1.7.8.orig/audisp/plugins/zos-remote/Makefile.am 2008-09-28 13:26:34.000000000 -0400
|
||||||
|
+++ audit-1.7.8/audisp/plugins/zos-remote/Makefile.am 2008-10-16 15:29:06.000000000 -0400
|
||||||
|
@@ -22,7 +22,6 @@
|
||||||
|
|
||||||
|
INCLUDES = -I${top_srcdir} -I${top_srcdir}/lib -I${top_srcdir}/auparse
|
||||||
|
CONFIG_CLEAN_FILES = *.rej *.orig
|
||||||
|
-SUBDIRS = policy
|
||||||
|
AUTOMAKE_OPTIONS = no-dependencies
|
||||||
|
EXTRA_DIST = zos-remote.conf audispd-zos-remote.conf
|
||||||
|
LIBS = -L${top_builddir}/auparse -lauparse
|
||||||
|
diff -ur audit-1.7.8.orig/audisp/plugins/zos-remote/Makefile.in audit-1.7.8/audisp/plugins/zos-remote/Makefile.in
|
||||||
|
--- audit-1.7.8.orig/audisp/plugins/zos-remote/Makefile.in 2008-09-28 13:27:01.000000000 -0400
|
||||||
|
+++ audit-1.7.8/audisp/plugins/zos-remote/Makefile.in 2008-10-16 15:29:25.000000000 -0400
|
||||||
|
@@ -97,19 +97,9 @@
|
||||||
|
$(LDFLAGS) -o $@
|
||||||
|
SOURCES = $(audispd_zos_remote_SOURCES)
|
||||||
|
DIST_SOURCES = $(audispd_zos_remote_SOURCES)
|
||||||
|
-RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
|
||||||
|
- html-recursive info-recursive install-data-recursive \
|
||||||
|
- install-dvi-recursive install-exec-recursive \
|
||||||
|
- install-html-recursive install-info-recursive \
|
||||||
|
- install-pdf-recursive install-ps-recursive install-recursive \
|
||||||
|
- installcheck-recursive installdirs-recursive pdf-recursive \
|
||||||
|
- ps-recursive uninstall-recursive
|
||||||
|
HEADERS = $(noinst_HEADERS)
|
||||||
|
-RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
|
||||||
|
- distclean-recursive maintainer-clean-recursive
|
||||||
|
ETAGS = etags
|
||||||
|
CTAGS = ctags
|
||||||
|
-DIST_SUBDIRS = $(SUBDIRS)
|
||||||
|
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||||
|
ACLOCAL = @ACLOCAL@
|
||||||
|
AMTAR = @AMTAR@
|
||||||
|
@@ -237,7 +227,6 @@
|
||||||
|
top_srcdir = @top_srcdir@
|
||||||
|
INCLUDES = -I${top_srcdir} -I${top_srcdir}/lib -I${top_srcdir}/auparse
|
||||||
|
CONFIG_CLEAN_FILES = *.rej *.orig
|
||||||
|
-SUBDIRS = policy
|
||||||
|
AUTOMAKE_OPTIONS = no-dependencies
|
||||||
|
EXTRA_DIST = zos-remote.conf audispd-zos-remote.conf
|
||||||
|
LDADD = -lpthread -lldap -llber
|
||||||
|
@@ -252,7 +241,7 @@
|
||||||
|
zos-remote-ldap.c zos-remote-config.c zos-remote-queue.c
|
||||||
|
|
||||||
|
audispd_zos_remote_CFLAGS = -W -Wall -Wundef -D_GNU_SOURCE
|
||||||
|
-all: all-recursive
|
||||||
|
+all: all-am
|
||||||
|
|
||||||
|
.SUFFIXES:
|
||||||
|
.SUFFIXES: .c .lo .o .obj
|
||||||
|
@@ -368,76 +357,6 @@
|
||||||
|
clean-libtool:
|
||||||
|
-rm -rf .libs _libs
|
||||||
|
|
||||||
|
-# This directory's subdirectories are mostly independent; you can cd
|
||||||
|
-# into them and run `make' without going through this Makefile.
|
||||||
|
-# To change the values of `make' variables: instead of editing Makefiles,
|
||||||
|
-# (1) if the variable is set in `config.status', edit `config.status'
|
||||||
|
-# (which will cause the Makefiles to be regenerated when you run `make');
|
||||||
|
-# (2) otherwise, pass the desired values on the `make' command line.
|
||||||
|
-$(RECURSIVE_TARGETS):
|
||||||
|
- @failcom='exit 1'; \
|
||||||
|
- for f in x $$MAKEFLAGS; do \
|
||||||
|
- case $$f in \
|
||||||
|
- *=* | --[!k]*);; \
|
||||||
|
- *k*) failcom='fail=yes';; \
|
||||||
|
- esac; \
|
||||||
|
- done; \
|
||||||
|
- dot_seen=no; \
|
||||||
|
- target=`echo $@ | sed s/-recursive//`; \
|
||||||
|
- list='$(SUBDIRS)'; for subdir in $$list; do \
|
||||||
|
- echo "Making $$target in $$subdir"; \
|
||||||
|
- if test "$$subdir" = "."; then \
|
||||||
|
- dot_seen=yes; \
|
||||||
|
- local_target="$$target-am"; \
|
||||||
|
- else \
|
||||||
|
- local_target="$$target"; \
|
||||||
|
- fi; \
|
||||||
|
- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
|
||||||
|
- || eval $$failcom; \
|
||||||
|
- done; \
|
||||||
|
- if test "$$dot_seen" = "no"; then \
|
||||||
|
- $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
|
||||||
|
- fi; test -z "$$fail"
|
||||||
|
-
|
||||||
|
-$(RECURSIVE_CLEAN_TARGETS):
|
||||||
|
- @failcom='exit 1'; \
|
||||||
|
- for f in x $$MAKEFLAGS; do \
|
||||||
|
- case $$f in \
|
||||||
|
- *=* | --[!k]*);; \
|
||||||
|
- *k*) failcom='fail=yes';; \
|
||||||
|
- esac; \
|
||||||
|
- done; \
|
||||||
|
- dot_seen=no; \
|
||||||
|
- case "$@" in \
|
||||||
|
- distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
|
||||||
|
- *) list='$(SUBDIRS)' ;; \
|
||||||
|
- esac; \
|
||||||
|
- rev=''; for subdir in $$list; do \
|
||||||
|
- if test "$$subdir" = "."; then :; else \
|
||||||
|
- rev="$$subdir $$rev"; \
|
||||||
|
- fi; \
|
||||||
|
- done; \
|
||||||
|
- rev="$$rev ."; \
|
||||||
|
- target=`echo $@ | sed s/-recursive//`; \
|
||||||
|
- for subdir in $$rev; do \
|
||||||
|
- echo "Making $$target in $$subdir"; \
|
||||||
|
- if test "$$subdir" = "."; then \
|
||||||
|
- local_target="$$target-am"; \
|
||||||
|
- else \
|
||||||
|
- local_target="$$target"; \
|
||||||
|
- fi; \
|
||||||
|
- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
|
||||||
|
- || eval $$failcom; \
|
||||||
|
- done && test -z "$$fail"
|
||||||
|
-tags-recursive:
|
||||||
|
- list='$(SUBDIRS)'; for subdir in $$list; do \
|
||||||
|
- test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
|
||||||
|
- done
|
||||||
|
-ctags-recursive:
|
||||||
|
- list='$(SUBDIRS)'; for subdir in $$list; do \
|
||||||
|
- test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
|
||||||
|
- done
|
||||||
|
-
|
||||||
|
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|
||||||
|
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
||||||
|
unique=`for i in $$list; do \
|
||||||
|
@@ -448,23 +367,10 @@
|
||||||
|
mkid -fID $$unique
|
||||||
|
tags: TAGS
|
||||||
|
|
||||||
|
-TAGS: tags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
||||||
|
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
||||||
|
$(TAGS_FILES) $(LISP)
|
||||||
|
tags=; \
|
||||||
|
here=`pwd`; \
|
||||||
|
- if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
|
||||||
|
- include_option=--etags-include; \
|
||||||
|
- empty_fix=.; \
|
||||||
|
- else \
|
||||||
|
- include_option=--include; \
|
||||||
|
- empty_fix=; \
|
||||||
|
- fi; \
|
||||||
|
- list='$(SUBDIRS)'; for subdir in $$list; do \
|
||||||
|
- if test "$$subdir" = .; then :; else \
|
||||||
|
- test ! -f $$subdir/TAGS || \
|
||||||
|
- tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
|
||||||
|
- fi; \
|
||||||
|
- done; \
|
||||||
|
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
||||||
|
unique=`for i in $$list; do \
|
||||||
|
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
|
||||||
|
@@ -477,7 +383,7 @@
|
||||||
|
$$tags $$unique; \
|
||||||
|
fi
|
||||||
|
ctags: CTAGS
|
||||||
|
-CTAGS: ctags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
||||||
|
+CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|
||||||
|
$(TAGS_FILES) $(LISP)
|
||||||
|
tags=; \
|
||||||
|
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
|
||||||
|
@@ -524,40 +430,22 @@
|
||||||
|
|| exit 1; \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
- list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
|
||||||
|
- if test "$$subdir" = .; then :; else \
|
||||||
|
- test -d "$(distdir)/$$subdir" \
|
||||||
|
- || $(MKDIR_P) "$(distdir)/$$subdir" \
|
||||||
|
- || exit 1; \
|
||||||
|
- distdir=`$(am__cd) $(distdir) && pwd`; \
|
||||||
|
- top_distdir=`$(am__cd) $(top_distdir) && pwd`; \
|
||||||
|
- (cd $$subdir && \
|
||||||
|
- $(MAKE) $(AM_MAKEFLAGS) \
|
||||||
|
- top_distdir="$$top_distdir" \
|
||||||
|
- distdir="$$distdir/$$subdir" \
|
||||||
|
- am__remove_distdir=: \
|
||||||
|
- am__skip_length_check=: \
|
||||||
|
- distdir) \
|
||||||
|
- || exit 1; \
|
||||||
|
- fi; \
|
||||||
|
- done
|
||||||
|
check-am: all-am
|
||||||
|
-check: check-recursive
|
||||||
|
+check: check-am
|
||||||
|
all-am: Makefile $(PROGRAMS) $(HEADERS)
|
||||||
|
-installdirs: installdirs-recursive
|
||||||
|
-installdirs-am:
|
||||||
|
+installdirs:
|
||||||
|
for dir in "$(DESTDIR)$(sbindir)"; do \
|
||||||
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||||
|
done
|
||||||
|
-install: install-recursive
|
||||||
|
-install-exec: install-exec-recursive
|
||||||
|
-install-data: install-data-recursive
|
||||||
|
-uninstall: uninstall-recursive
|
||||||
|
+install: install-am
|
||||||
|
+install-exec: install-exec-am
|
||||||
|
+install-data: install-data-am
|
||||||
|
+uninstall: uninstall-am
|
||||||
|
|
||||||
|
install-am: all-am
|
||||||
|
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||||
|
|
||||||
|
-installcheck: installcheck-recursive
|
||||||
|
+installcheck: installcheck-am
|
||||||
|
install-strip:
|
||||||
|
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
||||||
|
install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
||||||
|
@@ -573,23 +461,23 @@
|
||||||
|
maintainer-clean-generic:
|
||||||
|
@echo "This command is intended for maintainers to use"
|
||||||
|
@echo "it deletes files that may require special tools to rebuild."
|
||||||
|
-clean: clean-recursive
|
||||||
|
+clean: clean-am
|
||||||
|
|
||||||
|
clean-am: clean-generic clean-libtool clean-sbinPROGRAMS \
|
||||||
|
mostlyclean-am
|
||||||
|
|
||||||
|
-distclean: distclean-recursive
|
||||||
|
+distclean: distclean-am
|
||||||
|
-rm -f Makefile
|
||||||
|
distclean-am: clean-am distclean-compile distclean-generic \
|
||||||
|
distclean-tags
|
||||||
|
|
||||||
|
-dvi: dvi-recursive
|
||||||
|
+dvi: dvi-am
|
||||||
|
|
||||||
|
dvi-am:
|
||||||
|
|
||||||
|
-html: html-recursive
|
||||||
|
+html: html-am
|
||||||
|
|
||||||
|
-info: info-recursive
|
||||||
|
+info: info-am
|
||||||
|
|
||||||
|
info-am:
|
||||||
|
|
||||||
|
@@ -597,36 +485,36 @@
|
||||||
|
@$(NORMAL_INSTALL)
|
||||||
|
$(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
||||||
|
|
||||||
|
-install-dvi: install-dvi-recursive
|
||||||
|
+install-dvi: install-dvi-am
|
||||||
|
|
||||||
|
install-exec-am: install-sbinPROGRAMS
|
||||||
|
|
||||||
|
-install-html: install-html-recursive
|
||||||
|
+install-html: install-html-am
|
||||||
|
|
||||||
|
-install-info: install-info-recursive
|
||||||
|
+install-info: install-info-am
|
||||||
|
|
||||||
|
install-man:
|
||||||
|
|
||||||
|
-install-pdf: install-pdf-recursive
|
||||||
|
+install-pdf: install-pdf-am
|
||||||
|
|
||||||
|
-install-ps: install-ps-recursive
|
||||||
|
+install-ps: install-ps-am
|
||||||
|
|
||||||
|
installcheck-am:
|
||||||
|
|
||||||
|
-maintainer-clean: maintainer-clean-recursive
|
||||||
|
+maintainer-clean: maintainer-clean-am
|
||||||
|
-rm -f Makefile
|
||||||
|
maintainer-clean-am: distclean-am maintainer-clean-generic
|
||||||
|
|
||||||
|
-mostlyclean: mostlyclean-recursive
|
||||||
|
+mostlyclean: mostlyclean-am
|
||||||
|
|
||||||
|
mostlyclean-am: mostlyclean-compile mostlyclean-generic \
|
||||||
|
mostlyclean-libtool
|
||||||
|
|
||||||
|
-pdf: pdf-recursive
|
||||||
|
+pdf: pdf-am
|
||||||
|
|
||||||
|
pdf-am:
|
||||||
|
|
||||||
|
-ps: ps-recursive
|
||||||
|
+ps: ps-am
|
||||||
|
|
||||||
|
ps-am:
|
||||||
|
|
||||||
|
@@ -634,12 +522,10 @@
|
||||||
|
@$(NORMAL_INSTALL)
|
||||||
|
$(MAKE) $(AM_MAKEFLAGS) uninstall-hook
|
||||||
|
|
||||||
|
-.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) install-am \
|
||||||
|
- install-data-am install-strip uninstall-am
|
||||||
|
+.MAKE: install-am install-data-am install-strip uninstall-am
|
||||||
|
|
||||||
|
-.PHONY: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) CTAGS GTAGS \
|
||||||
|
- all all-am check check-am clean clean-generic clean-libtool \
|
||||||
|
- clean-sbinPROGRAMS ctags ctags-recursive distclean \
|
||||||
|
+.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
|
||||||
|
+ clean-libtool clean-sbinPROGRAMS ctags distclean \
|
||||||
|
distclean-compile distclean-generic distclean-libtool \
|
||||||
|
distclean-tags distdir dvi dvi-am html html-am info info-am \
|
||||||
|
install install-am install-data install-data-am \
|
||||||
|
@@ -647,11 +533,11 @@
|
||||||
|
install-exec-am install-html install-html-am install-info \
|
||||||
|
install-info-am install-man install-pdf install-pdf-am \
|
||||||
|
install-ps install-ps-am install-sbinPROGRAMS install-strip \
|
||||||
|
- installcheck installcheck-am installdirs installdirs-am \
|
||||||
|
- maintainer-clean maintainer-clean-generic mostlyclean \
|
||||||
|
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
|
||||||
|
- pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
|
||||||
|
- uninstall-hook uninstall-sbinPROGRAMS
|
||||||
|
+ installcheck installcheck-am installdirs maintainer-clean \
|
||||||
|
+ maintainer-clean-generic mostlyclean mostlyclean-compile \
|
||||||
|
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
|
||||||
|
+ tags uninstall uninstall-am uninstall-hook \
|
||||||
|
+ uninstall-sbinPROGRAMS
|
||||||
|
|
||||||
|
|
||||||
|
install-data-hook:
|
||||||
|
diff -ur audit-1.7.8.orig/configure audit-1.7.8/configure
|
||||||
|
--- audit-1.7.8.orig/configure 2008-09-28 13:26:59.000000000 -0400
|
||||||
|
+++ audit-1.7.8/configure 2008-10-16 15:29:23.000000000 -0400
|
||||||
|
@@ -23678,7 +23678,7 @@
|
||||||
|
|
||||||
|
subdirs="$subdirs system-config-audit"
|
||||||
|
|
||||||
|
-ac_config_files="$ac_config_files Makefile lib/Makefile lib/test/Makefile auparse/Makefile auparse/test/Makefile src/Makefile src/mt/Makefile src/libev/Makefile swig/Makefile docs/Makefile init.d/Makefile audisp/Makefile audisp/plugins/Makefile audisp/plugins/builtins/Makefile audisp/plugins/prelude/Makefile audisp/plugins/remote/Makefile audisp/plugins/zos-remote/Makefile audisp/plugins/zos-remote/policy/Makefile bindings/Makefile bindings/python/Makefile tools/Makefile tools/aulastlog/Makefile tools/ausyscall/Makefile"
|
||||||
|
+ac_config_files="$ac_config_files Makefile lib/Makefile lib/test/Makefile auparse/Makefile auparse/test/Makefile src/Makefile src/mt/Makefile src/libev/Makefile swig/Makefile docs/Makefile init.d/Makefile audisp/Makefile audisp/plugins/Makefile audisp/plugins/builtins/Makefile audisp/plugins/prelude/Makefile audisp/plugins/remote/Makefile audisp/plugins/zos-remote/Makefile bindings/Makefile bindings/python/Makefile tools/Makefile tools/aulastlog/Makefile tools/ausyscall/Makefile"
|
||||||
|
|
||||||
|
cat >confcache <<\_ACEOF
|
||||||
|
# This file is a shell script that caches the results of configure
|
||||||
|
@@ -24325,7 +24325,6 @@
|
||||||
|
"audisp/plugins/prelude/Makefile") CONFIG_FILES="$CONFIG_FILES audisp/plugins/prelude/Makefile" ;;
|
||||||
|
"audisp/plugins/remote/Makefile") CONFIG_FILES="$CONFIG_FILES audisp/plugins/remote/Makefile" ;;
|
||||||
|
"audisp/plugins/zos-remote/Makefile") CONFIG_FILES="$CONFIG_FILES audisp/plugins/zos-remote/Makefile" ;;
|
||||||
|
- "audisp/plugins/zos-remote/policy/Makefile") CONFIG_FILES="$CONFIG_FILES audisp/plugins/zos-remote/policy/Makefile" ;;
|
||||||
|
"bindings/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/Makefile" ;;
|
||||||
|
"bindings/python/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/python/Makefile" ;;
|
||||||
|
"tools/Makefile") CONFIG_FILES="$CONFIG_FILES tools/Makefile" ;;
|
||||||
|
diff -ur audit-1.7.8.orig/configure.ac audit-1.7.8/configure.ac
|
||||||
|
--- audit-1.7.8.orig/configure.ac 2008-09-28 13:26:34.000000000 -0400
|
||||||
|
+++ audit-1.7.8/configure.ac 2008-10-16 15:29:06.000000000 -0400
|
||||||
|
@@ -196,7 +196,7 @@
|
||||||
|
AC_SUBST(libev_LIBS)
|
||||||
|
|
||||||
|
AC_CONFIG_SUBDIRS([system-config-audit])
|
||||||
|
-AC_OUTPUT(Makefile lib/Makefile lib/test/Makefile auparse/Makefile auparse/test/Makefile src/Makefile src/mt/Makefile src/libev/Makefile swig/Makefile docs/Makefile init.d/Makefile audisp/Makefile audisp/plugins/Makefile audisp/plugins/builtins/Makefile audisp/plugins/prelude/Makefile audisp/plugins/remote/Makefile audisp/plugins/zos-remote/Makefile audisp/plugins/zos-remote/policy/Makefile bindings/Makefile bindings/python/Makefile tools/Makefile tools/aulastlog/Makefile tools/ausyscall/Makefile)
|
||||||
|
+AC_OUTPUT(Makefile lib/Makefile lib/test/Makefile auparse/Makefile auparse/test/Makefile src/Makefile src/mt/Makefile src/libev/Makefile swig/Makefile docs/Makefile init.d/Makefile audisp/Makefile audisp/plugins/Makefile audisp/plugins/builtins/Makefile audisp/plugins/prelude/Makefile audisp/plugins/remote/Makefile audisp/plugins/zos-remote/Makefile bindings/Makefile bindings/python/Makefile tools/Makefile tools/aulastlog/Makefile tools/ausyscall/Makefile)
|
||||||
|
|
||||||
|
echo .
|
||||||
|
echo "
|
||||||
|
diff -ur audit-1.7.8.orig/lib/audit_logging.c audit-1.7.8/lib/audit_logging.c
|
||||||
|
--- audit-1.7.8.orig/lib/audit_logging.c 2008-09-28 13:26:34.000000000 -0400
|
||||||
|
+++ audit-1.7.8/lib/audit_logging.c 2008-10-16 15:29:06.000000000 -0400
|
||||||
|
@@ -54,7 +54,8 @@
|
||||||
|
|
||||||
|
buf[0] = '?';
|
||||||
|
buf[1] = 0;
|
||||||
|
- if (host == NULL) /* Short circuit this lookup if NULL */
|
||||||
|
+ /* Short circuit this lookup if NULL, or empty */
|
||||||
|
+ if (host == NULL || *host == 0)
|
||||||
|
return;
|
||||||
|
|
||||||
|
memset(&hints, 0, sizeof(hints));
|
59
audit.spec
59
audit.spec
@ -1,18 +1,16 @@
|
|||||||
%define sca_version 0.4.8
|
%define sca_version 0.4.8
|
||||||
%define sca_release 3
|
%define sca_release 4
|
||||||
%define selinux_variants mls strict targeted
|
|
||||||
%define selinux_policyver 3.2.5
|
|
||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
Summary: User space tools for 2.6 kernel auditing
|
Summary: User space tools for 2.6 kernel auditing
|
||||||
Name: audit
|
Name: audit
|
||||||
Version: 1.7.7
|
Version: 1.7.7
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://people.redhat.com/sgrubb/audit/
|
URL: http://people.redhat.com/sgrubb/audit/
|
||||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||||
Patch1: audit-1.7.5-policy.patch
|
Patch1: audit-1.7.8-nopolicy.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gettext-devel intltool libtool swig python-devel
|
BuildRequires: gettext-devel intltool libtool swig python-devel
|
||||||
BuildRequires: tcp_wrappers-devel krb5-devel
|
BuildRequires: tcp_wrappers-devel krb5-devel
|
||||||
@ -64,18 +62,10 @@ Summary: Plugins for the audit event dispatcher
|
|||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
%if "%{selinux_policyver}" != ""
|
|
||||||
BuildRequires: checkpolicy selinux-policy-devel >= %{selinux_policyver}
|
|
||||||
%endif
|
|
||||||
BuildRequires: libprelude-devel >= 0.9.16
|
BuildRequires: libprelude-devel >= 0.9.16
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
Requires: openldap
|
Requires: openldap
|
||||||
%if "%{selinux_policyver}" != ""
|
|
||||||
Requires: selinux-policy >= %{selinux_policyver}
|
|
||||||
%endif
|
|
||||||
Requires(post): /usr/sbin/semodule /sbin/restorecon
|
|
||||||
Requires(postun): /usr/sbin/semodule
|
|
||||||
|
|
||||||
%description -n audispd-plugins
|
%description -n audispd-plugins
|
||||||
The audispd-plugins package provides plugins for the real-time
|
The audispd-plugins package provides plugins for the real-time
|
||||||
@ -98,26 +88,11 @@ A graphical utility for editing audit configuration.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
mkdir zos-remote-policy
|
|
||||||
cp -p audisp/plugins/zos-remote/policy/audispd-zos-remote.* zos-remote-policy
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
(cd system-config-audit; ./autogen.sh)
|
(cd system-config-audit; ./autogen.sh)
|
||||||
%configure --sbindir=/sbin --libdir=/%{_lib} --with-prelude --with-libwrap --enable-gssapi-krb5
|
%configure --sbindir=/sbin --libdir=/%{_lib} --with-prelude --with-libwrap --enable-gssapi-krb5
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
cd zos-remote-policy
|
|
||||||
for selinuxvariant in %{selinux_variants}
|
|
||||||
do
|
|
||||||
if [ "${selinuxvariant}" = "mls" ]; then
|
|
||||||
TYPE=mls-mls
|
|
||||||
else
|
|
||||||
TYPE=${selinuxvariant}-mcs
|
|
||||||
fi
|
|
||||||
make -f /usr/share/selinux/devel/Makefile
|
|
||||||
mv audispd-zos-remote.pp audispd-zos-remote.pp.${selinuxvariant}
|
|
||||||
make -f /usr/share/selinux/devel/Makefile clean
|
|
||||||
done
|
|
||||||
cd -
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -128,12 +103,6 @@ mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
|
mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
|
||||||
make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
|
make DESTDIR=$RPM_BUILD_ROOT %{?_smp_mflags} install
|
||||||
make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
|
make -C system-config-audit DESTDIR=$RPM_BUILD_ROOT install-fedora
|
||||||
for selinuxvariant in %{selinux_variants}
|
|
||||||
do
|
|
||||||
install -d $RPM_BUILD_ROOT/%{_datadir}/selinux/${selinuxvariant}
|
|
||||||
install -p -m 644 zos-remote-policy/audispd-zos-remote.pp.${selinuxvariant} \
|
|
||||||
$RPM_BUILD_ROOT/%{_datadir}/selinux/${selinuxvariant}/audispd-zos-remote.pp
|
|
||||||
done
|
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
||||||
# This winds up in the wrong place when libtool is involved
|
# This winds up in the wrong place when libtool is involved
|
||||||
@ -175,19 +144,9 @@ make check
|
|||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
rm -rf zos-remote-policy
|
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%post -n audispd-plugins
|
|
||||||
for selinuxvariant in %{selinux_variants}
|
|
||||||
do
|
|
||||||
/usr/sbin/semodule -s $selinuxvariant \
|
|
||||||
-i %{_datadir}/selinux/$selinuxvariant/audispd-zos-remote.pp \
|
|
||||||
&> /dev/null || :
|
|
||||||
done
|
|
||||||
/sbin/restorecon -F /sbin/audispd-zos-remote /etc/audisp/zos-remote.conf
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
/sbin/chkconfig --add auditd
|
/sbin/chkconfig --add auditd
|
||||||
# This is to migrate users from audit-1.0.x installations
|
# This is to migrate users from audit-1.0.x installations
|
||||||
@ -218,14 +177,6 @@ fi
|
|||||||
|
|
||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun -n audispd-plugins
|
|
||||||
if [ $1 -eq 0 ]; then
|
|
||||||
for selinuxvariant in %{selinux_variants}
|
|
||||||
do
|
|
||||||
/usr/sbin/semodule -s $selinuxvariant -r audispd-zos-remote &>/dev/null || :
|
|
||||||
done
|
|
||||||
fi
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
if [ $1 -ge 1 ]; then
|
if [ $1 -ge 1 ]; then
|
||||||
/sbin/service auditd condrestart > /dev/null 2>&1 || :
|
/sbin/service auditd condrestart > /dev/null 2>&1 || :
|
||||||
@ -298,7 +249,6 @@ fi
|
|||||||
%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
|
%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
|
%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
|
||||||
%attr(750,root,root) /sbin/audispd-zos-remote
|
%attr(750,root,root) /sbin/audispd-zos-remote
|
||||||
%attr(644,root,root) %{_datadir}/selinux/*/audispd-zos-remote.pp
|
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-prelude.conf
|
%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-prelude.conf
|
||||||
%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-prelude.conf
|
%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-prelude.conf
|
||||||
%attr(750,root,root) /sbin/audisp-prelude
|
%attr(750,root,root) /sbin/audisp-prelude
|
||||||
@ -326,6 +276,9 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 16 2008 Steve Grubb <sgrubb@redhat.com> 1.7.7-2
|
||||||
|
- Remove selinux policy for zos-remote
|
||||||
|
|
||||||
* Wed Sep 17 2008 Steve Grubb <sgrubb@redhat.com> 1.7.7-1
|
* Wed Sep 17 2008 Steve Grubb <sgrubb@redhat.com> 1.7.7-1
|
||||||
- Bug fixes for GSSAPI code in remote logging (DJ Delorie)
|
- Bug fixes for GSSAPI code in remote logging (DJ Delorie)
|
||||||
- Add watched syscall support to audisp-prelude
|
- Add watched syscall support to audisp-prelude
|
||||||
|
Loading…
Reference in New Issue
Block a user