- Fix segfault when using file input to aureport
- Quieten down messages about missing gssapi support
This commit is contained in:
parent
c183a174e4
commit
0961553dfe
42
audit-1.7.9-bugs.patch
Normal file
42
audit-1.7.9-bugs.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -urp audit-1.7.8/src/auditd-config.c audit-1.7.9/src/auditd-config.c
|
||||
--- audit-1.7.8/src/auditd-config.c 2008-10-22 14:02:04.000000000 -0400
|
||||
+++ audit-1.7.9/src/auditd-config.c 2008-10-23 15:55:45.000000000 -0400
|
||||
@@ -1372,7 +1372,7 @@ static int enable_krb5_parser(struct nv_
|
||||
nv->value);
|
||||
|
||||
#ifndef USE_GSSAPI
|
||||
- audit_msg(LOG_NOTICE,
|
||||
+ audit_msg(LOG_DEBUG,
|
||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
||||
line);
|
||||
return 0;
|
||||
@@ -1395,7 +1395,7 @@ static int krb5_principal_parser(struct
|
||||
|
||||
audit_msg(LOG_DEBUG,"krb5_principal_parser called with: %s",nv->value);
|
||||
#ifndef USE_GSSAPI
|
||||
- audit_msg(LOG_NOTICE,
|
||||
+ audit_msg(LOG_DEBUG,
|
||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
||||
line);
|
||||
return 0;
|
||||
@@ -1412,7 +1412,7 @@ static int krb5_key_file_parser(struct n
|
||||
|
||||
audit_msg(LOG_DEBUG, "krb5_key_file_parser called with: %s", nv->value);
|
||||
#ifndef USE_GSSAPI
|
||||
- audit_msg(LOG_NOTICE,
|
||||
+ audit_msg(LOG_DEBUG,
|
||||
"GSSAPI support is not enabled, ignoring value at line %d",
|
||||
line);
|
||||
return 0;
|
||||
diff -urp audit-1.7.8/src/aureport.c audit-1.7.9/src/aureport.c
|
||||
--- audit-1.7.8/src/aureport.c 2008-10-22 14:02:04.000000000 -0400
|
||||
+++ audit-1.7.9/src/aureport.c 2008-10-23 15:55:45.000000000 -0400
|
||||
@@ -105,6 +105,8 @@ int main(int argc, char *argv[])
|
||||
config.admin_space_left_exe = NULL;
|
||||
config.disk_full_exe = NULL;
|
||||
config.disk_error_exe = NULL;
|
||||
+ config.krb5_principal = NULL;
|
||||
+ config.krb5_key_file = NULL;
|
||||
}
|
||||
|
||||
print_title();
|
10
audit.spec
10
audit.spec
@ -1,15 +1,16 @@
|
||||
%define sca_version 0.4.8
|
||||
%define sca_release 5
|
||||
%define sca_release 6
|
||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
|
||||
Summary: User space tools for 2.6 kernel auditing
|
||||
Name: audit
|
||||
Version: 1.7.8
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://people.redhat.com/sgrubb/audit/
|
||||
Source0: http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
|
||||
Patch1: audit-1.7.9-bugs.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gettext-devel intltool libtool swig python-devel
|
||||
BuildRequires: tcp_wrappers-devel
|
||||
@ -86,6 +87,7 @@ A graphical utility for editing audit configuration.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
(cd system-config-audit; ./autogen.sh)
|
||||
@ -274,6 +276,10 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-audit-server
|
||||
|
||||
%changelog
|
||||
* Thu Oct 23 2008 Steve Grubb <sgrubb@redhat.com> 1.7.8-2
|
||||
- Fix segfault when using file input to aureport
|
||||
- Quieten down messages about missing gssapi support
|
||||
|
||||
* Wed Oct 22 2008 Steve Grubb <sgrubb@redhat.com> 1.7.8-1
|
||||
- Disable GSSAPI support until its reworked as plugin
|
||||
- Interpret TTY audit data in auparse (Miloslav Trmač)
|
||||
|
Loading…
Reference in New Issue
Block a user