import atlas-3.10.3-7.el8
This commit is contained in:
commit
4fbd7ce751
8
.atlas.metadata
Normal file
8
.atlas.metadata
Normal file
@ -0,0 +1,8 @@
|
||||
0e11ec19a521973eaa551954debd112c21479e9c SOURCES/ARMa732.tar.bz2
|
||||
9398518fe55b4a544278237bc639656e04543c50 SOURCES/ARMv732NEON.tar.bz2
|
||||
d2f7a62aacdc5091aaa673a311a23f521e5c6486 SOURCES/IBMz1264.tar.bz2
|
||||
b3ee9bca1510b11c6aa671ba5ba7dff8918ce0cf SOURCES/IBMz932.tar.bz2
|
||||
43f8d8eaf8cc62bc4665df3550b77e95f3dced22 SOURCES/IBMz964.tar.bz2
|
||||
c47ac6f00d7bf4ab882e71fa1ab894cc551c77b7 SOURCES/POWER332.tar.bz2
|
||||
85c00d3190abbe250d46472824b17d9164e3dfc2 SOURCES/PPRO32.tgz
|
||||
337eef1167030a9440ea645ce0037abfd4b0be4e SOURCES/atlas3.10.3.tar.bz2
|
8
.gitignore
vendored
Normal file
8
.gitignore
vendored
Normal file
@ -0,0 +1,8 @@
|
||||
SOURCES/ARMa732.tar.bz2
|
||||
SOURCES/ARMv732NEON.tar.bz2
|
||||
SOURCES/IBMz1264.tar.bz2
|
||||
SOURCES/IBMz932.tar.bz2
|
||||
SOURCES/IBMz964.tar.bz2
|
||||
SOURCES/POWER332.tar.bz2
|
||||
SOURCES/PPRO32.tgz
|
||||
SOURCES/atlas3.10.3.tar.bz2
|
47
SOURCES/README.dist
Normal file
47
SOURCES/README.dist
Normal file
@ -0,0 +1,47 @@
|
||||
Notes on the packaged version of ATLAS
|
||||
|
||||
by Quentin Spencer
|
||||
updated: October 4, 2005
|
||||
|
||||
updated by Deji Akingunola
|
||||
October 15, 2008
|
||||
|
||||
updated by Deji Akingunola
|
||||
June 15, 2011
|
||||
|
||||
updated by Frantisek Kluknavsky
|
||||
Nov 20, 2012
|
||||
|
||||
Because ATLAS relies on compile-time optimizations to obtain improved
|
||||
performance over BLAS and LAPACK, the resulting binaries are closely
|
||||
tied to the hardware on which they are compiled, and can likely result
|
||||
in very poor performance on other hardware. For this reason,
|
||||
including a package like ATLAS in Fedora requires some compromises.
|
||||
Optimizing ATLAS for the most modern hardware can result in
|
||||
significant performance penalties for users using the same package on
|
||||
older hardware. A binary ATLAS package must perform reasonably well on the
|
||||
entire range of hardware on which it could potentially be installed.
|
||||
|
||||
The result is a set of libraries that will not
|
||||
necessarily achieve optimal performance on any given hardware but
|
||||
should still offer significant performance gains over the reference
|
||||
BLAS and LAPACK libraries on most hardware.
|
||||
|
||||
In addition to the base 32bit build, subpackages are built for SSE, SSE2,
|
||||
and SSE3 ix86 extensions.
|
||||
|
||||
On 64bit x86 systems the default atlas package was built with SSE3
|
||||
optimization.
|
||||
|
||||
This packaging allows multiple installation of different atlas sub-packages
|
||||
at the same time. The alternatives system (read 'man alternatives' for usage)
|
||||
is used in the -devel subpackages to select the appropriate location for the
|
||||
architectural dependent header files.
|
||||
|
||||
For users who want optimal performance on
|
||||
particular hardware, custom RPMs can be built from the source package
|
||||
by setting the RPM macro "enable_native_atlas" to a value of 1. This
|
||||
can be done from the command line as in the following example:
|
||||
|
||||
rpmbuild -D "enable_native_atlas 1" --rebuild atlas-3.8.3-1.src.rpm
|
||||
|
14
SOURCES/atlas-genparse.patch
Normal file
14
SOURCES/atlas-genparse.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff --git a/include/atlas_genparse.h b/include/atlas_genparse.h
|
||||
index 909a38e..1e6d153 100644
|
||||
--- a/include/atlas_genparse.h
|
||||
+++ b/include/atlas_genparse.h
|
||||
@@ -163,7 +163,8 @@ static int GetDoubleArr(char *str, int N, double *d)
|
||||
if (!str)
|
||||
break;
|
||||
str++;
|
||||
- assert(sscanf(str, "%le", d+i) == 1);
|
||||
+ if (sscanf(str, "%le", d+i) != 1)
|
||||
+ break;
|
||||
i++;
|
||||
}
|
||||
return(i);
|
12
SOURCES/atlas-getri.patch
Normal file
12
SOURCES/atlas-getri.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/src/testing/ATL_f77getri.c b/src/testing/ATL_f77getri.c
|
||||
index 2cc576c..7ff8eba 100644
|
||||
--- a/src/testing/ATL_f77getri.c
|
||||
+++ b/src/testing/ATL_f77getri.c
|
||||
@@ -97,7 +97,6 @@ int f77getri(const enum ATLAS_ORDER Order, const int N, TYPE *A, const int lda,
|
||||
#ifdef ATL_FunkyInts
|
||||
*lwork = F77lwork;
|
||||
for (i=0; i < MN; i++) ipiv[i] = F77ipiv[i] + 1;
|
||||
- free(F77ipiv);
|
||||
#else
|
||||
for (i=0; i < MN; i++) ipiv[i]++;
|
||||
#endif
|
16
SOURCES/atlas-melf.patch
Normal file
16
SOURCES/atlas-melf.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/CONFIG/src/SpewMakeInc.c b/CONFIG/src/SpewMakeInc.c
|
||||
index eed259e..65d68a1 100644
|
||||
--- a/CONFIG/src/SpewMakeInc.c
|
||||
+++ b/CONFIG/src/SpewMakeInc.c
|
||||
@@ -764,9 +764,9 @@ int main(int nargs, char **args)
|
||||
else
|
||||
{
|
||||
if (ptrbits == 32)
|
||||
- fprintf(fpout, " -melf_i386");
|
||||
+ fprintf(fpout, " -Wl,-melf_i386");
|
||||
else if (ptrbits == 64)
|
||||
- fprintf(fpout, " -melf_x86_64");
|
||||
+ fprintf(fpout, " -Wl,-melf_x86_64");
|
||||
if (OS == OSFreeBSD)
|
||||
fprintf(fpout, "_fbsd");
|
||||
}
|
40
SOURCES/atlas-shared_libraries.patch
Normal file
40
SOURCES/atlas-shared_libraries.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 3119c671c566761a79ac98405cb619892acde3e8 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@redhat.com>
|
||||
Date: Fri, 20 Sep 2013 09:26:58 +0200
|
||||
Subject: [PATCH] atlas-shared_libraries
|
||||
|
||||
---
|
||||
ATLAS/makes/Make.lib | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ATLAS/makes/Make.lib b/ATLAS/makes/Make.lib
|
||||
index ab1eb9963d36678972a0a410905169aaa563dc64..27c6e316b442e09b0f46afac7940aaa11e25e45c 100644
|
||||
--- a/ATLAS/makes/Make.lib
|
||||
+++ b/ATLAS/makes/Make.lib
|
||||
@@ -4,6 +4,8 @@ mySRCdir = $(SRCdir)/lib
|
||||
#
|
||||
# override with libatlas.so only when atlas is built to one lib
|
||||
#
|
||||
+so_ver_major=3
|
||||
+so_ver = $(so_ver_major).10
|
||||
DYNlibs = liblapack.so libf77blas.so libcblas.so libatlas.so
|
||||
PTDYNlibs = liblapack.so libptf77blas.so libptcblas.so libatlas.so
|
||||
CDYNlibs = liblapack.so libcblas.so libatlas.so
|
||||
@@ -116,9 +116,12 @@ LDTRY:
|
||||
-rpath-link $(LIBINSTdir) \
|
||||
--whole-archive $(libas) --no-whole-archive $(LIBS)
|
||||
GCCTRY:
|
||||
- $(GOODGCC) -shared -o $(outso) \
|
||||
- -Wl,"-rpath-link $(LIBINSTdir)" \
|
||||
+ $(GOODGCC) -shared -o $(outso).$(so_ver) \
|
||||
+ \
|
||||
+ -Wl,-soname,"$(outso).$(so_ver_major)" \
|
||||
-Wl,--whole-archive $(libas) -Wl,--no-whole-archive $(LIBS)
|
||||
+ ln -s $(outso).$(so_ver) $(outso).$(so_ver_major)
|
||||
+ ln -s $(outso).$(so_ver) $(outso)
|
||||
GCCTRY_norp:
|
||||
$(GOODGCC) -shared -o $(outso) \
|
||||
-Wl,--whole-archive $(libas) -Wl,--no-whole-archive $(LIBS)
|
||||
--
|
||||
1.8.3.1
|
||||
|
12
SOURCES/atlas-throttling.patch
Normal file
12
SOURCES/atlas-throttling.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ATLAS/CONFIG/src/config.c.zaloha ATLAS/CONFIG/src/config.c
|
||||
--- ATLAS/CONFIG/src/config.c.zaloha 2012-10-25 11:29:02.495425989 +0200
|
||||
+++ ATLAS/CONFIG/src/config.c 2012-10-25 11:42:10.218216957 +0200
|
||||
@@ -711,6 +711,8 @@ int ProbePtrbits(int verb, char *targarg
|
||||
|
||||
int ProbeCPUThrottle(int verb, char *targarg, enum OSTYPE OS, enum ASMDIA asmb)
|
||||
{
|
||||
+ return 0; /* impossible to turn off cpu throttling => ignore */
|
||||
+ /* this undermines performance of compiled library */
|
||||
int i, iret;
|
||||
char *ln;
|
||||
i = strlen(targarg) + 22 + 12;
|
17
SOURCES/atlas.3.10.1-unbundle.patch
Normal file
17
SOURCES/atlas.3.10.1-unbundle.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up wrk/makes/Make.lib.wrk wrk/makes/Make.lib
|
||||
--- wrk/makes/Make.lib.wrk 2015-01-23 21:14:46.465494411 +0100
|
||||
+++ wrk/makes/Make.lib 2015-01-23 22:48:39.632479588 +0100
|
||||
@@ -185,11 +185,11 @@ TRYALL :
|
||||
#
|
||||
fat_ptshared : # threaded target
|
||||
$(MAKE) TRYALL outso=libtatlas.so \
|
||||
- libas="libptlapack.a libptf77blas.a libptcblas.a libatlas.a" \
|
||||
+ libas="libptlapack.a libptf77blas.a libptcblas.a libatlas.a $(SLAPACKlib)" \
|
||||
LIBINSTdir="$(LIBINSTdir)"
|
||||
fat_shared : # serial target
|
||||
$(MAKE) TRYALL outso=libsatlas.so \
|
||||
- libas="liblapack.a libf77blas.a libcblas.a libatlas.a" \
|
||||
+ libas="liblapack.a libf77blas.a libcblas.a libatlas.a $(SLAPACKlib)" \
|
||||
LIBINSTdir="$(LIBINSTdir)"
|
||||
#
|
||||
# Builds shared lib, not include fortran codes from LAPACK
|
1151
SPECS/atlas.spec
Normal file
1151
SPECS/atlas.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user