61a47903a5
- Removed at-3.1.14-usePOSIXtimers.patch and at-3.2.23-coverity-fix.patch, because upstream implemented them - Defined folder paths without %%{buildroot} in order to make them work with latest Makefile changes - Resolves: rhbz#2048132
85 lines
4.1 KiB
Diff
85 lines
4.1 KiB
Diff
diff -ur b/Makefile.in a/Makefile.in
|
|
--- b/Makefile.in 2022-01-29 17:42:19.000000000 +0100
|
|
+++ a/Makefile.in 2022-02-22 13:22:45.060320153 +0100
|
|
@@ -76,13 +76,13 @@
|
|
all: at atd atd.service atrun
|
|
|
|
at: $(ATOBJECTS)
|
|
- $(CC) $(LDFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
|
|
+ $(CC) $(LDFLAGS) -pie -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
|
|
rm -f $(CLONES)
|
|
$(LN_S) -f at atq
|
|
$(LN_S) -f at atrm
|
|
|
|
atd: $(RUNOBJECTS)
|
|
- $(CC) $(LDFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB) $(SELINUXLIB)
|
|
+ $(CC) $(LDFLAGS) -pie -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB) $(SELINUXLIB)
|
|
|
|
y.tab.c y.tab.h: parsetime.y
|
|
$(YACC) -d parsetime.y
|
|
@@ -99,40 +99,41 @@
|
|
configure
|
|
|
|
.c.o:
|
|
- $(CC) -c $(CFLAGS) $(DEFS) $*.c
|
|
+ $(CC) -c $(CFLAGS) -fPIE $(DEFS) $*.c
|
|
|
|
install: all
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(etcdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(bindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdatadir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(docdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdocdir)
|
|
- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
|
|
- chmod 1770 $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(etcdir)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(atdocdir)
|
|
+ $(INSTALL) -m 755 -d $(DESTDIR)$(etcdir)/pam.d/
|
|
+ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR)
|
|
+ chmod 700 $(DESTDIR)$(ATJOB_DIR) $(DESTDIR)$(ATSPOOL_DIR)
|
|
+ chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(ATJOB_DIR) $(DESTDIR)$(ATSPOOL_DIR)
|
|
touch $(DESTDIR)$(LFILE)
|
|
chmod 600 $(DESTDIR)$(LFILE)
|
|
chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(LFILE)
|
|
- test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(DESTDIR)$(etcdir)/
|
|
- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(DESTDIR)$(bindir)
|
|
+ test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -m 600 at.deny $(DESTDIR)$(etcdir)/
|
|
+ $(INSTALL) -o $(INSTALL_ROOT_USER) -g $(DAEMON_GROUPNAME) pam_atd $(DESTDIR)$(etcdir)/pam.d/atd
|
|
+ $(INSTALL) -m 4755 at $(DESTDIR)$(bindir)
|
|
$(LN_S) -f at $(DESTDIR)$(bindir)/atq
|
|
$(LN_S) -f at $(DESTDIR)$(bindir)/atrm
|
|
- $(INSTALL) -g root -o root -m 755 batch $(DESTDIR)$(bindir)
|
|
- $(INSTALL) -g root -o root -m 755 batch-job $(DESTDIR)$(atdatadir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man1dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man5dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man8dir)
|
|
- $(INSTALL) -g root -o root -m 755 atd $(DESTDIR)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 atrun $(DESTDIR)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 644 at.1 $(DESTDIR)$(man1dir)/
|
|
+ $(INSTALL) -m 755 batch $(DESTDIR)$(bindir)
|
|
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
|
|
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
|
|
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
|
|
+ $(INSTALL) -m 755 atd $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -m 755 atrun $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -m 644 at.1 $(DESTDIR)$(man1dir)/
|
|
cd $(DESTDIR)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
|
|
- $(INSTALL) -g root -o root -m 644 atd.8 $(DESTDIR)$(man8dir)/
|
|
+ $(INSTALL) -m 644 atd.8 $(DESTDIR)$(man8dir)/
|
|
sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
|
|
- $(INSTALL) -g root -o root -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
|
|
+ $(INSTALL) -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
|
|
rm -f tmpman
|
|
- $(INSTALL) -g root -o root -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
|
|
+ $(INSTALL) -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
|
|
cd $(DESTDIR)$(man5dir) && $(LN_S) -f at.allow.5 at.deny.5
|
|
- $(INSTALL) -g root -o root -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
|
|
+ $(INSTALL) -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
|
|
rm -f $(DESTDIR)$(mandir)/cat1/at.1* $(DESTDIR)$(mandir)/cat1/batch.1* \
|
|
$(DESTDIR)$(mandir)/cat1/atq.1*
|
|
rm -f $(DESTDIR)$(mandir)/cat1/atd.8*
|