a34e68fc4b
Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com> - Well, we will likely never really close the UTC issues, - because of 1) fractional timezones, and 2) daylight savigns time. - but there is a slight tweak to the handling of dst in the UTC patch. Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com> - fixed bug #15685 - which had at miscaluclating UTC times. Sat Jul 15 2000 Bill Nottingham <notting@redhat.com> - move initscript back Wed Jul 12 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Thu Jul 06 2000 Bill Nottingham <notting@redhat.com> - prereq /etc/init.d Sat Jul 01 2000 Nalin Dahyabhai <nalin@redhat.com> - fix syntax error in init script Tue Jun 27 2000 Preston Brown <pbrown@redhat.com> - don't prereq, only require initscripts Mon Jun 26 2000 Preston Brown <pbrown@redhat.com> - move init script - add condrestart directive - fix post/preun/postun scripts - prereq initscripts >= 5.20 Sat Jun 17 2000 Bill Nottingham <notting@redhat.com> - fix verify of /var/spool/at/.SEQ (#12262) Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com> - fix status checking and syntax error in init script Fri Jun 09 2000 Bill Nottingham <notting@redhat.com> - fix for long usernames (#11321) - add some bugfixes from debian Mon May 08 2000 Bernhard Rosenkraenzer <bero@redhat.com> - 3.1.8 Wed Mar 01 2000 Bill Nottingham <notting@redhat.com> - fix a couple of more typos, null-terminate some strings Thu Feb 10 2000 Bill Nottingham <notting@redhat.com> - fix many-years-old typo in atd.c Thu Feb 03 2000 Bill Nottingham <notting@redhat.com> - handle compressed man pages Mon Aug 16 1999 Bill Nottingham <notting@redhat.com> - initscript munging, build as non-root user Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com> - correct perms for /var/spool/at after defattr. Mon May 24 1999 Jeff Johnson <jbj@redhat.com> - reset SIGCHLD before exec (#3016). Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> - auto rebuild in the new build environment (release 8) Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com> - fix handling the 12:00 time Wed Jan 13 1999 Bill Nottingham <notting@redhat.com> - configure fix for arm Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com> - build for glibc 2.1 Tue May 05 1998 Prospector System <bugs@redhat.com> - translations modified for de, fr, tr Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com> - enhanced initscript Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com> - learned to spell Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com> - updated to at version 3.1.7 - updated lock and sequence file handling with %ghost - Use chkconfig and atd, now conflicts with old crontabs packages Thu Jun 19 1997 Erik Troan <ewt@redhat.com> - built against glibc
59 lines
3.0 KiB
Diff
59 lines
3.0 KiB
Diff
--- at-3.1.8/Makefile.in.noroot Fri Jun 9 11:45:52 2000
|
|
+++ at-3.1.8/Makefile.in Fri Jun 9 11:46:39 2000
|
|
@@ -87,11 +87,11 @@
|
|
$(CC) -c $(CFLAGS) $(DEFS) $*.c
|
|
|
|
install: all
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(etcdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(bindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(docdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(atdocdir)
|
|
+ $(INSTALL) -m 755 -d $(IROOT)$(etcdir)
|
|
+ $(INSTALL) -m 755 -d $(IROOT)$(bindir)
|
|
+ $(INSTALL) -m 755 -d $(IROOT)$(sbindir)
|
|
+ $(INSTALL) -m 755 -d $(IROOT)$(docdir)
|
|
+ $(INSTALL) -m 755 -d $(IROOT)$(atdocdir)
|
|
$(INSTALL) -m 755 -d $(IROOT)$(ATJOB_DIR)
|
|
$(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(IROOT)$(ATSPOOL_DIR)
|
|
chmod 700 $(IROOT)$(ATJOB_DIR) $(IROOT)$(ATSPOOL_DIR)
|
|
@@ -99,25 +99,25 @@
|
|
touch $(IROOT)$(LFILE)
|
|
chmod 600 $(IROOT)$(LFILE)
|
|
chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
|
|
- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -m 600 at.deny $(IROOT)$(etcdir)/
|
|
- $(INSTALL) -g root -o root -m 4755 -s at $(IROOT)$(bindir)
|
|
+ test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -m 600 at.deny $(IROOT)$(etcdir)/
|
|
+ $(INSTALL) -m 4755 -s at $(IROOT)$(bindir)
|
|
$(LN_S) -f at $(IROOT)$(bindir)/atq
|
|
$(LN_S) -f at $(IROOT)$(bindir)/atrm
|
|
- $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
|
|
- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
|
|
+ $(INSTALL) -m 755 batch $(IROOT)$(bindir)
|
|
+ $(INSTALL) -d -m 755 $(IROOT)$(man1dir)
|
|
+ $(INSTALL) -d -m 755 $(IROOT)$(man5dir)
|
|
+ $(INSTALL) -d -m 755 $(IROOT)$(man8dir)
|
|
+ $(INSTALL) -m 755 -s atd $(IROOT)$(sbindir)
|
|
+ $(INSTALL) -m 755 atrun $(IROOT)$(sbindir)
|
|
+ $(INSTALL) -m 644 at.1 $(IROOT)$(man1dir)/
|
|
cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
|
|
- $(INSTALL) -g root -o root -m 644 atd.8 $(IROOT)$(man8dir)/
|
|
+ $(INSTALL) -m 644 atd.8 $(IROOT)$(man8dir)/
|
|
sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
|
|
- $(INSTALL) -g root -o root -m 644 tmpman $(IROOT)$(man8dir)/atrun.8
|
|
+ $(INSTALL) -m 644 tmpman $(IROOT)$(man8dir)/atrun.8
|
|
rm -f tmpman
|
|
- $(INSTALL) -g root -o root -m 644 at_allow.5 $(IROOT)$(man5dir)/
|
|
+ $(INSTALL) -m 644 at_allow.5 $(IROOT)$(man5dir)/
|
|
cd $(IROOT)$(man5dir) && $(LN_S) -f at_allow.5 at_deny.5
|
|
- $(INSTALL) -g root -o root -m 644 $(DOCS) $(IROOT)$(atdocdir)
|
|
+ $(INSTALL) -m 644 $(DOCS) $(IROOT)$(atdocdir)
|
|
rm -f $(IROOT)$(mandir)/cat1/at.1* $(IROOT)$(mandir)/cat1/batch.1* \
|
|
$(IROOT)$(mandir)/cat1/atq.1*
|
|
rm -f $(IROOT)$(mandir)/cat1/atd.8*
|