Add missing bracket.
This commit is contained in:
parent
42434fb932
commit
8c0170ef17
@ -1,6 +1,6 @@
|
|||||||
diff -up at-3.1.14/at.c.pam at-3.1.14/at.c
|
diff -up at-3.1.14/at.c.pam at-3.1.14/at.c
|
||||||
--- at-3.1.14/at.c.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/at.c.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/at.c 2013-09-26 14:28:40.549603545 +0200
|
+++ at-3.1.14/at.c 2013-10-07 14:39:15.670837532 +0200
|
||||||
@@ -144,18 +144,14 @@ sigc(int signo)
|
@@ -144,18 +144,14 @@ sigc(int signo)
|
||||||
/* If the user presses ^C, remove the spool file and exit
|
/* If the user presses ^C, remove the spool file and exit
|
||||||
*/
|
*/
|
||||||
@ -91,7 +91,7 @@ diff -up at-3.1.14/at.c.pam at-3.1.14/at.c
|
|||||||
|
|
||||||
diff -up at-3.1.14/atd.c.pam at-3.1.14/atd.c
|
diff -up at-3.1.14/atd.c.pam at-3.1.14/atd.c
|
||||||
--- at-3.1.14/atd.c.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/atd.c.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/atd.c 2013-09-26 15:04:28.762185123 +0200
|
+++ at-3.1.14/atd.c 2013-10-07 14:40:22.102988905 +0200
|
||||||
@@ -83,6 +83,10 @@
|
@@ -83,6 +83,10 @@
|
||||||
#include "getloadavg.h"
|
#include "getloadavg.h"
|
||||||
#endif
|
#endif
|
||||||
@ -239,10 +239,12 @@ diff -up at-3.1.14/atd.c.pam at-3.1.14/atd.c
|
|||||||
|
|
||||||
PRIV_START
|
PRIV_START
|
||||||
|
|
||||||
@@ -511,7 +523,20 @@ run_file(const char *filename, uid_t uid
|
@@ -511,7 +523,22 @@ run_file(const char *filename, uid_t uid
|
||||||
perr("Exec failed for mail command");
|
perr("Exec failed for mail command");
|
||||||
|
|
||||||
PRIV_END
|
PRIV_END
|
||||||
|
+
|
||||||
|
+ }
|
||||||
+ else if ( mail_pid == -1 ) {
|
+ else if ( mail_pid == -1 ) {
|
||||||
+ perr("fork of mailer failed");
|
+ perr("fork of mailer failed");
|
||||||
+ }
|
+ }
|
||||||
@ -260,7 +262,7 @@ diff -up at-3.1.14/atd.c.pam at-3.1.14/atd.c
|
|||||||
exit(EXIT_SUCCESS);
|
exit(EXIT_SUCCESS);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -727,7 +752,7 @@ main(int argc, char *argv[])
|
@@ -727,7 +754,7 @@ main(int argc, char *argv[])
|
||||||
#define LOG_CRON LOG_DAEMON
|
#define LOG_CRON LOG_DAEMON
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -271,7 +273,7 @@ diff -up at-3.1.14/atd.c.pam at-3.1.14/atd.c
|
|||||||
errno = 0;
|
errno = 0;
|
||||||
diff -up at-3.1.14/config.h.in.pam at-3.1.14/config.h.in
|
diff -up at-3.1.14/config.h.in.pam at-3.1.14/config.h.in
|
||||||
--- at-3.1.14/config.h.in.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/config.h.in.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/config.h.in 2013-09-26 14:28:40.550603546 +0200
|
+++ at-3.1.14/config.h.in 2013-10-07 14:39:15.670837532 +0200
|
||||||
@@ -68,8 +68,8 @@
|
@@ -68,8 +68,8 @@
|
||||||
/* Define to 1 if you have the <nlist.h> header file. */
|
/* Define to 1 if you have the <nlist.h> header file. */
|
||||||
#undef HAVE_NLIST_H
|
#undef HAVE_NLIST_H
|
||||||
@ -285,7 +287,7 @@ diff -up at-3.1.14/config.h.in.pam at-3.1.14/config.h.in
|
|||||||
#undef HAVE_PSTAT_GETDYNAMIC
|
#undef HAVE_PSTAT_GETDYNAMIC
|
||||||
diff -up at-3.1.14/configure.ac.pam at-3.1.14/configure.ac
|
diff -up at-3.1.14/configure.ac.pam at-3.1.14/configure.ac
|
||||||
--- at-3.1.14/configure.ac.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/configure.ac.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/configure.ac 2013-09-26 14:28:40.550603546 +0200
|
+++ at-3.1.14/configure.ac 2013-10-07 14:39:15.671837535 +0200
|
||||||
@@ -78,7 +78,7 @@ AC_FUNC_GETLOADAVG
|
@@ -78,7 +78,7 @@ AC_FUNC_GETLOADAVG
|
||||||
AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
|
AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
|
||||||
AC_CHECK_HEADERS(security/pam_appl.h, [
|
AC_CHECK_HEADERS(security/pam_appl.h, [
|
||||||
@ -311,7 +313,7 @@ diff -up at-3.1.14/configure.ac.pam at-3.1.14/configure.ac
|
|||||||
[ --with-daemon_groupname=DAEMON_GROUPNAME Groupname to run under (default daemon) ],
|
[ --with-daemon_groupname=DAEMON_GROUPNAME Groupname to run under (default daemon) ],
|
||||||
diff -up at-3.1.14/perm.c.pam at-3.1.14/perm.c
|
diff -up at-3.1.14/perm.c.pam at-3.1.14/perm.c
|
||||||
--- at-3.1.14/perm.c.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/perm.c.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/perm.c 2013-09-26 14:28:40.550603546 +0200
|
+++ at-3.1.14/perm.c 2013-10-07 14:39:15.671837535 +0200
|
||||||
@@ -51,6 +51,14 @@
|
@@ -51,6 +51,14 @@
|
||||||
#define PRIV_END while(0)
|
#define PRIV_END while(0)
|
||||||
#endif
|
#endif
|
||||||
@ -378,7 +380,7 @@ diff -up at-3.1.14/perm.c.pam at-3.1.14/perm.c
|
|||||||
return allow;
|
return allow;
|
||||||
diff -up at-3.1.14/privs.h.pam at-3.1.14/privs.h
|
diff -up at-3.1.14/privs.h.pam at-3.1.14/privs.h
|
||||||
--- at-3.1.14/privs.h.pam 2013-09-08 14:43:53.000000000 +0200
|
--- at-3.1.14/privs.h.pam 2013-09-08 14:43:53.000000000 +0200
|
||||||
+++ at-3.1.14/privs.h 2013-09-26 14:28:40.551603547 +0200
|
+++ at-3.1.14/privs.h 2013-10-07 14:39:15.671837535 +0200
|
||||||
@@ -144,3 +144,64 @@ extern gid_t real_gid, effective_gid, da
|
@@ -144,3 +144,64 @@ extern gid_t real_gid, effective_gid, da
|
||||||
#error "Cannot implement user ID swapping without setreuid or setresuid"
|
#error "Cannot implement user ID swapping without setreuid or setresuid"
|
||||||
#endif
|
#endif
|
||||||
|
13
at.spec
13
at.spec
@ -22,9 +22,9 @@ Patch2: at-3.1.14-pam.patch
|
|||||||
Patch3: at-3.1.14-selinux.patch
|
Patch3: at-3.1.14-selinux.patch
|
||||||
Patch4: at-3.1.14-opt_V.patch
|
Patch4: at-3.1.14-opt_V.patch
|
||||||
Patch5: at-3.1.14-shell.patch
|
Patch5: at-3.1.14-shell.patch
|
||||||
#Patch4: at-3.1.13-nitpicks.patch
|
Patch6: at-3.1.14-nitpicks.patch
|
||||||
#Patch7: at-3.1.12-nowrap.patch
|
Patch7: at-3.1.14-nowrap.patch
|
||||||
#Patch8: at-3.1.12-fix_no_export.patch
|
Patch8: at-3.1.14-fix_no_export.patch
|
||||||
#Patch9: at-3.1.13-mailwithhostname.patch
|
#Patch9: at-3.1.13-mailwithhostname.patch
|
||||||
#Patch10: at-3.1.13-usePOSIXtimers.patch
|
#Patch10: at-3.1.13-usePOSIXtimers.patch
|
||||||
#Patch11: at-3.1.13-help.patch
|
#Patch11: at-3.1.13-help.patch
|
||||||
@ -75,9 +75,10 @@ cp %{SOURCE1} .
|
|||||||
%patch3 -p1 -b .selinux
|
%patch3 -p1 -b .selinux
|
||||||
%patch4 -p1 -b .opt_V
|
%patch4 -p1 -b .opt_V
|
||||||
%patch5 -p1 -b .shell
|
%patch5 -p1 -b .shell
|
||||||
#%%patch4 -p1 -b .nit
|
%patch6 -p1 -b .nit
|
||||||
#%%patch7 -p1 -b .nowrap
|
%patch7 -p1 -b .nowrap
|
||||||
#%%patch8 -p1 -b .export
|
%patch8 -p1 -b .export
|
||||||
|
|
||||||
#%%patch9 -p1 -b .mail
|
#%%patch9 -p1 -b .mail
|
||||||
#%%patch10 -p1 -b .posix
|
#%%patch10 -p1 -b .posix
|
||||||
#%%patch11 -p1 -b .help
|
#%%patch11 -p1 -b .help
|
||||||
|
Loading…
Reference in New Issue
Block a user