auto-import changelog data from at-3.1.8-31.src.rpm
Thu Jul 25 2002 Bill Huang <bhuang@redhat.com> - Fixed delaying job execution and missing starting jobs..(bug#69595) (Thanks Bujor D Silaghi <bujor@cs.umd.edu> for his patch.)
This commit is contained in:
parent
5b1e33b428
commit
737cec23f2
@ -1,5 +1,14 @@
|
||||
--- at-3.1.8.orig/atd.c Tue Jul 16 21:35:17 2002
|
||||
+++ at-3.1.8/atd.c Wed Jul 17 02:37:05 2002
|
||||
+++ at-3.1.8/atd.c Sat Jul 20 17:26:24 2002
|
||||
@@ -113,7 +113,7 @@
|
||||
static char rcsid[] = "$Id: atd.c,v 1.28 1997/05/06 08:31:09 ig25 Exp $";
|
||||
static double load_avg = LOADAVG_MX;
|
||||
static time_t now;
|
||||
-static time_t last_chg;
|
||||
+//static time_t last_chg;
|
||||
static int nothing_to_do;
|
||||
unsigned int batch_interval;
|
||||
static int run_as_daemon = 0;
|
||||
@@ -188,7 +188,7 @@
|
||||
#endif
|
||||
|
||||
@ -205,3 +214,35 @@
|
||||
|
||||
if (((send_mail != -1) && (buf.st_size != size)) || (send_mail == 1)) {
|
||||
|
||||
@@ -462,6 +502,8 @@
|
||||
exit(EXIT_SUCCESS);
|
||||
}
|
||||
|
||||
+#define CHECK_INTERVAL_5MIN 300
|
||||
+
|
||||
static time_t
|
||||
run_loop()
|
||||
{
|
||||
@@ -491,7 +533,7 @@
|
||||
* atrun.
|
||||
*/
|
||||
|
||||
- next_job = now + CHECK_INTERVAL;
|
||||
+ next_job = now + CHECK_INTERVAL_5MIN;
|
||||
if (next_batch == 0)
|
||||
next_batch = now;
|
||||
|
||||
@@ -502,11 +544,11 @@
|
||||
|
||||
if (stat(".", &buf) == -1)
|
||||
perr("Cannot stat " ATJOB_DIR);
|
||||
-
|
||||
+/*
|
||||
if (nothing_to_do && buf.st_mtime <= last_chg)
|
||||
return next_job;
|
||||
last_chg = buf.st_mtime;
|
||||
-
|
||||
+*/
|
||||
if ((spool = opendir(".")) == NULL)
|
||||
perr("Cannot read " ATJOB_DIR);
|
||||
|
||||
|
10
at.spec
10
at.spec
@ -1,7 +1,7 @@
|
||||
Summary: Job spooling tools.
|
||||
Name: at
|
||||
Version: 3.1.8
|
||||
Release: 30
|
||||
Release: 31
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
Source: ftp://tsx-11.mit.edu/pub/linux/sources/usr.bin/at-3.1.8.tar.bz2
|
||||
@ -137,9 +137,13 @@ fi
|
||||
%attr(4755,root,root) %{_prefix}/bin/at
|
||||
|
||||
%changelog
|
||||
* Tue Jul 25 2002 Bill Huang <bhuang@redhat.com>
|
||||
- Fixed delaying job execution and missing starting jobs..(bug#69595)
|
||||
(Thanks Bujor D Silaghi <bujor@cs.umd.edu> for his patch.)
|
||||
|
||||
* Fri Jul 19 2002 Bill Huang <bhuang@redhat.com>
|
||||
- Apply the patch from Mike Gahanagan <mgahagan@redhat.com>
|
||||
to fix cleaning atq and multiple atd daemon.(bug#67414)
|
||||
- Fixed cleaning atq and multiple atd daemon.(bug#67414)
|
||||
(Thanks Bujor D Silaghi <bujor@cs.umd.edu> for his patch.)
|
||||
|
||||
* Fri Jul 19 2002 Bill Huang <bhuang@redhat.com>
|
||||
- Fixed error message output in atd.c
|
||||
|
Loading…
Reference in New Issue
Block a user