The macro with_pam is used instead of have_pam. License tag was fixed.
This commit is contained in:
parent
71eb17f1f0
commit
0ba30c7da8
40
at-3.1.10-havepam.patch
Normal file
40
at-3.1.10-havepam.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
--- at-3.1.10/atd.c.havepam 2007-08-22 10:37:16.000000000 +0200
|
||||||
|
+++ at-3.1.10/atd.c 2007-08-22 10:39:42.000000000 +0200
|
||||||
|
@@ -121,7 +121,7 @@
|
||||||
|
|
||||||
|
static volatile sig_atomic_t term_signal = 0;
|
||||||
|
|
||||||
|
-#ifdef HAVE_PAM
|
||||||
|
+#ifdef WITH_PAM
|
||||||
|
#include <security/pam_appl.h>
|
||||||
|
|
||||||
|
static pam_handle_t *pamh = NULL;
|
||||||
|
@@ -139,7 +139,7 @@
|
||||||
|
#define PAM_END { retcode = pam_close_session(pamh,0); \
|
||||||
|
pam_end(pamh,retcode); }
|
||||||
|
|
||||||
|
-#endif /* HAVE_PAM */
|
||||||
|
+#endif /* WITH_PAM */
|
||||||
|
|
||||||
|
/* Signal handlers */
|
||||||
|
RETSIGTYPE
|
||||||
|
@@ -246,7 +246,7 @@
|
||||||
|
char queue;
|
||||||
|
char fmt[64];
|
||||||
|
unsigned long jobno;
|
||||||
|
-#ifdef HAVE_PAM
|
||||||
|
+#ifdef WITH_PAM
|
||||||
|
int retcode;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- at-3.1.10/configure.in.havepam 2007-08-22 10:37:16.000000000 +0200
|
||||||
|
+++ at-3.1.10/configure.in 2007-08-22 10:37:16.000000000 +0200
|
||||||
|
@@ -80,7 +80,7 @@
|
||||||
|
AC_FUNC_GETLOADAVG
|
||||||
|
AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
|
||||||
|
AC_CHECK_HEADERS(security/pam_appl.h, [PAMLIB="-lpam"
|
||||||
|
- AC_DEFINE(HAVE_PAM)])
|
||||||
|
+ AC_DEFINE(WITH_PAM)])
|
||||||
|
|
||||||
|
dnl Checking for programs
|
||||||
|
|
10
at.spec
10
at.spec
@ -6,8 +6,8 @@
|
|||||||
Summary: Job spooling tools
|
Summary: Job spooling tools
|
||||||
Name: at
|
Name: at
|
||||||
Version: 3.1.10
|
Version: 3.1.10
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
License: GPL
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://ftp.debian.org/debian/pool/main/a/at
|
URL: http://ftp.debian.org/debian/pool/main/a/at
|
||||||
Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{major_ver}.tar.gz
|
Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{major_ver}.tar.gz
|
||||||
@ -27,6 +27,7 @@ Patch9: at-3.1.10-dont_fork.patch
|
|||||||
Patch10: at-3.1.10-perm.patch
|
Patch10: at-3.1.10-perm.patch
|
||||||
Patch11: at-3.1.10-opt_V.patch
|
Patch11: at-3.1.10-opt_V.patch
|
||||||
Patch12: at-3.1.10-session.patch
|
Patch12: at-3.1.10-session.patch
|
||||||
|
Patch13: at-3.1.10-havepam.patch
|
||||||
|
|
||||||
BuildRequires: fileutils chkconfig /etc/init.d
|
BuildRequires: fileutils chkconfig /etc/init.d
|
||||||
BuildRequires: flex bison autoconf
|
BuildRequires: flex bison autoconf
|
||||||
@ -73,6 +74,7 @@ cp %{SOURCE1} .
|
|||||||
%patch10 -p1 -b .perm
|
%patch10 -p1 -b .perm
|
||||||
%patch11 -p1 -b .opt_V
|
%patch11 -p1 -b .opt_V
|
||||||
%patch12 -p1 -b .session
|
%patch12 -p1 -b .session
|
||||||
|
%patch13 -p1 -b .havepam
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# patch10 touches configure.in
|
# patch10 touches configure.in
|
||||||
@ -175,6 +177,10 @@ fi
|
|||||||
%attr(4755,root,root) %{_bindir}/at
|
%attr(4755,root,root) %{_bindir}/at
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 22 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-16
|
||||||
|
- macro with_pam instead of have_pam
|
||||||
|
- license tag is gplv2+ because of license in source files
|
||||||
|
|
||||||
* Tue Jul 11 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-15
|
* Tue Jul 11 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-15
|
||||||
- rewrite init script
|
- rewrite init script
|
||||||
- add own session - setsid
|
- add own session - setsid
|
||||||
|
Loading…
Reference in New Issue
Block a user