auto-import changelog data from at-3.1.8-49.src.rpm
Tue Dec 09 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-49 - replace at-3.1.8-SHELL-91233.patch by at-3.1.8-SHELL-111386.patch which now executes $SHELL directly in the at shell script after all the variables have been setup with /bin/sh (#91233) [suggested by Göran Uddeborg] - this changelog is now in utf-8 Fri Nov 07 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-48 - add at-3.1.8-pie.patch to build atd as pie (#108415) [Ulrich Drepper] Fri Oct 31 2003 Dan Walsh <dwalsh@redhat.com> - 3.1.8-47.sel Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46 - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697) - update at.1 description of shell behaviour (#91233)
This commit is contained in:
parent
a5082c8a6a
commit
08c5811143
26
at-3.1.8-SHELL-111386.patch
Normal file
26
at-3.1.8-SHELL-111386.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -u at-3.1.8/at.c.SHELL at-3.1.8/at.c
|
||||
--- at-3.1.8/at.c.SHELL 2003-12-09 17:03:28.000000000 +1000
|
||||
+++ at-3.1.8/at.c 2003-12-09 17:03:28.000000000 +1000
|
||||
@@ -433,6 +433,8 @@
|
||||
fprintf(fp, " || {\n\t echo 'Execution directory "
|
||||
"inaccessible' >&2\n\t exit 1\n}\n");
|
||||
|
||||
+ fprintf(fp, "${SHELL:-/bin/sh} << `(dd if=/dev/urandom count=200 bs=1 2>/dev/null|LC_ALL=C tr -d -c '[:alnum:]')`\n\n");
|
||||
+
|
||||
istty = isatty(fileno(stdin));
|
||||
if (istty) {
|
||||
fprintf(stderr, "at> ");
|
||||
@@ -854,10 +856,11 @@
|
||||
/* POSIX.2 allows the shell specified by the user's SHELL environment
|
||||
variable, the login shell from the user's password database entry,
|
||||
or /bin/sh to be the command interpreter that processes the at-job.
|
||||
- It also alows a warning diagnostic to be printed. Because of the
|
||||
+ It also allows a warning diagnostic to be printed. Because of the
|
||||
possible variance, we always output the diagnostic. */
|
||||
|
||||
- fprintf(stderr, "warning: commands will be executed using /bin/sh\n");
|
||||
+/* fprintf(stderr, "warning: commands will be executed using /bin/sh\n");
|
||||
+ */
|
||||
|
||||
writefile(timer, queue);
|
||||
break;
|
20
at-3.1.8-pie.patch
Normal file
20
at-3.1.8-pie.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- at-3.1.8/Makefile.in.pie 2003-10-28 23:12:43.000000000 -0800
|
||||
+++ at-3.1.8/Makefile.in 2003-10-28 23:14:22.000000000 -0800
|
||||
@@ -74,7 +74,7 @@
|
||||
$(LN_S) -f at atrm
|
||||
|
||||
atd: $(RUNOBJECTS)
|
||||
- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(SELINUXLIB)
|
||||
+ $(CC) $(CFLAGS) -o atd -pie $(RUNOBJECTS) $(LIBS) $(SELINUXLIB)
|
||||
|
||||
y.tab.c y.tab.h: parsetime.y
|
||||
$(YACC) -d parsetime.y
|
||||
@@ -85,6 +85,8 @@
|
||||
atrun: atrun.in
|
||||
configure
|
||||
|
||||
+$(RUNOBJECTS): %.o: %.c
|
||||
+ $(CC) -c $(CFLAGS) -fpie $(DEFS) $*.c
|
||||
.c.o:
|
||||
$(CC) -c $(CFLAGS) $(DEFS) $*.c
|
||||
|
29
at.spec
29
at.spec
@ -1,7 +1,10 @@
|
||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
||||
%define WITH_SELINUX 1
|
||||
%endif
|
||||
Summary: Job spooling tools.
|
||||
Name: at
|
||||
Version: 3.1.8
|
||||
Release: 46.1
|
||||
Release: 49
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
Source: http://ftp.debian.org/debian/pool/main/a/at/at_3.1.8-11.tar.gz
|
||||
@ -21,8 +24,10 @@ Patch15: at-3.1.8-env-tng.patch
|
||||
#Patch16: at-3.1.8-lsbdoc.patch
|
||||
Patch18: at-3.1.8-perr.patch
|
||||
Patch19: at-3.1.8-instinet.patch
|
||||
Patch20: at-3.1.8-SHELL-91233.patch
|
||||
Patch20: at-3.1.8-SHELL-111386.patch
|
||||
Patch21: at-3.1.8-atrun.8-typo-97697.patch
|
||||
Patch22: at-selinux.patch
|
||||
Patch23: at-3.1.8-pie.patch
|
||||
|
||||
Prereq: fileutils chkconfig /etc/init.d
|
||||
BuildPrereq: flex bison autoconf
|
||||
@ -70,6 +75,11 @@ cp %{SOURCE1} .
|
||||
%patch19 -p1 -b .instinet
|
||||
%patch20 -p1 -b .SHELL
|
||||
%patch21 -p1 -b .typo
|
||||
%if %{WITH_SELINUX}
|
||||
#SELinux
|
||||
%patch22 -p1 -b .selinux
|
||||
%endif
|
||||
%patch23 -p1 -b .pie
|
||||
|
||||
%build
|
||||
# patch10 touches configure.in
|
||||
@ -145,6 +155,17 @@ fi
|
||||
%attr(4755,root,root) %{_bindir}/at
|
||||
|
||||
%changelog
|
||||
* Tue Dec 9 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-49
|
||||
- replace at-3.1.8-SHELL-91233.patch by at-3.1.8-SHELL-111386.patch which
|
||||
now executes $SHELL directly in the at shell script after all the variables
|
||||
have been setup with /bin/sh (#91233) [suggested by Göran Uddeborg]
|
||||
- this changelog is now in utf-8
|
||||
|
||||
* Fri Nov 7 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-48
|
||||
- add at-3.1.8-pie.patch to build atd as pie (#108415) [Ulrich Drepper]
|
||||
|
||||
* Fri Oct 31 2003 Dan Walsh <dwalsh@redhat.com> - 3.1.8-47.sel
|
||||
|
||||
* Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
|
||||
- add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
|
||||
- update at.1 description of shell behaviour (#91233)
|
||||
@ -209,7 +230,7 @@ fi
|
||||
* Thu Jan 31 2002 Bill Nottingham <notting@redhat.com> 3.1.8-24
|
||||
- rebuild in new env.
|
||||
|
||||
* Thu Jan 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.1.8-23
|
||||
* Thu Jan 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.1.8-23
|
||||
- s/Copyright/License/
|
||||
|
||||
* Mon Jan 14 2002 Adrian Havill <havill@redhat.com> 3.1.8-21
|
||||
@ -238,7 +259,7 @@ fi
|
||||
- he also wrote a test harness in perl
|
||||
- bug #28448
|
||||
|
||||
* Fri Feb 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Fri Feb 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- i18nize initscript
|
||||
|
||||
* Wed Dec 12 2000 Bill Nottingham <notting@redhat.com>
|
||||
|
Loading…
Reference in New Issue
Block a user