- update to 0.60.4

- cleanup spec file
This commit is contained in:
Ivana Varekova 2007-01-02 14:29:02 +00:00
parent 84833ed496
commit f577289d86
5 changed files with 177 additions and 42 deletions

View File

@ -1 +1 @@
aspell-0.60.4.tar.gz
aspell-0.60.5.tar.gz

View File

@ -0,0 +1,81 @@
--- aspell-0.60.5/Makefile.in.fc 2006-12-19 12:03:37.000000000 +0100
+++ aspell-0.60.5/Makefile.in 2007-01-02 13:32:03.000000000 +0100
@@ -341,6 +341,7 @@
# These are needed due to a bug in Automake
pkgdatadir = @pkgdatadir@
+pkgdatadir2 = @pkgdatadir2@
pkglibdir = @pkglibdir@
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
@@ -1907,7 +1908,7 @@
cd gen; perl mk-dirs_h.pl ${prefix} ${pkgdatadir} ${pkglibdir} ${sysconfdir} > dirs.h
scripts/run-with-aspell: scripts/run-with-aspell.create
- sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir} > scripts/run-with-aspell
+ sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir2} > scripts/run-with-aspell
chmod 755 scripts/run-with-aspell
@PSPELL_COMPATIBILITY_TRUE@scripts/pspell-config: scripts/mkconfig
@PSPELL_COMPATIBILITY_TRUE@ sh ${srcdir}/scripts/mkconfig ${VERSION} ${datadir} ${pkgdatadir}
--- aspell-0.60.5/configure.fc 2006-12-19 12:03:38.000000000 +0100
+++ aspell-0.60.5/configure 2007-01-02 13:33:16.000000000 +0100
@@ -844,6 +844,7 @@
MAINT
pkgdocdir
pkgdatadir
+pkgdatadir2
pkglibdir
CXX
CXXFLAGS
@@ -2638,23 +2639,25 @@
# Check whether --enable-pkgdatadir was given.
if test "${enable_pkgdatadir+set}" = set; then
enableval=$enable_pkgdatadir; pkgdatadir=$enable_pkgdatadir
+ pkgdatadir2=$enable_pkgdatadir
fi
# Check whether --enable-pkgdata-dir was given.
if test "${enable_pkgdata_dir+set}" = set; then
enableval=$enable_pkgdata_dir; pkgdatadir=$enable_dict_dir
+ pkgdatadir2=$enable_dict_dir
fi
if test "$pkgdatadir" = "undef"
then
pkgdatadir=\${libdir}/aspell-0.60
+ pkgdatadir2=${exec_prefix}/lib/aspell-0.60:${exec_prefix}/lib64/aspell-0.60
fi
-
pkglibdir=undef
# Check whether --enable-pkglibdir was given.
if test "${enable_pkglibdir+set}" = set; then
@@ -24186,6 +24189,7 @@
ac_delim='%!_!# '
+
for ac_last_try in false false false false false :; do
cat >conf$$subs.sed <<_ACEOF
SHELL!$SHELL$ac_delim
@@ -24264,6 +24268,7 @@
MAINT!$MAINT$ac_delim
pkgdocdir!$pkgdocdir$ac_delim
pkgdatadir!$pkgdatadir$ac_delim
+pkgdatadir2!$pkgdatadir2$ac_delim
pkglibdir!$pkglibdir$ac_delim
CXX!$CXX$ac_delim
CXXFLAGS!$CXXFLAGS$ac_delim
@@ -24287,7 +24292,7 @@
CCDEPMODE!$CCDEPMODE$ac_delim
_ACEOF
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 97; then
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 98; then
break
elif $ac_last_try; then
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5

View File

@ -0,0 +1,57 @@
--- aspell-0.60.5/configure.mlib 2007-01-02 14:59:04.000000000 +0100
+++ aspell-0.60.5/configure 2007-01-02 15:03:38.000000000 +0100
@@ -23484,7 +23484,7 @@
# #
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
-ac_config_files="$ac_config_files Makefile gen/Makefile common/Makefile lib/Makefile data/Makefile auto/Makefile modules/Makefile modules/tokenizer/Makefile modules/speller/Makefile modules/speller/default/Makefile interfaces/Makefile interfaces/cc/Makefile scripts/Makefile examples/Makefile prog/Makefile manual/Makefile po/Makefile.in m4/Makefile modules/filter/Makefile myspell/Makefile lib5/Makefile"
+ac_config_files="$ac_config_files Makefile gen/Makefile common/Makefile lib/Makefile data/Makefile auto/Makefile modules/Makefile modules/tokenizer/Makefile modules/speller/Makefile modules/speller/default/Makefile interfaces/Makefile interfaces/cc/Makefile aspell.pc scripts/Makefile examples/Makefile prog/Makefile manual/Makefile po/Makefile.in m4/Makefile modules/filter/Makefile myspell/Makefile lib5/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -24129,7 +24129,7 @@
"modules/filter/Makefile") CONFIG_FILES="$CONFIG_FILES modules/filter/Makefile" ;;
"myspell/Makefile") CONFIG_FILES="$CONFIG_FILES myspell/Makefile" ;;
"lib5/Makefile") CONFIG_FILES="$CONFIG_FILES lib5/Makefile" ;;
-
+ "aspell.pc" ) CONFIG_FILES="$CONFIG_FILES aspell.pc" ;;
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
{ (exit 1); exit 1; }; };;
--- aspell-0.60.5/scripts/mkconfig.mlib 2004-01-03 13:06:24.000000000 +0100
+++ aspell-0.60.5/scripts/mkconfig 2007-01-02 14:59:04.000000000 +0100
@@ -15,7 +15,7 @@
echo "$2"
;;
--pkgdatadir | pkgdatadir)
- echo "$3"
+ pkg-config aspell --variable=pkgdatadir
;;
*)
echo "usage: pspell-config version|datadir|pkgdatadir"
--- aspell-0.60.5/Makefile.in.mlib 2007-01-02 14:59:04.000000000 +0100
+++ aspell-0.60.5/Makefile.in 2007-01-02 14:59:04.000000000 +0100
@@ -809,6 +809,8 @@
done
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
@$(NORMAL_INSTALL)
+ mkdir -p $(libdir)/pkgconfig; \
+ cp aspell.pc $(libdir)/pkgconfig/aspell.pc; \
test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
if test -f $$p; then \
--- /dev/null 2007-01-02 09:09:01.616000852 +0100
+++ aspell-0.60.5/aspell.pc.in 2007-01-02 14:59:04.000000000 +0100
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+pkgdatadir=@pkgdatadir@
+
+Name: Aspell
+Description: A spelling checker.
+Version: @VERSION@
+Requires:
+Libs: -L${libdir} -laspell
+Cflags: -I${includedir}

View File

@ -1,6 +1,6 @@
Summary: A spelling checker.
Summary: A spelling checker
Name: aspell
Version: 0.60.4
Version: 0.60.5
Release: 1%{?dist}
Epoch: 12
License: LGPL
@ -9,9 +9,8 @@ URL: http://aspell.net/
Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
Patch1: aspell-0.50.3-gcc33.patch
Patch3: aspell-0.60.3-install_info.patch
Patch4: aspell-0.60.3-gcc41.patch
Patch5: aspell-0.60.4-fileconflict.patch
Patch7: aspell-0.60.3-pspell_conf.patch
Patch5: aspell-0.60.5-fileconflict.patch
Patch7: aspell-0.60.5-pspell_conf.patch
Requires: aspell-en
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: gettext, ncurses-devel, pkgconfig
@ -41,11 +40,9 @@ Aspell is a spelling checker. The aspell-devel package includes the
static libraries and header files needed for Aspell development.
%prep
rm -rf $RPM_BUILD_ROOT
%setup -q -n aspell-%{version}
%patch1 -p1 -b .gcc33
%patch3 -p1 -b .iinfo
%patch4 -p1 -b .gcc41
%patch5 -p1 -b .fc
%patch7 -p1 -b .mlib
@ -64,10 +61,6 @@ mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/spell ${RPM_BUILD_ROOT}%{_bindir}
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
#rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
#mv $RPM_BUILD_ROOT/usr/share/doc/aspell $RPM_BUILD_ROOT/usr/share/doc/aspell-%{version}
%post
/sbin/ldconfig
@ -124,6 +117,10 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/pspell-config.1*
%changelog
* Tue Jan 2 2007 Ivana Varekova <varekova@redhat.com> - 12:0.60.5-1
- update to 0.60.4
- cleanup spec file
* Wed Nov 8 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.4-1
- update to 0.60.4
@ -267,106 +264,106 @@ rm -rf $RPM_BUILD_ROOT
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
- automated rebuild
* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
- Rebuild to make it work again... #66708
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
- Rebuild
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
- Disable evil patch
* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
- Build on more archs (doh)
* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
- Make it compile with new compiler (evil workaround)
* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
- Rebuild
- Unexclude alpha
* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
- Rebuild
- Don't build on alpha
* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
- "make it work with gcc 3.1" ;)
* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
- 0.33.7.1, which is a "make it work with gcc 3" release
* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
- rebuild with new gcc and binutils
* Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
* Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
- 0.33.7 bugfix release. Requested by the author, it fixes
coredumps in sug-mode and when not using typo-analyses.
It also contains code cleanups so it compiles with -ansi
- should fix coredump on IA64 (#49746)
* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Add the .la files in the main package - used for dynamic loading
* Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.6.3, which includes the fix made yesterday
* Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Make it search for directories in the correct location
* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
- No more workarounds at the specfile level
* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Use custom ltmain.sh to work around buggy bundled libtool
* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.6
- use standard %%configure macro - it works now.
* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
- Rebuild with new libltdl
* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.5
* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
- use new emacs init scheme for Emacs and XEmacs
* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.6
* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.5 bugfix release (also contains improved documentation),
obsolete old patch
- the compatibility scripts are now part of the package itself
- clean up build procedure
- remove manual.aux file from docs (#16424)
* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.1 bugfix release, obsolete old patch
- rename to 0.32.1
- add patch from author to change his email address
- add spell and ispell compatibility scripts
* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
- rebuild
* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
- remember to obsolete ispell
- build the Canadian and British dictionaries here now,
as part of the main package. Same package names and
descriptions.
* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32
- remove old patches, add a patch since namespace isn't
polluted as much anymore (as opposed to older toolchain)
* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
- rebuild
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
@ -375,24 +372,24 @@ rm -rf $RPM_BUILD_ROOT
* Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
- Rebuild with new C++
* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
- use RPM_OPT_FLAGS, not just -O0
- dont include .la-files
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
- excludearch ia64
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
- patch to work around compiler bug(?) wrt. inline functions
- use CFLAGS and CXXFLAGS
- set them to -O0 to work around YACB
- copy libtool files for IA64 support
* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
- update to .31.1. My patch was upstreamed and is no longer needed.
- new patch added so DESTDIR works properly
* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
- (this entry includes some old ones...)
- update to .31
- added patch to make it compile with a pickier compiler

View File

@ -1 +1 @@
4f1737e726d66476b9c7388831305510 aspell-0.60.4.tar.gz
17fd8acac6293336bcef44391b71e337 aspell-0.60.5.tar.gz