import aspell-0.60.8-8.el9

This commit is contained in:
CentOS Sources 2021-11-04 04:05:37 -04:00 committed by Stepan Oksanichenko
commit b8c32a19b5
6 changed files with 765 additions and 0 deletions

1
.aspell.metadata Normal file
View File

@ -0,0 +1 @@
ae554df297aee676b4d16f261fa5c60e285478f6 SOURCES/aspell-0.60.8.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/aspell-0.60.8.tar.gz

View File

@ -0,0 +1,55 @@
diff --git a/Makefile.in b/Makefile.in
index f293649..e5d2b1a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -518,6 +518,7 @@ distcleancheck_listfiles = find . -type f -print
# These are needed due to a bug in Automake
pkgdatadir = @pkgdatadir@
+pkgdatadir2 = @pkgdatadir2@
pkglibdir = @pkglibdir@
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
@@ -2071,7 +2072,7 @@ gen/dirs.h: gen/mk-dirs_h.pl
perl ${srcdir}/gen/mk-dirs_h.pl ${prefix} ${pkgdatadir} ${pkglibdir} ${sysconfdir} > gen/dirs.h
scripts/run-with-aspell: scripts/run-with-aspell.create
- sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir} > scripts/run-with-aspell
+ sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir2} > scripts/run-with-aspell
chmod 755 scripts/run-with-aspell
@PSPELL_COMPATIBILITY_TRUE@scripts/pspell-config: scripts/mkconfig
@PSPELL_COMPATIBILITY_TRUE@ sh ${srcdir}/scripts/mkconfig ${VERSION} ${datadir} ${pkgdatadir}
diff --git a/configure b/configure
index 1236c90..8a6e697 100755
--- a/configure
+++ b/configure
@@ -709,6 +709,7 @@ CXXFLAGS
CXX
pkglibdir
pkgdatadir
+pkgdatadir2
pkgdocdir
MAINT
MAINTAINER_MODE_FALSE
@@ -3297,18 +3298,21 @@ pkgdatadir=undef
# Check whether --enable-pkgdatadir was given.
if test "${enable_pkgdatadir+set}" = set; then :
enableval=$enable_pkgdatadir; pkgdatadir=$enable_pkgdatadir
+ pkgdatadir2=$enable_pkgdatadir
fi
# Check whether --enable-pkgdata-dir was given.
if test "${enable_pkgdata_dir+set}" = set; then :
enableval=$enable_pkgdata_dir; pkgdatadir=$enable_dict_dir
+ pkgdatadir2=$enable_dict_dir
fi
if test "$pkgdatadir" = "undef"
then
pkgdatadir=\${libdir}/aspell-0.60
+ pkgdatadir2=${exec_prefix}/lib/aspell-0.60:${exec_prefix}/lib64/aspell-0.60
fi

View File

@ -0,0 +1,48 @@
diff --git a/manual/aspell.1 b/manual/aspell.1
index 854debf..b1106ca 100644
--- a/manual/aspell.1
+++ b/manual/aspell.1
@@ -328,7 +328,6 @@ are also allowed. The \fI/etc/aspell.conf\fR file is a good example of
how to set these options and the Aspell Manual has more detailed info.
.SH SEE ALSO
.PP
-.BR aspell\-import (1),
.BR prezip\-bin (1),
.BR run\-with\-aspell (1),
.BR word\-list\-compress (1)
diff --git a/manual/prezip-bin.1 b/manual/prezip-bin.1
index afb6c05..09b5784 100644
--- a/manual/prezip-bin.1
+++ b/manual/prezip-bin.1
@@ -99,7 +99,6 @@ the output file is not complete.
.SH SEE ALSO
.PP
.BR aspell (1),
-.BR aspell\-import (1),
.BR run\-with\-aspell (1),
.BR word\-list\-compress (1)
.PP
diff --git a/manual/run-with-aspell.1 b/manual/run-with-aspell.1
index 8dea131..67f3117 100644
--- a/manual/run-with-aspell.1
+++ b/manual/run-with-aspell.1
@@ -28,7 +28,6 @@ such as ispell's own scripts.
.SH SEE ALSO
.PP
.BR aspell (1),
-.BR aspell\-import (1),
.BR word\-list\-compress (1)
.PP
Aspell is fully documented in its Texinfo manual. See the
diff --git a/manual/word-list-compress.1 b/manual/word-list-compress.1
index 5126cd2..6686997 100644
--- a/manual/word-list-compress.1
+++ b/manual/word-list-compress.1
@@ -80,7 +80,6 @@ be written to.
.SH SEE ALSO
.PP
.BR aspell (1),
-.BR aspell\-import (1),
.BR prezip\-bin (1),
.BR run\-with\-aspell (1)
.PP

View File

@ -0,0 +1,65 @@
diff --git a/Makefile.in b/Makefile.in
index e5d2b1a..bc53e34 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1019,6 +1019,8 @@ clean-filterLTLIBRARIES:
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
@$(NORMAL_INSTALL)
@list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
+ mkdir -p $(DESTDIR)$(libdir)/pkgconfig; \
+ cp aspell.pc $(DESTDIR)$(libdir)/pkgconfig/aspell.pc; \
list2=; for p in $$list; do \
if test -f $$p; then \
list2="$$list2 $$p"; \
diff --git a/aspell.pc.in b/aspell.pc.in
new file mode 100644
index 0000000..13da044
--- /dev/null
+++ b/aspell.pc.in
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+pkgdatadir=@pkgdatadir@
+
+Name: Aspell
+Description: A spelling checker.
+Version: @VERSION@
+Requires:
+Libs: -L${libdir} -laspell
+Cflags: -I${includedir}
diff --git a/configure b/configure
index 8a6e697..995a3df 100755
--- a/configure
+++ b/configure
@@ -18732,7 +18732,7 @@ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
# #
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
-ac_config_files="$ac_config_files Makefile gen/Makefile common/Makefile lib/Makefile data/Makefile auto/Makefile modules/Makefile modules/tokenizer/Makefile modules/speller/Makefile modules/speller/default/Makefile interfaces/Makefile interfaces/cc/Makefile scripts/Makefile examples/Makefile prog/Makefile manual/Makefile po/Makefile.in m4/Makefile modules/filter/Makefile myspell/Makefile lib5/Makefile"
+ac_config_files="$ac_config_files Makefile gen/Makefile common/Makefile lib/Makefile data/Makefile auto/Makefile modules/Makefile modules/tokenizer/Makefile modules/speller/Makefile modules/speller/default/Makefile interfaces/Makefile interfaces/cc/Makefile aspell.pc scripts/Makefile examples/Makefile prog/Makefile manual/Makefile po/Makefile.in m4/Makefile modules/filter/Makefile myspell/Makefile lib5/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -19887,6 +19887,7 @@ do
"modules/filter/Makefile") CONFIG_FILES="$CONFIG_FILES modules/filter/Makefile" ;;
"myspell/Makefile") CONFIG_FILES="$CONFIG_FILES myspell/Makefile" ;;
"lib5/Makefile") CONFIG_FILES="$CONFIG_FILES lib5/Makefile" ;;
+ "aspell.pc") CONFIG_FILES="$CONFIG_FILES aspell.pc" ;;
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac
diff --git a/scripts/mkconfig b/scripts/mkconfig
index 608e3f7..f15f31c 100755
--- a/scripts/mkconfig
+++ b/scripts/mkconfig
@@ -15,7 +15,7 @@ case \$1 in
echo "$2"
;;
--pkgdatadir | pkgdatadir)
- echo "$3"
+ pkg-config aspell --variable=pkgdatadir
;;
*)
echo "usage: pspell-config version|datadir|pkgdatadir"

595
SPECS/aspell.spec Normal file
View File

@ -0,0 +1,595 @@
Summary: Spell checker
Name: aspell
Version: 0.60.8
Release: 8%{?dist}
Epoch: 12
# LGPLv2+ .. common/gettext.h
# LGPLv2 .. modules/speller/default/phonet.hpp,
# modules/speller/default/phonet.cpp,
# modules/speller/default/affix.cpp
# GPLv2+ .. ltmain.sh, misc/po-filter.c
# BSD .. myspell/munch.c
License: LGPLv2+ and LGPLv2 and GPLv2+ and BSD
URL: http://aspell.net/
Source: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
Patch0: aspell-0.60.7-fileconflict.patch
Patch1: aspell-0.60.7-pspell_conf.patch
Patch2: aspell-0.60.7-mp.patch
BuildRequires: gcc-c++
BuildRequires: chrpath, gettext, ncurses-devel, pkgconfig, perl-interpreter
BuildRequires: make
%description
GNU Aspell is a spell checker designed to eventually replace Ispell. It can
either be used as a library or as an independent spell checker. Its main
feature is that it does a much better job of coming up with possible
suggestions than just about any other spell checker out there for the
English language, including Ispell and Microsoft Word. It also has many
other technical enhancements over Ispell such as using shared memory for
dictionaries and intelligently handling personal dictionaries when more
than one Aspell process is open at once.
%package devel
Summary: Libraries and header files for Aspell development
Requires: %{name} = %{epoch}:%{version}-%{release}
Requires: pkgconfig
%description devel
The aspell-devel package includes libraries
and header files needed for Aspell development.
%prep
%setup -q
%patch0 -p1 -b .fc
%patch1 -p1 -b .mlib
%patch2 -p1 -b .ai
iconv -f iso-8859-2 -t utf-8 < manual/aspell.info > manual/aspell.info.aux
mv manual/aspell.info.aux manual/aspell.info
%build
%configure --disable-rpath
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
%make_build
cp scripts/aspell-import examples/aspell-import
chmod 644 examples/aspell-import
cp manual/aspell-import.1 examples/aspell-import.1
%install
%make_install
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60
mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/ispell ${RPM_BUILD_ROOT}%{_bindir}
mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/spell ${RPM_BUILD_ROOT}%{_bindir}
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//nroff-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//sgml-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//context-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//email-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//tex-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//texinfo-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//markdown-filter.so
chrpath --delete ${RPM_BUILD_ROOT}%{_bindir}/aspell
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/libpspell.so.*
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
rm -f ${RPM_BUILD_ROOT}%{_bindir}/aspell-import
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/aspell-import.1
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
%find_lang %{name}
%files -f %{name}.lang
%doc README TODO COPYING examples/aspell-import examples/aspell-import.1
%dir %{_libdir}/aspell-0.60
%{_bindir}/a*
%{_bindir}/ispell
%{_bindir}/pr*
%{_bindir}/run-with-aspell
%{_bindir}/spell
%{_bindir}/word-list-compress
%{_libdir}/lib*.so.*
%{_libdir}/aspell-0.60/*
%{_infodir}/aspell.*
%{_mandir}/man1/aspell.1.*
%{_mandir}/man1/run-with-aspell.1*
%{_mandir}/man1/word-list-compress.1*
%{_mandir}/man1/prezip-bin.1.*
%files devel
%dir %{_includedir}/pspell
%{_bindir}/pspell-config
%{_includedir}/aspell.h
%{_includedir}/pspell/pspell.h
%{_libdir}/lib*spell.so
%{_libdir}/pkgconfig/*
%{_infodir}/aspell-dev.*
%{_mandir}/man1/pspell-config.1*
%changelog
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 12:0.60.8-8
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 12:0.60.8-7
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.8-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.8-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue Jul 14 2020 Tom Stellard <tstellar@redhat.com> - 12:0.60.8-4
- Use make macros
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Tue Oct 22 2019 Nikola Forró <nforro@redhat.com> - 12:0.60.8-2
- remove RPATH from markdown-filter.so
* Fri Oct 18 2019 Nikola Forró <nforro@redhat.com> - 12:0.60.8-1
- resolves: #1761152
update to 0.60.8
* Mon Aug 19 2019 Nikola Forró <nforro@redhat.com> - 12:0.60.7-1
- resolves: #1742373
update to 0.60.7
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu Jun 28 2018 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-23
- remove ldconfig from scriptlets
* Tue Jun 19 2018 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-22
- remove install-info from scriptlets
* Wed Apr 04 2018 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-21
- resolves: #1562364
do not call back() on an empty vector
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-20
- add missing gcc-c++ build dependency
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Thu Feb 23 2017 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-16
- resolves: #1423239
fix building with GCC 7
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Dec 06 2016 Nikola Forró <nforro@redhat.com> - 12:0.60.6.1-14
- resolves: #1401713
add perl to BuildRequires
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 12:0.60.6.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 12:0.60.6.1-11
- Rebuilt for GCC 5 C++11 ABI change
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Mar 25 2013 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-7
- resolves: #925034
add support for aarch64
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Aug 27 2012 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-5
- done some minor .spec file cleanup
* Thu Jul 19 2012 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-4
- resolves: #813261
fixed crash when trying to run "aspell dump personal"
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Aug 16 2011 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-1
- resolves: #718946
update to 0.60.6.1
* Mon May 2 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 12.0.60.6-15
- fix minor problems in spec file
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Aug 17 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 12.0.60.6-13
- remove obsolete links from man-pages
* Tue Mar 2 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 12.0.60.6-12
- fix -devel scriptlets
* Tue Dec 15 2009 Ivana Hutarova Varekova <varekova@redhat.com> - 12:0.60.6-11
- remove obsolete patch
* Fri Dec 4 2009 Ivana Hutarova Varekova <varekova@redhat.com> - 12:0.60.6-10
- fix rpath problem (chrpath)
* Tue Dec 1 2009 Ivana Hutarova Varekova <varekova@redhat.com> - 12:0.60.6-9
- add --disable-rpath to configure part
remove remanent obsolete tags
fix license field
* Fri Nov 27 2009 Ivana Hutarova Varekova <varekova@redhat.com> - 12:0.60.6-8
- change summary name
remove outdated Obsoletes, Conflicts and Provides flag
fix requirement to install-info (pre -> post)
move aspell-import to documentation part
remove exit 0 from scriptlets
* Mon Aug 10 2009 Ivana Varekova <varekova@redhat.com> - 12:0.60.6-7
- fix installation with --excludedocs option (#515911)
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12:0.60.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Thu Feb 12 2009 Ivana Varekova <varekova@redhat.com> - 12:0.60.6-4
- remove aspell-en require
* Mon Sep 1 2008 Ivana Varekova <varekova@redhat.com> - 12:0.60.6-3
- fix patch format
* Thu May 29 2008 Ivana Varekova <varekova@redhat.com> - 12:0.60.6-2
- Resolves: #447428
aspell sigserv on checking file with 0 length
* Wed May 7 2008 Ivana Varekova <varekova@redhat.com> - 12:0.60.6-1
- update to 0.60.6
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 12:0.60.5-5
- Autorebuild for GCC 4.3
* Tue Jan 22 2008 Ivana Varekova <varekova@redhat.com> - 12:0.60.5-4
- add gcc43 patch
* Thu Feb 8 2007 Ivana Varekova <varekova@redhat.com> - 12:0.60.5-3
- incorporate package review feedback
* Mon Jan 22 2007 Ivana Varekova <varekova@redhat.com> - 12:0.60.5-2
- Resolves: 223676
fix non-failsafe install-info problem
* Tue Jan 2 2007 Ivana Varekova <varekova@redhat.com> - 12:0.60.5-1
- update to 0.60.4
- cleanup spec file
* Wed Nov 8 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.4-1
- update to 0.60.4
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 12:0.60.3-7.1
- rebuild
* Tue May 23 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.3-7
- fix multilib problem (used pkgconfig)
* Wed Mar 22 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.3-6
- remove .la files (bug 184184)
* Thu Mar 2 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.3-5
- update aspell man page (bug 183205)
* Tue Feb 21 2006 Ivana Varekova <varekova@redhat.com> - 12:0.60.3-4
- fix multilib file conflict
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 12:0.60.3-3.2
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 12:0.60.3-3.1
- rebuilt for new gcc4.1 snapshot and glibc changes
* Mon Dec 19 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-3
- fix for gcc 4.1
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Fri Jul 15 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-2
- fix install-info problem
* Wed Jul 13 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-1
- update to 0.60.3 - (bug 141968) thanks to Dawid Gajownik
- add BuildRequires: ncurses-devel, gettext
- add config script patch (thanks tmraz@redhat.com)
* Mon Mar 7 2005 Ivana Varekova <varekova@redhat.com> 12:0.50.5-6
- rebuilt
* Thu Jan 13 2005 Adrian Havill <havill@redhat.com> 12:0.50.5-5
- added aspell-pt_BR to the obsoletes
* Fri Nov 12 2004 Warren Togami <wtogami@redhat.com> 12:0.50.5-4
- rebuild
* Wed Oct 06 2004 Than Ngo <than@redhat.com> 12:0.50.5-3.fc3
- add obsolete aspell-config
* Mon Aug 23 2004 Adrian Havill <havill@redhat.com> 12:0.50.5-2.fc3
- fix doc dir (#128140) (don't flag aspell doc stuff with the doc macro
flag due to rpm badness)
* Mon Jun 21 2004 Warren Togami <wtogami@redhat.com> 12:0.50.5-1
- update to 0.50.5
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Thu Jan 29 2004 Adrian Havill <havill@redhat.com> 12:0.50.50.3-18
- make rpm own some unclaimed dirs (#112984, #113778)
- explicitly claim kbd anbd dat files in /usr/share/aspell
- a little spec file files cleanup-- macro subs, dir prefix
- make /usr/lib/aspell; don't make the dictionary packages do it
* Mon Nov 17 2003 Thomas Woerner <twoerner@redhat.com> 12:0.50.3-17
- fixed build: added make to %%build to avoid rpath for build directory
* Tue Oct 07 2003 Adrian Havill <havill@redhat.com> 12:0.50.3-16
- moved spell compat script from /usr/share/aspell to /usr/bin (#105921)
* Tue Jul 01 2003 Adrian Havill <havill@redhat.com> 11:0.50.3-15
- moved ispell compat script from /usr/share/aspell to /usr/bin (#90907)
* Tue Jun 24 2003 Adrian Havill <havill@redhat.com> 10:0.50.3-14
- removed emacs/xemacs el files which are already provided
* Wed Jun 18 2003 Adrian Havill <havill@redhat.com> 9:0.50.3-13
- provide pspell-devel in addition to obsoleting it
* Tue Jun 10 2003 Adrian Havill <havill@redhat.com> 8:0.50.3-12
- obsolete old dicts designed for previous aspell
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
- rebuild again to fix libpspell deps
* Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
- remove ExcludeArch
* Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
- fix build with gcc 3.3
* Wed May 21 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
- require aspell-en for upgrades
* Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
- -devel should obsolete pspell-devel
* Tue May 6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
- include libpspell.so in devel package
* Thu May 1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
- removed .la files
* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
- Changed the header for provides, obsoletes, epoch
- fixed config prefix in dirs.h
* Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
- upgrade to 0.50.3
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt
* Fri Nov 8 2002 Tim Powers <timp@redhat.com>
- fix broken pspell epoch dep
- create $RPM_BUILD_ROOT/usr/bin by hand
- remove /usr/doc
- fix hardcoding of /usr/lib so that we can build on x86_64
* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
- require pspell and pspell-devel using the proper epoch
* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
- rebuilt with gcc-3.2 (we hope)
* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
- rebuild using gcc-3.2-0.1
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
- automated rebuild
* Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
- Rebuild to make it work again... #66708
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
- Rebuild
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
- Disable evil patch
* Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
- Build on more archs (doh)
* Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
- Make it compile with new compiler (evil workaround)
* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
- Rebuild
- Unexclude alpha
* Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
- Rebuild
- Don't build on alpha
* Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
- "make it work with gcc 3.1" ;)
* Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
- 0.33.7.1, which is a "make it work with gcc 3" release
* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
- rebuild with new gcc and binutils
* Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
- 0.33.7 bugfix release. Requested by the author, it fixes
coredumps in sug-mode and when not using typo-analyses.
It also contains code cleanups so it compiles with -ansi
- should fix coredump on IA64 (#49746)
* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Add the .la files in the main package - used for dynamic loading
* Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.6.3, which includes the fix made yesterday
* Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Make it search for directories in the correct location
* Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
- No more workarounds at the specfile level
* Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Use custom ltmain.sh to work around buggy bundled libtool
* Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.6
- use standard %%configure macro - it works now.
* Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
- Rebuild with new libltdl
* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
- 0.33.5
* Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
- use new emacs init scheme for Emacs and XEmacs
* Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.6
* Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.5 bugfix release (also contains improved documentation),
obsolete old patch
- the compatibility scripts are now part of the package itself
- clean up build procedure
- remove manual.aux file from docs (#16424)
* Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32.1 bugfix release, obsolete old patch
- rename to 0.32.1
- add patch from author to change his email address
- add spell and ispell compatibility scripts
* Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
- rebuild
* Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
- remember to obsolete ispell
- build the Canadian and British dictionaries here now,
as part of the main package. Same package names and
descriptions.
* Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
- .32
- remove old patches, add a patch since namespace isn't
polluted as much anymore (as opposed to older toolchain)
* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
- rebuild
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
- Rebuild with new C++
* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
- use RPM_OPT_FLAGS, not just -O0
- dont include .la-files
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
- excludearch ia64
* Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
- patch to work around compiler bug(?) wrt. inline functions
- use CFLAGS and CXXFLAGS
- set them to -O0 to work around YACB
- copy libtool files for IA64 support
* Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
- update to .31.1. My patch was upstreamed and is no longer needed.
- new patch added so DESTDIR works properly
* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
- (this entry includes some old ones...)
- update to .31
- added patch to make it compile with a pickier compiler
- include /usr/share/pspell
* Mon May 1 2000 Tim Powers <timp@redhat.com>
- updated to .30.1
- used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
- updated URL, download/ftp location
- removed redundant define's at top of spec file
* Thu Jul 8 1999 Tim Powers <timp@redhat.com>
- built for Powertools 6.1
- removed serial macro definitions from spec file to make versioning
consistant with the other packages we ship.
- changed build root path
- general spec file cleanups
* Tue Mar 2 1999 Ryan Weaver <ryanw@infohwy.com>
[aspell-.27.2-2]
- Changes from .27.1 to .27.2 (Mar 1, 1999)
- Fixed a major bug that caused aspell to dump core when used
without any arguments
- Fixed another major bug that caused aspell to do nothing when used
in interactive mode.
- Added an option to exit in Aspell's interactive mode.
- Removed some old documentation files from the distribution.
- Minor changes on to the section on using Aspell with egcs.
- Minor changes to remove -Wall warnings.