- done some minor .spec file cleanup
This commit is contained in:
parent
a3d083066a
commit
a4d17e2afa
@ -1,15 +0,0 @@
|
||||
--- aspell-0.50.3/common/Makefile.in.prefix 2003-04-28 14:47:40.000000000 -0400
|
||||
+++ aspell-0.50.3/common/Makefile.in 2003-04-28 14:50:50.000000000 -0400
|
||||
@@ -516,10 +516,10 @@
|
||||
|
||||
|
||||
dirs.h: mk-dirs_h
|
||||
- echo '#define PREFIX "${prefix}"' > dirs.h
|
||||
+ echo '#define PREFIX "/usr"' > dirs.h
|
||||
./mk-dirs_h ${prefix} DICT_DIR ${pkglibdir} >> dirs.h
|
||||
./mk-dirs_h ${prefix} DATA_DIR ${pkgdatadir} >> dirs.h
|
||||
- ./mk-dirs_h ${prefix} CONF_DIR ${sysconfdir} >> dirs.h
|
||||
+ echo '#define CONF_DIR "/etc"' >> dirs.h
|
||||
|
||||
config.cpp: dirs.h
|
||||
|
73
aspell.spec
73
aspell.spec
@ -1,23 +1,29 @@
|
||||
Summary: Spell checker
|
||||
Name: aspell
|
||||
Version: 0.60.6.1
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Epoch: 12
|
||||
# LGPLv2+ .. aspell-0.60.6/misc/po-filter.c, ltmain.sh, modules/speller/default/affix.cpp
|
||||
# GPLv2+ .. aspell-0.60.6/misc/po-filter.c, aspell-0.60.6/ltmain.sh
|
||||
# LGPLv2+ .. common/gettext.h
|
||||
# LGPLv2 .. modules/speller/default/phonet.hpp,
|
||||
# modules/speller/default/phonet.cpp,
|
||||
# modules/speller/default/affix.cpp
|
||||
# GPLv2+ .. ltmain.sh, misc/po-filter.c
|
||||
# BSD .. myspell/munch.c
|
||||
License: LGPLv2 and LGPLv2+ and GPLv2+ and MIT
|
||||
License: LGPLv2+ and LGPLv2 and GPLv2+ and BSD
|
||||
Group: Applications/Text
|
||||
URL: http://aspell.net/
|
||||
Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
|
||||
Patch3: aspell-0.60.3-install_info.patch
|
||||
Patch5: aspell-0.60.5-fileconflict.patch
|
||||
Patch7: aspell-0.60.5-pspell_conf.patch
|
||||
Patch8: aspell-0.60.6-zero.patch
|
||||
Patch9: aspell-0.60.6-mp.patch
|
||||
Patch10: aspell-0.60.6.1-dump-personal-abort.patch
|
||||
BuildRequires: gettext, ncurses-devel, pkgconfig
|
||||
BuildRequires: chrpath
|
||||
Source: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
|
||||
|
||||
Patch0: aspell-0.60.3-install_info.patch
|
||||
Patch1: aspell-0.60.5-fileconflict.patch
|
||||
Patch2: aspell-0.60.5-pspell_conf.patch
|
||||
# resolves: #447428
|
||||
Patch3: aspell-0.60.6-zero.patch
|
||||
Patch4: aspell-0.60.6-mp.patch
|
||||
# resolves: #813261
|
||||
Patch5: aspell-0.60.6.1-dump-personal-abort.patch
|
||||
|
||||
BuildRequires: chrpath, gettext, ncurses-devel, pkgconfig
|
||||
Requires(pre): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
@ -31,38 +37,39 @@ other technical enhancements over Ispell such as using shared memory for
|
||||
dictionaries and intelligently handling personal dictionaries when more
|
||||
than one Aspell process is open at once.
|
||||
|
||||
%package devel
|
||||
%package devel
|
||||
Summary: Libraries and header files for Aspell development
|
||||
Group: Development/Libraries
|
||||
Requires: aspell = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
%description devel
|
||||
Aspell is a spelling checker. The aspell-devel package includes
|
||||
libraries and header files needed for Aspell development.
|
||||
%description devel
|
||||
The aspell-devel package includes libraries
|
||||
and header files needed for Aspell development.
|
||||
|
||||
%prep
|
||||
%setup -q -n aspell-%{version}
|
||||
%patch3 -p1 -b .iinfo
|
||||
%patch5 -p1 -b .fc
|
||||
%patch7 -p1 -b .mlib
|
||||
%patch8 -p1 -b .zero
|
||||
%patch9 -p1 -b .ai
|
||||
%patch10 -p1 -b .dump-personal
|
||||
iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
|
||||
%setup -q
|
||||
%patch0 -p1 -b .iinfo
|
||||
%patch1 -p1 -b .fc
|
||||
%patch2 -p1 -b .mlib
|
||||
%patch3 -p1 -b .zero
|
||||
%patch4 -p1 -b .ai
|
||||
%patch5 -p1 -b .dump-personal
|
||||
iconv -f iso-8859-2 -t utf-8 < manual/aspell.info > manual/aspell.info.aux
|
||||
mv manual/aspell.info.aux manual/aspell.info
|
||||
|
||||
%build
|
||||
%configure --disable-rpath
|
||||
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
|
||||
make %{?_smp_mflags}
|
||||
cp scripts/aspell-import examples/aspell-import
|
||||
chmod 644 examples/aspell-import
|
||||
cp manual/aspell-import.1 examples/aspell-import.1
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
# make install DESTDIR=$RPM_BUILD_ROOT doesn't work
|
||||
%makeinstall
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60
|
||||
@ -79,7 +86,6 @@ chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60//texinfo-filter.so
|
||||
chrpath --delete ${RPM_BUILD_ROOT}%{_bindir}/aspell
|
||||
chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/libpspell.so.*
|
||||
|
||||
|
||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
|
||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
|
||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
|
||||
@ -94,7 +100,7 @@ if [ -f %{_infodir}/aspell.info.gz ]; then
|
||||
/sbin/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir --entry="* Aspell: (aspell). " || :
|
||||
fi
|
||||
|
||||
%post devel
|
||||
%post devel
|
||||
if [ -f %{_infodir}/aspell-dev.info.gz ]; then
|
||||
/sbin/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir --entry="* Aspell-dev: (aspell-dev). " || :
|
||||
fi
|
||||
@ -106,7 +112,7 @@ if [ $1 = 0 ]; then
|
||||
fi
|
||||
fi
|
||||
|
||||
%preun devel
|
||||
%preun devel
|
||||
if [ $1 = 0 ]; then
|
||||
if [ -f %{_infodir}/aspell-dev.info.gz ]; then
|
||||
/sbin/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir || :
|
||||
@ -116,7 +122,6 @@ fi
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc README TODO COPYING examples/aspell-import examples/aspell-import.1
|
||||
%dir %{_libdir}/aspell-0.60
|
||||
%{_bindir}/a*
|
||||
@ -133,8 +138,7 @@ fi
|
||||
%{_mandir}/man1/word-list-compress.1*
|
||||
%{_mandir}/man1/prezip-bin.1.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%files devel
|
||||
%dir %{_includedir}/pspell
|
||||
%{_bindir}/pspell-config
|
||||
%{_includedir}/aspell.h
|
||||
@ -145,6 +149,9 @@ fi
|
||||
%{_mandir}/man1/pspell-config.1*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 27 2012 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-5
|
||||
- done some minor .spec file cleanup
|
||||
|
||||
* Thu Jul 19 2012 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-4
|
||||
- resolves: #813261
|
||||
fixed crash when trying to run "aspell dump personal"
|
||||
|
Loading…
Reference in New Issue
Block a user