- fix install-info problem
This commit is contained in:
parent
b7fc23b80f
commit
a300b31a41
29
aspell-0.60.3-install_info.patch
Normal file
29
aspell-0.60.3-install_info.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- aspell-0.60.3/manual/Makefile.in.iinfo 2005-06-27 11:54:58.000000000 +0200
|
||||||
|
+++ aspell-0.60.3/manual/Makefile.in 2005-07-15 12:59:23.492024424 +0200
|
||||||
|
@@ -517,16 +517,16 @@
|
||||||
|
else : ; fi; \
|
||||||
|
done; \
|
||||||
|
done
|
||||||
|
- @$(POST_INSTALL)
|
||||||
|
- @if (install-info --version && \
|
||||||
|
- install-info --version 2>&1 | sed 1q | grep -i -v debian) >/dev/null 2>&1; then \
|
||||||
|
- list='$(INFO_DEPS)'; \
|
||||||
|
- for file in $$list; do \
|
||||||
|
- relfile=`echo "$$file" | sed 's|^.*/||'`; \
|
||||||
|
- echo " install-info --info-dir='$(DESTDIR)$(infodir)' '$(DESTDIR)$(infodir)/$$relfile'";\
|
||||||
|
- install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$$relfile" || :;\
|
||||||
|
- done; \
|
||||||
|
- else : ; fi
|
||||||
|
+# @$(POST_INSTALL)
|
||||||
|
+# @if (install-info --version && \
|
||||||
|
+# install-info --version 2>&1 | sed 1q | grep -i -v debian) >/dev/null 2>&1; then \
|
||||||
|
+# list='$(INFO_DEPS)'; \
|
||||||
|
+# for file in $$list; do \
|
||||||
|
+# relfile=`echo "$$file" | sed 's|^.*/||'`; \
|
||||||
|
+# echo " install-info --info-dir='$(DESTDIR)$(infodir)' '$(DESTDIR)$(infodir)/$$relfile'";\
|
||||||
|
+# install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$$relfile" || :;\
|
||||||
|
+# done; \
|
||||||
|
+# else : ; fi
|
||||||
|
install-man: install-man1
|
||||||
|
|
||||||
|
installcheck-am:
|
31
aspell.spec
31
aspell.spec
@ -1,18 +1,19 @@
|
|||||||
Summary: A spelling checker.
|
Summary: A spelling checker.
|
||||||
Name: aspell
|
Name: aspell
|
||||||
Version: 0.60.3
|
Version: 0.60.3
|
||||||
Release: 1
|
Release: 2
|
||||||
Epoch: 12
|
Epoch: 12
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: Applications/Text
|
Group: Applications/Text
|
||||||
URL: http://aspell.net/
|
URL: http://aspell.net/
|
||||||
Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
|
Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
|
||||||
#Patch0: aspell-0.50.3.prefix.patch
|
|
||||||
Patch1: aspell-0.50.3-gcc33.patch
|
Patch1: aspell-0.50.3-gcc33.patch
|
||||||
Patch2: aspell-0.60.3-long_gettext.patch
|
Patch2: aspell-0.60.3-long_gettext.patch
|
||||||
|
Patch3: aspell-0.60.3-install_info.patch
|
||||||
Requires: aspell-en
|
Requires: aspell-en
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: gettext, ncurses-devel
|
BuildRequires: gettext, ncurses-devel
|
||||||
|
Prereq: /sbin/install-info
|
||||||
Provides: pspell
|
Provides: pspell
|
||||||
Obsoletes: ispell, pspell, aspell-de < 0.50, aspell-fr < 0.50, aspell-ca < 0.50, aspell-da < 0.50, aspell-es < 0.50, aspell-it < 0.50, aspell-nl < 0.50, aspell-no < 0.50, aspell-sv < 0.50, aspell-pt_BR, aspell-config
|
Obsoletes: ispell, pspell, aspell-de < 0.50, aspell-fr < 0.50, aspell-ca < 0.50, aspell-da < 0.50, aspell-es < 0.50, aspell-it < 0.50, aspell-nl < 0.50, aspell-no < 0.50, aspell-sv < 0.50, aspell-pt_BR, aspell-config
|
||||||
|
|
||||||
@ -40,9 +41,9 @@ static libraries and header files needed for Aspell development.
|
|||||||
%prep
|
%prep
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
%setup -q -n aspell-%{version}
|
%setup -q -n aspell-%{version}
|
||||||
#%patch -p1 -b .prefix
|
|
||||||
%patch1 -p1 -b .gcc33
|
%patch1 -p1 -b .gcc33
|
||||||
%patch2 -p1 -b .long
|
%patch2 -p1 -b .long
|
||||||
|
%patch3 -p1 -b .iinfo
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -58,13 +59,30 @@ mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/spell ${RPM_BUILD_ROOT}%{_bindir}
|
|||||||
|
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
|
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
|
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
|
||||||
|
|
||||||
#rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
|
#rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
|
||||||
|
|
||||||
#mv $RPM_BUILD_ROOT/usr/share/doc/aspell $RPM_BUILD_ROOT/usr/share/doc/aspell-%{version}
|
#mv $RPM_BUILD_ROOT/usr/share/doc/aspell $RPM_BUILD_ROOT/usr/share/doc/aspell-%{version}
|
||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
/sbin/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir --entry="* Aspell: (aspell). "
|
||||||
|
|
||||||
|
%post devel
|
||||||
|
/sbin/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir --entry="* Aspell-dev: (aspell-dev). "
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 = 0 ]; then
|
||||||
|
/sbin/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
|
||||||
|
fi
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun devel
|
||||||
|
if [ $1 = 0 ]; then
|
||||||
|
/sbin/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
|
||||||
|
fi
|
||||||
|
exit 0
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -84,7 +102,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/aspell-0.60/*
|
%{_libdir}/aspell-0.60/*
|
||||||
%{_datadir}/locale/*/LC_MESSAGES/aspell.mo
|
%{_datadir}/locale/*/LC_MESSAGES/aspell.mo
|
||||||
%{_infodir}/aspell.*
|
%{_infodir}/aspell.*
|
||||||
%{_infodir}/*
|
|
||||||
%{_mandir}/man1/aspell*
|
%{_mandir}/man1/aspell*
|
||||||
%{_mandir}/man1/run-with-aspell.1*
|
%{_mandir}/man1/run-with-aspell.1*
|
||||||
%{_mandir}/man1/word-list-compress.1*
|
%{_mandir}/man1/word-list-compress.1*
|
||||||
@ -100,6 +117,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/pspell-config.1*
|
%{_mandir}/man1/pspell-config.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 15 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-2
|
||||||
|
- fix install-info problem
|
||||||
|
|
||||||
* Wed Jul 13 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-1
|
* Wed Jul 13 2005 Ivana Varekova <varekova@redhat.com> 12:0.60.3-1
|
||||||
- update to 0.60.3 - (bug 141968) thanks to Dawid Gajownik
|
- update to 0.60.3 - (bug 141968) thanks to Dawid Gajownik
|
||||||
|
Loading…
Reference in New Issue
Block a user