parent
2e02193f53
commit
09e3e85a53
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
aspell-0.60.6.tar.gz
|
||||
/aspell-0.60.6.1.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up aspell-0.60.6/manual/Makefile.in.iinfo aspell-0.60.6/manual/Makefile.in
|
||||
--- aspell-0.60.6/manual/Makefile.in.iinfo 2008-04-07 06:56:27.000000000 +0200
|
||||
+++ aspell-0.60.6/manual/Makefile.in 2008-09-01 11:21:26.000000000 +0200
|
||||
@@ -593,16 +593,16 @@ install-info-am: $(INFO_DEPS)
|
||||
diff -up aspell-0.60.6.1/manual/Makefile.in.iinfo aspell-0.60.6.1/manual/Makefile.in
|
||||
--- aspell-0.60.6.1/manual/Makefile.in.iinfo 2011-07-04 10:58:49.000000000 +0200
|
||||
+++ aspell-0.60.6.1/manual/Makefile.in 2011-08-15 16:29:40.999718535 +0200
|
||||
@@ -607,16 +607,16 @@ install-info-am: $(INFO_DEPS)
|
||||
else : ; fi; \
|
||||
done; \
|
||||
done
|
||||
|
@ -1,25 +1,7 @@
|
||||
--- aspell-0.60.5/Makefile.in.fc 2006-12-19 12:03:37.000000000 +0100
|
||||
+++ aspell-0.60.5/Makefile.in 2007-01-02 13:32:03.000000000 +0100
|
||||
@@ -341,6 +341,7 @@
|
||||
|
||||
# These are needed due to a bug in Automake
|
||||
pkgdatadir = @pkgdatadir@
|
||||
+pkgdatadir2 = @pkgdatadir2@
|
||||
pkglibdir = @pkglibdir@
|
||||
ACLOCAL = @ACLOCAL@
|
||||
AMTAR = @AMTAR@
|
||||
@@ -1907,7 +1908,7 @@
|
||||
cd gen; perl mk-dirs_h.pl ${prefix} ${pkgdatadir} ${pkglibdir} ${sysconfdir} > dirs.h
|
||||
|
||||
scripts/run-with-aspell: scripts/run-with-aspell.create
|
||||
- sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir} > scripts/run-with-aspell
|
||||
+ sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir2} > scripts/run-with-aspell
|
||||
chmod 755 scripts/run-with-aspell
|
||||
@PSPELL_COMPATIBILITY_TRUE@scripts/pspell-config: scripts/mkconfig
|
||||
@PSPELL_COMPATIBILITY_TRUE@ sh ${srcdir}/scripts/mkconfig ${VERSION} ${datadir} ${pkgdatadir}
|
||||
--- aspell-0.60.5/configure.fc 2006-12-19 12:03:38.000000000 +0100
|
||||
+++ aspell-0.60.5/configure 2007-01-02 13:33:16.000000000 +0100
|
||||
@@ -844,6 +844,7 @@
|
||||
diff -up aspell-0.60.6.1/configure.fc aspell-0.60.6.1/configure
|
||||
--- aspell-0.60.6.1/configure.fc 2011-07-04 10:58:50.000000000 +0200
|
||||
+++ aspell-0.60.6.1/configure 2011-08-16 11:28:58.626771599 +0200
|
||||
@@ -839,6 +839,7 @@ MAINTAINER_MODE_FALSE
|
||||
MAINT
|
||||
pkgdocdir
|
||||
pkgdatadir
|
||||
@ -27,7 +9,7 @@
|
||||
pkglibdir
|
||||
CXX
|
||||
CXXFLAGS
|
||||
@@ -2638,23 +2639,25 @@
|
||||
@@ -2634,18 +2635,21 @@ pkgdatadir=undef
|
||||
# Check whether --enable-pkgdatadir was given.
|
||||
if test "${enable_pkgdatadir+set}" = set; then
|
||||
enableval=$enable_pkgdatadir; pkgdatadir=$enable_pkgdatadir
|
||||
@ -45,24 +27,11 @@
|
||||
if test "$pkgdatadir" = "undef"
|
||||
then
|
||||
pkgdatadir=\${libdir}/aspell-0.60
|
||||
+ pkgdatadir2=${exec_prefix}/lib/aspell-0.60:${exec_prefix}/lib64/aspell-0.60
|
||||
+ pkgdatadir2=${exec_prefix}/lib/aspell-0.60:${exec_prefix}/lib64/aspell-0.60
|
||||
fi
|
||||
|
||||
|
||||
|
||||
-
|
||||
pkglibdir=undef
|
||||
# Check whether --enable-pkglibdir was given.
|
||||
if test "${enable_pkglibdir+set}" = set; then
|
||||
@@ -24186,6 +24189,7 @@
|
||||
|
||||
|
||||
ac_delim='%!_!# '
|
||||
+
|
||||
for ac_last_try in false false false false false :; do
|
||||
cat >conf$$subs.sed <<_ACEOF
|
||||
SHELL!$SHELL$ac_delim
|
||||
@@ -24264,6 +24268,7 @@
|
||||
@@ -20119,6 +20123,7 @@ MAINTAINER_MODE_FALSE!$MAINTAINER_MODE_F
|
||||
MAINT!$MAINT$ac_delim
|
||||
pkgdocdir!$pkgdocdir$ac_delim
|
||||
pkgdatadir!$pkgdatadir$ac_delim
|
||||
@ -70,7 +39,7 @@
|
||||
pkglibdir!$pkglibdir$ac_delim
|
||||
CXX!$CXX$ac_delim
|
||||
CXXFLAGS!$CXXFLAGS$ac_delim
|
||||
@@ -24287,7 +24292,7 @@
|
||||
@@ -20142,7 +20147,7 @@ ac_ct_CC!$ac_ct_CC$ac_delim
|
||||
CCDEPMODE!$CCDEPMODE$ac_delim
|
||||
_ACEOF
|
||||
|
||||
@ -79,3 +48,23 @@
|
||||
break
|
||||
elif $ac_last_try; then
|
||||
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
|
||||
diff -up aspell-0.60.6.1/Makefile.in.fc aspell-0.60.6.1/Makefile.in
|
||||
--- aspell-0.60.6.1/Makefile.in.fc 2011-07-04 10:58:49.000000000 +0200
|
||||
+++ aspell-0.60.6.1/Makefile.in 2011-08-16 11:20:09.030887258 +0200
|
||||
@@ -344,6 +344,7 @@ distcleancheck_listfiles = find . -type
|
||||
|
||||
# These are needed due to a bug in Automake
|
||||
pkgdatadir = @pkgdatadir@
|
||||
+pkgdatadir2 = @pkgdatadir2@
|
||||
pkglibdir = @pkglibdir@
|
||||
ACLOCAL = @ACLOCAL@
|
||||
AMTAR = @AMTAR@
|
||||
@@ -1932,7 +1933,7 @@ gen/dirs.h: gen/mk-dirs_h.pl
|
||||
cd gen; perl mk-dirs_h.pl ${prefix} ${pkgdatadir} ${pkglibdir} ${sysconfdir} > dirs.h
|
||||
|
||||
scripts/run-with-aspell: scripts/run-with-aspell.create
|
||||
- sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir} > scripts/run-with-aspell
|
||||
+ sh ${srcdir}/scripts/run-with-aspell.create ${pkgdatadir2} > scripts/run-with-aspell
|
||||
chmod 755 scripts/run-with-aspell
|
||||
@PSPELL_COMPATIBILITY_TRUE@scripts/pspell-config: scripts/mkconfig
|
||||
@PSPELL_COMPATIBILITY_TRUE@ sh ${srcdir}/scripts/mkconfig ${VERSION} ${datadir} ${pkgdatadir}
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- aspell-0.60.5/configure.mlib 2007-01-02 14:59:04.000000000 +0100
|
||||
+++ aspell-0.60.5/configure 2007-01-02 15:03:38.000000000 +0100
|
||||
@@ -23484,7 +23484,7 @@
|
||||
diff -up aspell-0.60.6.1/configure.mlib aspell-0.60.6.1/configure
|
||||
--- aspell-0.60.6.1/configure.mlib 2011-08-16 11:40:48.000000000 +0200
|
||||
+++ aspell-0.60.6.1/configure 2011-08-16 11:41:44.013663519 +0200
|
||||
@@ -18989,7 +18989,7 @@ rm -f core conftest.err conftest.$ac_obj
|
||||
# #
|
||||
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
|
||||
|
||||
@ -9,7 +10,7 @@
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
# This file is a shell script that caches the results of configure
|
||||
@@ -24129,7 +24129,7 @@
|
||||
@@ -19985,7 +19985,7 @@ do
|
||||
"modules/filter/Makefile") CONFIG_FILES="$CONFIG_FILES modules/filter/Makefile" ;;
|
||||
"myspell/Makefile") CONFIG_FILES="$CONFIG_FILES myspell/Makefile" ;;
|
||||
"lib5/Makefile") CONFIG_FILES="$CONFIG_FILES lib5/Makefile" ;;
|
||||
@ -18,20 +19,10 @@
|
||||
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
|
||||
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
|
||||
{ (exit 1); exit 1; }; };;
|
||||
--- aspell-0.60.5/scripts/mkconfig.mlib 2004-01-03 13:06:24.000000000 +0100
|
||||
+++ aspell-0.60.5/scripts/mkconfig 2007-01-02 14:59:04.000000000 +0100
|
||||
@@ -15,7 +15,7 @@
|
||||
echo "$2"
|
||||
;;
|
||||
--pkgdatadir | pkgdatadir)
|
||||
- echo "$3"
|
||||
+ pkg-config aspell --variable=pkgdatadir
|
||||
;;
|
||||
*)
|
||||
echo "usage: pspell-config version|datadir|pkgdatadir"
|
||||
--- aspell-0.60.5/Makefile.in.mlib 2007-01-02 14:59:04.000000000 +0100
|
||||
+++ aspell-0.60.5/Makefile.in 2007-01-02 14:59:04.000000000 +0100
|
||||
@@ -809,6 +809,8 @@
|
||||
diff -up aspell-0.60.6.1/Makefile.in.mlib aspell-0.60.6.1/Makefile.in
|
||||
--- aspell-0.60.6.1/Makefile.in.mlib 2011-08-16 11:20:09.000000000 +0200
|
||||
+++ aspell-0.60.6.1/Makefile.in 2011-08-16 11:46:30.643236786 +0200
|
||||
@@ -816,6 +816,8 @@ clean-filterLTLIBRARIES:
|
||||
done
|
||||
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
@ -40,8 +31,20 @@
|
||||
test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
diff -up aspell-0.60.6.1/scripts/mkconfig.mlib aspell-0.60.6.1/scripts/mkconfig
|
||||
--- aspell-0.60.6.1/scripts/mkconfig.mlib 2004-01-03 13:06:24.000000000 +0100
|
||||
+++ aspell-0.60.6.1/scripts/mkconfig 2011-08-16 11:42:46.810519200 +0200
|
||||
@@ -15,7 +15,7 @@ case \$1 in
|
||||
echo "$2"
|
||||
;;
|
||||
--pkgdatadir | pkgdatadir)
|
||||
- echo "$3"
|
||||
+ pkg-config aspell --variable=pkgdatadir
|
||||
;;
|
||||
*)
|
||||
echo "usage: pspell-config version|datadir|pkgdatadir"
|
||||
--- /dev/null 2007-01-02 09:09:01.616000852 +0100
|
||||
+++ aspell-0.60.5/aspell.pc.in 2007-01-02 14:59:04.000000000 +0100
|
||||
+++ aspell-0.60.6.1/aspell.pc.in 2007-01-02 14:59:04.000000000 +0100
|
||||
@@ -0,0 +1,12 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: Spell checker
|
||||
Name: aspell
|
||||
Version: 0.60.6
|
||||
Release: 15%{?dist}
|
||||
Version: 0.60.6.1
|
||||
Release: 1%{?dist}
|
||||
Epoch: 12
|
||||
# LGPLv2+ .. aspell-0.60.6/misc/po-filter.c, ltmain.sh, modules/speller/default/affix.cpp
|
||||
# GPLv2+ .. aspell-0.60.6/misc/po-filter.c, aspell-0.60.6/ltmain.sh
|
||||
@ -143,6 +143,10 @@ fi
|
||||
%{_mandir}/man1/pspell-config.1*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 16 2011 Peter Schiffer <pschiffe@redhat.com> - 12:0.60.6.1-1
|
||||
- resolves: #718946
|
||||
update to 0.60.6.1
|
||||
|
||||
* Mon May 2 2011 Ivana Hutarova Varekova <varekova@redhat.com> - 12.0.60.6-15
|
||||
- fix minor problems in spec file
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user